]> git.pld-linux.org Git - packages/python-dateutil.git/commitdiff
- updated to 2.2, now works again with python 2.x (2.6+, with six)
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 19 Oct 2014 16:33:54 +0000 (18:33 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 19 Oct 2014 16:33:54 +0000 (18:33 +0200)
- updated system-zoneinfo patch

python-dateutil.spec
system-zoneinfo.patch

index 322d74f929da87ead322901a6ba3d2895838f05e..b26db02c11697128e324866cdebfcca8a7028a2a 100644 (file)
@@ -2,17 +2,20 @@
 Summary:       Extensions to the standard datetime module
 Summary(pl.UTF-8):     Rozszerzenia modułu datetime języka Python
 Name:          python-dateutil
-Version:       1.5
-Release:       4
+Version:       2.2
+Release:       1
 License:       BSD
 Group:         Libraries/Python
-Source0:       http://niemeyer.net/download/python-dateutil/python-%{module}-%{version}.tar.gz
-# Source0-md5: 35f3732db3f2cc4afdc68a8533b60a52
+Source0:       https://pypi.python.org/packages/source/p/python-dateutil/python-%{module}-%{version}.tar.gz
+# Source0-md5: c1f654d0ff7e33999380a8ba9783fd5c
 Patch0:                system-zoneinfo.patch
-URL:           http://niemeyer.net/python-dateutil
+URL:           http://labix.org/python-dateutil
+BuildRequires: python-modules >= 1:2.6
+BuildRequires: python-six
 BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 0.219
-Requires:      tzdata
+Requires:      python-six
+Requires:      tzdata >= 2013h
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
index 2f909dc12679e2d199ab42e8b4ada30460546d43..b669624e5dbddf30525495e1bbe588c0566819bb 100644 (file)
@@ -72,12 +72,11 @@ diff -up python-dateutil-1.5/dateutil/zoneinfo/__init__.py\~ python-dateutil-1.5
      return tzinfo
  
  def rebuild(filename, tag=None, format="gz"):
-diff -up python-dateutil-1.5/setup.py\~ python-dateutil-1.5/setup.py
---- python-dateutil-1.5/setup.py~      2010-01-11 10:43:22.000000000 +0100
-+++ python-dateutil-1.5/setup.py       2011-08-17 15:38:13.206304651 +0200
-@@ -15,6 +15,16 @@ TOPDIR = os.path.dirname(__file__) or ".
+--- python-dateutil-2.2/setup.py.orig  2013-11-01 09:32:03.000000000 +0100
++++ python-dateutil-2.2/setup.py       2014-10-19 16:56:34.244854176 +0200
+@@ -16,6 +16,16 @@
  VERSION = re.search('__version__ = "([^"]+)"',
-                     open(TOPDIR + "/dateutil/__init__.py").read()).group(1)
+                     codecs.open(TOPDIR + "/dateutil/__init__.py", encoding='utf-8').read()).group(1)
  
 +# XXX We would like to bind this to something like
 +# --system-zoneinfo=/path/to/zoneinfo.  Any way of doing this short of
@@ -92,12 +91,19 @@ diff -up python-dateutil-1.5/setup.py\~ python-dateutil-1.5/setup.py
  
  setup(name="python-dateutil",
        version = VERSION,
-@@ -29,7 +39,7 @@ The dateutil module provides powerful ex
- datetime module, available in Python 2.3+.
+@@ -30,7 +40,6 @@
+ datetime module available in the Python standard library.
  """,
        packages = ["dateutil", "dateutil.zoneinfo"],
--      package_data={"": ["*.tar.gz"]},
-       include_package_data=True,
-       zip_safe=False,
+-      package_data = {"": ["*.tar.gz"]},
+       include_package_data = True,
+       zip_safe = False,
+       requires = ["six"],
+@@ -47,5 +56,6 @@
+           'Programming Language :: Python :: 3.2',
+           'Programming Language :: Python :: 3.3',
+           'Topic :: Software Development :: Libraries',
+-      ]
++      ],
 +      **extra_options
        )
This page took 0.063663 seconds and 4 git commands to generate.