]> git.pld-linux.org Git - packages/python-dateutil.git/blob - python-dateutil.spec
- up to 1.2
[packages/python-dateutil.git] / python-dateutil.spec
1 %define         module dateutil
2 Summary:        Extensions to the standard datetime module
3 Summary(pl.UTF-8):      Rozszerzenia modułu datetime języka Python
4 Name:           python-dateutil
5 Version:        1.2
6 Release:        1
7 License:        PSF
8 Group:          Libraries/Python
9 Source0:        http://labix.org/download/python-dateutil/python-%{module}-%{version}.tar.bz2
10 # Source0-md5:  6ff3de3ab61fd4ad92dceea36f7121b4
11 URL:            http://labix.org/python-dateutil
12 BuildRequires:  rpm-pythonprov
13 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
14
15 %description
16 The dateutil module provides powerful extensions to the standard
17 datetime module, available in Python 2.3+. Allows:
18 - computing of relative deltas (next month, next year, next monday,
19   last week of month, etc),
20 - computing of dates based on very flexible recurrence rules, using a
21   superset of the [WWW] iCalendar specification,
22 - parsing of RFC strings,
23 - peneric parsing of dates in almost any string format.
24
25 %description -l pl.UTF-8
26 Moduł dateutil jest potężnym rozszerzeniem standardowego modułu
27 datetime, dostępnego w Pythonie 2.3+. Pozwala na:
28 - obliczanie relatywnych różnic (następny miesiąc, rok, poniedziałek,
29   ostatni tydzień miesiąca itp.),
30 - obliczanie dat w oparciu o bardzo elastyczne rekurencyjne zasady, z
31   użyciem nadzbioru specyfikacji [WWW] iCalendar,
32 - analizę łańcuchow znakowych RFC,
33 - analizę dat w prawie każdym formacie.
34
35 %prep
36 %setup -q
37
38 %build
39 python setup.py build
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 python setup.py install \
45         --root=$RPM_BUILD_ROOT \
46         --optimize=2
47
48 %py_postclean %{py_sitescriptdir}/dateutil
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc LICENSE NEWS README
56 %dir %{py_sitescriptdir}/dateutil
57 %{py_sitescriptdir}/dateutil/*.py[co]
58 #NOTE: Not sure but seems zoneinfo is needed under windows only
59 #%%dir %{py_sitescriptdir}/dateutil/zoneinfo
60 #%%{py_sitescriptdir}/dateutil/zoneinfo/*.py[co]
This page took 0.038172 seconds and 4 git commands to generate.