]> git.pld-linux.org Git - packages/python-alabaster.git/blob - python-alabaster.spec
- release 3 (by relup.sh)
[packages/python-alabaster.git] / python-alabaster.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module  alabaster
7 Summary:        A configurable sidebar-enabled Sphinx theme
8 Summary(pl.UTF-8):      Konfigurowany motyw z bocznym panelem dla Sphinksa
9 Name:           python-%{module}
10 Version:        0.7.4
11 Release:        3
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.python.org/pypi/alabaster
15 Source0:        https://pypi.python.org/packages/source/a/alabaster/%{module}-%{version}.tar.gz
16 # Source0-md5:  ba31bf652194200428aa4e3d976f5ccd
17 URL:            https://pypi.python.org/pypi/alabaster
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.219
20 %if %{with python2}
21 BuildRequires:  python-devel
22 BuildRequires:  python-setuptools >= 7.0
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3-devel
26 BuildRequires:  python3-modules
27 BuildRequires:  python3-setuptools >= 7.0
28 %endif
29 Requires:       python-modules
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 A configurable sidebar-enabled Sphinx theme.
35
36 This theme is a modified "Kr" Sphinx theme from @kennethreitz
37 (especially as used in his Requests project), which was itself
38 originally based on @mitsuhiko's theme used for Flask & related
39 projects.
40
41 %description -l pl.UTF-8
42 Konfigurowany motyw z bocznym panelem (sidebarem) dla Sphinksa.
43
44 Motyw ten to zmodyfikowany motyw Sphinksa "Kr" od @kennethreitz
45 (konkretnie wersja używana w jego projekcie Requests), pierwotnie
46 oparty na motywie @mitsuhiko używanym w projekcie Flash i powiązanych
47 z nim.
48
49 %package -n python3-%{module}
50 Summary:        A configurable sidebar-enabled Sphinx theme
51 Summary(pl.UTF-8):      Konfigurowany motyw z bocznym panelem dla Sphinksa
52 Group:          Libraries/Python
53 Requires:       python3-modules
54
55 %description -n python3-%{module}
56 A configurable sidebar-enabled Sphinx theme
57
58 This theme is a modified "Kr" Sphinx theme from @kennethreitz
59 (especially as used in his Requests project), which was itself
60 originally based on @mitsuhiko's theme used for Flask & related
61 projects.
62
63 %description -n python3-%{module} -l pl.UTF-8
64 Konfigurowany motyw z bocznym panelem (sidebarem) dla Sphinksa.
65
66 Motyw ten to zmodyfikowany motyw Sphinksa "Kr" od @kennethreitz
67 (konkretnie wersja używana w jego projekcie Requests), pierwotnie
68 oparty na motywie @mitsuhiko używanym w projekcie Flash i powiązanych
69 z nim.
70
71 %prep
72 %setup -q -n %{module}-%{version}
73
74 %build
75 %if %{with python2}
76 %{__python} setup.py build --build-base build-2 %{?with_tests:test}
77 %endif
78
79 %if %{with python3}
80 %{__python3} setup.py build --build-base build-3 %{?with_tests:test}
81 %endif
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %if %{with python2}
87 %{__python} setup.py \
88         build --build-base build-2 \
89         install --skip-build \
90         --optimize=2 \
91         --root=$RPM_BUILD_ROOT
92
93 %py_postclean
94 %endif
95
96 %if %{with python3}
97 %{__python3} setup.py \
98         build --build-base build-3 \
99         install --skip-build \
100         --optimize=2 \
101         --root=$RPM_BUILD_ROOT
102 %endif
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %if %{with python2}
108 %files
109 %defattr(644,root,root,755)
110 %doc README.rst
111 %{py_sitescriptdir}/%{module}
112 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
113 %endif
114
115 %if %{with python3}
116 %files -n python3-%{module}
117 %defattr(644,root,root,755)
118 %doc README.rst
119 %{py3_sitescriptdir}/%{module}
120 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
121 %endif
This page took 0.061723 seconds and 3 git commands to generate.