]> git.pld-linux.org Git - packages/python-CDDB.git/blob - python-CDDB.spec
- small fix, release 1
[packages/python-CDDB.git] / python-CDDB.spec
1 %define         module CDDB
2
3 Summary:        Module for accessing CDDB and FreeDB
4 Summary(pl):    Modu³ do ³±czenia z bazami CDDB i FreeDB
5 Name:           python-%{module}
6 Version:        1.4
7 Release:        1
8 License:        GNU
9 Group:          Development/Languages/Python
10 Source0:        http://cddb-py.sourceforge.net/%{module}-%{version}.tar.gz
11 # Source0-md5:  254698082bafe3030d07d88fb7e13fe2
12 URL:            http://cddb-py.sourceforge.net/
13 %pyrequires_eq  python-modules
14 BuildRequires:  python-devel >= 2.3
15 BuildRequires:  rpm-pythonprov
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 This is a set of three modules to access the CDDB and FreeDB online
20 databases of audio CD track titles and information. It includes a C
21 extension module to fetch track lengths under Linux, FreeBSD, OpenBSD,
22 Mac OS X, Solaris, and Win32, which is easily ported to other
23 operating systems.
24
25 %description -l pl
26 Jest to zestaw trzech modu³ów umo¿liwiaj±cych po³±czenie z bazami CDDB
27 i FreeDB. Pakiet zawiera te¿ modu³ w C do wyci±gania d³ugo¶ci ¶cie¿ek.
28
29 %prep
30 %setup -q -n %{module}-%{version}
31
32 %build
33 CFLAGS="%{rpmcflags}"
34 export CLFAGS
35 python setup.py build
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39 install -d $RPM_BUILD_ROOT%{py_sitedir}
40 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
41 install cddb-info.py $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
42 python setup.py install \
43         --root=$RPM_BUILD_ROOT \
44         --optimize=2
45
46 rm -f $RPM_BUILD_ROOT%{py_sitedir}/*.py
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc README CHANGES COPYING
54 %{py_sitedir}/*.py[co]
55 %{py_sitedir}/cdrom.so
56 %dir %{_examplesdir}/%{name}-%{version}
57 %{_examplesdir}/%{name}-%{version}/*
This page took 0.027734 seconds and 3 git commands to generate.