]> git.pld-linux.org Git - packages/pysvn-workbench.git/blob - pysvn-workbench.spec
update rpm group; rel 1
[packages/pysvn-workbench.git] / pysvn-workbench.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # build with tests
4
5 Summary:        Python SVN GUI Tools
6 Summary(pl.UTF-8):      Graficzne narzędzia w Pythonie do SVN
7 Name:           pysvn-workbench
8 Version:        1.7.0
9 Release:        1
10 License:        Apache
11 Group:          Development/Tools
12 Source0:        http://pysvn.barrys-emacs.org/source_kits/WorkBench-%{version}.tar.gz
13 # Source0-md5:  aed0cc35a87c6dd287ad6a1a2fcf5b06
14 Source1:        wb.sh
15 URL:            http://pysvn.tigris.org/
16 BuildRequires:  rpm-pythonprov
17 BuildRequires:  rpmbuild(macros) >= 1.714
18 BuildRequires:  sed >= 4.0
19 Requires:       desktop-file-utils
20 Requires:       python
21 Requires:       python-pysvn >= 1.8.0
22 Requires:       python-wxPython
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 pysvn WorkBench Features:
28 - Easy to learn and use
29 - All subversion client operations in a GUI
30 - Support software development workflow
31 - Builtin GUI diff showing line and character diffs
32 - Ability to diff between revisions in a files history
33 - Runs on Windows and Unix platforms
34 - Implemented in Python, allowing customisation
35
36 %description -l pl.UTF-8
37 Cechy pysvn WorkBench:
38 - łatwy do nauki i używania
39 - wszystkie operacje klienckie subversion z poziomu GUI
40 - obsługa przepływu pracy przy tworzeniu oprogramowania
41 - wbudowany graficzny diff pokazujący różnice linii i znaków
42 - możliwość porównywania między rewizjami plików w historii
43 - działa na platformach Windows i Unix
44 - zaimplementowany w Pythonie, konfigurowalny
45
46 %prep
47 %setup -q -n WorkBench-%{version}
48
49 ln -s Source/linux-rpmbuild.mak Makefile
50
51 %{__sed} -i -e 's/install /install -p /' Makefile
52
53 %build
54 %{__make} \
55         PYTHON=%{__python}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 %{__make} install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 rm $RPM_BUILD_ROOT%{_bindir}/%{name}
63 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/%{name}
64
65 %py_ocomp $RPM_BUILD_ROOT%{_datadir}/%{name}
66 %py_comp $RPM_BUILD_ROOT%{_datadir}/%{name}
67 %py_postclean %{_datadir}/%{name}
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %post
73 %update_desktop_database
74
75 %postun
76 %update_desktop_database
77
78 %files
79 %defattr(644,root,root,755)
80 %attr(755,root,root) %{_bindir}/pysvn-workbench
81 %dir %{_datadir}/%{name}
82 %{_datadir}/%{name}/*.py[co]
83 %{_datadir}/%{name}/wb.png
84 %{_desktopdir}/pysvn-workbench.desktop
This page took 0.092092 seconds and 3 git commands to generate.