]> git.pld-linux.org Git - packages/pwdutils.git/blob - pwdutils.spec
- rel 5 (shadow), rel 2 (pwdutils)
[packages/pwdutils.git] / pwdutils.spec
1 # TODO:
2 # - finish and test it
3 # - subpackage with rpasswd daemon
4 #
5 Summary:        Utilities to manage the passwd and shadow user information
6 Summary(pl):    Narzêdzia do zarz±dzania informacjami o u¿ytkownikach z passwd i shadow
7 Name:           pwdutils
8 Version:        2.4
9 Release:        2
10 License:        GPL
11 Group:          Applications/System
12 Source0:        ftp://ftp.kernel.org/pub/linux/utils/net/NIS/%{name}-%{version}.tar.bz2
13 # Source0-md5:  7635c09b005f0e9447df8b42b3942187
14 Source1:        %{name}.useradd
15 Source2:        %{name}.rpasswdd.init
16 Source3:        %{name}.login.defs
17 Source4:        chage.pamd
18 Source5:        chfn.pamd
19 Source6:        chsh.pamd
20 Source7:        passwd.pamd
21 Source8:        useradd.pamd
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  gettext-devel
25 BuildRequires:  libselinux-devel
26 BuildRequires:  openldap-devel
27 BuildRequires:  openssl-devel
28 BuildRequires:  pam-devel
29 Obsoletes:      shadow
30 Obsoletes:      shadow-extras
31 Provides:       shadow
32 Provides:       shadow-extras
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 pwdutils is a collection of utilities to manage the passwd and shadow
37 user information. The difference to the shadow suite is that these
38 utilities can also modify the information stored in NIS, NIS+, or
39 LDAP. PAM is used for user authentication and changing the pasword. It
40 contains passwd, chage, chfn, chsh, and a daemon for changing the
41 password on a remote machine over a secure SSL connection. The daemon
42 also uses PAM so that it can change passwords independent of where
43 they are stored.
44
45 %description -l pl
46 pwdutils to zestaw narzêdzi do zarz±dzania informacjami o
47 u¿ytkownikach z passwd i shadow. Ró¿nica w stosunku do pakietu shadow
48 polega na tym, ¿e te narzêdzia mog± tak¿e modyfikowaæ informacje
49 zapisane w bazie NIS, NIS+ lub LDAP. PAM jest u¿ywany do
50 uwierzytelniania u¿ytkowników i zmiany hase³. Zestaw zawiera passwd,
51 chage, chfn, chsh oraz demona do zmiany has³a na zdalnej maszynie po
52 bezpiecznym po³±czeniu SSL. Demon tak¿e u¿ywa PAM, wiêc mo¿na zmieniaæ
53 has³a niezale¿nie od tego, gdzie s± przechowywane.
54
55 %package -n rpasswdd
56 Summary:        Remote password update daemon
57 Group:          Applications/System
58
59 %description -n rpasswdd
60 rpasswdd is a daemon that lets users change their passwords in the
61 presence of a directory service like NIS, NIS+ or LDAP over a secure
62 SSL connection. rpasswdd behaves like the normal passwd(1) program and
63 uses PAM for authentification and changing the password, so it can be
64 configured very flexibel for the local requirements.
65
66 %prep
67 %setup -q
68
69 %build
70 %{__gettextize}
71 %{__aclocal}
72 %{__autoconf}
73 %{__autoheader}
74 %{__automake}
75 %configure \
76         --enable-selinux \
77         --disable-rpath
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d/,pwdutils,skel}
83
84 %{__make} install \
85         DESTDIR=$RPM_BUILD_ROOT
86
87 mv $RPM_BUILD_ROOT%{_sbindir}/*.local $RPM_BUILD_ROOT%{_sysconfdir}/pwdutils
88 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/default/useradd
89 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/rpasswdd
90 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/login.defs
91
92 install %{SOURCE4} $RPM_BUILD_ROOT/etc/pam.d/chage
93 install %{SOURCE5} $RPM_BUILD_ROOT/etc/pam.d/chfn
94 install %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/chsh
95 install %{SOURCE7} $RPM_BUILD_ROOT/etc/pam.d/passwd
96 install %{SOURCE8} $RPM_BUILD_ROOT/etc/pam.d/useradd
97
98 :> $RPM_BUILD_ROOT/etc/shadow
99
100 %find_lang %{name}
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %post
106 /sbin/ldconfig
107 if [ ! -f /etc/shadow ]; then
108         %{_sbindir}/pwconv
109 fi
110
111 %postun -p /sbin/ldconfig
112
113 %post -n rpasswdd
114 /sbin/chkconfig --add rpasswdd
115 if [ -f /var/lock/subsys/rpasswdd ]; then
116         /etc/rc.d/init.d/rpasswdd restart 1>&2
117 else
118         echo "Run \"/etc/rc.d/init.d/rpasswdd start\" to start rpasswdd daemon."
119 fi
120
121 %preun -n rpasswdd
122 if [ "$1" = "0" ]; then
123         if [ -f /var/lock/subsys/rpasswdd ]; then
124                 /etc/rc.d/init.d/rpasswdd stop 1>&2
125         fi
126         /sbin/chkconfig --del rpasswdd
127 fi
128
129 %files -f %{name}.lang
130 %defattr(644,root,root,755)
131 %doc ChangeLog NEWS README THANKS TODO
132 %attr(600,root,root) %config(noreplace) %verify(not md5 size mtime) %ghost %{_sysconfdir}/shadow
133 %attr(750,root,root) %dir %{_sysconfdir}/default
134 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/default/*
135 %attr(750,root,root) %dir %{_sysconfdir}/%{name}
136 %attr(750,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}/*.local
137 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chage
138 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chfn
139 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/chsh
140 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/passwd
141 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/useradd
142 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/login.defs
143 %dir /etc/skel
144 %attr(755,root,root) %{_bindir}/chage
145 %attr(4755,root,root) %{_bindir}/chfn
146 %attr(4755,root,root) %{_bindir}/chsh
147 %attr(4755,root,root) %{_bindir}/expiry
148 %attr(4755,root,root) %{_bindir}/gpasswd
149 %attr(4755,root,root) %{_bindir}/passwd
150 %attr(755,root,root) %{_bindir}/rpasswd
151 %attr(755,root,root) %{_sbindir}/chpasswd
152 %attr(755,root,root) %{_sbindir}/groupadd
153 %attr(755,root,root) %{_sbindir}/groupdel
154 %attr(755,root,root) %{_sbindir}/groupmod
155 %attr(755,root,root) %{_sbindir}/rpasswdd
156 %attr(755,root,root) %{_sbindir}/useradd
157 %attr(755,root,root) %{_sbindir}/userdel
158 %attr(755,root,root) %{_sbindir}/usermod
159 %attr(755,root,root) %{_sbindir}/vigr
160 %attr(755,root,root) %{_sbindir}/vipw
161 %{_mandir}/man?/*
162 %exclude %{_mandir}/man8/rpasswdd*
163
164 %files -n rpasswdd
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_sbindir}/rpasswdd
167 %attr(754,root,root) /etc/rc.d/init.d/rpasswdd
168 %attr(640,root,root) %config(noreplace) %verify(not md5 size mtime) /etc/pam.d/rpasswd
169 %{_mandir}/man8/rpasswdd*
This page took 0.045658 seconds and 4 git commands to generate.