]> git.pld-linux.org Git - packages/pspp.git/blob - pspp.spec
- updated to 2.0.0
[packages/pspp.git] / pspp.spec
1 #
2 # Conditional build:
3 %bcond_with     glade   # Glade extensions for PSPP development (broken in 1.4.1)
4 %bcond_without  perl    # Perl module
5
6 Summary:        GNU PSPP - program for statistical analysis of sampled data
7 Summary(pl.UTF-8):      GNU PSPP - program do analizy statystycznej danych próbkowanych
8 Name:           pspp
9 Version:        2.0.0
10 Release:        1
11 License:        GPL v3+
12 Group:          Applications/Science
13 Source0:        https://ftp.gnu.org/gnu/pspp/%{name}-%{version}.tar.gz
14 # Source0-md5:  11f5949311bfe66a44999b9d7db6c99b
15 Patch0:         %{name}-info.patch
16 Patch1:         %{name}-perl.patch
17 URL:            http://www.gnu.org/software/pspp/
18 BuildRequires:  autoconf >= 2.64
19 BuildRequires:  automake >= 1:1.14
20 BuildRequires:  cairo-devel >= 1.5
21 BuildRequires:  gettext-tools >= 0.20
22 BuildRequires:  glib2-devel >= 1:2.44
23 BuildRequires:  gsl-devel >= 1.13
24 BuildRequires:  gtk+3-devel >= 3.22.0
25 BuildRequires:  gtksourceview4-devel >= 4.0
26 %{?with_glade:BuildRequires:    glade-devel >= 3.0}
27 BuildRequires:  libtool >= 2:2
28 BuildRequires:  libxml2-devel >= 2.0
29 BuildRequires:  openssl-devel
30 BuildRequires:  pango-devel >= 1:1.22
31 BuildRequires:  perl-base >= 5.005_03
32 %{?with_perl:BuildRequires:     perl-devel >= 1:5.8}
33 BuildRequires:  pkgconfig
34 BuildRequires:  postgresql-devel
35 BuildRequires:  python3 >= 1:3
36 BuildRequires:  readline-devel
37 BuildRequires:  rpm-perlprov >= 4.1-13
38 BuildRequires:  rpmbuild(macros) >= 1.745
39 BuildRequires:  spread-sheet-widget-devel >= 0.7
40 BuildRequires:  texinfo
41 # tex
42 BuildRequires:  texlive
43 BuildRequires:  zlib-devel
44 Requires(post,postun):  desktop-file-utils
45 Requires(post,postun):  gtk-update-icon-cache
46 Requires:       %{name}-libs = %{version}-%{release}
47 Requires:       cairo >= 1.5
48 Requires:       glib2 >= 1:2.44
49 Requires:       gtk+3 >= 3.22.0
50 Requires:       gtksourceview4 >= 4.0
51 Requires:       pango >= 1:1.22
52 Requires:       shared-mime-info
53 Requires:       spread-sheet-widget >= 0.7
54 %if %{without glade}
55 Obsoletes:      pspp-glade < 1.4.1
56 %endif
57 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
58
59 %description
60 GNU PSPP is a program for statistical analysis of sampled data. It is
61 a Free replacement for the proprietary program SPSS, and appears very
62 similar to it with a few exceptions.
63
64 %description -l pl.UTF-8
65 GNU PSPP to program do analizy statystycznej danych próbkowanych. Jest
66 to wolnodostępny zamiennik własnościowego programu SPSS; jest do niego
67 dosyć podobny z kilkoma wyjątkami.
68
69 %package libs
70 Summary:        GNU PSPP libraries and command line tools
71 Summary(pl.UTF-8):      Biblioteki GNU PSPP i narzędzia linii poleceń
72 Group:          Applications/Science
73 Requires:       gsl >= 1.13
74 Conflicts:      pspp < 0.8.5-1
75
76 %description libs
77 GNU PSP libraries command line tools.
78
79 %description libs -l pl.UTF-8
80 Biblioteki GNU PSPP i narzędzia linii poleceń.
81
82 %package -n perl-PSPP
83 Summary:        PSPP module for Perl
84 Summary(pl.UTF-8):      Moduł PSPP dla Perla
85 Group:          Development/Languages/Perl
86 Requires:       %{name}-libs = %{version}-%{release}
87
88 %description -n perl-PSPP
89 PSPP Perl module provides an interface to the libraries used by pspp
90 to read and write system files.
91
92 %description -n perl-PSPP -l pl.UTF-8
93 Moduł Perla PSPP udostępnia interfejs do bibliotek wykorzystywanych
94 przez pspp do odczytu i zapisu plików systemowych.
95
96 %package glade
97 Summary:        Glade extensions for PSPP development
98 Summary(pl.UTF-8):      Rozszerzenia Glade do rozwijania PSPP
99 Group:          X11/Development/Libraries
100 Requires:       glade >= 3.0
101
102 %description glade
103 Glade extensions for PSPP development.
104
105 %description glade -l pl.UTF-8
106 Rozszerzenia Glade do rozwijania PSPP.
107
108 %prep
109 %setup -q
110 %patch0 -p1
111 %patch1 -p1
112
113 %build
114 %{__libtoolize}
115 %{__aclocal} -I gl/m4
116 %{__autoconf}
117 %{__autoheader}
118 %{__automake}
119 %configure \
120         --disable-static \
121         %{?with_glade:--with-gui-tools} \
122         --with-packager="PLD Linux (http://pld-linux.org/)" \
123         %{!?with_perl:--without-perl-module}
124
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 %{__make} install \
131         DESTDIR=$RPM_BUILD_ROOT
132
133 # program no longer installed, but manual still is... restore for now
134 install utilities/pspp-dump-sav $RPM_BUILD_ROOT%{_bindir}
135
136 %if %{with perl}
137 %{__make} -C perl-module install \
138         DESTDIR=$RPM_BUILD_ROOT
139 %endif
140
141 # API not exported
142 %{__rm} $RPM_BUILD_ROOT%{_libdir}/pspp/lib{pspp,pspp-core}.{la,so}
143 %if %{with glade}
144 # loadable module
145 %{__rm} $RPM_BUILD_ROOT%{_libdir}/glade/modules/*.la
146 %endif
147
148 %find_lang %{name}
149
150 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post
156 %update_desktop_database
157 %update_icon_cache hicolor
158 %update_mime_database
159
160 %postun
161 %update_desktop_database
162 %update_icon_cache hicolor
163 %update_mime_database
164
165 %files -f %{name}.lang
166 %defattr(644,root,root,755)
167 %attr(755,root,root) %{_bindir}/pspp
168 %attr(755,root,root) %{_bindir}/pspp-output
169 %attr(755,root,root) %{_bindir}/psppire
170 %{_datadir}/pspp
171 %{_datadir}/metainfo/org.gnu.pspp.metainfo.xml
172 %{_datadir}/mime/packages/org.gnu.pspp.xml
173 %{_desktopdir}/org.gnu.pspp.desktop
174 %{_iconsdir}/hicolor/*/apps/org.gnu.pspp.*
175 %{_iconsdir}/hicolor/*x*/mimetypes/application-x-spss-*.png
176 %{_infodir}/pspp.info*
177 %{_infodir}/pspp-dev.info*
178 %{_infodir}/pspp-figures
179 %{_infodir}/screenshots
180 %{_mandir}/man1/pspp.1*
181 %{_mandir}/man1/pspp-output.1*
182 %{_mandir}/man1/psppire.1*
183
184 %files libs
185 %defattr(644,root,root,755)
186 %doc AUTHORS ChangeLog NEWS ONEWS README THANKS
187 %attr(755,root,root) %{_bindir}/pspp-convert
188 %attr(755,root,root) %{_bindir}/pspp-dump-sav
189 %dir %{_libdir}/pspp
190 %attr(755,root,root) %{_libdir}/pspp/libpspp-%{version}.so
191 %attr(755,root,root) %{_libdir}/pspp/libpspp-core-%{version}.so
192 %{_mandir}/man1/pspp-convert.1*
193 %{_mandir}/man1/pspp-dump-sav.1*
194
195 %if %{with perl}
196 %files -n perl-PSPP
197 %defattr(644,root,root,755)
198 %{perl_vendorarch}/PSPP.pm
199 %dir %{perl_vendorarch}/auto/PSPP
200 %attr(755,root,root) %{perl_vendorarch}/auto/PSPP/PSPP.so
201 %{_mandir}/man3/PSPP.3pm*
202 %{_mandir}/man3/PSPP::Examples.3pm*
203 %endif
204
205 %if %{with glade}
206 %files glade
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_libdir}/glade/modules/libglade-psppire.so
209 %{_datadir}/glade/catalogs/psppire.xml
210 %{_datadir}/glade/pixmaps/hicolor/16x16/actions/widget-psppire-psppire-*.png
211 %{_datadir}/glade/pixmaps/hicolor/22x22/actions/widget-psppire-psppire-*.png
212 %endif
This page took 0.195055 seconds and 4 git commands to generate.