]> git.pld-linux.org Git - packages/pslib.git/commitdiff
- updated giflib patch for giflib 5.1 auto/th/pslib-0.4.5-7
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 10 Nov 2014 07:04:56 +0000 (08:04 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 10 Nov 2014 07:04:56 +0000 (08:04 +0100)
- rel 7

pslib-giflib.patch
pslib.spec

index ebd167aa7dd645ec37206f42a564c48fb93d779e..cb1739b95bd2ece8ce77573582d98e144e2a5983 100644 (file)
                        fclose(fp);
                        return(0);
      }
+@@ -4939,7 +4939,7 @@
+               if(NULL == (psimage->palette = psdoc->malloc(psdoc, sizeof(PSColor) * numcolors, _("Allocate memory for color palette.")))) {
+                       ps_error(psdoc, PS_MemoryError, _("Could not allocate memory for color palette."));
+-                      DGifCloseFile(gft);
++                      DGifCloseFile(gft, NULL);
+                       psdoc->free(psdoc, psimage);
+                       fclose(fp);
+                       return(0);
+@@ -4964,7 +4964,7 @@
+               psimage->length = psimage->width * psimage->height;
+               if(NULL == (psimage->data = psdoc->malloc(psdoc, psimage->length, _("Allocate memory for image data.")))) {
+                       ps_error(psdoc, PS_MemoryError, _("Could not allocate memory for image data."));
+-                      DGifCloseFile(gft);
++                      DGifCloseFile(gft, NULL);
+                       psdoc->free(psdoc, psimage->palette);
+                       psdoc->free(psdoc, psimage);
+                       fclose(fp);
+@@ -4998,7 +4998,7 @@
+                       memcpy(psimage->data, dataptr, psimage->length);
+               }
+-              DGifCloseFile(gft);
++              DGifCloseFile(gft, NULL);
+       } else
+ #endif /* HAVE_LIBGIF */
index 497f70c3323bc22ddb1d60c329f8f82ab82f31f5..c59b4e24d693a39347808a80f4b200c04b5642ba 100644 (file)
@@ -2,7 +2,7 @@ Summary:        The pslib C-library to create PostScript on the fly
 Summary(pl.UTF-8):     Biblioteka do generowania w locie plików PostScript
 Name:          pslib
 Version:       0.4.5
-Release:       6
+Release:       7
 License:       LGPL v2+
 Group:         Libraries
 Source0:       http://downloads.sourceforge.net/pslib/%{name}-%{version}.tar.gz
This page took 0.03369 seconds and 4 git commands to generate.