]> git.pld-linux.org Git - packages/pound.git/blob - pound.spec
- logging patch bugfixes; rel 5
[packages/pound.git] / pound.spec
1 Summary:        Pound - reverse-proxy and load-balancer
2 Summary(pl.UTF-8):      Pound - reverse-proxy i load-balancer
3 Name:           pound
4 Version:        2.4.3
5 Release:        5
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://www.apsis.ch/pound/Pound-%{version}.tgz
9 # Source0-md5:  2de4c2ac1023b420b74a1bc08fb93b8a
10 Patch0:         %{name}-overquote.patch
11 Patch1:         %{name}-hash-UL.patch
12 Patch2:         %{name}-logfile.patch
13 Patch3:         %{name}-daemonize.patch
14 Patch4:         %{name}-log-notice.patch
15 Source1:        %{name}.cfg
16 Source2:        %{name}.init
17 Source3:        %{name}.sysconfig
18 Source4:        %{name}.logrotate
19 URL:            http://www.apsis.ch/pound/
20 BuildRequires:  automake
21 BuildRequires:  openssl-devel >= 0.9.7d
22 BuildRequires:  pcre-devel
23 BuildRequires:  rpmbuild(macros) >= 1.202
24 Requires(post,preun):   /sbin/chkconfig
25 Requires(postun):       /usr/sbin/groupdel
26 Requires(postun):       /usr/sbin/userdel
27 Requires(pre):  /bin/id
28 Requires(pre):  /usr/bin/getgid
29 Requires(pre):  /usr/sbin/groupadd
30 Requires(pre):  /usr/sbin/useradd
31 Requires:       rc-scripts
32 Provides:       group(pound)
33 Provides:       user(pound)
34 Conflicts:      logrotate < 3.7-4
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         _sysconfdir     /etc/pound
38
39 %description
40 The Pound program is a reverse proxy, load balancer and HTTPS
41 front-end for Web server(s). Pound was developped to enable
42 distributing the load among several Web-servers and to allow for a
43 convenient SSL wrapper for those Web servers that do not offer it
44 natively. Pound is distributed under the GPL - no warranty, it's free
45 to use, copy and give away.
46
47 %description -l pl.UTF-8
48 Program Pound jest odwrotnym proxy, load-balancerem i interfejsem
49 HTTPS do serwera(ów) WWW. Pount został stworzony by pozwolić na
50 rozdzielenie obciążenia na kilka serwerów WWW i pozwolić na wygodne
51 opakowanie SSL-em tych serwerów, które same nie obsługują SSL. Pound
52 jest rozpowszechniany na licencji GPL - bez gwarancji, z możliwością
53 swobodnego używania, kopiowania i rozdawania.
54
55 %prep
56 %setup -q -n Pound-%{version}
57 %patch0 -p1
58 %patch1 -p1
59 %patch2 -p1
60 %patch3 -p1
61 %patch4 -p1
62
63 %build
64 cp -f /usr/share/automake/config.sub .
65 %configure \
66         --with-maxbuf=2048
67 %{__make}
68
69 %install
70 rm -rf $RPM_BUILD_ROOT
71 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8,%{_sysconfdir},/etc/{sysconfig,logrotate.d,rc.d/init.d}} \
72         $RPM_BUILD_ROOT{/var/log/{%{name},archive/%{name}},/var/run/%{name}}
73
74 install pound    $RPM_BUILD_ROOT%{_sbindir}
75 install poundctl $RPM_BUILD_ROOT%{_sbindir}
76 install pound.8  $RPM_BUILD_ROOT%{_mandir}/man8
77 install poundctl.8 $RPM_BUILD_ROOT%{_mandir}/man8
78 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
79 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
80 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
81 install %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %pre
87 %groupadd -g 200 %{name}
88 %useradd -u 200 -d /var/lib/%{name} -g %{name} -c "Pound Daemon" %{name}
89
90 %post
91 for a in access.log pound.log; do
92         if [ ! -f /var/log/%{name}/$a ]; then
93                 touch /var/log/%{name}/$a
94                 chown pound:pound /var/log/%{name}/$a
95                 chmod 644 /var/log/%{name}/$a
96         fi
97 done
98 /sbin/chkconfig --add %{name}
99 %service %{name} restart "Pound Daemon"
100
101 %preun
102 if [ "$1" = "0" ]; then
103         %service %{name} stop
104         /sbin/chkconfig --del %{name}
105 fi
106
107 %postun
108 if [ "$1" = "0" ]; then
109         %userremove %{name}
110         %groupremove %{name}
111 fi
112
113 %files
114 %defattr(644,root,root,755)
115 %doc README FAQ CHANGELOG z*.py
116 %attr(755,root,root) %{_sbindir}/pound
117 %attr(755,root,root) %{_sbindir}/poundctl
118 %dir %{_sysconfdir}
119 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pound.cfg
120 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
121 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
122 %attr(754,root,root) /etc/rc.d/init.d/%{name}
123 %{_mandir}/man8/*
124 %dir /var/run/%{name}
125 %dir %attr(751,root,root) /var/log/%{name}
126 %attr(750,root,root) %dir /var/log/archive/%{name}
This page took 0.047962 seconds and 4 git commands to generate.