]> git.pld-linux.org Git - packages/pound.git/blob - pound.spec
- add -overquote, -hash-UL, -logfile patches
[packages/pound.git] / pound.spec
1 Summary:        Pound - reverse-proxy and load-balancer
2 Summary(pl.UTF-8):      Pound - reverse-proxy i load-balancer
3 Name:           pound
4 Version:        2.4.3
5 Release:        3
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://www.apsis.ch/pound/Pound-%{version}.tgz
9 # Source0-md5:  2de4c2ac1023b420b74a1bc08fb93b8a
10 Patch0:         %{name}-overquote.patch
11 Patch1:         %{name}-hash-UL.patch
12 Patch2:         %{name}-logfile.patch
13 Source1:        %{name}.cfg
14 Source2:        %{name}.init
15 Source3:        %{name}.sysconfig
16 URL:            http://www.apsis.ch/pound/
17 BuildRequires:  automake
18 BuildRequires:  openssl-devel >= 0.9.7d
19 BuildRequires:  pcre-devel
20 BuildRequires:  rpmbuild(macros) >= 1.202
21 Requires(post,preun):   /sbin/chkconfig
22 Requires(postun):       /usr/sbin/groupdel
23 Requires(postun):       /usr/sbin/userdel
24 Requires(pre):  /bin/id
25 Requires(pre):  /usr/bin/getgid
26 Requires(pre):  /usr/sbin/groupadd
27 Requires(pre):  /usr/sbin/useradd
28 Requires:       rc-scripts
29 Provides:       group(pound)
30 Provides:       user(pound)
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _sysconfdir     /etc/pound
34
35 %description
36 The Pound program is a reverse proxy, load balancer and HTTPS
37 front-end for Web server(s). Pound was developped to enable
38 distributing the load among several Web-servers and to allow for a
39 convenient SSL wrapper for those Web servers that do not offer it
40 natively. Pound is distributed under the GPL - no warranty, it's free
41 to use, copy and give away.
42
43 %description -l pl.UTF-8
44 Program Pound jest odwrotnym proxy, load-balancerem i interfejsem
45 HTTPS do serwera(ów) WWW. Pount został stworzony by pozwolić na
46 rozdzielenie obciążenia na kilka serwerów WWW i pozwolić na wygodne
47 opakowanie SSL-em tych serwerów, które same nie obsługują SSL. Pound
48 jest rozpowszechniany na licencji GPL - bez gwarancji, z możliwością
49 swobodnego używania, kopiowania i rozdawania.
50
51 %prep
52 %setup -q -n Pound-%{version}
53 %patch0 -p1
54 %patch1 -p1
55 %patch2 -p1
56
57 %build
58 cp -f /usr/share/automake/config.sub .
59 %configure \
60         --with-maxbuf=2048
61 %{__make}
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8,%{_sysconfdir},/etc/{sysconfig,rc.d/init.d}} \
66         $RPM_BUILD_ROOT{/var/log/{%{name},archive/%{name}},/var/run/%{name}}
67
68 install pound    $RPM_BUILD_ROOT%{_sbindir}
69 install poundctl $RPM_BUILD_ROOT%{_sbindir}
70 install pound.8  $RPM_BUILD_ROOT%{_mandir}/man8
71 install poundctl.8 $RPM_BUILD_ROOT%{_mandir}/man8
72 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
73 install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
74 install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %pre
80 %groupadd -g 200 %{name}
81 %useradd -u 200 -d /var/lib/%{name} -g %{name} -c "Pound Daemon" %{name}
82
83 %post
84 /sbin/chkconfig --add %{name}
85 %service %{name} restart "Pound Daemon"
86
87 %preun
88 if [ "$1" = "0" ]; then
89         %service %{name} stop
90         /sbin/chkconfig --del %{name}
91 fi
92
93 %postun
94 if [ "$1" = "0" ]; then
95         %userremove %{name}
96         %groupremove %{name}
97 fi
98
99 %files
100 %defattr(644,root,root,755)
101 %doc README FAQ CHANGELOG z*.py
102 %attr(755,root,root) %{_sbindir}/*
103 %dir %{_sysconfdir}
104 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pound.cfg
105 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
106 %attr(754,root,root) /etc/rc.d/init.d/%{name}
107 %{_mandir}/man8/*
108 %dir /var/run/%{name}
109 %dir %attr(751,root,root) /var/log/%{name}
110 %attr(750,root,root) %dir /var/log/archive/%{name}
This page took 0.063016 seconds and 3 git commands to generate.