]> git.pld-linux.org Git - packages/pound.git/blame - pound.spec
- add systemd tmpfiles config
[packages/pound.git] / pound.spec
CommitLineData
73807a5d 1Summary: Pound - reverse-proxy and load-balancer
7fbec31c 2Summary(pl.UTF-8): Pound - reverse-proxy i load-balancer
73807a5d 3Name: pound
99431378
ER
4Version: 2.6
5Release: 1
73807a5d 6License: GPL
7Group: Networking/Daemons
73807a5d 8Source0: http://www.apsis.ch/pound/Pound-%{version}.tgz
99431378 9# Source0-md5: 8c913b527332694943c4c67c8f152071
487cceae
ER
10Patch0: %{name}-hash-UL.patch
11Patch1: %{name}-logfile.patch
12Patch2: %{name}-daemonize.patch
13Patch3: %{name}-log-notice.patch
14Patch4: %{name}-man.patch
73807a5d 15Source1: %{name}.cfg
16Source2: %{name}.init
ef2dd428 17Source3: %{name}.sysconfig
6b1b2506 18Source4: %{name}.logrotate
73807a5d 19URL: http://www.apsis.ch/pound/
f8a55c4f 20BuildRequires: automake
18e83af5 21BuildRequires: openssl-devel >= 0.9.7d
335ccc63 22BuildRequires: openssl-tools
f8a55c4f 23BuildRequires: pcre-devel
5474a5a6 24BuildRequires: rpmbuild(macros) >= 1.202
6e57d9ed 25Requires(post,preun): /sbin/chkconfig
5474a5a6
ER
26Requires(postun): /usr/sbin/groupdel
27Requires(postun): /usr/sbin/userdel
28Requires(pre): /bin/id
29Requires(pre): /usr/bin/getgid
30Requires(pre): /usr/sbin/groupadd
31Requires(pre): /usr/sbin/useradd
767184e8 32Requires: pcre >= 7.8
2dbe9c52 33Requires: rc-scripts
5474a5a6
ER
34Provides: group(pound)
35Provides: user(pound)
6b1b2506 36Conflicts: logrotate < 3.7-4
73807a5d 37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
9df600c4
ER
39%define _sysconfdir /etc/pound
40
73807a5d 41%description
42The Pound program is a reverse proxy, load balancer and HTTPS
43front-end for Web server(s). Pound was developped to enable
44distributing the load among several Web-servers and to allow for a
45convenient SSL wrapper for those Web servers that do not offer it
46natively. Pound is distributed under the GPL - no warranty, it's free
47to use, copy and give away.
48
ebd232a4 49%description -l pl.UTF-8
f8243939 50Program Pound jest odwrotnym proxy, load-balancerem i interfejsem
ebd232a4
JR
51HTTPS do serwera(ów) WWW. Pount został stworzony by pozwolić na
52rozdzielenie obciążenia na kilka serwerów WWW i pozwolić na wygodne
53opakowanie SSL-em tych serwerów, które same nie obsługują SSL. Pound
54jest rozpowszechniany na licencji GPL - bez gwarancji, z możliwością
55swobodnego używania, kopiowania i rozdawania.
f8243939 56
73807a5d 57%prep
fd0369ad 58%setup -q -n Pound-%{version}
9df600c4
ER
59%patch0 -p1
60%patch1 -p1
61%patch2 -p1
6b1b2506
ER
62%patch3 -p1
63%patch4 -p1
73807a5d 64
65%build
f8a55c4f 66cp -f /usr/share/automake/config.sub .
9ea1ad0e 67%configure \
68 --with-maxbuf=2048
9df600c4 69%{__make}
73807a5d 70
71%install
72rm -rf $RPM_BUILD_ROOT
6b1b2506 73install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8,%{_sysconfdir},/etc/{sysconfig,logrotate.d,rc.d/init.d}} \
9df600c4 74 $RPM_BUILD_ROOT{/var/log/{%{name},archive/%{name}},/var/run/%{name}}
73807a5d 75
b329097e
ER
76install -p pound $RPM_BUILD_ROOT%{_sbindir}
77install -p poundctl $RPM_BUILD_ROOT%{_sbindir}
78cp -p pound.8 $RPM_BUILD_ROOT%{_mandir}/man8
79cp -p poundctl.8 $RPM_BUILD_ROOT%{_mandir}/man8
80cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
81install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
82cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
83cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
73807a5d 84
6e57d9ed
JB
85%clean
86rm -rf $RPM_BUILD_ROOT
87
5474a5a6
ER
88%pre
89%groupadd -g 200 %{name}
90%useradd -u 200 -d /var/lib/%{name} -g %{name} -c "Pound Daemon" %{name}
91
73807a5d 92%post
6b1b2506
ER
93for a in access.log pound.log; do
94 if [ ! -f /var/log/%{name}/$a ]; then
95 touch /var/log/%{name}/$a
96 chown pound:pound /var/log/%{name}/$a
97 chmod 644 /var/log/%{name}/$a
98 fi
99done
73807a5d 100/sbin/chkconfig --add %{name}
5474a5a6 101%service %{name} restart "Pound Daemon"
73807a5d 102
103%preun
cfc0cb59
ER
104if [ "$1" = "0" ]; then
105 %service %{name} stop
106 /sbin/chkconfig --del %{name}
73807a5d 107fi
73807a5d 108
5474a5a6
ER
109%postun
110if [ "$1" = "0" ]; then
111 %userremove %{name}
112 %groupremove %{name}
113fi
114
73807a5d 115%files
116%defattr(644,root,root,755)
35c6c398 117%doc README FAQ CHANGELOG z*.py
6b1b2506
ER
118%attr(755,root,root) %{_sbindir}/pound
119%attr(755,root,root) %{_sbindir}/poundctl
9df600c4
ER
120%dir %{_sysconfdir}
121%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pound.cfg
ef2dd428 122%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
6b1b2506 123%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
9a81a858 124%attr(754,root,root) /etc/rc.d/init.d/%{name}
83dd8e4d 125%{_mandir}/man8/*
5474a5a6 126%dir /var/run/%{name}
9df600c4
ER
127%dir %attr(751,root,root) /var/log/%{name}
128%attr(750,root,root) %dir /var/log/archive/%{name}
This page took 0.116491 seconds and 4 git commands to generate.