]> git.pld-linux.org Git - packages/pound.git/blame - pound.spec
- just in case: do not free(NULL)
[packages/pound.git] / pound.spec
CommitLineData
73807a5d 1Summary: Pound - reverse-proxy and load-balancer
7fbec31c 2Summary(pl.UTF-8): Pound - reverse-proxy i load-balancer
73807a5d 3Name: pound
fe6cfeb6 4Version: 2.5
1ec54a15 5Release: 2
73807a5d 6License: GPL
7Group: Networking/Daemons
73807a5d 8Source0: http://www.apsis.ch/pound/Pound-%{version}.tgz
fe6cfeb6 9# Source0-md5: 8a39f5902094619afcda7d12d9d8342c
487cceae
ER
10Patch0: %{name}-hash-UL.patch
11Patch1: %{name}-logfile.patch
12Patch2: %{name}-daemonize.patch
13Patch3: %{name}-log-notice.patch
14Patch4: %{name}-man.patch
fe6cfeb6 15Patch5: %{name}-openssl.patch
1ec54a15 16Patch6: MultipleAddHeaderHonored.diff
73807a5d 17Source1: %{name}.cfg
18Source2: %{name}.init
ef2dd428 19Source3: %{name}.sysconfig
6b1b2506 20Source4: %{name}.logrotate
73807a5d 21URL: http://www.apsis.ch/pound/
f8a55c4f 22BuildRequires: automake
18e83af5 23BuildRequires: openssl-devel >= 0.9.7d
335ccc63 24BuildRequires: openssl-tools
f8a55c4f 25BuildRequires: pcre-devel
5474a5a6 26BuildRequires: rpmbuild(macros) >= 1.202
6e57d9ed 27Requires(post,preun): /sbin/chkconfig
5474a5a6
ER
28Requires(postun): /usr/sbin/groupdel
29Requires(postun): /usr/sbin/userdel
30Requires(pre): /bin/id
31Requires(pre): /usr/bin/getgid
32Requires(pre): /usr/sbin/groupadd
33Requires(pre): /usr/sbin/useradd
767184e8 34Requires: pcre >= 7.8
2dbe9c52 35Requires: rc-scripts
5474a5a6
ER
36Provides: group(pound)
37Provides: user(pound)
6b1b2506 38Conflicts: logrotate < 3.7-4
73807a5d 39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
9df600c4
ER
41%define _sysconfdir /etc/pound
42
73807a5d 43%description
44The Pound program is a reverse proxy, load balancer and HTTPS
45front-end for Web server(s). Pound was developped to enable
46distributing the load among several Web-servers and to allow for a
47convenient SSL wrapper for those Web servers that do not offer it
48natively. Pound is distributed under the GPL - no warranty, it's free
49to use, copy and give away.
50
ebd232a4 51%description -l pl.UTF-8
f8243939 52Program Pound jest odwrotnym proxy, load-balancerem i interfejsem
ebd232a4
JR
53HTTPS do serwera(ów) WWW. Pount został stworzony by pozwolić na
54rozdzielenie obciążenia na kilka serwerów WWW i pozwolić na wygodne
55opakowanie SSL-em tych serwerów, które same nie obsługują SSL. Pound
56jest rozpowszechniany na licencji GPL - bez gwarancji, z możliwością
57swobodnego używania, kopiowania i rozdawania.
f8243939 58
73807a5d 59%prep
fd0369ad 60%setup -q -n Pound-%{version}
9df600c4
ER
61%patch0 -p1
62%patch1 -p1
63%patch2 -p1
6b1b2506
ER
64%patch3 -p1
65%patch4 -p1
fe6cfeb6 66%patch5 -p1
1ec54a15 67%patch6 -p0
73807a5d 68
69%build
f8a55c4f 70cp -f /usr/share/automake/config.sub .
9ea1ad0e 71%configure \
72 --with-maxbuf=2048
9df600c4 73%{__make}
73807a5d 74
75%install
76rm -rf $RPM_BUILD_ROOT
6b1b2506 77install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8,%{_sysconfdir},/etc/{sysconfig,logrotate.d,rc.d/init.d}} \
9df600c4 78 $RPM_BUILD_ROOT{/var/log/{%{name},archive/%{name}},/var/run/%{name}}
73807a5d 79
49082852 80install pound $RPM_BUILD_ROOT%{_sbindir}
81install poundctl $RPM_BUILD_ROOT%{_sbindir}
82install pound.8 $RPM_BUILD_ROOT%{_mandir}/man8
83install poundctl.8 $RPM_BUILD_ROOT%{_mandir}/man8
9df600c4 84install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
9a81a858 85install %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
ef2dd428 86install %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
6b1b2506 87install %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
73807a5d 88
6e57d9ed
JB
89%clean
90rm -rf $RPM_BUILD_ROOT
91
5474a5a6
ER
92%pre
93%groupadd -g 200 %{name}
94%useradd -u 200 -d /var/lib/%{name} -g %{name} -c "Pound Daemon" %{name}
95
73807a5d 96%post
6b1b2506
ER
97for a in access.log pound.log; do
98 if [ ! -f /var/log/%{name}/$a ]; then
99 touch /var/log/%{name}/$a
100 chown pound:pound /var/log/%{name}/$a
101 chmod 644 /var/log/%{name}/$a
102 fi
103done
73807a5d 104/sbin/chkconfig --add %{name}
5474a5a6 105%service %{name} restart "Pound Daemon"
73807a5d 106
107%preun
cfc0cb59
ER
108if [ "$1" = "0" ]; then
109 %service %{name} stop
110 /sbin/chkconfig --del %{name}
73807a5d 111fi
73807a5d 112
5474a5a6
ER
113%postun
114if [ "$1" = "0" ]; then
115 %userremove %{name}
116 %groupremove %{name}
117fi
118
73807a5d 119%files
120%defattr(644,root,root,755)
35c6c398 121%doc README FAQ CHANGELOG z*.py
6b1b2506
ER
122%attr(755,root,root) %{_sbindir}/pound
123%attr(755,root,root) %{_sbindir}/poundctl
9df600c4
ER
124%dir %{_sysconfdir}
125%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pound.cfg
ef2dd428 126%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
6b1b2506 127%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
9a81a858 128%attr(754,root,root) /etc/rc.d/init.d/%{name}
83dd8e4d 129%{_mandir}/man8/*
5474a5a6 130%dir /var/run/%{name}
9df600c4
ER
131%dir %attr(751,root,root) /var/log/%{name}
132%attr(750,root,root) %dir /var/log/archive/%{name}
This page took 0.574679 seconds and 4 git commands to generate.