]> git.pld-linux.org Git - packages/postgresql.git/commitdiff
Up to 15.3. auto/th/postgresql-15.3-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 22 May 2023 10:31:55 +0000 (12:31 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 22 May 2023 10:31:55 +0000 (12:31 +0200)
ac.patch
postgresql-conf.patch
postgresql.spec

index b0340cfd01d8092fbc1232c0dd1969c90135a562..4f0e687d5abe084ed117dc4ffec37f5d58850ae0 100644 (file)
--- a/ac.patch
+++ b/ac.patch
@@ -2,12 +2,13 @@
 +++ postgresql-14.0/configure.ac       2021-11-09 09:38:45.296275820 +0100
 @@ -19,10 +19,6 @@ m4_pattern_forbid(^PGAC_)dnl to catch un
  
- AC_INIT([PostgreSQL], [14.8], [pgsql-bugs@lists.postgresql.org], [], [https://www.postgresql.org/])
+ AC_INIT([PostgreSQL], [15.3], [pgsql-bugs@lists.postgresql.org], [], [https://www.postgresql.org/])
  
 -m4_if(m4_defn([m4_PACKAGE_VERSION]), [2.69], [], [m4_fatal([Autoconf version 2.69 is required.
 -Untested combinations of 'autoconf' and PostgreSQL versions are not
 -recommended.  You can remove the check from 'configure.ac' but it is then
 -your responsibility whether the result works or not.])])
- AC_COPYRIGHT([Copyright (c) 1996-2021, PostgreSQL Global Development Group])
+ AC_COPYRIGHT([Copyright (c) 1996-2022, PostgreSQL Global Development Group])
  AC_CONFIG_SRCDIR([src/backend/access/common/heaptuple.c])
  AC_CONFIG_AUX_DIR(config)
+
index 805b22dab0d63c1aec96f94f69d1ea7b3a0ba360..71db0803f5d23cfff92ee3e7a8ef5cbf4240a0dc 100644 (file)
@@ -1,15 +1,15 @@
 diff -urNp -x '*.orig' postgresql-12.4.org/src/backend/utils/misc/postgresql.conf.sample postgresql-12.4/src/backend/utils/misc/postgresql.conf.sample
 --- postgresql-12.4.org/src/backend/utils/misc/postgresql.conf.sample  2020-08-10 23:15:53.000000000 +0200
 +++ postgresql-12.4/src/backend/utils/misc/postgresql.conf.sample      2021-11-09 09:30:59.882648111 +0100
-@@ -416,7 +416,7 @@
+@@ -441,7 +441,7 @@
  
  # - Where to Log -
  
 -#log_destination = 'stderr'           # Valid values are combinations of
 +log_destination = 'syslog'            # Valid values are combinations of
-                                       # stderr, csvlog, syslog, and eventlog,
-                                       # depending on platform.  csvlog
-                                       # requires logging_collector to be on.
+                                       # stderr, csvlog, jsonlog, syslog, and
+                                       # eventlog, depending on platform.
+                                       # csvlog and jsonlog require
 @@ -463,9 +463,9 @@ log_destination = 'syslog'         # Valid valu
                                        # in all cases.
  
index 2eba9a991feb214bf9848361ac39ff647e2f38a2..637fee50d9e576d790e49c51777595b364bef6d5 100644 (file)
@@ -21,7 +21,7 @@
                                        # (disabled by default because it is a security risk)
 #
 
-%define mver 14
+%define mver 15
 
 Summary:       PostgreSQL Data Base Management System
 Summary(de.UTF-8):     PostgreSQL Datenbankverwaltungssystem
@@ -34,12 +34,12 @@ Summary(tr.UTF-8):  Veri Tabanı Yönetim Sistemi
 Summary(uk.UTF-8):     PostgreSQL - система керування базами даних
 Summary(zh_CN.UTF-8):  PostgreSQL 客户端程序和库文件
 Name:          postgresql
-Version:       %{mver}.8
+Version:       %{mver}.3
 Release:       1
 License:       BSD
 Group:         Applications/Databases
 Source0:       https://ftp.postgresql.org/pub/source/v%{version}/%{name}-%{version}.tar.bz2
-# Source0-md5: d089f6f4f15f5b278252e867f3a45fd7
+# Source0-md5: 7cb75773ff8fbe533701562c3278206b
 Source1:       %{name}.init
 Source2:       pgsql-Database-HOWTO-html.tar.gz
 # Source2-md5: 5b656ddf1db41965761f85204a14398e
@@ -84,9 +84,9 @@ BuildRequires:        perl-Scalar-List-Utils
 BuildRequires: perl-devel
 %endif
 %if %{with python}
-BuildRequires: python >= 1:2.4
-BuildRequires: python-devel >= 1:2.4
-BuildRequires: python-modules >= 1:2.4
+BuildRequires: python3 >= 1:2.4
+BuildRequires: python3-devel >= 1:2.4
+BuildRequires: python3-modules >= 1:2.4
 %endif
 BuildRequires: readline-devel >= 4.2
 BuildRequires: rpmbuild(macros) >= 1.671
@@ -128,6 +128,9 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _ulibdir        /usr/lib
 
+%define          filterout_c     -fvar-tracking-assignments
+%define          filterout_cxx   -fvar-tracking-assignments
+
 # omitted contribs:
 # spi, test_decoding, worker_spi - examples/tests
 # tsearch2 - old module for compatibility only
@@ -1151,6 +1154,7 @@ fi
 %{_includedir}/postgres_ext.h
 %dir %{_includedir}/postgresql/internal
 %{_includedir}/postgresql/internal/c.h
+%{_includedir}/postgresql/internal/fe-auth-sasl.h
 %{_includedir}/postgresql/internal/libpq-int.h
 %{_includedir}/postgresql/internal/port.h
 %{_includedir}/postgresql/internal/postgres_fe.h
@@ -1244,7 +1248,7 @@ fi
 %if %{with python}
 %files module-plpython -f plpython-%{mver}.lang
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_pgmoduledir}/plpython2.so
+%attr(755,root,root) %{_pgmoduledir}/plpython3.so
 %{_pgsqldir}/plpython*--*.sql
 %{_pgsqldir}/plpython*.control
 %endif
@@ -1520,33 +1524,21 @@ fi
 %endif
 %endif
 %if %{with python}
-%attr(755,root,root) %{_pgmoduledir}/hstore_plpython2.so
-%attr(755,root,root) %{_pgmoduledir}/jsonb_plpython2.so
-%attr(755,root,root) %{_pgmoduledir}/ltree_plpython2.so
+%attr(755,root,root) %{_pgmoduledir}/hstore_plpython3.so
+%attr(755,root,root) %{_pgmoduledir}/jsonb_plpython3.so
+%attr(755,root,root) %{_pgmoduledir}/ltree_plpython3.so
 %if %{with llvm}
-%{_pgmoduledir}/bitcode/hstore_plpython2
-%{_pgmoduledir}/bitcode/hstore_plpython2.index.bc
-%{_pgmoduledir}/bitcode/jsonb_plpython2
-%{_pgmoduledir}/bitcode/jsonb_plpython2.index.bc
-%{_pgmoduledir}/bitcode/ltree_plpython2
-%{_pgmoduledir}/bitcode/ltree_plpython2.index.bc
+%{_pgmoduledir}/bitcode/hstore_plpython3
+%{_pgmoduledir}/bitcode/hstore_plpython3.index.bc
+%{_pgmoduledir}/bitcode/jsonb_plpython3
+%{_pgmoduledir}/bitcode/jsonb_plpython3.index.bc
+%{_pgmoduledir}/bitcode/ltree_plpython3
+%{_pgmoduledir}/bitcode/ltree_plpython3.index.bc
 %endif
-%{_pgsqldir}/hstore_plpythonu--*.sql
-%{_pgsqldir}/hstore_plpythonu.control
-%{_pgsqldir}/hstore_plpython2u--*.sql
-%{_pgsqldir}/hstore_plpython2u.control
 %{_pgsqldir}/hstore_plpython3u--*.sql
 %{_pgsqldir}/hstore_plpython3u.control
-%{_pgsqldir}/jsonb_plpythonu--*.sql
-%{_pgsqldir}/jsonb_plpythonu.control
-%{_pgsqldir}/jsonb_plpython2u--*.sql
-%{_pgsqldir}/jsonb_plpython2u.control
 %{_pgsqldir}/jsonb_plpython3u--*.sql
 %{_pgsqldir}/jsonb_plpython3u.control
-%{_pgsqldir}/ltree_plpythonu--*.sql
-%{_pgsqldir}/ltree_plpythonu.control
-%{_pgsqldir}/ltree_plpython2u--*.sql
-%{_pgsqldir}/ltree_plpython2u.control
 %{_pgsqldir}/ltree_plpython3u--*.sql
 %{_pgsqldir}/ltree_plpython3u.control
 %endif
This page took 0.207652 seconds and 4 git commands to generate.