]> git.pld-linux.org Git - packages/portaudio.git/blob - portaudio.spec
7633f0094346a9853aeb0f1fbbfc83cf0bdb4622
[packages/portaudio.git] / portaudio.spec
1 #
2 # TODO: portaudio_asihpi_406.patch is broken
3 #
4 # Conditional build:
5 %bcond_without  static_libs     # don't build static libraries
6 %bcond_without  apidocs         # documentation generated with doxygen
7 %bcond_with     asahpi          # ASA HPI support
8 #
9 Summary:        Free, cross platform, open-source, audio I/O library
10 Summary(pl.UTF-8):      Darmowa, międzyplatformowa i otwarta biblioteka I/O audio
11 Name:           portaudio
12 Version:        19
13 %define snap    20110326
14 Release:        1.%{snap}.1
15 License:        MIT-like (see LICENSE.txt)
16 Group:          Libraries
17 Source0:        http://www.portaudio.com/archives/pa_stable_v%{version}_%{snap}.tgz
18 # Source0-md5:  8f266ce03638419ef46e4efcb0fabde6
19 Patch0:         %{name}-ac.patch
20 Patch1:         http://audioscience.com/internet/download/drivers/released/v4/06/portaudio_asihpi_406.patch
21 URL:            http://www.portaudio.com/
22 BuildRequires:  alsa-lib-devel >= 0.9
23 BuildRequires:  autoconf >= 2.13
24 BuildRequires:  automake
25 %{?with_apidocs:BuildRequires:  doxygen}
26 %{?with_asahpi:BuildRequires:   hpklinux-devel >= 4.06}
27 BuildRequires:  jack-audio-connection-kit-devel
28 BuildRequires:  libstdc++-devel
29 BuildRequires:  pkgconfig
30 %{?with_asahpi:Requires:        hpklinux-libs >= 4.06}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 PortAudio is a free, cross platform, open-source, audio I/O library.
35 It lets you write simple audio programs in 'C' that will compile and
36 run on many platforms including Windows, Macintosh (8,9,X), Unix
37 (OSS), SGI, and BeOS.
38
39 %description -l pl.UTF-8
40 PortAudio to darmowa, międzyplatformowa i otwarta biblioteka I/O
41 audio. Pozwala na pisanie prostych programów w "C", które będą się
42 kompilować i uruchamiać na wielu platformach, w tym Windows, Macintosh
43 (8,9,X), Unix (OSS), SGI, i BeOS.
44
45 %package devel
46 Summary:        Header files for PortAudio library
47 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki PortAudio
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       alsa-lib-devel >= 0.9
51 %{?with_asahpi:Requires:        hpklinux-devel >= 4.06}
52 Requires:       jack-audio-connection-kit-devel
53
54 %description devel
55 Header files for PortAudio library.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe biblioteki PortAudio.
59
60 %package static
61 Summary:        Static PortAudio library
62 Summary(pl.UTF-8):      Statyczna biblioteka PortAudio
63 Group:          Development/Libraries
64 Requires:       %{name}-devel = %{version}-%{release}
65
66 %description static
67 Static PortAudio library.
68
69 %description static -l pl.UTF-8
70 Statyczna biblioteka PortAudio.
71
72 %package apidocs
73 Summary:        portaudio API documentation
74 Summary(pl.UTF-8):      Documentacja API portaudio
75 Group:          Documentation
76
77 %description apidocs
78 Documentation for portaudio API in HTML format generated from portaudio
79 sources by doxygen.
80
81 %description apidocs -l pl.UTF-8
82 Dokumentacja API portaudio w formacie HTML generowane ze
83 źrodeł portaudio przez doxygen.
84
85 %package c++
86 Summary:        C++ binding for PortAudio library
87 Summary(pl.UTF-8):      Wiązanie C++ do biblioteki PortAudio
88 Group:          Libraries
89 Requires:       %{name} = %{version}-%{release}
90
91 %description c++
92 C++ binding for PortAudio library.
93
94 %description c++ -l pl.UTF-8
95 Wiązanie C++ do biblioteki PortAudio.
96
97 %package c++-devel
98 Summary:        Header files for C++ binding for PortAudio library
99 Summary(pl.UTF-8):      Pliki nagłówkowe wiązania C++ do biblioteki PortAudio
100 Group:          Development/Libraries
101 Requires:       %{name}-c++ = %{version}-%{release}
102 Requires:       %{name}-devel = %{version}-%{release}
103 Requires:       libstdc++-devel
104
105 %description c++-devel
106 Header files for C++ binding for PortAudio library.
107
108 %description c++-devel -l pl.UTF-8
109 Pliki nagłówkowe wiązania C++ do biblioteki PortAudio.
110
111 %package c++-static
112 Summary:        Static library of C++ binding for PortAudio library
113 Summary(pl.UTF-8):      Statyczna biblioteka wiązania C++ do biblioteki PortAudio
114 Group:          Development/Libraries
115 Requires:       %{name}-c++-devel = %{version}-%{release}
116
117 %description c++-static
118 Static library of C++ binding for PortAudio library.
119
120 %description c++-static -l pl.UTF-8
121 Statyczna biblioteka wiązania C++ do biblioteki PortAudio.
122
123 %prep
124 %setup -q -n %{name}
125 %patch0 -p1
126 %if %{with asahpi}
127 %patch1 -p0
128 %endif
129
130 %build
131 cp -f /usr/share/automake/config.sub .
132 %{__libtoolize}
133 cd bindings/cpp
134 %{__aclocal}
135 %{__autoconf}
136 %{__automake}
137 cd ../..
138 %{__aclocal}
139 %{__autoconf}
140 %configure \
141         --enable-cxx \
142         --enable-static%{!?with_static_libs:=no}
143
144 %{__make}
145 %{?with_apidocs:/usr/bin/doxygen}
146
147 %install
148 rm -rf $RPM_BUILD_ROOT
149
150 %{__make} install \
151         DESTDIR=$RPM_BUILD_ROOT
152
153 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post   -p /sbin/ldconfig
159 %postun -p /sbin/ldconfig
160
161 %files
162 %defattr(644,root,root,755)
163 %doc README.txt LICENSE.txt
164 %attr(755,root,root) %{_libdir}/libportaudio.so.*.*.*
165 %attr(755,root,root) %ghost %{_libdir}/libportaudio.so.2
166
167 %files devel
168 %defattr(644,root,root,755)
169 %attr(755,root,root) %{_libdir}/libportaudio.so
170 %{_includedir}/pa_jack.h
171 %{_includedir}/pa_linux_alsa.h
172 %{_includedir}/portaudio.h
173 %{_pkgconfigdir}/portaudio-2.0.pc
174
175 %if %{with static_libs}
176 %files static
177 %defattr(644,root,root,755)
178 %{_libdir}/libportaudio.a
179 %endif
180
181 %if %{with apidocs}
182 %files apidocs
183 %defattr(644,root,root,755)
184 %doc doc/html/*
185 %endif
186
187 %files c++
188 %defattr(644,root,root,755)
189 %doc bindings/cpp/{COPYING,ChangeLog}
190 %attr(755,root,root) %{_libdir}/libportaudiocpp.so.*.*.*
191 %attr(755,root,root) %ghost %{_libdir}/libportaudiocpp.so.0
192
193 %files c++-devel
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{_libdir}/libportaudiocpp.so
196 %{_includedir}/portaudiocpp
197 %{_pkgconfigdir}/portaudiocpp.pc
198
199 %files c++-static
200 %defattr(644,root,root,755)
201 %{_libdir}/libportaudiocpp.a
This page took 0.089347 seconds and 2 git commands to generate.