]> git.pld-linux.org Git - packages/poppler.git/blob - poppler.spec
- 0.14.1
[packages/poppler.git] / poppler.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # disable gtk-doc
4 %bcond_without  cairo   # disable Cairo backend
5 %bcond_without  qt      # disable qt wrapper
6 %bcond_without  qt4     # disable qt4 wrapper
7 %bcond_without  cpp     # disable cpp wrapper
8 %bcond_without  glib    # disable glib wrapper
9 #
10 %define         cairo_ver       1.4.0
11 #
12 Summary:        PDF rendering library
13 Summary(pl.UTF-8):      Biblioteka renderująca PDF
14 Name:           poppler
15 Version:        0.14.1
16 Release:        1
17 License:        GPL v2+
18 Group:          Libraries
19 Source0:        http://poppler.freedesktop.org/%{name}-%{version}.tar.gz
20 # Source0-md5:  1d27cb8a09aaa373660fd608b258022a
21 URL:            http://poppler.freedesktop.org/
22 %{?with_qt4:BuildRequires:      QtGui-devel >= 4.1.0}
23 %{?with_qt4:BuildRequires:      QtTest-devel >= 4.1.0}
24 %{?with_qt4:BuildRequires:      QtXml-devel >= 4.1.0}
25 BuildRequires:  autoconf >= 2.59
26 BuildRequires:  automake
27 %{?with_cairo:BuildRequires:    cairo-devel >= %{cairo_ver}}
28 BuildRequires:  docbook-dtd412-xml
29 BuildRequires:  fontconfig-devel
30 BuildRequires:  freetype-devel >= 2.0
31 %{?with_glib:BuildRequires:     glib2-devel >= 1:2.6.0}}
32 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.0}
33 BuildRequires:  libjpeg-devel
34 BuildRequires:  libstdc++-devel
35 BuildRequires:  libtool >= 2:1.5
36 BuildRequires:  libxml2-devel >= 2.0
37 BuildRequires:  openjpeg-devel
38 BuildRequires:  pkgconfig
39 %{?with_qt:BuildRequires:       qt-devel >= 3.0}
40 %{?with_qt4:BuildRequires:      qt4-build}
41 BuildRequires:  which
42 BuildRequires:  zlib-devel
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 A common PDF rendering library for integrating PDF viewing into
47 desktop applications (based on the xpdf-3.0 code base).
48
49 %description -l pl.UTF-8
50 Wspólna biblioteka renderująca PDF do integrowania oglądania PDF w
51 aplikacjach desktopowych (oparta na kodzie xpdf-3.0).
52
53 %package devel
54 Summary:        Poppler header files
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Poppler
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       fontconfig-devel
59 Requires:       freetype-devel >= 2.0
60 Requires:       libstdc++-devel
61 Requires:       openjpeg-devel
62
63 %description devel
64 Header files for the Poppler library.
65
66 %description devel -l pl.UTF-8
67 Pliki nagłówkowe biblioteki Poppler.
68
69 %package static
70 Summary:        Poppler static libraries
71 Summary(pl.UTF-8):      Statyczne biblioteki Poppler
72 Group:          Development/Libraries
73 Requires:       %{name}-devel = %{version}-%{release}
74
75 %description static
76 Poppler static libraries.
77
78 %description static -l pl.UTF-8
79 Statyczne biblioteki Poppler.
80
81 %package apidocs
82 Summary:        Poppler library API documentation
83 Summary(pl.UTF-8):      Dokumentacja API biblioteki Poppler
84 Group:          Documentation
85 Requires:       gtk-doc-common
86
87 %description apidocs
88 Poppler library API documentation.
89
90 %description apidocs -l pl.UTF-8
91 Dokumentacja API biblioteki Poppler.
92
93 %package cpp
94 Summary:        Cpp wrapper for poppler
95 Summary(pl.UTF-8):      Wrapper cpp dla popplera
96 Group:          Libraries
97 Requires:       %{name} = %{version}-%{release}
98
99 %description cpp
100 Cpp wrapper for poppler.
101
102 %description cpp -l pl.UTF-8
103 Wrapper cpp dla popplera.
104
105 %package cpp-devel
106 Summary:        Header files for cpp wrapper for poppler
107 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera cpp dla popplera
108 Group:          Development/Libraries
109 Requires:       %{name}-cpp = %{version}-%{release}
110 Requires:       %{name}-devel = %{version}-%{release}
111
112 %description cpp-devel
113 Header files for cpp wrapper for poppler.
114
115 %description cpp-devel -l pl.UTF-8
116 Pliki nagłówkowe wrappera cpp dla popplera.
117
118 %package cpp-static
119 Summary:        Static version of cpp wrapper for poppler
120 Summary(pl.UTF-8):      Statyczna wersja wrappera cpp dla popplera
121 Group:          Development/Libraries
122 Requires:       %{name}-cpp-devel = %{version}-%{release}
123
124 %description cpp-static
125 Static version of cpp wrapper for poppler.
126
127 %description cpp-static -l pl.UTF-8
128 Statyczna wersja wrappera cpp dla popplera.
129
130 %package glib
131 Summary:        GLib wrapper for poppler
132 Summary(pl.UTF-8):      Wrapper GLib dla popplera
133 Group:          Libraries
134 Requires:       %{name} = %{version}-%{release}
135 %{?with_cairo:Requires: cairo >= %{cairo_ver}}
136 Requires:       glib2 >= 1:2.6.0
137
138 %description glib
139 GLib wrapper for poppler.
140
141 %description glib -l pl.UTF-8
142 Wrapper GLib dla popplera.
143
144 %package glib-devel
145 Summary:        Header files for GLib wrapper for poppler
146 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera GLib dla popplera
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{version}-%{release}
149 Requires:       %{name}-glib = %{version}-%{release}
150 %{?with_cairo:Requires: cairo-devel >= %{cairo_ver}}
151 Requires:       glib2-devel >= 1:2.6.0
152
153 %description glib-devel
154 Header files for GLib wrapper for poppler.
155
156 %description glib-devel -l pl.UTF-8
157 Pliki nagłówkowe wrappera GLib dla popplera.
158
159 %package glib-static
160 Summary:        Static version of GLib wrapper for poppler
161 Summary(pl.UTF-8):      Statyczna wersja wrappera GLib dla popplera
162 Group:          Development/Libraries
163 Requires:       %{name}-glib-devel = %{version}-%{release}
164
165 %description glib-static
166 Static version of GLib wrapper for poppler.
167
168 %description glib-static -l pl.UTF-8
169 Statyczna wersja wrappera GLib dla popplera.
170
171 %package qt
172 Summary:        Qt wrapper for poppler
173 Summary(pl.UTF-8):      Wrapper Qt dla popplera
174 Group:          Libraries
175 Requires:       %{name} = %{version}-%{release}
176
177 %description qt
178 Qt wrapper for poppler.
179
180 %description qt -l pl.UTF-8
181 Wrapper Qt dla popplera.
182
183 %package qt-devel
184 Summary:        Header files for Qt wrapper for poppler
185 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt dla popplera
186 Group:          Development/Libraries
187 Requires:       %{name}-devel = %{version}-%{release}
188 Requires:       %{name}-qt = %{version}-%{release}
189 Requires:       qt-devel
190
191 %description qt-devel
192 Header files for Qt wrapper for poppler.
193
194 %description qt-devel -l pl.UTF-8
195 Pliki nagłówkowe wrappera Qt dla popplera.
196
197 %package qt-static
198 Summary:        Static version of Qt wrapper for poppler
199 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt dla popplera
200 Group:          Development/Libraries
201 Requires:       %{name}-qt-devel = %{version}-%{release}
202
203 %description qt-static
204 Static version of Qt wrapper for poppler.
205
206 %description qt-static -l pl.UTF-8
207 Statyczna wersja wrappera Qt dla popplera.
208
209 %package Qt
210 Summary:        Qt4 wrapper for poppler
211 Summary(pl.UTF-8):      Wrapper Qt4 dla popplera
212 Group:          Libraries
213 Requires:       %{name} = %{version}-%{release}
214
215 %description Qt
216 Qt4 wrapper for poppler.
217
218 %description Qt -l pl.UTF-8
219 Wrapper Qt4 dla popplera.
220
221 %package Qt-devel
222 Summary:        Header files for Qt4 wrapper for poppler
223 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt4 dla popplera
224 Group:          Development/Libraries
225 Requires:       %{name}-Qt = %{version}-%{release}
226 Requires:       %{name}-devel = %{version}-%{release}
227 Requires:       QtGui-devel
228 Requires:       QtXml-devel
229
230 %description Qt-devel
231 Header files for Qt4 wrapper for poppler.
232
233 %description Qt-devel -l pl.UTF-8
234 Pliki nagłówkowe wrapper Qt4 dla popplera.
235
236 %package Qt-static
237 Summary:        Static version of Qt4 wrapper for poppler
238 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt4 dla popplera
239 Group:          Development/Libraries
240 Requires:       %{name}-Qt-devel = %{version}-%{release}
241
242 %description Qt-static
243 Static version of Qt4 wrapper for poppler.
244
245 %description Qt-static -l pl.UTF-8
246 Statyczna wersja wrappera Qt4 dla popplera.
247
248 %package progs
249 Summary:        Set of tools for viewing information and converting PDF files
250 Summary(pl.UTF-8):      Zestaw narzędzi do wyświetlania informacji i konwertowania plików PDF
251 Group:          Applications/Publishing
252 Provides:       pdftops
253 Obsoletes:      pdftohtml
254 Obsoletes:      pdftohtml-pdftops
255 Obsoletes:      poppler-utils
256 Obsoletes:      xpdf-tools
257
258 %description progs
259 Package contains utilites for PDF files. These utilities allow to
260 - extract information about PDF files
261 - extract images from PDF files
262 - convert PDF files to HTML, plain text and PS formats
263
264 %description progs -l pl.UTF-8
265 Pakiet zawiera zestaw narzędzi do plików PDF. Programy te umożliwiają
266 - wyświetlanie informacji o plikach PDF
267 - wydobywanie obrazków z plików PDF
268 - konwersję plików PDF do formatów takich jak HTML, PS czy też
269   czystego tekstu
270
271 %prep
272 %setup -q
273
274 %build
275 %{?with_apidocs:%{__gtkdocize}}
276 %{__libtoolize}
277 %{__aclocal} -I m4
278 %{__autoconf} -f
279 %{__autoheader}
280 %{__automake}
281 %configure \
282         QTINC=%{_includedir}/qt \
283         QTLIB=%{_libdir} \
284         --disable-gtk-test \
285         %{!?with_cairo:--disable-cairo-output} \
286         %{!?with_qt:--disable-poppler-qt} \
287         %{!?with_qt4:--disable-poppler-qt4} \
288         %{!?with_cpp:--disable-poppler-cpp} \
289         %{!?with_glib:--disable-poppler-glib} \
290         --enable-a4-paper \
291         %{?with_apidocs:--enable-gtk-doc} \
292         --enable-xpdf-headers \
293         --enable-zlib \
294         --enable-dependency-tracking \
295         --with-html-dir=%{_gtkdocdir}
296
297 %{__make}
298
299 %install
300 rm -rf $RPM_BUILD_ROOT
301
302 %{__make} install \
303         DESTDIR=$RPM_BUILD_ROOT
304
305 %if %{without apidocs}
306 # why it still installs them, brr
307 rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/poppler
308 %endif
309
310 %clean
311 rm -rf $RPM_BUILD_ROOT
312
313 %post   -p /sbin/ldconfig
314 %postun -p /sbin/ldconfig
315
316 %post   glib -p /sbin/ldconfig
317 %postun glib -p /sbin/ldconfig
318
319 %post   qt -p /sbin/ldconfig
320 %postun qt -p /sbin/ldconfig
321
322 %post   Qt -p /sbin/ldconfig
323 %postun Qt -p /sbin/ldconfig
324
325 %files
326 %defattr(644,root,root,755)
327 %doc AUTHORS ChangeLog NEWS README* TODO
328 %attr(755,root,root) %{_libdir}/libpoppler.so.*.*.*
329 %attr(755,root,root) %ghost %{_libdir}/libpoppler.so.6
330
331 %files devel
332 %defattr(644,root,root,755)
333 %attr(755,root,root) %{_libdir}/libpoppler.so
334 %{_libdir}/libpoppler.la
335 %dir %{_includedir}/poppler
336 %{_includedir}/poppler/poppler-config.h
337 %{_includedir}/poppler/[ABCDEFGJLMNOPRSTUX]*.h
338 %{_includedir}/poppler/goo
339 %{_includedir}/poppler/fofi
340 %{_includedir}/poppler/splash
341 %exclude %{_includedir}/poppler/glib
342 %{_pkgconfigdir}/poppler.pc
343 %{?with_cairo:%{_pkgconfigdir}/poppler-cairo.pc}
344 %{_pkgconfigdir}/poppler-splash.pc
345
346 %files static
347 %defattr(644,root,root,755)
348 %{_libdir}/libpoppler.a
349
350 %if %{with apidocs}
351 %files apidocs
352 %defattr(644,root,root,755)
353 %{_gtkdocdir}/poppler
354 %endif
355
356 %if %{with cpp}
357 %files cpp
358 %defattr(644,root,root,755)
359 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so.*.*.*
360 %attr(755,root,root) %ghost %{_libdir}/libpoppler-cpp.so.0
361
362 %files cpp-devel
363 %defattr(644,root,root,755)
364 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so
365 %{_libdir}/libpoppler-cpp.la
366 %{_includedir}/poppler/cpp
367 %{_pkgconfigdir}/poppler-cpp.pc
368
369 %files cpp-static
370 %defattr(644,root,root,755)
371 %{_libdir}/libpoppler-cpp.a
372 %endif
373
374 %if %{with glib}
375 %files glib
376 %defattr(644,root,root,755)
377 %attr(755,root,root) %{_libdir}/libpoppler-glib.so.*.*.*
378 %attr(755,root,root) %ghost %{_libdir}/libpoppler-glib.so.5
379
380 %files glib-devel
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_libdir}/libpoppler-glib.so
383 %{_libdir}/libpoppler-glib.la
384 %{_includedir}/poppler/glib
385 %{_pkgconfigdir}/poppler-glib.pc
386
387 %files glib-static
388 %defattr(644,root,root,755)
389 %{_libdir}/libpoppler-glib.a
390 %endif
391
392 %if %{with qt}
393 %files qt
394 %defattr(644,root,root,755)
395 %attr(755,root,root) %{_libdir}/libpoppler-qt.so.*.*.*
396 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt.so.2
397
398 %files qt-devel
399 %defattr(644,root,root,755)
400 %attr(755,root,root) %{_libdir}/libpoppler-qt.so
401 %{_libdir}/libpoppler-qt.la
402 %{_includedir}/poppler/qt3
403 %{_pkgconfigdir}/poppler-qt.pc
404
405 %files qt-static
406 %defattr(644,root,root,755)
407 %{_libdir}/libpoppler-qt.a
408 %endif
409
410 %if %{with qt4}
411 %files Qt
412 %defattr(644,root,root,755)
413 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so.*.*.*
414 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt4.so.3
415
416 %files Qt-devel
417 %defattr(644,root,root,755)
418 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so
419 %{_libdir}/libpoppler-qt4.la
420 %{_includedir}/poppler/qt4
421 %{_pkgconfigdir}/poppler-qt4.pc
422
423 %files Qt-static
424 %defattr(644,root,root,755)
425 %{_libdir}/libpoppler-qt4.a
426 %endif
427
428 %files progs
429 %defattr(644,root,root,755)
430 %attr(755,root,root) %{_bindir}/pdf*
431 %{_mandir}/man1/pdf*
This page took 0.159094 seconds and 4 git commands to generate.