]> git.pld-linux.org Git - packages/poppler.git/blob - poppler.spec
- BR: gettext-devel
[packages/poppler.git] / poppler.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # disable gtk-doc
4 %bcond_without  cairo   # disable Cairo backend
5 %bcond_without  qt      # disable qt wrapper
6 %bcond_without  qt4     # disable qt4 wrapper
7 %bcond_without  cpp     # disable cpp wrapper
8 %bcond_without  glib    # disable glib wrapper
9 #
10 %define         cairo_ver       1.4.0
11 #
12 Summary:        PDF rendering library
13 Summary(pl.UTF-8):      Biblioteka renderująca PDF
14 Name:           poppler
15 Version:        0.14.2
16 Release:        1
17 License:        GPL v2+
18 Group:          Libraries
19 Source0:        http://poppler.freedesktop.org/%{name}-%{version}.tar.gz
20 # Source0-md5:  f050ade7438aa45e50f94b3f86848d28
21 URL:            http://poppler.freedesktop.org/
22 %{?with_qt4:BuildRequires:      QtGui-devel >= 4.1.0}
23 %{?with_qt4:BuildRequires:      QtTest-devel >= 4.1.0}
24 %{?with_qt4:BuildRequires:      QtXml-devel >= 4.1.0}
25 BuildRequires:  autoconf >= 2.59
26 BuildRequires:  automake
27 %{?with_cairo:BuildRequires:    cairo-devel >= %{cairo_ver}}
28 BuildRequires:  docbook-dtd412-xml
29 BuildRequires:  fontconfig-devel
30 BuildRequires:  freetype-devel >= 2.0
31 BuildRequires:  gettext-devel
32 %{?with_glib:BuildRequires:     glib2-devel >= 1:2.6.0}}
33 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.0}
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libstdc++-devel
36 BuildRequires:  libtool >= 2:1.5
37 BuildRequires:  libxml2-devel >= 2.0
38 BuildRequires:  openjpeg-devel
39 BuildRequires:  pkgconfig
40 %{?with_qt:BuildRequires:       qt-devel >= 3.0}
41 %{?with_qt4:BuildRequires:      qt4-build}
42 BuildRequires:  which
43 BuildRequires:  zlib-devel
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %description
47 A common PDF rendering library for integrating PDF viewing into
48 desktop applications (based on the xpdf-3.0 code base).
49
50 %description -l pl.UTF-8
51 Wspólna biblioteka renderująca PDF do integrowania oglądania PDF w
52 aplikacjach desktopowych (oparta na kodzie xpdf-3.0).
53
54 %package devel
55 Summary:        Poppler header files
56 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Poppler
57 Group:          Development/Libraries
58 Requires:       %{name} = %{version}-%{release}
59 Requires:       fontconfig-devel
60 Requires:       freetype-devel >= 2.0
61 Requires:       libstdc++-devel
62 Requires:       openjpeg-devel
63
64 %description devel
65 Header files for the Poppler library.
66
67 %description devel -l pl.UTF-8
68 Pliki nagłówkowe biblioteki Poppler.
69
70 %package static
71 Summary:        Poppler static libraries
72 Summary(pl.UTF-8):      Statyczne biblioteki Poppler
73 Group:          Development/Libraries
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description static
77 Poppler static libraries.
78
79 %description static -l pl.UTF-8
80 Statyczne biblioteki Poppler.
81
82 %package apidocs
83 Summary:        Poppler library API documentation
84 Summary(pl.UTF-8):      Dokumentacja API biblioteki Poppler
85 Group:          Documentation
86 Requires:       gtk-doc-common
87
88 %description apidocs
89 Poppler library API documentation.
90
91 %description apidocs -l pl.UTF-8
92 Dokumentacja API biblioteki Poppler.
93
94 %package cpp
95 Summary:        Cpp wrapper for poppler
96 Summary(pl.UTF-8):      Wrapper cpp dla popplera
97 Group:          Libraries
98 Requires:       %{name} = %{version}-%{release}
99
100 %description cpp
101 Cpp wrapper for poppler.
102
103 %description cpp -l pl.UTF-8
104 Wrapper cpp dla popplera.
105
106 %package cpp-devel
107 Summary:        Header files for cpp wrapper for poppler
108 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera cpp dla popplera
109 Group:          Development/Libraries
110 Requires:       %{name}-cpp = %{version}-%{release}
111 Requires:       %{name}-devel = %{version}-%{release}
112
113 %description cpp-devel
114 Header files for cpp wrapper for poppler.
115
116 %description cpp-devel -l pl.UTF-8
117 Pliki nagłówkowe wrappera cpp dla popplera.
118
119 %package cpp-static
120 Summary:        Static version of cpp wrapper for poppler
121 Summary(pl.UTF-8):      Statyczna wersja wrappera cpp dla popplera
122 Group:          Development/Libraries
123 Requires:       %{name}-cpp-devel = %{version}-%{release}
124
125 %description cpp-static
126 Static version of cpp wrapper for poppler.
127
128 %description cpp-static -l pl.UTF-8
129 Statyczna wersja wrappera cpp dla popplera.
130
131 %package glib
132 Summary:        GLib wrapper for poppler
133 Summary(pl.UTF-8):      Wrapper GLib dla popplera
134 Group:          Libraries
135 Requires:       %{name} = %{version}-%{release}
136 %{?with_cairo:Requires: cairo >= %{cairo_ver}}
137 Requires:       glib2 >= 1:2.6.0
138
139 %description glib
140 GLib wrapper for poppler.
141
142 %description glib -l pl.UTF-8
143 Wrapper GLib dla popplera.
144
145 %package glib-devel
146 Summary:        Header files for GLib wrapper for poppler
147 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera GLib dla popplera
148 Group:          Development/Libraries
149 Requires:       %{name}-devel = %{version}-%{release}
150 Requires:       %{name}-glib = %{version}-%{release}
151 %{?with_cairo:Requires: cairo-devel >= %{cairo_ver}}
152 Requires:       glib2-devel >= 1:2.6.0
153
154 %description glib-devel
155 Header files for GLib wrapper for poppler.
156
157 %description glib-devel -l pl.UTF-8
158 Pliki nagłówkowe wrappera GLib dla popplera.
159
160 %package glib-static
161 Summary:        Static version of GLib wrapper for poppler
162 Summary(pl.UTF-8):      Statyczna wersja wrappera GLib dla popplera
163 Group:          Development/Libraries
164 Requires:       %{name}-glib-devel = %{version}-%{release}
165
166 %description glib-static
167 Static version of GLib wrapper for poppler.
168
169 %description glib-static -l pl.UTF-8
170 Statyczna wersja wrappera GLib dla popplera.
171
172 %package qt
173 Summary:        Qt wrapper for poppler
174 Summary(pl.UTF-8):      Wrapper Qt dla popplera
175 Group:          Libraries
176 Requires:       %{name} = %{version}-%{release}
177
178 %description qt
179 Qt wrapper for poppler.
180
181 %description qt -l pl.UTF-8
182 Wrapper Qt dla popplera.
183
184 %package qt-devel
185 Summary:        Header files for Qt wrapper for poppler
186 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt dla popplera
187 Group:          Development/Libraries
188 Requires:       %{name}-devel = %{version}-%{release}
189 Requires:       %{name}-qt = %{version}-%{release}
190 Requires:       qt-devel
191
192 %description qt-devel
193 Header files for Qt wrapper for poppler.
194
195 %description qt-devel -l pl.UTF-8
196 Pliki nagłówkowe wrappera Qt dla popplera.
197
198 %package qt-static
199 Summary:        Static version of Qt wrapper for poppler
200 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt dla popplera
201 Group:          Development/Libraries
202 Requires:       %{name}-qt-devel = %{version}-%{release}
203
204 %description qt-static
205 Static version of Qt wrapper for poppler.
206
207 %description qt-static -l pl.UTF-8
208 Statyczna wersja wrappera Qt dla popplera.
209
210 %package Qt
211 Summary:        Qt4 wrapper for poppler
212 Summary(pl.UTF-8):      Wrapper Qt4 dla popplera
213 Group:          Libraries
214 Requires:       %{name} = %{version}-%{release}
215
216 %description Qt
217 Qt4 wrapper for poppler.
218
219 %description Qt -l pl.UTF-8
220 Wrapper Qt4 dla popplera.
221
222 %package Qt-devel
223 Summary:        Header files for Qt4 wrapper for poppler
224 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt4 dla popplera
225 Group:          Development/Libraries
226 Requires:       %{name}-Qt = %{version}-%{release}
227 Requires:       %{name}-devel = %{version}-%{release}
228 Requires:       QtGui-devel
229 Requires:       QtXml-devel
230
231 %description Qt-devel
232 Header files for Qt4 wrapper for poppler.
233
234 %description Qt-devel -l pl.UTF-8
235 Pliki nagłówkowe wrapper Qt4 dla popplera.
236
237 %package Qt-static
238 Summary:        Static version of Qt4 wrapper for poppler
239 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt4 dla popplera
240 Group:          Development/Libraries
241 Requires:       %{name}-Qt-devel = %{version}-%{release}
242
243 %description Qt-static
244 Static version of Qt4 wrapper for poppler.
245
246 %description Qt-static -l pl.UTF-8
247 Statyczna wersja wrappera Qt4 dla popplera.
248
249 %package progs
250 Summary:        Set of tools for viewing information and converting PDF files
251 Summary(pl.UTF-8):      Zestaw narzędzi do wyświetlania informacji i konwertowania plików PDF
252 Group:          Applications/Publishing
253 Provides:       pdftops
254 Obsoletes:      pdftohtml
255 Obsoletes:      pdftohtml-pdftops
256 Obsoletes:      poppler-utils
257 Obsoletes:      xpdf-tools
258
259 %description progs
260 Package contains utilites for PDF files. These utilities allow to
261 - extract information about PDF files
262 - extract images from PDF files
263 - convert PDF files to HTML, plain text and PS formats
264
265 %description progs -l pl.UTF-8
266 Pakiet zawiera zestaw narzędzi do plików PDF. Programy te umożliwiają
267 - wyświetlanie informacji o plikach PDF
268 - wydobywanie obrazków z plików PDF
269 - konwersję plików PDF do formatów takich jak HTML, PS czy też
270   czystego tekstu
271
272 %prep
273 %setup -q
274
275 %build
276 %{?with_apidocs:%{__gtkdocize}}
277 %{__libtoolize}
278 %{__aclocal} -I m4
279 %{__autoconf} -f
280 %{__autoheader}
281 %{__automake}
282 %configure \
283         QTINC=%{_includedir}/qt \
284         QTLIB=%{_libdir} \
285         --disable-gtk-test \
286         %{!?with_cairo:--disable-cairo-output} \
287         %{!?with_qt:--disable-poppler-qt} \
288         %{!?with_qt4:--disable-poppler-qt4} \
289         %{!?with_cpp:--disable-poppler-cpp} \
290         %{!?with_glib:--disable-poppler-glib} \
291         --enable-a4-paper \
292         %{?with_apidocs:--enable-gtk-doc} \
293         --enable-xpdf-headers \
294         --enable-zlib \
295         --enable-dependency-tracking \
296         --with-html-dir=%{_gtkdocdir}
297
298 %{__make}
299
300 %install
301 rm -rf $RPM_BUILD_ROOT
302
303 %{__make} install \
304         DESTDIR=$RPM_BUILD_ROOT
305
306 %if %{without apidocs}
307 # why it still installs them, brr
308 rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/poppler
309 %endif
310
311 %clean
312 rm -rf $RPM_BUILD_ROOT
313
314 %post   -p /sbin/ldconfig
315 %postun -p /sbin/ldconfig
316
317 %post   glib -p /sbin/ldconfig
318 %postun glib -p /sbin/ldconfig
319
320 %post   qt -p /sbin/ldconfig
321 %postun qt -p /sbin/ldconfig
322
323 %post   Qt -p /sbin/ldconfig
324 %postun Qt -p /sbin/ldconfig
325
326 %files
327 %defattr(644,root,root,755)
328 %doc AUTHORS ChangeLog NEWS README* TODO
329 %attr(755,root,root) %{_libdir}/libpoppler.so.*.*.*
330 %attr(755,root,root) %ghost %{_libdir}/libpoppler.so.7
331
332 %files devel
333 %defattr(644,root,root,755)
334 %attr(755,root,root) %{_libdir}/libpoppler.so
335 %{_libdir}/libpoppler.la
336 %dir %{_includedir}/poppler
337 %{_includedir}/poppler/poppler-config.h
338 %{_includedir}/poppler/[ABCDEFGJLMNOPRSTUX]*.h
339 %{_includedir}/poppler/goo
340 %{_includedir}/poppler/fofi
341 %{_includedir}/poppler/splash
342 %exclude %{_includedir}/poppler/glib
343 %{_pkgconfigdir}/poppler.pc
344 %{?with_cairo:%{_pkgconfigdir}/poppler-cairo.pc}
345 %{_pkgconfigdir}/poppler-splash.pc
346
347 %files static
348 %defattr(644,root,root,755)
349 %{_libdir}/libpoppler.a
350
351 %if %{with apidocs}
352 %files apidocs
353 %defattr(644,root,root,755)
354 %{_gtkdocdir}/poppler
355 %endif
356
357 %if %{with cpp}
358 %files cpp
359 %defattr(644,root,root,755)
360 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so.*.*.*
361 %attr(755,root,root) %ghost %{_libdir}/libpoppler-cpp.so.0
362
363 %files cpp-devel
364 %defattr(644,root,root,755)
365 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so
366 %{_libdir}/libpoppler-cpp.la
367 %{_includedir}/poppler/cpp
368 %{_pkgconfigdir}/poppler-cpp.pc
369
370 %files cpp-static
371 %defattr(644,root,root,755)
372 %{_libdir}/libpoppler-cpp.a
373 %endif
374
375 %if %{with glib}
376 %files glib
377 %defattr(644,root,root,755)
378 %attr(755,root,root) %{_libdir}/libpoppler-glib.so.*.*.*
379 %attr(755,root,root) %ghost %{_libdir}/libpoppler-glib.so.5
380
381 %files glib-devel
382 %defattr(644,root,root,755)
383 %attr(755,root,root) %{_libdir}/libpoppler-glib.so
384 %{_libdir}/libpoppler-glib.la
385 %{_includedir}/poppler/glib
386 %{_pkgconfigdir}/poppler-glib.pc
387
388 %files glib-static
389 %defattr(644,root,root,755)
390 %{_libdir}/libpoppler-glib.a
391 %endif
392
393 %if %{with qt}
394 %files qt
395 %defattr(644,root,root,755)
396 %attr(755,root,root) %{_libdir}/libpoppler-qt.so.*.*.*
397 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt.so.2
398
399 %files qt-devel
400 %defattr(644,root,root,755)
401 %attr(755,root,root) %{_libdir}/libpoppler-qt.so
402 %{_libdir}/libpoppler-qt.la
403 %{_includedir}/poppler/qt3
404 %{_pkgconfigdir}/poppler-qt.pc
405
406 %files qt-static
407 %defattr(644,root,root,755)
408 %{_libdir}/libpoppler-qt.a
409 %endif
410
411 %if %{with qt4}
412 %files Qt
413 %defattr(644,root,root,755)
414 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so.*.*.*
415 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt4.so.3
416
417 %files Qt-devel
418 %defattr(644,root,root,755)
419 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so
420 %{_libdir}/libpoppler-qt4.la
421 %{_includedir}/poppler/qt4
422 %{_pkgconfigdir}/poppler-qt4.pc
423
424 %files Qt-static
425 %defattr(644,root,root,755)
426 %{_libdir}/libpoppler-qt4.a
427 %endif
428
429 %files progs
430 %defattr(644,root,root,755)
431 %attr(755,root,root) %{_bindir}/pdf*
432 %{_mandir}/man1/pdf*
This page took 0.066927 seconds and 4 git commands to generate.