]> git.pld-linux.org Git - packages/poppler.git/blob - poppler.spec
- up to 0.14.4
[packages/poppler.git] / poppler.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # disable gtk-doc
4 %bcond_without  cairo   # disable Cairo backend
5 %bcond_without  qt      # disable qt wrapper
6 %bcond_without  qt4     # disable qt4 wrapper
7 %bcond_without  cpp     # disable cpp wrapper
8 %bcond_without  glib    # disable glib wrapper
9 #
10 %define         cairo_ver       1.4.0
11 #
12 Summary:        PDF rendering library
13 Summary(pl.UTF-8):      Biblioteka renderująca PDF
14 Name:           poppler
15 Version:        0.14.4
16 Release:        1
17 License:        GPL v2+
18 Group:          Libraries
19 Source0:        http://poppler.freedesktop.org/%{name}-%{version}.tar.gz
20 # Source0-md5:  a40fe96e1115f648ce4689e667743530
21 URL:            http://poppler.freedesktop.org/
22 %{?with_qt4:BuildRequires:      QtGui-devel >= 4.1.0}
23 %{?with_qt4:BuildRequires:      QtTest-devel >= 4.1.0}
24 %{?with_qt4:BuildRequires:      QtXml-devel >= 4.1.0}
25 BuildRequires:  autoconf >= 2.59
26 BuildRequires:  automake
27 %{?with_cairo:BuildRequires:    cairo-devel >= %{cairo_ver}}
28 BuildRequires:  docbook-dtd412-xml
29 BuildRequires:  fontconfig-devel
30 BuildRequires:  freetype-devel >= 2.0
31 BuildRequires:  gettext-devel
32 %{?with_glib:BuildRequires:     glib2-devel >= 1:2.6.0}}
33 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.0}
34 BuildRequires:  libjpeg-devel
35 BuildRequires:  libstdc++-devel
36 BuildRequires:  libtool >= 2:1.5
37 BuildRequires:  libxml2-devel >= 2.0
38 BuildRequires:  openjpeg-devel
39 BuildRequires:  pkgconfig
40 %{?with_qt:BuildRequires:       qt-devel >= 3.0}
41 %{?with_qt4:BuildRequires:      qt4-build}
42 BuildRequires:  sed >= 4.0
43 BuildRequires:  which
44 BuildRequires:  zlib-devel
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 A common PDF rendering library for integrating PDF viewing into
49 desktop applications (based on the xpdf-3.0 code base).
50
51 %description -l pl.UTF-8
52 Wspólna biblioteka renderująca PDF do integrowania oglądania PDF w
53 aplikacjach desktopowych (oparta na kodzie xpdf-3.0).
54
55 %package devel
56 Summary:        Poppler header files
57 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Poppler
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       fontconfig-devel
61 Requires:       freetype-devel >= 2.0
62 Requires:       libstdc++-devel
63 Requires:       openjpeg-devel
64
65 %description devel
66 Header files for the Poppler library.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe biblioteki Poppler.
70
71 %package static
72 Summary:        Poppler static libraries
73 Summary(pl.UTF-8):      Statyczne biblioteki Poppler
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Poppler static libraries.
79
80 %description static -l pl.UTF-8
81 Statyczne biblioteki Poppler.
82
83 %package apidocs
84 Summary:        Poppler library API documentation
85 Summary(pl.UTF-8):      Dokumentacja API biblioteki Poppler
86 Group:          Documentation
87 Requires:       gtk-doc-common
88
89 %description apidocs
90 Poppler library API documentation.
91
92 %description apidocs -l pl.UTF-8
93 Dokumentacja API biblioteki Poppler.
94
95 %package cpp
96 Summary:        Cpp wrapper for poppler
97 Summary(pl.UTF-8):      Wrapper cpp dla popplera
98 Group:          Libraries
99 Requires:       %{name} = %{version}-%{release}
100
101 %description cpp
102 Cpp wrapper for poppler.
103
104 %description cpp -l pl.UTF-8
105 Wrapper cpp dla popplera.
106
107 %package cpp-devel
108 Summary:        Header files for cpp wrapper for poppler
109 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera cpp dla popplera
110 Group:          Development/Libraries
111 Requires:       %{name}-cpp = %{version}-%{release}
112 Requires:       %{name}-devel = %{version}-%{release}
113
114 %description cpp-devel
115 Header files for cpp wrapper for poppler.
116
117 %description cpp-devel -l pl.UTF-8
118 Pliki nagłówkowe wrappera cpp dla popplera.
119
120 %package cpp-static
121 Summary:        Static version of cpp wrapper for poppler
122 Summary(pl.UTF-8):      Statyczna wersja wrappera cpp dla popplera
123 Group:          Development/Libraries
124 Requires:       %{name}-cpp-devel = %{version}-%{release}
125
126 %description cpp-static
127 Static version of cpp wrapper for poppler.
128
129 %description cpp-static -l pl.UTF-8
130 Statyczna wersja wrappera cpp dla popplera.
131
132 %package glib
133 Summary:        GLib wrapper for poppler
134 Summary(pl.UTF-8):      Wrapper GLib dla popplera
135 Group:          Libraries
136 Requires:       %{name} = %{version}-%{release}
137 %{?with_cairo:Requires: cairo >= %{cairo_ver}}
138 Requires:       glib2 >= 1:2.6.0
139
140 %description glib
141 GLib wrapper for poppler.
142
143 %description glib -l pl.UTF-8
144 Wrapper GLib dla popplera.
145
146 %package glib-devel
147 Summary:        Header files for GLib wrapper for poppler
148 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera GLib dla popplera
149 Group:          Development/Libraries
150 Requires:       %{name}-devel = %{version}-%{release}
151 Requires:       %{name}-glib = %{version}-%{release}
152 %{?with_cairo:Requires: cairo-devel >= %{cairo_ver}}
153 Requires:       glib2-devel >= 1:2.6.0
154
155 %description glib-devel
156 Header files for GLib wrapper for poppler.
157
158 %description glib-devel -l pl.UTF-8
159 Pliki nagłówkowe wrappera GLib dla popplera.
160
161 %package glib-static
162 Summary:        Static version of GLib wrapper for poppler
163 Summary(pl.UTF-8):      Statyczna wersja wrappera GLib dla popplera
164 Group:          Development/Libraries
165 Requires:       %{name}-glib-devel = %{version}-%{release}
166
167 %description glib-static
168 Static version of GLib wrapper for poppler.
169
170 %description glib-static -l pl.UTF-8
171 Statyczna wersja wrappera GLib dla popplera.
172
173 %package qt
174 Summary:        Qt wrapper for poppler
175 Summary(pl.UTF-8):      Wrapper Qt dla popplera
176 Group:          Libraries
177 Requires:       %{name} = %{version}-%{release}
178
179 %description qt
180 Qt wrapper for poppler.
181
182 %description qt -l pl.UTF-8
183 Wrapper Qt dla popplera.
184
185 %package qt-devel
186 Summary:        Header files for Qt wrapper for poppler
187 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt dla popplera
188 Group:          Development/Libraries
189 Requires:       %{name}-devel = %{version}-%{release}
190 Requires:       %{name}-qt = %{version}-%{release}
191 Requires:       qt-devel
192
193 %description qt-devel
194 Header files for Qt wrapper for poppler.
195
196 %description qt-devel -l pl.UTF-8
197 Pliki nagłówkowe wrappera Qt dla popplera.
198
199 %package qt-static
200 Summary:        Static version of Qt wrapper for poppler
201 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt dla popplera
202 Group:          Development/Libraries
203 Requires:       %{name}-qt-devel = %{version}-%{release}
204
205 %description qt-static
206 Static version of Qt wrapper for poppler.
207
208 %description qt-static -l pl.UTF-8
209 Statyczna wersja wrappera Qt dla popplera.
210
211 %package Qt
212 Summary:        Qt4 wrapper for poppler
213 Summary(pl.UTF-8):      Wrapper Qt4 dla popplera
214 Group:          Libraries
215 Requires:       %{name} = %{version}-%{release}
216
217 %description Qt
218 Qt4 wrapper for poppler.
219
220 %description Qt -l pl.UTF-8
221 Wrapper Qt4 dla popplera.
222
223 %package Qt-devel
224 Summary:        Header files for Qt4 wrapper for poppler
225 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt4 dla popplera
226 Group:          Development/Libraries
227 Requires:       %{name}-Qt = %{version}-%{release}
228 Requires:       %{name}-devel = %{version}-%{release}
229 Requires:       QtGui-devel
230 Requires:       QtXml-devel
231
232 %description Qt-devel
233 Header files for Qt4 wrapper for poppler.
234
235 %description Qt-devel -l pl.UTF-8
236 Pliki nagłówkowe wrapper Qt4 dla popplera.
237
238 %package Qt-static
239 Summary:        Static version of Qt4 wrapper for poppler
240 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt4 dla popplera
241 Group:          Development/Libraries
242 Requires:       %{name}-Qt-devel = %{version}-%{release}
243
244 %description Qt-static
245 Static version of Qt4 wrapper for poppler.
246
247 %description Qt-static -l pl.UTF-8
248 Statyczna wersja wrappera Qt4 dla popplera.
249
250 %package progs
251 Summary:        Set of tools for viewing information and converting PDF files
252 Summary(pl.UTF-8):      Zestaw narzędzi do wyświetlania informacji i konwertowania plików PDF
253 Group:          Applications/Publishing
254 Provides:       pdftops
255 Obsoletes:      pdftohtml
256 Obsoletes:      pdftohtml-pdftops
257 Obsoletes:      poppler-utils
258 Obsoletes:      xpdf-tools
259
260 %description progs
261 Package contains utilites for PDF files. These utilities allow to
262 - extract information about PDF files
263 - extract images from PDF files
264 - convert PDF files to HTML, plain text and PS formats
265
266 %description progs -l pl.UTF-8
267 Pakiet zawiera zestaw narzędzi do plików PDF. Programy te umożliwiają
268 - wyświetlanie informacji o plikach PDF
269 - wydobywanie obrazków z plików PDF
270 - konwersję plików PDF do formatów takich jak HTML, PS czy też
271   czystego tekstu
272
273 %prep
274 %setup -q
275
276 # fix link with Qt4 libraries
277 %{__sed} -i 's,(POPPLER_QT_LIBS),(POPPLER_QT4_LIBS) -lqt-mt,' qt/Makefile.am
278
279 %build
280 %{?with_apidocs:%{__gtkdocize}}
281 %{__libtoolize}
282 %{__aclocal} -I m4
283 %{__autoconf} -f
284 %{__autoheader}
285 %{__automake}
286 %configure \
287         QTINC=%{_includedir}/qt \
288         QTLIB=%{_libdir} \
289         --disable-gtk-test \
290         %{!?with_cairo:--disable-cairo-output} \
291         %{!?with_qt:--disable-poppler-qt} \
292         %{!?with_qt4:--disable-poppler-qt4} \
293         %{!?with_cpp:--disable-poppler-cpp} \
294         %{!?with_glib:--disable-poppler-glib} \
295         --enable-a4-paper \
296         %{?with_apidocs:--enable-gtk-doc} \
297         --enable-xpdf-headers \
298         --enable-zlib \
299         --enable-dependency-tracking \
300         --with-html-dir=%{_gtkdocdir}
301
302 %{__make}
303
304 %install
305 rm -rf $RPM_BUILD_ROOT
306
307 %{__make} install \
308         DESTDIR=$RPM_BUILD_ROOT
309
310 %if %{without apidocs}
311 # why it still installs them, brr
312 rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/poppler
313 %endif
314
315 %clean
316 rm -rf $RPM_BUILD_ROOT
317
318 %post   -p /sbin/ldconfig
319 %postun -p /sbin/ldconfig
320
321 %post   glib -p /sbin/ldconfig
322 %postun glib -p /sbin/ldconfig
323
324 %post   qt -p /sbin/ldconfig
325 %postun qt -p /sbin/ldconfig
326
327 %post   Qt -p /sbin/ldconfig
328 %postun Qt -p /sbin/ldconfig
329
330 %files
331 %defattr(644,root,root,755)
332 %doc AUTHORS ChangeLog NEWS README* TODO
333 %attr(755,root,root) %{_libdir}/libpoppler.so.*.*.*
334 %attr(755,root,root) %ghost %{_libdir}/libpoppler.so.7
335
336 %files devel
337 %defattr(644,root,root,755)
338 %attr(755,root,root) %{_libdir}/libpoppler.so
339 %{_libdir}/libpoppler.la
340 %dir %{_includedir}/poppler
341 %{_includedir}/poppler/poppler-config.h
342 %{_includedir}/poppler/[ABCDEFGJLMNOPRSTUX]*.h
343 %{_includedir}/poppler/goo
344 %{_includedir}/poppler/fofi
345 %{_includedir}/poppler/splash
346 %exclude %{_includedir}/poppler/glib
347 %{_pkgconfigdir}/poppler.pc
348 %{?with_cairo:%{_pkgconfigdir}/poppler-cairo.pc}
349 %{_pkgconfigdir}/poppler-splash.pc
350
351 %files static
352 %defattr(644,root,root,755)
353 %{_libdir}/libpoppler.a
354
355 %if %{with apidocs}
356 %files apidocs
357 %defattr(644,root,root,755)
358 %{_gtkdocdir}/poppler
359 %endif
360
361 %if %{with cpp}
362 %files cpp
363 %defattr(644,root,root,755)
364 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so.*.*.*
365 %attr(755,root,root) %ghost %{_libdir}/libpoppler-cpp.so.0
366
367 %files cpp-devel
368 %defattr(644,root,root,755)
369 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so
370 %{_libdir}/libpoppler-cpp.la
371 %{_includedir}/poppler/cpp
372 %{_pkgconfigdir}/poppler-cpp.pc
373
374 %files cpp-static
375 %defattr(644,root,root,755)
376 %{_libdir}/libpoppler-cpp.a
377 %endif
378
379 %if %{with glib}
380 %files glib
381 %defattr(644,root,root,755)
382 %attr(755,root,root) %{_libdir}/libpoppler-glib.so.*.*.*
383 %attr(755,root,root) %ghost %{_libdir}/libpoppler-glib.so.5
384
385 %files glib-devel
386 %defattr(644,root,root,755)
387 %attr(755,root,root) %{_libdir}/libpoppler-glib.so
388 %{_libdir}/libpoppler-glib.la
389 %{_includedir}/poppler/glib
390 %{_pkgconfigdir}/poppler-glib.pc
391
392 %files glib-static
393 %defattr(644,root,root,755)
394 %{_libdir}/libpoppler-glib.a
395 %endif
396
397 %if %{with qt}
398 %files qt
399 %defattr(644,root,root,755)
400 %attr(755,root,root) %{_libdir}/libpoppler-qt.so.*.*.*
401 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt.so.2
402
403 %files qt-devel
404 %defattr(644,root,root,755)
405 %attr(755,root,root) %{_libdir}/libpoppler-qt.so
406 %{_libdir}/libpoppler-qt.la
407 %{_includedir}/poppler/qt3
408 %{_pkgconfigdir}/poppler-qt.pc
409
410 %files qt-static
411 %defattr(644,root,root,755)
412 %{_libdir}/libpoppler-qt.a
413 %endif
414
415 %if %{with qt4}
416 %files Qt
417 %defattr(644,root,root,755)
418 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so.*.*.*
419 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt4.so.3
420
421 %files Qt-devel
422 %defattr(644,root,root,755)
423 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so
424 %{_libdir}/libpoppler-qt4.la
425 %{_includedir}/poppler/qt4
426 %{_pkgconfigdir}/poppler-qt4.pc
427
428 %files Qt-static
429 %defattr(644,root,root,755)
430 %{_libdir}/libpoppler-qt4.a
431 %endif
432
433 %files progs
434 %defattr(644,root,root,755)
435 %attr(755,root,root) %{_bindir}/pdf*
436 %{_mandir}/man1/pdf*
This page took 0.0704 seconds and 4 git commands to generate.