]> git.pld-linux.org Git - packages/poppler.git/blob - poppler.spec
- mention that 0.14 is stable
[packages/poppler.git] / poppler.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # disable gtk-doc
4 %bcond_without  cairo   # disable Cairo backend
5 %bcond_without  qt      # disable qt wrapper
6 %bcond_without  qt4     # disable qt4 wrapper
7 %bcond_without  cpp     # disable cpp wrapper
8 %bcond_without  glib    # disable glib wrapper
9 #
10 %define         cairo_ver       1.8.4
11 #
12 Summary:        PDF rendering library
13 Summary(pl.UTF-8):      Biblioteka renderująca PDF
14 Name:           poppler
15 # keep stable line: 0.14 at this moment, 0.15 is development version
16 Version:        0.14.4
17 Release:        1
18 License:        GPL v2+
19 Group:          Libraries
20 Source0:        http://poppler.freedesktop.org/%{name}-%{version}.tar.gz
21 # Source0-md5:  a40fe96e1115f648ce4689e667743530
22 URL:            http://poppler.freedesktop.org/
23 %{?with_qt4:BuildRequires:      QtGui-devel >= 4.4.0}
24 %{?with_qt4:BuildRequires:      QtTest-devel >= 4.4.0}
25 %{?with_qt4:BuildRequires:      QtXml-devel >= 4.4.0}
26 BuildRequires:  autoconf >= 2.59
27 BuildRequires:  automake
28 %{?with_cairo:BuildRequires:    cairo-devel >= %{cairo_ver}}
29 BuildRequires:  docbook-dtd412-xml
30 BuildRequires:  fontconfig-devel >= 2.0.0
31 BuildRequires:  freetype-devel >= 2.0
32 BuildRequires:  gettext-devel
33 %{?with_glib:BuildRequires:     glib2-devel >= 1:2.18.0}
34 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.0}
35 BuildRequires:  lcms-devel
36 BuildRequires:  libjpeg-devel
37 BuildRequires:  libstdc++-devel
38 BuildRequires:  libtool >= 2:1.5
39 BuildRequires:  libxml2-devel >= 2.0
40 BuildRequires:  openjpeg-devel
41 BuildRequires:  pkgconfig
42 %{?with_qt:BuildRequires:       qt-devel >= 3.0}
43 %{?with_qt4:BuildRequires:      qt4-build}
44 BuildRequires:  sed >= 4.0
45 BuildRequires:  which
46 BuildRequires:  zlib-devel
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %description
50 A common PDF rendering library for integrating PDF viewing into
51 desktop applications (based on the xpdf-3.0 code base).
52
53 %description -l pl.UTF-8
54 Wspólna biblioteka renderująca PDF do integrowania oglądania PDF w
55 aplikacjach desktopowych (oparta na kodzie xpdf-3.0).
56
57 %package devel
58 Summary:        Poppler header files
59 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Poppler
60 Group:          Development/Libraries
61 Requires:       %{name} = %{version}-%{release}
62 Requires:       fontconfig-devel >= 2.0.0
63 Requires:       freetype-devel >= 2.0
64 Requires:       lcms-devel
65 Requires:       libstdc++-devel
66 Requires:       openjpeg-devel
67
68 %description devel
69 Header files for the Poppler library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki Poppler.
73
74 %package static
75 Summary:        Poppler static libraries
76 Summary(pl.UTF-8):      Statyczne biblioteki Poppler
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Poppler static libraries.
82
83 %description static -l pl.UTF-8
84 Statyczne biblioteki Poppler.
85
86 %package apidocs
87 Summary:        Poppler library API documentation
88 Summary(pl.UTF-8):      Dokumentacja API biblioteki Poppler
89 Group:          Documentation
90 Requires:       gtk-doc-common
91
92 %description apidocs
93 Poppler library API documentation.
94
95 %description apidocs -l pl.UTF-8
96 Dokumentacja API biblioteki Poppler.
97
98 %package cpp
99 Summary:        Cpp wrapper for poppler
100 Summary(pl.UTF-8):      Wrapper cpp dla popplera
101 Group:          Libraries
102 Requires:       %{name} = %{version}-%{release}
103
104 %description cpp
105 Cpp wrapper for poppler.
106
107 %description cpp -l pl.UTF-8
108 Wrapper cpp dla popplera.
109
110 %package cpp-devel
111 Summary:        Header files for cpp wrapper for poppler
112 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera cpp dla popplera
113 Group:          Development/Libraries
114 Requires:       %{name}-cpp = %{version}-%{release}
115 Requires:       %{name}-devel = %{version}-%{release}
116
117 %description cpp-devel
118 Header files for cpp wrapper for poppler.
119
120 %description cpp-devel -l pl.UTF-8
121 Pliki nagłówkowe wrappera cpp dla popplera.
122
123 %package cpp-static
124 Summary:        Static version of cpp wrapper for poppler
125 Summary(pl.UTF-8):      Statyczna wersja wrappera cpp dla popplera
126 Group:          Development/Libraries
127 Requires:       %{name}-cpp-devel = %{version}-%{release}
128
129 %description cpp-static
130 Static version of cpp wrapper for poppler.
131
132 %description cpp-static -l pl.UTF-8
133 Statyczna wersja wrappera cpp dla popplera.
134
135 %package glib
136 Summary:        GLib wrapper for poppler
137 Summary(pl.UTF-8):      Wrapper GLib dla popplera
138 Group:          Libraries
139 Requires:       %{name} = %{version}-%{release}
140 %{?with_cairo:Requires: cairo >= %{cairo_ver}}
141 Requires:       glib2 >= 1:2.18.0
142
143 %description glib
144 GLib wrapper for poppler.
145
146 %description glib -l pl.UTF-8
147 Wrapper GLib dla popplera.
148
149 %package glib-devel
150 Summary:        Header files for GLib wrapper for poppler
151 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera GLib dla popplera
152 Group:          Development/Libraries
153 Requires:       %{name}-devel = %{version}-%{release}
154 Requires:       %{name}-glib = %{version}-%{release}
155 %{?with_cairo:Requires: cairo-devel >= %{cairo_ver}}
156 Requires:       glib2-devel >= 1:2.18.0
157
158 %description glib-devel
159 Header files for GLib wrapper for poppler.
160
161 %description glib-devel -l pl.UTF-8
162 Pliki nagłówkowe wrappera GLib dla popplera.
163
164 %package glib-static
165 Summary:        Static version of GLib wrapper for poppler
166 Summary(pl.UTF-8):      Statyczna wersja wrappera GLib dla popplera
167 Group:          Development/Libraries
168 Requires:       %{name}-glib-devel = %{version}-%{release}
169
170 %description glib-static
171 Static version of GLib wrapper for poppler.
172
173 %description glib-static -l pl.UTF-8
174 Statyczna wersja wrappera GLib dla popplera.
175
176 %package qt
177 Summary:        Qt wrapper for poppler
178 Summary(pl.UTF-8):      Wrapper Qt dla popplera
179 Group:          Libraries
180 Requires:       %{name} = %{version}-%{release}
181
182 %description qt
183 Qt wrapper for poppler.
184
185 %description qt -l pl.UTF-8
186 Wrapper Qt dla popplera.
187
188 %package qt-devel
189 Summary:        Header files for Qt wrapper for poppler
190 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt dla popplera
191 Group:          Development/Libraries
192 Requires:       %{name}-devel = %{version}-%{release}
193 Requires:       %{name}-qt = %{version}-%{release}
194 Requires:       qt-devel
195
196 %description qt-devel
197 Header files for Qt wrapper for poppler.
198
199 %description qt-devel -l pl.UTF-8
200 Pliki nagłówkowe wrappera Qt dla popplera.
201
202 %package qt-static
203 Summary:        Static version of Qt wrapper for poppler
204 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt dla popplera
205 Group:          Development/Libraries
206 Requires:       %{name}-qt-devel = %{version}-%{release}
207
208 %description qt-static
209 Static version of Qt wrapper for poppler.
210
211 %description qt-static -l pl.UTF-8
212 Statyczna wersja wrappera Qt dla popplera.
213
214 %package Qt
215 Summary:        Qt4 wrapper for poppler
216 Summary(pl.UTF-8):      Wrapper Qt4 dla popplera
217 Group:          Libraries
218 Requires:       %{name} = %{version}-%{release}
219 Requires:       QtGui >= 4.4.0
220 Requires:       QtXml >= 4.4.0
221
222 %description Qt
223 Qt4 wrapper for poppler.
224
225 %description Qt -l pl.UTF-8
226 Wrapper Qt4 dla popplera.
227
228 %package Qt-devel
229 Summary:        Header files for Qt4 wrapper for poppler
230 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt4 dla popplera
231 Group:          Development/Libraries
232 Requires:       %{name}-Qt = %{version}-%{release}
233 Requires:       %{name}-devel = %{version}-%{release}
234 Requires:       QtGui-devel >= 4.4.0
235 Requires:       QtXml-devel >= 4.4.0
236
237 %description Qt-devel
238 Header files for Qt4 wrapper for poppler.
239
240 %description Qt-devel -l pl.UTF-8
241 Pliki nagłówkowe wrapper Qt4 dla popplera.
242
243 %package Qt-static
244 Summary:        Static version of Qt4 wrapper for poppler
245 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt4 dla popplera
246 Group:          Development/Libraries
247 Requires:       %{name}-Qt-devel = %{version}-%{release}
248
249 %description Qt-static
250 Static version of Qt4 wrapper for poppler.
251
252 %description Qt-static -l pl.UTF-8
253 Statyczna wersja wrappera Qt4 dla popplera.
254
255 %package progs
256 Summary:        Set of tools for viewing information and converting PDF files
257 Summary(pl.UTF-8):      Zestaw narzędzi do wyświetlania informacji i konwertowania plików PDF
258 Group:          Applications/Publishing
259 Provides:       pdftops
260 Obsoletes:      pdftohtml
261 Obsoletes:      pdftohtml-pdftops
262 Obsoletes:      poppler-utils
263 Obsoletes:      xpdf-tools
264
265 %description progs
266 Package contains utilites for PDF files. These utilities allow to
267 - extract information about PDF files
268 - extract images from PDF files
269 - convert PDF files to HTML, plain text and PS formats
270
271 %description progs -l pl.UTF-8
272 Pakiet zawiera zestaw narzędzi do plików PDF. Programy te umożliwiają
273 - wyświetlanie informacji o plikach PDF
274 - wydobywanie obrazków z plików PDF
275 - konwersję plików PDF do formatów takich jak HTML, PS czy też
276   czystego tekstu
277
278 %prep
279 %setup -q
280
281 # fix link with Qt 3 libraries
282 %{__sed} -i 's,(POPPLER_QT_LIBS),(libqt3_LIBS),' qt/Makefile.am
283
284 %build
285 %{?with_apidocs:%{__gtkdocize}}
286 %{__libtoolize}
287 %{__aclocal} -I m4
288 %{__autoconf} -f
289 %{__autoheader}
290 %{__automake}
291 %configure \
292         QTINC=%{_includedir}/qt \
293         QTLIB=%{_libdir} \
294         --disable-gtk-test \
295         %{!?with_cairo:--disable-cairo-output} \
296         %{!?with_qt:--disable-poppler-qt} \
297         %{!?with_qt4:--disable-poppler-qt4} \
298         %{!?with_cpp:--disable-poppler-cpp} \
299         %{!?with_glib:--disable-poppler-glib} \
300         --disable-silent-rules \
301         --enable-a4-paper \
302         %{?with_apidocs:--enable-gtk-doc} \
303         --enable-xpdf-headers \
304         --enable-zlib \
305         --enable-dependency-tracking \
306         --with-html-dir=%{_gtkdocdir}
307
308 %{__make}
309
310 %install
311 rm -rf $RPM_BUILD_ROOT
312
313 %{__make} install \
314         DESTDIR=$RPM_BUILD_ROOT
315
316 %if %{without apidocs}
317 # why it still installs them, brr
318 rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/poppler
319 %endif
320
321 %clean
322 rm -rf $RPM_BUILD_ROOT
323
324 %post   -p /sbin/ldconfig
325 %postun -p /sbin/ldconfig
326
327 %post   cpp -p /sbin/ldconfig
328 %postun cpp -p /sbin/ldconfig
329
330 %post   glib -p /sbin/ldconfig
331 %postun glib -p /sbin/ldconfig
332
333 %post   qt -p /sbin/ldconfig
334 %postun qt -p /sbin/ldconfig
335
336 %post   Qt -p /sbin/ldconfig
337 %postun Qt -p /sbin/ldconfig
338
339 %files
340 %defattr(644,root,root,755)
341 %doc AUTHORS ChangeLog NEWS README* TODO
342 %attr(755,root,root) %{_libdir}/libpoppler.so.*.*.*
343 %attr(755,root,root) %ghost %{_libdir}/libpoppler.so.7
344
345 %files devel
346 %defattr(644,root,root,755)
347 %attr(755,root,root) %{_libdir}/libpoppler.so
348 %{_libdir}/libpoppler.la
349 %dir %{_includedir}/poppler
350 %{_includedir}/poppler/poppler-config.h
351 %{_includedir}/poppler/[ABCDEFGJLMNOPRSTUX]*.h
352 %{_includedir}/poppler/fofi
353 %{_includedir}/poppler/goo
354 %{_includedir}/poppler/splash
355 %exclude %{_includedir}/poppler/glib
356 %{_pkgconfigdir}/poppler.pc
357 %{?with_cairo:%{_pkgconfigdir}/poppler-cairo.pc}
358 %{_pkgconfigdir}/poppler-splash.pc
359
360 %files static
361 %defattr(644,root,root,755)
362 %{_libdir}/libpoppler.a
363
364 %if %{with apidocs}
365 %files apidocs
366 %defattr(644,root,root,755)
367 %{_gtkdocdir}/poppler
368 %endif
369
370 %if %{with cpp}
371 %files cpp
372 %defattr(644,root,root,755)
373 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so.*.*.*
374 %attr(755,root,root) %ghost %{_libdir}/libpoppler-cpp.so.0
375
376 %files cpp-devel
377 %defattr(644,root,root,755)
378 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so
379 %{_libdir}/libpoppler-cpp.la
380 %{_includedir}/poppler/cpp
381 %{_pkgconfigdir}/poppler-cpp.pc
382
383 %files cpp-static
384 %defattr(644,root,root,755)
385 %{_libdir}/libpoppler-cpp.a
386 %endif
387
388 %if %{with glib}
389 %files glib
390 %defattr(644,root,root,755)
391 %attr(755,root,root) %{_libdir}/libpoppler-glib.so.*.*.*
392 %attr(755,root,root) %ghost %{_libdir}/libpoppler-glib.so.5
393
394 %files glib-devel
395 %defattr(644,root,root,755)
396 %attr(755,root,root) %{_libdir}/libpoppler-glib.so
397 %{_libdir}/libpoppler-glib.la
398 %{_includedir}/poppler/glib
399 %{_pkgconfigdir}/poppler-glib.pc
400
401 %files glib-static
402 %defattr(644,root,root,755)
403 %{_libdir}/libpoppler-glib.a
404 %endif
405
406 %if %{with qt}
407 %files qt
408 %defattr(644,root,root,755)
409 %attr(755,root,root) %{_libdir}/libpoppler-qt.so.*.*.*
410 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt.so.2
411
412 %files qt-devel
413 %defattr(644,root,root,755)
414 %attr(755,root,root) %{_libdir}/libpoppler-qt.so
415 %{_libdir}/libpoppler-qt.la
416 %{_includedir}/poppler/qt3
417 %{_pkgconfigdir}/poppler-qt.pc
418
419 %files qt-static
420 %defattr(644,root,root,755)
421 %{_libdir}/libpoppler-qt.a
422 %endif
423
424 %if %{with qt4}
425 %files Qt
426 %defattr(644,root,root,755)
427 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so.*.*.*
428 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt4.so.3
429
430 %files Qt-devel
431 %defattr(644,root,root,755)
432 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so
433 %{_libdir}/libpoppler-qt4.la
434 %{_includedir}/poppler/qt4
435 %{_pkgconfigdir}/poppler-qt4.pc
436
437 %files Qt-static
438 %defattr(644,root,root,755)
439 %{_libdir}/libpoppler-qt4.a
440 %endif
441
442 %files progs
443 %defattr(644,root,root,755)
444 %attr(755,root,root) %{_bindir}/pdf*
445 %{_mandir}/man1/pdf*
This page took 0.083906 seconds and 4 git commands to generate.