]> git.pld-linux.org Git - packages/poppler.git/blob - poppler.spec
- up to 0.16.7
[packages/poppler.git] / poppler.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # disable gtk-doc
4 %bcond_without  cairo   # disable Cairo backend
5 %bcond_without  qt      # disable qt wrapper
6 %bcond_without  qt4     # disable qt4 wrapper
7 %bcond_without  cpp     # disable cpp wrapper
8 %bcond_without  glib    # disable glib wrapper
9 #
10 %define         cairo_ver       1.10.0
11 #
12 Summary:        PDF rendering library
13 Summary(pl.UTF-8):      Biblioteka renderująca PDF
14 Name:           poppler
15 Version:        0.16.7
16 Release:        1
17 License:        GPL v2+
18 Group:          Libraries
19 Source0:        http://poppler.freedesktop.org/%{name}-%{version}.tar.gz
20 # Source0-md5:  3afa28e3c8c4f06b0fbca3c91e06394e
21 URL:            http://poppler.freedesktop.org/
22 %{?with_qt4:BuildRequires:      QtGui-devel >= 4.4.0}
23 %{?with_qt4:BuildRequires:      QtTest-devel >= 4.4.0}
24 %{?with_qt4:BuildRequires:      QtXml-devel >= 4.4.0}
25 BuildRequires:  autoconf >= 2.59
26 BuildRequires:  automake
27 %{?with_cairo:BuildRequires:    cairo-devel >= %{cairo_ver}}
28 BuildRequires:  curl-devel
29 BuildRequires:  docbook-dtd412-xml
30 BuildRequires:  fontconfig-devel >= 2.0.0
31 BuildRequires:  freetype-devel >= 2.0
32 BuildRequires:  gettext-devel
33 %{?with_glib:BuildRequires:     glib2-devel >= 1:2.18.0}
34 BuildRequires:  gobject-introspection-devel >= 0.6.7
35 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.14}
36 BuildRequires:  lcms-devel
37 BuildRequires:  libjpeg-devel
38 BuildRequires:  libstdc++-devel
39 BuildRequires:  libtool >= 2:1.5
40 BuildRequires:  libxml2-devel >= 2.0
41 BuildRequires:  openjpeg-devel
42 BuildRequires:  pkgconfig >= 1:0.18
43 %{?with_qt:BuildRequires:       qt-devel >= 3.0}
44 %{?with_qt4:BuildRequires:      qt4-build}
45 BuildRequires:  sed >= 4.0
46 BuildRequires:  which
47 BuildRequires:  zlib-devel
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %description
51 A common PDF rendering library for integrating PDF viewing into
52 desktop applications (based on the xpdf-3.0 code base).
53
54 %description -l pl.UTF-8
55 Wspólna biblioteka renderująca PDF do integrowania oglądania PDF w
56 aplikacjach desktopowych (oparta na kodzie xpdf-3.0).
57
58 %package devel
59 Summary:        Poppler header files
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Poppler
61 Group:          Development/Libraries
62 Requires:       %{name} = %{version}-%{release}
63 Requires:       fontconfig-devel >= 2.0.0
64 Requires:       freetype-devel >= 2.0
65 Requires:       lcms-devel
66 Requires:       libstdc++-devel
67 Requires:       openjpeg-devel
68
69 %description devel
70 Header files for the Poppler library.
71
72 %description devel -l pl.UTF-8
73 Pliki nagłówkowe biblioteki Poppler.
74
75 %package static
76 Summary:        Poppler static libraries
77 Summary(pl.UTF-8):      Statyczne biblioteki Poppler
78 Group:          Development/Libraries
79 Requires:       %{name}-devel = %{version}-%{release}
80
81 %description static
82 Poppler static libraries.
83
84 %description static -l pl.UTF-8
85 Statyczne biblioteki Poppler.
86
87 %package apidocs
88 Summary:        Poppler library API documentation
89 Summary(pl.UTF-8):      Dokumentacja API biblioteki Poppler
90 Group:          Documentation
91 Requires:       gtk-doc-common
92
93 %description apidocs
94 Poppler library API documentation.
95
96 %description apidocs -l pl.UTF-8
97 Dokumentacja API biblioteki Poppler.
98
99 %package cpp
100 Summary:        Cpp wrapper for poppler
101 Summary(pl.UTF-8):      Wrapper cpp dla popplera
102 Group:          Libraries
103 Requires:       %{name} = %{version}-%{release}
104
105 %description cpp
106 Cpp wrapper for poppler.
107
108 %description cpp -l pl.UTF-8
109 Wrapper cpp dla popplera.
110
111 %package cpp-devel
112 Summary:        Header files for cpp wrapper for poppler
113 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera cpp dla popplera
114 Group:          Development/Libraries
115 Requires:       %{name}-cpp = %{version}-%{release}
116 Requires:       %{name}-devel = %{version}-%{release}
117
118 %description cpp-devel
119 Header files for cpp wrapper for poppler.
120
121 %description cpp-devel -l pl.UTF-8
122 Pliki nagłówkowe wrappera cpp dla popplera.
123
124 %package cpp-static
125 Summary:        Static version of cpp wrapper for poppler
126 Summary(pl.UTF-8):      Statyczna wersja wrappera cpp dla popplera
127 Group:          Development/Libraries
128 Requires:       %{name}-cpp-devel = %{version}-%{release}
129
130 %description cpp-static
131 Static version of cpp wrapper for poppler.
132
133 %description cpp-static -l pl.UTF-8
134 Statyczna wersja wrappera cpp dla popplera.
135
136 %package glib
137 Summary:        GLib wrapper for poppler
138 Summary(pl.UTF-8):      Wrapper GLib dla popplera
139 Group:          Libraries
140 Requires:       %{name} = %{version}-%{release}
141 %{?with_cairo:Requires: cairo >= %{cairo_ver}}
142 Requires:       glib2 >= 1:2.18.0
143
144 %description glib
145 GLib wrapper for poppler.
146
147 %description glib -l pl.UTF-8
148 Wrapper GLib dla popplera.
149
150 %package glib-devel
151 Summary:        Header files for GLib wrapper for poppler
152 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera GLib dla popplera
153 Group:          Development/Libraries
154 Requires:       %{name}-devel = %{version}-%{release}
155 Requires:       %{name}-glib = %{version}-%{release}
156 %{?with_cairo:Requires: cairo-devel >= %{cairo_ver}}
157 Requires:       glib2-devel >= 1:2.18.0
158
159 %description glib-devel
160 Header files for GLib wrapper for poppler.
161
162 %description glib-devel -l pl.UTF-8
163 Pliki nagłówkowe wrappera GLib dla popplera.
164
165 %package glib-static
166 Summary:        Static version of GLib wrapper for poppler
167 Summary(pl.UTF-8):      Statyczna wersja wrappera GLib dla popplera
168 Group:          Development/Libraries
169 Requires:       %{name}-glib-devel = %{version}-%{release}
170
171 %description glib-static
172 Static version of GLib wrapper for poppler.
173
174 %description glib-static -l pl.UTF-8
175 Statyczna wersja wrappera GLib dla popplera.
176
177 %package qt
178 Summary:        Qt wrapper for poppler
179 Summary(pl.UTF-8):      Wrapper Qt dla popplera
180 Group:          Libraries
181 Requires:       %{name} = %{version}-%{release}
182
183 %description qt
184 Qt wrapper for poppler.
185
186 %description qt -l pl.UTF-8
187 Wrapper Qt dla popplera.
188
189 %package qt-devel
190 Summary:        Header files for Qt wrapper for poppler
191 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt dla popplera
192 Group:          Development/Libraries
193 Requires:       %{name}-devel = %{version}-%{release}
194 Requires:       %{name}-qt = %{version}-%{release}
195 Requires:       qt-devel
196
197 %description qt-devel
198 Header files for Qt wrapper for poppler.
199
200 %description qt-devel -l pl.UTF-8
201 Pliki nagłówkowe wrappera Qt dla popplera.
202
203 %package qt-static
204 Summary:        Static version of Qt wrapper for poppler
205 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt dla popplera
206 Group:          Development/Libraries
207 Requires:       %{name}-qt-devel = %{version}-%{release}
208
209 %description qt-static
210 Static version of Qt wrapper for poppler.
211
212 %description qt-static -l pl.UTF-8
213 Statyczna wersja wrappera Qt dla popplera.
214
215 %package Qt
216 Summary:        Qt4 wrapper for poppler
217 Summary(pl.UTF-8):      Wrapper Qt4 dla popplera
218 Group:          Libraries
219 Requires:       %{name} = %{version}-%{release}
220 Requires:       QtGui >= 4.4.0
221 Requires:       QtXml >= 4.4.0
222
223 %description Qt
224 Qt4 wrapper for poppler.
225
226 %description Qt -l pl.UTF-8
227 Wrapper Qt4 dla popplera.
228
229 %package Qt-devel
230 Summary:        Header files for Qt4 wrapper for poppler
231 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt4 dla popplera
232 Group:          Development/Libraries
233 Requires:       %{name}-Qt = %{version}-%{release}
234 Requires:       %{name}-devel = %{version}-%{release}
235 Requires:       QtGui-devel >= 4.4.0
236 Requires:       QtXml-devel >= 4.4.0
237
238 %description Qt-devel
239 Header files for Qt4 wrapper for poppler.
240
241 %description Qt-devel -l pl.UTF-8
242 Pliki nagłówkowe wrapper Qt4 dla popplera.
243
244 %package Qt-static
245 Summary:        Static version of Qt4 wrapper for poppler
246 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt4 dla popplera
247 Group:          Development/Libraries
248 Requires:       %{name}-Qt-devel = %{version}-%{release}
249
250 %description Qt-static
251 Static version of Qt4 wrapper for poppler.
252
253 %description Qt-static -l pl.UTF-8
254 Statyczna wersja wrappera Qt4 dla popplera.
255
256 %package progs
257 Summary:        Set of tools for viewing information and converting PDF files
258 Summary(pl.UTF-8):      Zestaw narzędzi do wyświetlania informacji i konwertowania plików PDF
259 Group:          Applications/Publishing
260 Provides:       pdftops
261 Obsoletes:      pdftohtml
262 Obsoletes:      pdftohtml-pdftops
263 Obsoletes:      poppler-utils
264 Obsoletes:      xpdf-tools
265
266 %description progs
267 Package contains utilites for PDF files. These utilities allow to
268 - extract information about PDF files,
269 - extract images from PDF files,
270 - convert PDF files to HTML, plain text and PS formats.
271
272 %description progs -l pl.UTF-8
273 Pakiet zawiera zestaw narzędzi do plików PDF. Programy te umożliwiają
274 - wyświetlanie informacji o plikach PDF,
275 - wydobywanie obrazków z plików PDF,
276 - konwersję plików PDF do formatów takich jak HTML, PS czy też
277   czystego tekstu.
278
279 %prep
280 %setup -q
281
282 # fix link with Qt 3 libraries
283 %{__sed} -i 's,(POPPLER_QT_LIBS),(libqt3_LIBS),' qt/Makefile.am
284
285 %build
286 %{?with_apidocs:%{__gtkdocize}}
287 %{__libtoolize}
288 %{__aclocal} -I m4
289 %{__autoconf} -f
290 %{__autoheader}
291 %{__automake}
292 %configure \
293         QTINC=%{_includedir}/qt \
294         QTLIB=%{_libdir} \
295         --disable-gtk-test \
296         --enable-libcurl \
297         %{?with_apidocs:--enable-gtk-doc} \
298         %{!?with_cairo:--disable-cairo-output} \
299         %{!?with_cpp:--disable-poppler-cpp} \
300         %{!?with_glib:--disable-poppler-glib} \
301         %{!?with_qt:--disable-poppler-qt} \
302         %{!?with_qt4:--disable-poppler-qt4} \
303         --disable-silent-rules \
304         --enable-xpdf-headers \
305         --enable-zlib \
306         --enable-dependency-tracking \
307         --with-html-dir=%{_gtkdocdir} 
308
309 %{__make}
310
311 %install
312 rm -rf $RPM_BUILD_ROOT
313
314 %{__make} install \
315         DESTDIR=$RPM_BUILD_ROOT
316
317 %if %{without apidocs}
318 # why it still installs them, brr
319 %{__rm} -rf $RPM_BUILD_ROOT%{_gtkdocdir}/poppler || :
320 %endif
321
322 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
323
324 %clean
325 rm -rf $RPM_BUILD_ROOT
326
327 %post   -p /sbin/ldconfig
328 %postun -p /sbin/ldconfig
329
330 %post   cpp -p /sbin/ldconfig
331 %postun cpp -p /sbin/ldconfig
332
333 %post   glib -p /sbin/ldconfig
334 %postun glib -p /sbin/ldconfig
335
336 %post   qt -p /sbin/ldconfig
337 %postun qt -p /sbin/ldconfig
338
339 %post   Qt -p /sbin/ldconfig
340 %postun Qt -p /sbin/ldconfig
341
342 %files
343 %defattr(644,root,root,755)
344 %doc AUTHORS ChangeLog NEWS README* TODO
345 %attr(755,root,root) %{_libdir}/libpoppler.so.*.*.*
346 %attr(755,root,root) %ghost %{_libdir}/libpoppler.so.13
347
348 %files devel
349 %defattr(644,root,root,755)
350 %attr(755,root,root) %{_libdir}/libpoppler.so
351 %dir %{_includedir}/poppler
352 %{_includedir}/poppler/poppler-config.h
353 %{_includedir}/poppler/[ABCDEFGHJLMNOPRSTUX]*.h
354 %{_includedir}/poppler/fofi
355 %{_includedir}/poppler/goo
356 %{_includedir}/poppler/splash
357 %{_pkgconfigdir}/poppler.pc
358 %{?with_cairo:%{_pkgconfigdir}/poppler-cairo.pc}
359 %{_pkgconfigdir}/poppler-splash.pc
360
361 %files static
362 %defattr(644,root,root,755)
363 %{_libdir}/libpoppler.a
364
365 %if %{with apidocs}
366 %files apidocs
367 %defattr(644,root,root,755)
368 %{_gtkdocdir}/poppler
369 %endif
370
371 %if %{with cpp}
372 %files cpp
373 %defattr(644,root,root,755)
374 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so.*.*.*
375 %attr(755,root,root) %ghost %{_libdir}/libpoppler-cpp.so.0
376
377 %files cpp-devel
378 %defattr(644,root,root,755)
379 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so
380 %{_includedir}/poppler/cpp
381 %{_pkgconfigdir}/poppler-cpp.pc
382
383 %files cpp-static
384 %defattr(644,root,root,755)
385 %{_libdir}/libpoppler-cpp.a
386 %endif
387
388 %if %{with glib}
389 %files glib
390 %defattr(644,root,root,755)
391 %attr(755,root,root) %{_libdir}/libpoppler-glib.so.*.*.*
392 %attr(755,root,root) %ghost %{_libdir}/libpoppler-glib.so.6
393 %{_libdir}/girepository-1.0/Poppler-0.16.typelib
394
395 %files glib-devel
396 %defattr(644,root,root,755)
397 %attr(755,root,root) %{_libdir}/libpoppler-glib.so
398 %{_includedir}/poppler/glib
399 %{_pkgconfigdir}/poppler-glib.pc
400 %{_datadir}/gir-1.0/Poppler-0.16.gir
401
402 %files glib-static
403 %defattr(644,root,root,755)
404 %{_libdir}/libpoppler-glib.a
405 %endif
406
407 %if %{with qt}
408 %files qt
409 %defattr(644,root,root,755)
410 %attr(755,root,root) %{_libdir}/libpoppler-qt.so.*.*.*
411 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt.so.3
412
413 %files qt-devel
414 %defattr(644,root,root,755)
415 %attr(755,root,root) %{_libdir}/libpoppler-qt.so
416 %{_includedir}/poppler/qt3
417 %{_pkgconfigdir}/poppler-qt.pc
418
419 %files qt-static
420 %defattr(644,root,root,755)
421 %{_libdir}/libpoppler-qt.a
422 %endif
423
424 %if %{with qt4}
425 %files Qt
426 %defattr(644,root,root,755)
427 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so.*.*.*
428 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt4.so.3
429
430 %files Qt-devel
431 %defattr(644,root,root,755)
432 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so
433 %{_includedir}/poppler/qt4
434 %{_pkgconfigdir}/poppler-qt4.pc
435
436 %files Qt-static
437 %defattr(644,root,root,755)
438 %{_libdir}/libpoppler-qt4.a
439 %endif
440
441 %files progs
442 %defattr(644,root,root,755)
443 %attr(755,root,root) %{_bindir}/pdf*
444 %{_mandir}/man1/pdf*
This page took 0.122083 seconds and 4 git commands to generate.