]> git.pld-linux.org Git - packages/poppler.git/blob - poppler.spec
7dca8df5d1f0ed49f24feb581d96d288b6c16bac
[packages/poppler.git] / poppler.spec
1 #
2 # TODO: unpackaged files
3 #
4 # Conditional build:
5 %bcond_without  apidocs # disable gtk-doc
6 %bcond_without  cairo   # disable Cairo backend
7 %bcond_without  qt      # disable qt wrapper
8 %bcond_without  qt4     # disable qt4 wrapper
9 %bcond_without  cpp     # disable cpp wrapper
10 %bcond_without  glib    # disable glib wrapper
11 #
12 %define         cairo_ver       1.4.0
13 #
14 Summary:        PDF rendering library
15 Summary(pl.UTF-8):      Biblioteka renderująca PDF
16 Name:           poppler
17 Version:        0.14.0
18 Release:        2
19 License:        GPL v2+
20 Group:          Libraries
21 Source0:        http://poppler.freedesktop.org/%{name}-%{version}.tar.gz
22 # Source0-md5:  76f003b8fa2b905674088c306aa857c5
23 URL:            http://poppler.freedesktop.org/
24 %{?with_qt4:BuildRequires:      QtGui-devel >= 4.1.0}
25 %{?with_qt4:BuildRequires:      QtTest-devel >= 4.1.0}
26 %{?with_qt4:BuildRequires:      QtXml-devel >= 4.1.0}
27 BuildRequires:  autoconf >= 2.59
28 BuildRequires:  automake
29 %{?with_cairo:BuildRequires:    cairo-devel >= %{cairo_ver}}
30 BuildRequires:  docbook-dtd412-xml
31 BuildRequires:  fontconfig-devel
32 BuildRequires:  freetype-devel >= 2.0
33 BuildRequires:  glib2-devel >= 1:2.6.0
34 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.0}
35 BuildRequires:  libjpeg-devel
36 BuildRequires:  libstdc++-devel
37 BuildRequires:  libtool >= 2:1.5
38 BuildRequires:  libxml2-devel >= 2.0
39 BuildRequires:  openjpeg-devel
40 BuildRequires:  pkgconfig
41 %{?with_qt:BuildRequires:       qt-devel >= 3.0}
42 %{?with_qt4:BuildRequires:      qt4-build}
43 BuildRequires:  which
44 BuildRequires:  zlib-devel
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 A common PDF rendering library for integrating PDF viewing into
49 desktop applications (based on the xpdf-3.0 code base).
50
51 %description -l pl.UTF-8
52 Wspólna biblioteka renderująca PDF do integrowania oglądania PDF w
53 aplikacjach desktopowych (oparta na kodzie xpdf-3.0).
54
55 %package devel
56 Summary:        Poppler header files
57 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Poppler
58 Group:          Development/Libraries
59 Requires:       %{name} = %{version}-%{release}
60 Requires:       fontconfig-devel
61 Requires:       freetype-devel >= 2.0
62 Requires:       libstdc++-devel
63 Requires:       openjpeg-devel
64
65 %description devel
66 Header files for the Poppler library.
67
68 %description devel -l pl.UTF-8
69 Pliki nagłówkowe biblioteki Poppler.
70
71 %package static
72 Summary:        Poppler static libraries
73 Summary(pl.UTF-8):      Statyczne biblioteki Poppler
74 Group:          Development/Libraries
75 Requires:       %{name}-devel = %{version}-%{release}
76
77 %description static
78 Poppler static libraries.
79
80 %description static -l pl.UTF-8
81 Statyczne biblioteki Poppler.
82
83 %package apidocs
84 Summary:        Poppler library API documentation
85 Summary(pl.UTF-8):      Dokumentacja API biblioteki Poppler
86 Group:          Documentation
87 Requires:       gtk-doc-common
88
89 %description apidocs
90 Poppler library API documentation.
91
92 %description apidocs -l pl.UTF-8
93 Dokumentacja API biblioteki Poppler.
94
95 %package cpp
96 Summary:        Cpp wrapper for poppler
97 Summary(pl.UTF-8):      Wrapper cpp dla popplera
98 Group:          Libraries
99 Requires:       %{name} = %{version}-%{release}
100
101 %description cpp
102 Cpp wrapper for poppler.
103
104 %description cpp -l pl.UTF-8
105 Wrapper cpp dla popplera.
106
107 %package cpp-devel
108 Summary:        Header files for cpp wrapper for poppler
109 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera cpp dla popplera
110 Group:          Development/Libraries
111 Requires:       %{name}-cpp = %{version}-%{release}
112 Requires:       %{name}-devel = %{version}-%{release}
113
114 %description cpp-devel
115 Header files for cpp wrapper for poppler.
116
117 %description cpp-devel -l pl.UTF-8
118 Pliki nagłówkowe wrappera cpp dla popplera.
119
120 %package cpp-static
121 Summary:        Static version of cpp wrapper for poppler
122 Summary(pl.UTF-8):      Statyczna wersja wrappera cpp dla popplera
123 Group:          Development/Libraries
124 Requires:       %{name}-cpp-devel = %{version}-%{release}
125
126 %description cpp-static
127 Static version of cpp wrapper for poppler.
128
129 %description cpp-static -l pl.UTF-8
130 Statyczna wersja wrappera cpp dla popplera.
131
132 %package glib
133 Summary:        GLib wrapper for poppler
134 Summary(pl.UTF-8):      Wrapper GLib dla popplera
135 Group:          Libraries
136 Requires:       %{name} = %{version}-%{release}
137 %{?with_cairo:Requires: cairo >= %{cairo_ver}}
138 Requires:       glib2 >= 1:2.6.0
139
140 %description glib
141 GLib wrapper for poppler.
142
143 %description glib -l pl.UTF-8
144 Wrapper GLib dla popplera.
145
146 %package glib-devel
147 Summary:        Header files for GLib wrapper for poppler
148 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera GLib dla popplera
149 Group:          Development/Libraries
150 Requires:       %{name}-devel = %{version}-%{release}
151 Requires:       %{name}-glib = %{version}-%{release}
152 %{?with_cairo:Requires: cairo-devel >= %{cairo_ver}}
153 Requires:       glib2-devel >= 1:2.6.0
154
155 %description glib-devel
156 Header files for GLib wrapper for poppler.
157
158 %description glib-devel -l pl.UTF-8
159 Pliki nagłówkowe wrappera GLib dla popplera.
160
161 %package glib-static
162 Summary:        Static version of GLib wrapper for poppler
163 Summary(pl.UTF-8):      Statyczna wersja wrappera GLib dla popplera
164 Group:          Development/Libraries
165 Requires:       %{name}-glib-devel = %{version}-%{release}
166
167 %description glib-static
168 Static version of GLib wrapper for poppler.
169
170 %description glib-static -l pl.UTF-8
171 Statyczna wersja wrappera GLib dla popplera.
172
173 %package qt
174 Summary:        Qt wrapper for poppler
175 Summary(pl.UTF-8):      Wrapper Qt dla popplera
176 Group:          Libraries
177 Requires:       %{name} = %{version}-%{release}
178
179 %description qt
180 Qt wrapper for poppler.
181
182 %description qt -l pl.UTF-8
183 Wrapper Qt dla popplera.
184
185 %package qt-devel
186 Summary:        Header files for Qt wrapper for poppler
187 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt dla popplera
188 Group:          Development/Libraries
189 Requires:       %{name}-devel = %{version}-%{release}
190 Requires:       %{name}-qt = %{version}-%{release}
191 Requires:       qt-devel
192
193 %description qt-devel
194 Header files for Qt wrapper for poppler.
195
196 %description qt-devel -l pl.UTF-8
197 Pliki nagłówkowe wrappera Qt dla popplera.
198
199 %package qt-static
200 Summary:        Static version of Qt wrapper for poppler
201 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt dla popplera
202 Group:          Development/Libraries
203 Requires:       %{name}-qt-devel = %{version}-%{release}
204
205 %description qt-static
206 Static version of Qt wrapper for poppler.
207
208 %description qt-static -l pl.UTF-8
209 Statyczna wersja wrappera Qt dla popplera.
210
211 %package Qt
212 Summary:        Qt4 wrapper for poppler
213 Summary(pl.UTF-8):      Wrapper Qt4 dla popplera
214 Group:          Libraries
215 Requires:       %{name} = %{version}-%{release}
216
217 %description Qt
218 Qt4 wrapper for poppler.
219
220 %description Qt -l pl.UTF-8
221 Wrapper Qt4 dla popplera.
222
223 %package Qt-devel
224 Summary:        Header files for Qt4 wrapper for poppler
225 Summary(pl.UTF-8):      Pliki nagłówkowe wrappera Qt4 dla popplera
226 Group:          Development/Libraries
227 Requires:       %{name}-Qt = %{version}-%{release}
228 Requires:       %{name}-devel = %{version}-%{release}
229 Requires:       QtGui-devel
230 Requires:       QtXml-devel
231
232 %description Qt-devel
233 Header files for Qt4 wrapper for poppler.
234
235 %description Qt-devel -l pl.UTF-8
236 Pliki nagłówkowe wrapper Qt4 dla popplera.
237
238 %package Qt-static
239 Summary:        Static version of Qt4 wrapper for poppler
240 Summary(pl.UTF-8):      Statyczna wersja wrappera Qt4 dla popplera
241 Group:          Development/Libraries
242 Requires:       %{name}-Qt-devel = %{version}-%{release}
243
244 %description Qt-static
245 Static version of Qt4 wrapper for poppler.
246
247 %description Qt-static -l pl.UTF-8
248 Statyczna wersja wrappera Qt4 dla popplera.
249
250 %package progs
251 Summary:        Set of tools for viewing information and converting PDF files
252 Summary(pl.UTF-8):      Zestaw narzędzi do wyświetlania informacji i konwertowania plików PDF
253 Group:          Applications/Publishing
254 Provides:       pdftops
255 Obsoletes:      pdftohtml
256 Obsoletes:      pdftohtml-pdftops
257 Obsoletes:      poppler-utils
258 Obsoletes:      xpdf-tools
259
260 %description progs
261 Package contains utilites for PDF files. These utilities allow to
262 - extract information about PDF files
263 - extract images from PDF files
264 - convert PDF files to HTML, plain text and PS formats
265
266 %description progs -l pl.UTF-8
267 Pakiet zawiera zestaw narzędzi do plików PDF. Programy te umożliwiają
268 - wyświetlanie informacji o plikach PDF
269 - wydobywanie obrazków z plików PDF
270 - konwersję plików PDF do formatów takich jak HTML, PS czy też
271   czystego tekstu
272
273 %prep
274 %setup -q
275
276 %build
277 %{?with_apidocs:%{__gtkdocize}}
278 %{__libtoolize}
279 %{__aclocal} -I m4
280 %{__autoconf} -f
281 %{__autoheader}
282 %{__automake}
283 %configure \
284         QTINC=%{_includedir}/qt \
285         QTLIB=%{_libdir} \
286         --disable-gtk-test \
287         %{!?with_cairo:--disable-cairo-output} \
288         %{!?with_qt:--disable-poppler-qt} \
289         %{!?with_qt4:--disable-poppler-qt4} \
290         %{!?with_cpp:--disable-poppler-cpp} \
291         %{!?with_glib:--disable-poppler-glib} \
292         --enable-a4-paper \
293         %{?with_apidocs:--enable-gtk-doc} \
294         --enable-xpdf-headers \
295         --enable-zlib \
296         --enable-dependency-tracking \
297         --with-html-dir=%{_gtkdocdir}
298
299 %{__make}
300
301 %install
302 rm -rf $RPM_BUILD_ROOT
303
304 %{__make} install \
305         DESTDIR=$RPM_BUILD_ROOT
306
307 %if %{without apidocs}
308 # why it still installs them, brr
309 rm -rf $RPM_BUILD_ROOT%{_gtkdocdir}/poppler
310 %endif
311
312 %clean
313 rm -rf $RPM_BUILD_ROOT
314
315 %post   -p /sbin/ldconfig
316 %postun -p /sbin/ldconfig
317
318 %post   glib -p /sbin/ldconfig
319 %postun glib -p /sbin/ldconfig
320
321 %post   qt -p /sbin/ldconfig
322 %postun qt -p /sbin/ldconfig
323
324 %post   Qt -p /sbin/ldconfig
325 %postun Qt -p /sbin/ldconfig
326
327 %files
328 %defattr(644,root,root,755)
329 %doc AUTHORS ChangeLog NEWS README* TODO
330 %attr(755,root,root) %{_libdir}/libpoppler.so.*.*.*
331 %attr(755,root,root) %ghost %{_libdir}/libpoppler.so.6
332
333 %files devel
334 %defattr(644,root,root,755)
335 %attr(755,root,root) %{_libdir}/libpoppler.so
336 %{_libdir}/libpoppler.la
337 %dir %{_includedir}/poppler
338 %{_includedir}/poppler/poppler-config.h
339 %{_includedir}/poppler/[ABCDEFGJLMNOPSTUX]*.h
340 %{_includedir}/poppler/goo
341 %{_includedir}/poppler/fofi
342 %{_includedir}/poppler/splash
343 %exclude %{_includedir}/poppler/glib
344 %{_pkgconfigdir}/poppler.pc
345 %{?with_cairo:%{_pkgconfigdir}/poppler-cairo.pc}
346 %{_pkgconfigdir}/poppler-splash.pc
347
348 %files static
349 %defattr(644,root,root,755)
350 %{_libdir}/libpoppler.a
351
352 %if %{with apidocs}
353 %files apidocs
354 %defattr(644,root,root,755)
355 %{_gtkdocdir}/poppler
356 %endif
357
358 %if %{with cpp}
359 %files cpp
360 %defattr(644,root,root,755)
361 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so.*.*.*
362 %attr(755,root,root) %ghost %{_libdir}/libpoppler-cpp.so.0
363
364 %files cpp-devel
365 %defattr(644,root,root,755)
366 %attr(755,root,root) %{_libdir}/libpoppler-cpp.so
367 %{_libdir}/libpoppler-cpp.la
368 %{_includedir}/poppler/cpp
369 %{_pkgconfigdir}/poppler-cpp.pc
370
371 %files cpp-static
372 %defattr(644,root,root,755)
373 %{_libdir}/libpoppler-cpp.a
374 %endif
375
376 %if %{with glib}
377 %files glib
378 %defattr(644,root,root,755)
379 %attr(755,root,root) %{_libdir}/libpoppler-glib.so.*.*.*
380 %attr(755,root,root) %ghost %{_libdir}/libpoppler-glib.so.5
381
382 %files glib-devel
383 %defattr(644,root,root,755)
384 %attr(755,root,root) %{_libdir}/libpoppler-glib.so
385 %{_libdir}/libpoppler-glib.la
386 %{_includedir}/poppler/glib
387 %{_pkgconfigdir}/poppler-glib.pc
388
389 %files glib-static
390 %defattr(644,root,root,755)
391 %{_libdir}/libpoppler-glib.a
392 %endif
393
394 %if %{with qt}
395 %files qt
396 %defattr(644,root,root,755)
397 %attr(755,root,root) %{_libdir}/libpoppler-qt.so.*.*.*
398 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt.so.2
399
400 %files qt-devel
401 %defattr(644,root,root,755)
402 %attr(755,root,root) %{_libdir}/libpoppler-qt.so
403 %{_libdir}/libpoppler-qt.la
404 %{_includedir}/poppler/qt3
405 %{_pkgconfigdir}/poppler-qt.pc
406
407 %files qt-static
408 %defattr(644,root,root,755)
409 %{_libdir}/libpoppler-qt.a
410 %endif
411
412 %if %{with qt4}
413 %files Qt
414 %defattr(644,root,root,755)
415 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so.*.*.*
416 %attr(755,root,root) %ghost %{_libdir}/libpoppler-qt4.so.3
417
418 %files Qt-devel
419 %defattr(644,root,root,755)
420 %attr(755,root,root) %{_libdir}/libpoppler-qt4.so
421 %{_libdir}/libpoppler-qt4.la
422 %{_includedir}/poppler/qt4
423 %{_pkgconfigdir}/poppler-qt4.pc
424
425 %files Qt-static
426 %defattr(644,root,root,755)
427 %{_libdir}/libpoppler-qt4.a
428 %endif
429
430 %files progs
431 %defattr(644,root,root,755)
432 %attr(755,root,root) %{_bindir}/pdf*
433 %{_mandir}/man1/pdf*
This page took 0.098607 seconds and 2 git commands to generate.