]> git.pld-linux.org Git - packages/polkit.git/commitdiff
- rel 2; add nodebug patch - fix lots of debug info in systemd dmesg
authorBartłomiej Zimoń <cactus@pld-linux.org>
Mon, 28 Nov 2011 14:44:06 +0000 (14:44 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    polkit-stdout-and-stderr.patch -> 1.1
    polkit.spec -> 1.23

polkit-stdout-and-stderr.patch [new file with mode: 0644]
polkit.spec

diff --git a/polkit-stdout-and-stderr.patch b/polkit-stdout-and-stderr.patch
new file mode 100644 (file)
index 0000000..afe2c7c
--- /dev/null
@@ -0,0 +1,77 @@
+From 3811e51b81320a574bb31aa64b6af56340012527 Mon Sep 17 00:00:00 2001
+From: David Zeuthen <davidz@redhat.com>
+Date: Tue, 18 Oct 2011 13:13:16 -0400
+Subject: [PATCH] Add --no-debug option and use this for D-Bus activation
+
+Signed-off-by: David Zeuthen <davidz@redhat.com>
+---
+ data/org.freedesktop.PolicyKit1.service.in |    2 +-
+ src/polkitd/main.c                         |   27 ++++++++++++++++++++++++++-
+ 2 files changed, 27 insertions(+), 2 deletions(-)
+
+diff --git a/data/org.freedesktop.PolicyKit1.service.in b/data/org.freedesktop.PolicyKit1.service.in
+index 5a54ca1..b6cd02b 100644
+--- a/data/org.freedesktop.PolicyKit1.service.in
++++ b/data/org.freedesktop.PolicyKit1.service.in
+@@ -1,4 +1,4 @@
+ [D-BUS Service]
+ Name=org.freedesktop.PolicyKit1
+-Exec=@libexecdir@/polkitd
++Exec=@libexecdir@/polkitd --no-debug
+ User=root
+diff --git a/src/polkitd/main.c b/src/polkitd/main.c
+index 33ea511..b21723f 100644
+--- a/src/polkitd/main.c
++++ b/src/polkitd/main.c
+@@ -22,6 +22,9 @@
+ #include "config.h"
+ #include <signal.h>
++
++#include <glib-unix.h>
++
+ #include <polkit/polkit.h>
+ #include <polkitbackend/polkitbackend.h>
+@@ -33,8 +36,10 @@ static PolkitBackendAuthority *authority = NULL;
+ static gpointer                registration_id = NULL;
+ static GMainLoop              *loop = NULL;
+ static gboolean                opt_replace = FALSE;
++static gboolean                opt_no_debug = FALSE;
+ static GOptionEntry            opt_entries[] = {
+-  {"replace", 0, 0, G_OPTION_ARG_NONE, &opt_replace, "Replace existing daemon", NULL},
++  {"replace", 'r', 0, G_OPTION_ARG_NONE, &opt_replace, "Replace existing daemon", NULL},
++  {"no-debug", 'n', 0, G_OPTION_ARG_NONE, &opt_no_debug, "Don't print debug information", NULL},
+   {NULL }
+ };
+@@ -120,6 +125,26 @@ main (int    argc,
+       goto out;
+     }
++  /* If --no-debug is requested don't clutter stdout/stderr etc.
++   */
++  if (opt_no_debug)
++    {
++      gint dev_null_fd;
++      dev_null_fd = open ("/dev/null", O_RDWR);
++      if (dev_null_fd >= 0)
++        {
++          dup2 (dev_null_fd, STDIN_FILENO);
++          dup2 (dev_null_fd, STDOUT_FILENO);
++          dup2 (dev_null_fd, STDERR_FILENO);
++          close (dev_null_fd);
++        }
++      else
++        {
++          g_warning ("Error opening /dev/null: %m");
++        }
++    }
++
++
+   loop = g_main_loop_new (NULL, FALSE);
+   sigint_id = _g_posix_signal_watch_add (SIGINT,
+-- 
+1.7.6.4
+
index 90692889ec9ed80129797139ddedc0c5fad7fb4f..75b1baeb576f9caff08c52eb73dccf09e640d732 100644 (file)
@@ -6,11 +6,12 @@ Summary:      A framework for defining policy for system-wide components
 Summary(pl.UTF-8):     Szkielet do definiowania polityki dla komponentów systemowych
 Name:          polkit
 Version:       0.102
-Release:       1
+Release:       2
 License:       LGPL v2+
 Group:         Libraries
 Source0:       http://hal.freedesktop.org/releases/%{name}-%{version}.tar.gz
 # Source0-md5: a3726bdb9728c103e58f62131e26693a
+Patch0:                %{name}-stdout-and-stderr.patch
 URL:           http://www.freedesktop.org/wiki/Software/PolicyKit
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1:1.7
@@ -98,6 +99,7 @@ Statyczne biblioteki PolicyKit.
 
 %prep
 %setup -q
+%patch0 -p1
 
 %build
 %{?with_apidocs:%{__gtkdocize}}
This page took 0.062322 seconds and 4 git commands to generate.