]> git.pld-linux.org Git - packages/poldek.git/commitdiff
Add patch to fix rpmvercmp on rpm that supports tilde in version auto/th/poldek-0.30.0-1.rc7.2
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Tue, 19 Mar 2013 23:22:05 +0000 (00:22 +0100)
committerMarcin Banasiak <marcin.banasiak@gmail.com>
Tue, 19 Mar 2013 23:22:05 +0000 (00:22 +0100)
poldek-git.patch [new file with mode: 0644]
poldek.spec

diff --git a/poldek-git.patch b/poldek-git.patch
new file mode 100644 (file)
index 0000000..44c4125
--- /dev/null
@@ -0,0 +1,41 @@
+commit 9ecd484cd077adba94649b83b3f3bfd639644056
+Author: Marcin Banasiak <marcin.banasiak@gmail.com>
+Date:   Wed Mar 20 00:09:57 2013 +0100
+
+    rpmvercmp: read macro configuration files before using rpmEVRparse()
+
+diff --git a/pm/rpm/rpmvercmp.c b/pm/rpm/rpmvercmp.c
+index 968489a..d83f26b 100644
+--- a/pm/rpm/rpmvercmp.c
++++ b/pm/rpm/rpmvercmp.c
+@@ -1,6 +1,6 @@
+ /*
+   Copyright (C) 2000 - 2008 Pawel A. Gajda <mis@pld-linux.org>
+-  Copyright (C) 2010 - 2012 Marcin Banasiak <marcin.banasiak@gmail.com>
++  Copyright (C) 2010 - 2013 Marcin Banasiak <marcin.banasiak@gmail.com>
+   This program is free software; you can redistribute it and/or modify
+   it under the terms of the GNU General Public License, version 2 as
+@@ -20,7 +20,10 @@
+ #include <stdlib.h>
+ #ifdef HAVE_RPM_5
++# include <rpm/rpmrc.h>
+ # include <rpm/rpmtag.h>
++#else
++# include <rpm/rpmlib.h>
+ #endif
+ #define _RPMEVR_INTERNAL
+@@ -61,6 +64,11 @@ int main(int argc, char *argv[])
+         exit(1);
+     }
++    if (rpmReadConfigFiles(NULL, NULL) < 0) {
++      fprintf(stderr, "Failed to read configuration files\n");
++      exit(2);
++    }
++
+     evr1 = malloc(sizeof(struct EVR_s));
+     evr2 = malloc(sizeof(struct EVR_s));
index a3a12289b0f41c522d62d3fc872d02ba9499224c..c8fcf48ff52329fbec37ac01e8137e035d41ccfc 100644 (file)
@@ -15,7 +15,7 @@
 %define                ver_rpm         5.4.10
 
 %define                snap    rc7
-%define                rel     1%{?with_snap:.%{SNAP}}
+%define                rel     2%{?with_snap:.%{SNAP}}
 Summary:       RPM packages management helper tool
 Summary(hu.UTF-8):     RPM csomagkezelést segítő eszköz
 Summary(pl.UTF-8):     Pomocnicze narzędzie do zarządzania pakietami RPM
@@ -43,6 +43,7 @@ Patch0:               %{name}-vserver-packages.patch
 Patch1:                %{name}-config.patch
 Patch2:                %{name}-size-type.patch
 Patch3:                %{name}-Os-fail-workaround.patch
+Patch4:                %{name}-git.patch
 URL:           http://poldek.pld-linux.org/
 BuildRequires: autoconf
 BuildRequires: automake
@@ -205,6 +206,7 @@ Moduły języka Python dla poldka.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %{__rm} m4/libtool.m4 m4/lt*.m4
 
This page took 0.039449 seconds and 4 git commands to generate.