]> git.pld-linux.org Git - packages/poldek.git/commitdiff
- rel 13; allow poldek to fetch over ftp even if mktime fails (and that auto/th/poldek-0.32.2-13
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 2 Oct 2019 08:59:44 +0000 (08:59 +0000)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 2 Oct 2019 08:59:44 +0000 (08:59 +0000)
can easily happen if there is no tzdata installed). Error manifested
itself with:

[...]
Retrieving th::packages.ndir.md...
error: vfff: unknown error
Retrying...(#2)
[...]

poldek-notzdata.patch [new file with mode: 0644]
poldek.spec

diff --git a/poldek-notzdata.patch b/poldek-notzdata.patch
new file mode 100644 (file)
index 0000000..24ac681
--- /dev/null
@@ -0,0 +1,12 @@
+--- poldek-0.32.2/vfile/vfff/ftp.c~    2016-01-30 14:05:57.000000000 +0000
++++ poldek-0.32.2/vfile/vfff/ftp.c     2019-10-02 08:50:20.832444438 +0000
+@@ -654,6 +654,9 @@
+         tm.tm_year -= 1900;
+         tm.tm_mon -=  1;
+         ts = mktime(&tm);
++        /* We can't do much if time can't be represented */
++        if (ts < 0)
++            return 0;
+     }
+     return ts;
+ }
index 013a8191b3e5f3d03c3fa560eba286246845f7dd..5d725a600982e19b308bc6cba5aedc69d6b05265 100644 (file)
@@ -34,7 +34,7 @@
 %define                ver_rpm         5.4.10
 %endif
 
-%define                rel     12
+%define                rel     13
 Summary:       RPM packages management helper tool
 Summary(hu.UTF-8):     RPM csomagkezelést segítő eszköz
 Summary(pl.UTF-8):     Pomocnicze narzędzie do zarządzania pakietami RPM
@@ -69,6 +69,7 @@ Patch5:               python-fix.patch
 Patch6:                poldek-ext-down-enable.patch
 Patch7:                multiple-options.patch
 Patch8:                openssl.patch
+Patch9:                poldek-notzdata.patch
 URL:           http://poldek.pld-linux.org/
 BuildRequires: %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
 BuildRequires: autoconf
@@ -238,6 +239,7 @@ Moduły języka Python dla poldka.
 %patch6 -p1
 %patch7 -p1
 %patch8 -p1
+%patch9 -p1
 
 %{__rm} m4/libtool.m4 m4/lt*.m4
 
This page took 0.045749 seconds and 4 git commands to generate.