]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- increase release component so that conflict poldek-libs < 0.30-0.20080820.23.40...
[packages/poldek.git] / poldek.spec
1 # TODO:
2 # - fails to build without poldek-devel - fix it !
3 #
4 # Conditional build:
5 %bcond_with     static  # don't use shared libraries
6 %bcond_without  imode   # don't build interactive mode
7 %bcond_without  python  # don't build python bindings
8
9 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
10 %if "%{pld_release}" == "ti"
11 %define ver_db  4.5.20
12 %define ver_db_rel      8
13 %else
14 %define ver_db  4.7.25
15 %define ver_db_rel      1
16 %endif
17 %define ver_rpm 4.5-49
18
19 %define         snap    rc3
20 %define         rel     2
21 Summary:        RPM packages management helper tool
22 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
23 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
24 Name:           poldek
25 Version:        0.30
26 Release:        1.%{snap}.%{rel}
27 License:        GPL v2
28 Group:          Applications/System
29 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
30 Source0:        http://carme.pld-linux.org/~cactus/snaps/poldek/%{name}-%{version}%{snap}.tar.bz2
31 # Source0-md5:  d85c14544d02d03d67d0b1ebd6ec7c61
32 Source1:        %{name}.conf
33 Source2:        %{name}-multilib.conf
34 Source3:        %{name}-ti.conf
35 Source4:        %{name}-multilib-ti.conf
36 Source5:        %{name}-aliases.conf
37 Source6:        %{name}.desktop
38 Source7:        %{name}.png
39 Source8:        %{name}-debuginfo.conf
40 Source9:        %{name}-aidath.conf
41 Source10:       %{name}-multilib-aidath.conf
42 Source11:       %{name}-archive.conf
43 Patch0:         %{name}-vserver-packages.patch
44 Patch1:         %{name}-config.patch
45 Patch2:         %{name}-size-type.patch
46 Patch3:         %{name}-Os-fail-workaround.patch
47 URL:            http://poldek.pld-linux.org/
48 BuildRequires:  autoconf
49 BuildRequires:  automake
50 BuildRequires:  bzip2-devel
51 BuildRequires:  check-devel
52 BuildRequires:  db-devel >= %{ver_db}-%{ver_db_rel}
53 BuildRequires:  docbook-dtd412-xml
54 BuildRequires:  gettext-devel
55 BuildRequires:  libtool
56 BuildRequires:  libxml2-devel
57 BuildRequires:  neon-devel
58 BuildRequires:  openssl-devel >= 0.9.7d
59 BuildRequires:  pcre-devel
60 BuildRequires:  pkgconfig
61 BuildRequires:  popt-devel
62 %{?with_python:BuildRequires:   python-devel}
63 BuildRequires:  readline-devel >= 5.0
64 BuildRequires:  rpm-devel >= %{ver_rpm}
65 %{?with_python:BuildRequires:   rpm-pythonprov}
66 BuildRequires:  swig-python
67 BuildRequires:  zlib-devel
68 %if %{with static}
69 BuildRequires:  bzip2-static
70 BuildRequires:  db-static >= %{ver_db}-%{ver_db_rel}
71 BuildRequires:  glibc-static
72 BuildRequires:  libselinux-static
73 BuildRequires:  libxml2-static
74 BuildRequires:  ncurses-static
75 BuildRequires:  openssl-static
76 BuildRequires:  pcre-static
77 BuildRequires:  popt-static
78 BuildRequires:  readline-static
79 BuildRequires:  rpm-static
80 BuildRequires:  zlib-static
81 %endif
82 Requires(triggerpostun):        awk
83 Requires(triggerpostun):        sed >= 4.0
84 Requires:       %{name}-libs = %{version}-%{release}
85 Requires:       db >= %{ver_db}-%{ver_db_rel}
86 Requires:       rpm >= %{ver_rpm}
87 Requires:       rpm-db-ver = %{ver_db}
88 Requires:       rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
89 # vf* scripts use sed
90 Requires:       sed
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %description
94 poldek is an RPM package management tool which allows you to easily
95 perform package verification, installation (including system
96 installation from scratch), upgrading, and removal.
97
98 Program can be used in batch (like apt-get from Debian's APT) or
99 interactive mode. The interactive mode puts you into a readline
100 interface with command line autocompletion and history, similar to the
101 shell mode of Perl's CPAN.
102
103 %{?with_static:This version is statically linked.}
104
105 %{!?with_imode:This version hasn't got interactive mode.}
106 #'vim
107
108 %description -l hu.UTF-8
109 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
110 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
111 nulláról), frissítést és eltávolítást.
112
113 A program használható parancssorból (mint a Debian apt-get programja)
114 vagy interaktív módban. Az interaktív mód egy readline környezetet
115 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
116 shell módjához.
117
118 %{?with_static:Ez a verzió statikusan linkelt.}
119
120 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
121
122 %description -l pl.UTF-8
123 poldek jest narzędziem linii poleceń służącym do weryfikacji,
124 instalacji (włączając instalację systemu od zera), aktualizacji i
125 usuwania pakietów.
126
127 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
128 interaktywnym. Tryb interaktywny posiada interfejs readline z
129 dopełnianiem komend i historią, podobny do trybu shell perlowego
130 modułu CPAN.
131
132 %{?with_static:Ta wersja jest konsolidowana statycznie.}
133
134 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
135
136 %package libs
137 Summary:        poldek libraries
138 Summary(hu.UTF-8):      A poldek könyvtárai
139 Summary(pl.UTF-8):      Biblioteki poldka
140 Group:          Libraries
141
142 %description libs
143 poldek libraries.
144
145 %description libs -l hu.UTF-8
146 A poldek könyvtárai.
147
148 %description libs -l pl.UTF-8
149 Biblioteki poldka.
150
151 %package devel
152 Summary:        Header files for poldek libraries
153 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
154 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
155 Group:          Development/Libraries
156 Requires:       %{name}-libs = %{version}-%{release}
157 Requires:       rpm-devel >= %{ver_rpm}
158
159 %description devel
160 Header files for poldek libraries.
161
162 %description devel -l hu.UTF-8
163 A poldek könyvtár fejlesztői fájljai.
164
165 %description devel -l pl.UTF-8
166 Pliki nagłówkowe bibliotek poldka.
167
168 %package static
169 Summary:        poldek static libraries
170 Summary(hu.UTF-8):      poldek statikus könyvtárak
171 Summary(pl.UTF-8):      Biblioteki statyczne poldka
172 Group:          Development/Libraries
173 Requires:       %{name}-devel = %{version}-%{release}
174
175 %description static
176 poldek static libraries.
177
178 %description static -l hu.UTF-8
179 poldek statikus könyvtárak.
180
181 %description static -l pl.UTF-8
182 Biblioteki statyczne poldka.
183
184 %package -n python-poldek
185 Summary:        Python modules for poldek
186 Summary(hu.UTF-8):      Python modulok poldek-hez
187 Summary(pl.UTF-8):      Moduły języka Python dla poldka
188 Group:          Libraries/Python
189 Requires:       %{name}-libs = %{version}-%{release}
190 %pyrequires_eq  python-libs
191
192 %description -n python-poldek
193 Python modules for poldek.
194
195 %description -n python-poldek -l hu.UTF-8
196 Python modulok poldek-hez.
197
198 %description -n python-poldek -l pl.UTF-8
199 Moduły języka Python dla poldka.
200
201 %prep
202 %setup -q
203 %patch0 -p1
204 %patch1 -p1
205 %patch2 -p1
206 %patch3 -p1
207
208 rm -f m4/libtool.m4 m4/lt*.m4
209
210 # cleanup backups after patching
211 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
212 chmod u+x ./configure ./doc/conf-xml2.sh
213
214 %build
215 %{__libtoolize}
216 %{__aclocal} -I m4
217 %{__autoheader}
218 %{__autoconf}
219 %{__automake}
220 cd tndb
221 autoreconf -i
222 cd ../trurlib
223 autoreconf -i
224 cd ..
225
226 CPPFLAGS="-std=gnu99"
227 %configure \
228         %{?with_static:--enable-static --disable-shared} \
229         %{!?with_imode:--disable-imode} \
230         --enable-nls \
231         %{?with_python:--with-python}
232 %{__make}
233 #       --enable-trace
234
235 %install
236 rm -rf $RPM_BUILD_ROOT
237 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d
238
239 %{__make} install \
240         DESTDIR=$RPM_BUILD_ROOT
241
242 %if %{with python}
243 %{__make} -C python install \
244         DESTDIR=$RPM_BUILD_ROOT \
245         libdir=%{py_sitedir}
246 %endif
247
248 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
249
250 %ifarch i486 i686 ppc sparc alpha athlon
251         %define         _ftp_arch       %{_target_cpu}
252 %endif
253 %ifarch %{x8664}
254         %define         _ftp_arch       x86_64
255         %define         _ftp_alt_arch   i686
256 %endif
257 %ifarch i586
258         %if "%{pld_release}" == "ti"
259                 %define         _ftp_arch       i586
260         %else
261                 %define         _ftp_arch       i486
262         %endif
263 %endif
264 %ifarch pentium2 pentium3 pentium4
265         %define         _ftp_arch       i686
266 %endif
267 %ifarch sparcv9 sparc64
268         %define         _ftp_arch       sparc
269         %if "%{pld_release}" == "th"
270                 %define         _ftp_arch       %{_target_cpu}
271                 %ifarch sparc64
272                 %define         _ftp_alt_arch   sparcv9
273                 %endif
274         %endif
275 %endif
276
277 %if "%{pld_release}" == "ti"
278         %define pld_conf %{SOURCE3}
279         %ifarch %{x8664}
280                 %define pld_multilib_conf %{SOURCE4}
281         %endif
282 %endif
283
284 %if "%{pld_release}" == "th"
285         %define pld_conf %{SOURCE1}
286         %define pld_debuginfo_conf %{SOURCE8}
287         %define pld_archive_conf %{SOURCE11}
288
289         %ifarch %{x8664}
290                 %define pld_multilib_conf %{SOURCE2}
291         %endif
292
293         # aidath
294         %ifarch sparcv9 sparc64
295                 %define pld_conf %{SOURCE9}
296                 %undefine pld_archive_conf
297         %endif
298         %ifarch sparc64
299                 %define pld_multilib_conf %{SOURCE10}
300         %endif
301 %endif
302
303 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
304
305 %if 0%{?pld_multilib_conf:1}
306         sed 's|%%ARCH%%|%{_ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
307 %endif
308
309 %if 0%{?pld_debuginfo_conf:1}
310 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
311 %endif
312
313 %if 0%{?pld_archive_conf:1}
314 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
315 %endif
316
317 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
318
319 %if %{with imode}
320 # add desktop file and icon
321 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
322 cp -a %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
323 cp -a %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
324 %endif
325
326 # sources we don't package
327 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,pld,fedora,centos}-source.conf
328 # include them in %doc
329 rm -rf configs
330 cp -a conf configs
331 rm -f configs/Makefile*
332
333 %if %{with python}
334 %py_postclean
335 rm -f $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
336 %endif
337
338 %find_lang %{name}
339
340 %clean
341 rm -rf $RPM_BUILD_ROOT
342
343 %post
344 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
345 if [ "$1" = "1" ]; then
346         # remove ignore = vserver-packages inside vserver on first install
347         {
348                 while read f ctx; do
349                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
350                 done </proc/self/status
351         } 2>/dev/null
352         if [ -z "$ctx" -o "$ctx" = "0" ]; then
353                 VSERVER=no
354         else
355                 VSERVER=yes
356         fi
357         if [ "$VSERVER" = "yes" ]; then
358                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
359         fi
360 fi
361
362 %postun -p      /sbin/postshell
363 -/usr/sbin/fix-info-dir -c %{_infodir}
364
365 %post   libs -p /sbin/ldconfig
366 %postun libs -p /sbin/ldconfig
367
368 %triggerpostun -- poldek < 0.19.0-1.20050613.22.0
369 if [ -f /etc/poldek.conf.rpmsave ]; then
370         awk '/^source/ {
371         name = $3;
372         path = $4;
373         auto = "yes";
374         autoup = "yes";
375         type = "pdir";
376         pri = "";
377
378         if (sub(",noauto", "", name)) {
379                 auto = "no";
380         }
381
382         # process pri=\d+
383         if (match(name, /,pri=[0-9]+/)) {
384                 pri = substr(name, RSTART + 5, RLENGTH - 5);
385                 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
386         }
387
388         # skip ac sources. already in new config.
389         if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
390                 print "";
391                 print "[source]";
392                 print "name = " name;
393                 print "type = " type;
394                 print "path = " path;
395                 print "auto = " auto;
396                 print "autoup = " autoup;
397                 if (pri) {
398                         print "pri = " pri;
399                 }
400         }
401
402         }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
403         echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
404
405         # copy hold=
406         hold=$(grep ^hold /etc/poldek.conf.rpmsave)
407         if [ "$hold" ]; then
408                 sed -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
409         fi
410 fi
411
412 %triggerpostun -- poldek < 0.30-0.20080225.00.1
413 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
414         %{__sed} -i -e '/^%%include source.conf/{
415                 a
416                 a# /etc/poldek/repos.d/*.conf
417                 a%%includedir repos.d
418         }' %{_sysconfdir}/%{name}/poldek.conf
419 fi
420
421 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
422 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
423
424 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
425         cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
426         cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
427 fi
428
429 %ifarch %{x8664}
430 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
431         cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
432         cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
433 fi
434 %endif
435
436 %files -f %{name}.lang
437 %defattr(644,root,root,755)
438 %doc ChangeLog README* NEWS TODO configs
439 %dir %{_sysconfdir}/%{name}
440 %dir %{_sysconfdir}/%{name}/repos.d
441 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
442 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
443 %attr(755,root,root) %{_bindir}/*
444 %dir %{_libdir}/%{name}
445 %attr(755,root,root) %{_libdir}/%{name}/*
446 %{_mandir}/man1/%{name}*
447 %lang(pl) %{_mandir}/pl/man1/%{name}*
448 %{_infodir}/poldek.info*
449 %if %{with imode}
450 %{_desktopdir}/%{name}.desktop
451 %{_pixmapsdir}/%{name}.png
452 %endif
453
454 %if %{without static}
455 %files libs
456 %defattr(644,root,root,755)
457 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
458 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
459 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
460 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
461 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
462 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
463 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
464 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
465 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
466 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
467 %endif
468
469 %files devel
470 %defattr(644,root,root,755)
471 %{!?with_static:%attr(755,root,root) %{_libdir}/lib*.so}
472 %{_libdir}/lib*.la
473 %{_includedir}/*
474
475 %files static
476 %defattr(644,root,root,755)
477 %{_libdir}/lib*.a
478
479 %if %{with python}
480 %files -n python-poldek
481 %defattr(644,root,root,755)
482 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
483 %{py_sitescriptdir}/poldek.py[co]
484 %{py_sitescriptdir}/poldekmod.py[co]
485 %endif
This page took 0.297684 seconds and 4 git commands to generate.