]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
Th snapshot support
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_without  python  # don't build python bindings
6 %bcond_with     snap    # don't build python bindings
7
8 %if %{with snap}
9 %define         SNAP    2012
10 %endif
11
12 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
13 %define ver_db  4.7.25
14 %define ver_db_rel      1
15 %define ver_rpm 4.5-49
16
17 %define         snap    rc5
18 %define         rel     12
19 Summary:        RPM packages management helper tool
20 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
21 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
22 Name:           poldek
23 Version:        0.30
24 Release:        1.%{snap}.%{rel}
25 License:        GPL v2
26 Group:          Applications/System
27 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
28 Source0:        http://carme.pld-linux.org/~cactus/snaps/poldek/%{name}-%{version}%{snap}.tar.xz
29 # Source0-md5:  ab89926c28cfb6b7d72497fc37c16ac4
30 Source1:        %{name}.conf
31 Source2:        %{name}-multilib.conf
32 Source5:        %{name}-aliases.conf
33 Source6:        %{name}.desktop
34 Source7:        %{name}.png
35 Source8:        %{name}-debuginfo.conf
36 Source9:        %{name}-aidath.conf
37 Source10:       %{name}-multilib-aidath.conf
38 Source11:       %{name}-archive.conf
39 Source100:      %{name}-snap.conf
40 Source101:      %{name}-multilib-snap.conf
41 Source102:      %{name}-debuginfo-snap.conf
42 Patch0:         %{name}-vserver-packages.patch
43 Patch1:         %{name}-config.patch
44 Patch2:         %{name}-size-type.patch
45 Patch3:         %{name}-Os-fail-workaround.patch
46 Patch4:         %{name}-git.patch
47 Patch5:         %{name}-am.patch
48 URL:            http://poldek.pld-linux.org/
49 BuildRequires:  autoconf
50 BuildRequires:  automake
51 BuildRequires:  bzip2-devel
52 BuildRequires:  check-devel
53 BuildRequires:  db-devel >= %{ver_db}-%{ver_db_rel}
54 BuildRequires:  docbook-dtd412-xml
55 BuildRequires:  gettext-devel
56 BuildRequires:  libtool
57 BuildRequires:  libxml2-devel
58 BuildRequires:  neon-devel
59 BuildRequires:  openssl-devel >= 0.9.7d
60 BuildRequires:  pcre-devel
61 BuildRequires:  pkgconfig
62 BuildRequires:  popt-devel
63 %{?with_python:BuildRequires:   python-devel}
64 BuildRequires:  readline-devel >= 5.0
65 BuildRequires:  rpm-devel >= %{ver_rpm}
66 %{?with_python:BuildRequires:   rpm-pythonprov}
67 BuildRequires:  swig-python
68 BuildRequires:  xmlto
69 BuildRequires:  zlib-devel
70 %if %{with static}
71 BuildRequires:  bzip2-static
72 BuildRequires:  db-static >= %{ver_db}-%{ver_db_rel}
73 BuildRequires:  glibc-static
74 BuildRequires:  libselinux-static
75 BuildRequires:  libxml2-static
76 BuildRequires:  ncurses-static
77 BuildRequires:  openssl-static
78 BuildRequires:  pcre-static
79 BuildRequires:  popt-static
80 BuildRequires:  readline-static
81 BuildRequires:  rpm-static
82 BuildRequires:  zlib-static
83 %endif
84 Requires(triggerpostun):        awk
85 Requires(triggerpostun):        sed >= 4.0
86 Requires:       %{name}-libs = %{version}-%{release}
87 Requires:       db >= %{ver_db}-%{ver_db_rel}
88 Requires:       rpm >= %{ver_rpm}
89 Requires:       rpm-db-ver = %{ver_db}
90 Requires:       rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
91 # vf* scripts use sed
92 Requires:       sed
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %description
96 poldek is an RPM package management tool which allows you to easily
97 perform package verification, installation (including system
98 installation from scratch), upgrading, and removal.
99
100 Program can be used in batch (like apt-get from Debian's APT) or
101 interactive mode. The interactive mode puts you into a readline
102 interface with command line autocompletion and history, similar to the
103 shell mode of Perl's CPAN.
104
105 %{?with_static:This version is statically linked.}
106
107 %{!?with_imode:This version hasn't got interactive mode.}
108 #'vim
109
110 %description -l hu.UTF-8
111 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
112 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
113 nulláról), frissítést és eltávolítást.
114
115 A program használható parancssorból (mint a Debian apt-get programja)
116 vagy interaktív módban. Az interaktív mód egy readline környezetet
117 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
118 shell módjához.
119
120 %{?with_static:Ez a verzió statikusan linkelt.}
121
122 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
123
124 %description -l pl.UTF-8
125 poldek jest narzędziem linii poleceń służącym do weryfikacji,
126 instalacji (włączając instalację systemu od zera), aktualizacji i
127 usuwania pakietów.
128
129 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
130 interaktywnym. Tryb interaktywny posiada interfejs readline z
131 dopełnianiem komend i historią, podobny do trybu shell perlowego
132 modułu CPAN.
133
134 %{?with_static:Ta wersja jest konsolidowana statycznie.}
135
136 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
137
138 %package libs
139 Summary:        poldek libraries
140 Summary(hu.UTF-8):      A poldek könyvtárai
141 Summary(pl.UTF-8):      Biblioteki poldka
142 Group:          Libraries
143
144 %description libs
145 poldek libraries.
146
147 %description libs -l hu.UTF-8
148 A poldek könyvtárai.
149
150 %description libs -l pl.UTF-8
151 Biblioteki poldka.
152
153 %package devel
154 Summary:        Header files for poldek libraries
155 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
156 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
157 Group:          Development/Libraries
158 Requires:       %{name}-libs = %{version}-%{release}
159 Requires:       rpm-devel >= %{ver_rpm}
160
161 %description devel
162 Header files for poldek libraries.
163
164 %description devel -l hu.UTF-8
165 A poldek könyvtár fejlesztői fájljai.
166
167 %description devel -l pl.UTF-8
168 Pliki nagłówkowe bibliotek poldka.
169
170 %package static
171 Summary:        poldek static libraries
172 Summary(hu.UTF-8):      poldek statikus könyvtárak
173 Summary(pl.UTF-8):      Biblioteki statyczne poldka
174 Group:          Development/Libraries
175 Requires:       %{name}-devel = %{version}-%{release}
176
177 %description static
178 poldek static libraries.
179
180 %description static -l hu.UTF-8
181 poldek statikus könyvtárak.
182
183 %description static -l pl.UTF-8
184 Biblioteki statyczne poldka.
185
186 %package -n python-poldek
187 Summary:        Python modules for poldek
188 Summary(hu.UTF-8):      Python modulok poldek-hez
189 Summary(pl.UTF-8):      Moduły języka Python dla poldka
190 Group:          Libraries/Python
191 Requires:       %{name}-libs = %{version}-%{release}
192 %pyrequires_eq  python-libs
193
194 %description -n python-poldek
195 Python modules for poldek.
196
197 %description -n python-poldek -l hu.UTF-8
198 Python modulok poldek-hez.
199
200 %description -n python-poldek -l pl.UTF-8
201 Moduły języka Python dla poldka.
202
203 %prep
204 %setup -q
205 %patch0 -p1
206 %patch1 -p1
207 %patch2 -p1
208 %patch3 -p1
209 %patch4 -p1
210 %patch5 -p1
211
212 %{__rm} m4/libtool.m4 m4/lt*.m4
213
214 # cleanup backups after patching
215 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
216 chmod u+x ./configure ./doc/conf-xml2.sh
217
218 %build
219 %{__libtoolize}
220 %{__aclocal} -I m4
221 %{__autoheader}
222 %{__autoconf}
223 %{__automake}
224 cd tndb
225 %{__libtoolize}
226 %{__aclocal}
227 %{__autoheader}
228 %{__autoconf}
229 %{__automake}
230 cd ../trurlib
231 %{__libtoolize}
232 %{__aclocal}
233 %{__autoheader}
234 %{__autoconf}
235 %{__automake}
236 cd ..
237
238 CPPFLAGS="%{rpmcppflags} -std=gnu99"
239 %configure \
240         %{?with_static:--enable-static --disable-shared} \
241         %{!?with_imode:--disable-imode} \
242         --enable-nls \
243         %{?with_python:--with-python}
244 %{__make} -j1
245 #       --enable-trace
246
247 %install
248 rm -rf $RPM_BUILD_ROOT
249 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}/repos.d,/var/cache/%{name}}
250
251 %{__make} install -j1 \
252         DESTDIR=$RPM_BUILD_ROOT
253
254 %if %{with python}
255 %{__make} -C python -j1 install \
256         DESTDIR=$RPM_BUILD_ROOT \
257         libdir=%{py_sitedir}
258 %endif
259
260 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
261
262 %ifarch i486 i686 ppc sparc alpha athlon
263         %define         _ftp_arch       %{_target_cpu}
264 %endif
265 %ifarch %{x8664}
266         %define         _ftp_arch       x86_64
267         %define         _ftp_alt_arch   i686
268 %endif
269 %ifarch i586
270         %define         _ftp_arch       i486
271 %endif
272 %ifarch pentium2 pentium3 pentium4
273         %define         _ftp_arch       i686
274 %endif
275 %ifarch sparcv9 sparc64
276         %define         _ftp_arch       sparc
277         %define         _ftp_arch       %{_target_cpu}
278         %ifarch sparc64
279                 %define         _ftp_alt_arch   sparcv9
280         %endif
281 %endif
282
283 %define pld_conf %{SOURCE1}
284 %define pld_debuginfo_conf %{SOURCE8}
285 %define pld_archive_conf %{SOURCE11}
286
287 %ifarch %{x8664}
288         %define pld_multilib_conf %{SOURCE2}
289 %endif
290
291 # aidath
292 %ifarch sparcv9 sparc64
293         %define pld_conf %{SOURCE9}
294         %undefine pld_archive_conf
295 %endif
296 %ifarch sparc64
297         %define pld_multilib_conf %{SOURCE10}
298 %endif
299
300 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
301
302 %if 0%{?pld_multilib_conf:1}
303         sed 's|%%ARCH%%|%{_ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
304 %endif
305
306 %if 0%{?pld_debuginfo_conf:1}
307 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
308 %endif
309
310 %if 0%{?pld_archive_conf:1}
311 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
312 %endif
313
314 %if %{with snap}
315 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' \
316         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
317 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' \
318         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
319 %ifarch %{x8664}
320         sed -e 's|%%ARCH%%|%{_ftp_alt_arch}|g' \
321                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf
322 %endif
323 sed -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
324 %else
325 sed -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
326 %endif
327
328 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
329
330 %if %{with imode}
331 # add desktop file and icon
332 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
333 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
334 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
335 %endif
336
337 # sources we don't package
338 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
339 # include them in %doc
340 rm -rf configs
341 cp -a conf configs
342 rm -f configs/Makefile*
343
344 %if %{with python}
345 %py_postclean
346 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
347 %endif
348
349 %find_lang %{name}
350
351 %clean
352 rm -rf $RPM_BUILD_ROOT
353
354 %post
355 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
356 if [ "$1" = "1" ]; then
357         # remove ignore = vserver-packages inside vserver on first install
358         {
359                 while read f ctx; do
360                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
361                 done </proc/self/status
362         } 2>/dev/null
363         if [ -z "$ctx" -o "$ctx" = "0" ]; then
364                 VSERVER=no
365         else
366                 VSERVER=yes
367         fi
368         if [ "$VSERVER" = "yes" ]; then
369                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
370         fi
371 fi
372
373 %postun -p      /sbin/postshell
374 -/usr/sbin/fix-info-dir -c %{_infodir}
375
376 %post   libs -p /sbin/ldconfig
377 %postun libs -p /sbin/ldconfig
378
379 %triggerpostun -- poldek < 0.19.0-1.20050613.22.0
380 if [ -f /etc/poldek.conf.rpmsave ]; then
381         awk '/^source/ {
382         name = $3;
383         path = $4;
384         auto = "yes";
385         autoup = "yes";
386         type = "pdir";
387         pri = "";
388
389         if (sub(",noauto", "", name)) {
390                 auto = "no";
391         }
392
393         # process pri=\d+
394         if (match(name, /,pri=[0-9]+/)) {
395                 pri = substr(name, RSTART + 5, RLENGTH - 5);
396                 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
397         }
398
399         # skip ac sources. already in new config.
400         if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
401                 print "";
402                 print "[source]";
403                 print "name = " name;
404                 print "type = " type;
405                 print "path = " path;
406                 print "auto = " auto;
407                 print "autoup = " autoup;
408                 if (pri) {
409                         print "pri = " pri;
410                 }
411         }
412
413         }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
414         echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
415
416         # copy hold=
417         hold=$(grep ^hold /etc/poldek.conf.rpmsave)
418         if [ "$hold" ]; then
419                 sed -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
420         fi
421 fi
422
423 %triggerpostun -- poldek < 0.30-0.20080225.00.1
424 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
425         %{__sed} -i -e '/^%%include source.conf/{
426                 a
427                 a# /etc/poldek/repos.d/*.conf
428                 a%%includedir repos.d
429         }' %{_sysconfdir}/%{name}/poldek.conf
430 fi
431
432 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
433 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
434
435 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
436         cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
437         cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
438 fi
439
440 %ifarch %{x8664}
441 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
442         cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
443         cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
444 fi
445 %endif
446
447 %files -f %{name}.lang
448 %defattr(644,root,root,755)
449 %doc ChangeLog README* NEWS TODO configs
450 %dir %{_sysconfdir}/%{name}
451 %dir %{_sysconfdir}/%{name}/repos.d
452 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
453 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
454 %attr(755,root,root) %{_bindir}/ipoldek
455 %attr(755,root,root) %{_bindir}/poldek
456 %attr(755,root,root) %{_bindir}/rpmvercmp
457 %dir %{_libdir}/%{name}
458 %attr(755,root,root) %{_libdir}/%{name}/*
459 %{_mandir}/man1/%{name}*.1*
460 %lang(pl) %{_mandir}/pl/man1/%{name}*
461 %{_infodir}/poldek.info*
462 %if %{with imode}
463 %{_desktopdir}/%{name}.desktop
464 %{_pixmapsdir}/%{name}.png
465 %endif
466 %dir /var/cache/%{name}
467
468 %if %{without static}
469 %files libs
470 %defattr(644,root,root,755)
471 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
472 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
473 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
474 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
475 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
476 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
477 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
478 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
479 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
480 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
481 %endif
482
483 %files devel
484 %defattr(644,root,root,755)
485 %if %{without static}
486 %attr(755,root,root) %{_libdir}/libpoclidek.so
487 %attr(755,root,root) %{_libdir}/libpoldek.so
488 %attr(755,root,root) %{_libdir}/libtndb.so
489 %attr(755,root,root) %{_libdir}/libtrurl.so
490 %attr(755,root,root) %{_libdir}/libvfile.so
491 %endif
492 %{_libdir}/libpoclidek.la
493 %{_libdir}/libpoldek.la
494 %{_libdir}/libtndb.la
495 %{_libdir}/libtrurl.la
496 %{_libdir}/libvfile.la
497 %{_includedir}/poldek
498 %{_includedir}/tndb
499 %{_includedir}/trurl
500 %{_includedir}/vfile
501 %{_pkgconfigdir}/tndb.pc
502
503 %files static
504 %defattr(644,root,root,755)
505 %{_libdir}/libtndb.a
506 %{_libdir}/libtrurl.a
507
508 %if %{with python}
509 %files -n python-poldek
510 %defattr(644,root,root,755)
511 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
512 %{py_sitescriptdir}/poldek.py[co]
513 %{py_sitescriptdir}/poldekmod.py[co]
514 %endif
This page took 0.114681 seconds and 4 git commands to generate.