]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- workaround for fetch.conf being overwritten with source.conf contents. lp#891997
[packages/poldek.git] / poldek.spec
1 # TODO:
2 # - fails to build without poldek-devel - fix it !
3 #
4 # Conditional build:
5 %bcond_with     static  # don't use shared libraries
6 %bcond_without  imode   # don't build interactive mode
7 %bcond_without  python  # don't build python bindings
8
9 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
10 %if "%{pld_release}" == "ti"
11 %define ver_db  4.5.20
12 %define ver_db_rel      8
13 %else
14 %define ver_db  4.7.25
15 %define ver_db_rel      1
16 %endif
17 %define ver_rpm 4.5-49
18
19 %define         snap    rc2
20 %define         rel             4
21 Summary:        RPM packages management helper tool
22 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
23 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
24 Name:           poldek
25 Version:        0.30
26 Release:        0.%{snap}.%{rel}
27 License:        GPL v2
28 Group:          Applications/System
29 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
30 Source0:        http://carme.pld-linux.org/~cactus/snaps/poldek/%{name}-%{version}%{snap}.tar.bz2
31 # Source0-md5:  14135ae2960da09990c50d5b5342be64
32 Source1:        %{name}.conf
33 Source2:        %{name}-multilib.conf
34 Source3:        %{name}-ti.conf
35 Source4:        %{name}-multilib-ti.conf
36 Source5:        %{name}-aliases.conf
37 Source6:        %{name}.desktop
38 Source7:        %{name}.png
39 Source8:        %{name}-debuginfo.conf
40 Source9:        %{name}-aidath.conf
41 Source10:       %{name}-multilib-aidath.conf
42 Source11:       %{name}-archive.conf
43 Patch0:         %{name}-vserver-packages.patch
44 Patch1:         %{name}-config.patch
45 Patch2:         %{name}-size-type.patch
46 Patch4:         %{name}-Os-fail-workaround.patch
47 URL:            http://poldek.pld-linux.org/
48 BuildRequires:  autoconf
49 BuildRequires:  automake
50 BuildRequires:  bzip2-devel
51 BuildRequires:  check-devel
52 BuildRequires:  db-devel >= %{ver_db}-%{ver_db_rel}
53 BuildRequires:  docbook-dtd412-xml
54 BuildRequires:  gettext-devel
55 BuildRequires:  libtool
56 BuildRequires:  libxml2-devel
57 BuildRequires:  neon-devel
58 BuildRequires:  openssl-devel >= 0.9.7d
59 BuildRequires:  pcre-devel
60 BuildRequires:  pkgconfig
61 BuildRequires:  popt-devel
62 %{?with_python:BuildRequires:   python-devel}
63 BuildRequires:  readline-devel >= 5.0
64 BuildRequires:  rpm-devel >= %{ver_rpm}
65 %{?with_python:BuildRequires:   rpm-pythonprov}
66 BuildRequires:  swig-python
67 BuildRequires:  zlib-devel
68 %if %{with static}
69 BuildRequires:  bzip2-static
70 BuildRequires:  db-static >= %{ver_db}-%{ver_db_rel}
71 BuildRequires:  glibc-static
72 BuildRequires:  libselinux-static
73 BuildRequires:  libxml2-static
74 BuildRequires:  ncurses-static
75 BuildRequires:  openssl-static
76 BuildRequires:  pcre-static
77 BuildRequires:  popt-static
78 BuildRequires:  readline-static
79 BuildRequires:  rpm-static
80 BuildRequires:  zlib-static
81 %endif
82 Requires(triggerpostun):        awk
83 Requires(triggerpostun):        sed >= 4.0
84 Requires:       %{name}-libs = %{version}-%{release}
85 Requires:       db >= %{ver_db}-%{ver_db_rel}
86 Requires:       rpm >= %{ver_rpm}
87 Requires:       rpm-db-ver = %{ver_db}
88 Requires:       rpm-lib = %(rpm -q --qf '%{V}' rpm-lib)
89 # vf* scripts use sed
90 Requires:       sed
91 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
92
93 %description
94 poldek is an RPM package management tool which allows you to easily
95 perform package verification, installation (including system
96 installation from scratch), upgrading, and removal.
97
98 Program can be used in batch (like apt-get from Debian's APT) or
99 interactive mode. The interactive mode puts you into a readline
100 interface with command line autocompletion and history, similar to the
101 shell mode of Perl's CPAN.
102
103 %{?with_static:This version is statically linked.}
104
105 %{!?with_imode:This version hasn't got interactive mode.}
106 #'vim
107
108 %description -l hu.UTF-8
109 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
110 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
111 nulláról), frissítést és eltávolítást.
112
113 A program használható parancssorból (mint a Debian apt-get programja)
114 vagy interaktív módban. Az interaktív mód egy readline környezetet
115 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
116 shell módjához.
117
118 %{?with_static:Ez a verzió statikusan linkelt.}
119
120 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
121
122 %description -l pl.UTF-8
123 poldek jest narzędziem linii poleceń służącym do weryfikacji,
124 instalacji (włączając instalację systemu od zera), aktualizacji i
125 usuwania pakietów.
126
127 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
128 interaktywnym. Tryb interaktywny posiada interfejs readline z
129 dopełnianiem komend i historią, podobny do trybu shell perlowego
130 modułu CPAN.
131
132 %{?with_static:Ta wersja jest konsolidowana statycznie.}
133
134 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
135
136 %package libs
137 Summary:        poldek libraries
138 Summary(hu.UTF-8):      A poldek könyvtárai
139 Summary(pl.UTF-8):      Biblioteki poldka
140 Group:          Libraries
141
142 %description libs
143 poldek libraries.
144
145 %description libs -l hu.UTF-8
146 A poldek könyvtárai.
147
148 %description libs -l pl.UTF-8
149 Biblioteki poldka.
150
151 %package devel
152 Summary:        Header files for poldek libraries
153 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
154 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
155 Group:          Development/Libraries
156 Requires:       %{name}-libs = %{version}-%{release}
157 Requires:       rpm-devel >= %{ver_rpm}
158
159 %description devel
160 Header files for poldek libraries.
161
162 %description devel -l hu.UTF-8
163 A poldek könyvtár fejlesztői fájljai.
164
165 %description devel -l pl.UTF-8
166 Pliki nagłówkowe bibliotek poldka.
167
168 %package static
169 Summary:        poldek static libraries
170 Summary(hu.UTF-8):      poldek statikus könyvtárak
171 Summary(pl.UTF-8):      Biblioteki statyczne poldka
172 Group:          Development/Libraries
173 Requires:       %{name}-devel = %{version}-%{release}
174
175 %description static
176 poldek static libraries.
177
178 %description static -l hu.UTF-8
179 poldek statikus könyvtárak.
180
181 %description static -l pl.UTF-8
182 Biblioteki statyczne poldka.
183
184 %package -n python-poldek
185 Summary:        Python modules for poldek
186 Summary(hu.UTF-8):      Python modulok poldek-hez
187 Summary(pl.UTF-8):      Moduły języka Python dla poldka
188 Group:          Libraries/Python
189 Requires:       %{name}-libs = %{version}-%{release}
190 %pyrequires_eq  python-libs
191
192 %description -n python-poldek
193 Python modules for poldek.
194
195 %description -n python-poldek -l hu.UTF-8
196 Python modulok poldek-hez.
197
198 %description -n python-poldek -l pl.UTF-8
199 Moduły języka Python dla poldka.
200
201 %prep
202 %setup -q
203 %patch0 -p1
204 %patch1 -p1
205 %patch2 -p1
206 %patch4 -p1
207
208 rm -f m4/libtool.m4 m4/lt*.m4
209
210 # cleanup backups after patching
211 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
212 chmod u+x ./configure ./doc/conf-xml2.sh
213
214 %build
215 %{__libtoolize}
216 %{__aclocal} -I m4
217 %{__autoheader}
218 %{__autoconf}
219 %{__automake}
220 cp -f config.sub trurlib
221
222 CPPFLAGS="-std=gnu99"
223 %configure \
224         %{?with_static:--enable-static --disable-shared} \
225         %{!?with_imode:--disable-imode} \
226         --enable-nls \
227         %{?with_python:--with-python}
228 %{__make}
229 #       --enable-trace
230
231 %install
232 rm -rf $RPM_BUILD_ROOT
233 install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d
234
235 # -j1 due: https://bugs.launchpad.net/poldek/+bug/891997
236 %{__make} -j1 install \
237         DESTDIR=$RPM_BUILD_ROOT
238
239 %if %{with python}
240 %{__make} -C python install \
241         DESTDIR=$RPM_BUILD_ROOT \
242         libdir=%{py_sitedir}
243 %endif
244
245 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
246
247 %ifarch i486 i686 ppc sparc alpha athlon
248         %define         _ftp_arch       %{_target_cpu}
249 %endif
250 %ifarch %{x8664}
251         %define         _ftp_arch       x86_64
252         %define         _ftp_alt_arch   i686
253 %endif
254 %ifarch i586
255         %if "%{pld_release}" == "ti"
256                 %define         _ftp_arch       i586
257         %else
258                 %define         _ftp_arch       i486
259         %endif
260 %endif
261 %ifarch pentium2 pentium3 pentium4
262         %define         _ftp_arch       i686
263 %endif
264 %ifarch sparcv9 sparc64
265         %define         _ftp_arch       sparc
266         %if "%{pld_release}" == "th"
267                 %define         _ftp_arch       %{_target_cpu}
268                 %ifarch sparc64
269                 %define         _ftp_alt_arch   sparcv9
270                 %endif
271         %endif
272 %endif
273
274 %if "%{pld_release}" == "ti"
275         %define pld_conf %{SOURCE3}
276         %ifarch %{x8664}
277                 %define pld_multilib_conf %{SOURCE4}
278         %endif
279 %endif
280
281 %if "%{pld_release}" == "th"
282         %define pld_conf %{SOURCE1}
283         %define pld_debuginfo_conf %{SOURCE8}
284         %define pld_archive_conf %{SOURCE11}
285
286         %ifarch %{x8664}
287                 %define pld_multilib_conf %{SOURCE2}
288         %endif
289
290         # aidath
291         %ifarch sparcv9 sparc64
292                 %define pld_conf %{SOURCE9}
293                 %undefine pld_archive_conf
294         %endif
295         %ifarch sparc64
296                 %define pld_multilib_conf %{SOURCE10}
297         %endif
298 %endif
299
300 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
301
302 %if 0%{?pld_multilib_conf:1}
303         sed 's|%%ARCH%%|%{_ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
304 %endif
305
306 %if 0%{?pld_debuginfo_conf:1}
307 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
308 %endif
309
310 %if 0%{?pld_archive_conf:1}
311 sed -e 's|%%ARCH%%|%{_ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
312 %endif
313
314 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
315
316 %if %{with imode}
317 # add desktop file and icon
318 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
319 cp -a %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
320 cp -a %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
321 %endif
322
323 # sources we don't package
324 rm -f $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,pld,fedora,centos}-source.conf
325 # include them in %doc
326 rm -rf configs
327 cp -a conf configs
328 rm -f configs/Makefile*
329
330 %if %{with python}
331 %py_postclean
332 rm -f $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
333 %endif
334
335 %find_lang %{name}
336
337 %clean
338 rm -rf $RPM_BUILD_ROOT
339
340 %post
341 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
342 if [ "$1" = "1" ]; then
343         # remove ignore = vserver-packages inside vserver on first install
344         {
345                 while read f ctx; do
346                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
347                 done </proc/self/status
348         } 2>/dev/null
349         if [ -z "$ctx" -o "$ctx" = "0" ]; then
350                 VSERVER=no
351         else
352                 VSERVER=yes
353         fi
354         if [ "$VSERVER" = "yes" ]; then
355                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
356         fi
357 fi
358
359 %postun -p      /sbin/postshell
360 -/usr/sbin/fix-info-dir -c %{_infodir}
361
362 %post   libs -p /sbin/ldconfig
363 %postun libs -p /sbin/ldconfig
364
365 %triggerpostun -- poldek < 0.19.0-1.20050613.22.0
366 if [ -f /etc/poldek.conf.rpmsave ]; then
367         awk '/^source/ {
368         name = $3;
369         path = $4;
370         auto = "yes";
371         autoup = "yes";
372         type = "pdir";
373         pri = "";
374
375         if (sub(",noauto", "", name)) {
376                 auto = "no";
377         }
378
379         # process pri=\d+
380         if (match(name, /,pri=[0-9]+/)) {
381                 pri = substr(name, RSTART + 5, RLENGTH - 5);
382                 name = substr(name, 1, RSTART - 1) substr(name, RSTART + RLENGTH);
383         }
384
385         # skip ac sources. already in new config.
386         if (name !~ /^ac(-(ready|test|supported|updates-(general|security)))?$/) {
387                 print "";
388                 print "[source]";
389                 print "name = " name;
390                 print "type = " type;
391                 print "path = " path;
392                 print "auto = " auto;
393                 print "autoup = " autoup;
394                 if (pri) {
395                         print "pri = " pri;
396                 }
397         }
398
399         }' < /etc/poldek.conf.rpmsave >> /etc/poldek/source.conf
400         echo "Converted old custom sources from /etc/poldek.conf.rpmsave to new poldek format in /etc/poldek/source.conf"
401
402         # copy hold=
403         hold=$(grep ^hold /etc/poldek.conf.rpmsave)
404         if [ "$hold" ]; then
405                 sed -i -e "/^#hold =/s/^.*/$hold/" /etc/poldek/poldek.conf
406         fi
407 fi
408
409 %triggerpostun -- poldek < 0.30-0.20080225.00.1
410 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
411         %{__sed} -i -e '/^%%include source.conf/{
412                 a
413                 a# /etc/poldek/repos.d/*.conf
414                 a%%includedir repos.d
415         }' %{_sysconfdir}/%{name}/poldek.conf
416 fi
417
418 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
419 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
420
421 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
422         cp -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
423         cp -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
424 fi
425
426 %ifarch %{x8664}
427 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
428         cp -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
429         cp -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
430 fi
431 %endif
432
433 %files -f %{name}.lang
434 %defattr(644,root,root,755)
435 %doc ChangeLog README* NEWS TODO configs
436 %dir %{_sysconfdir}/%{name}
437 %dir %{_sysconfdir}/%{name}/repos.d
438 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
439 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
440 %attr(755,root,root) %{_bindir}/*
441 %dir %{_libdir}/%{name}
442 %attr(755,root,root) %{_libdir}/%{name}/*
443 %{_mandir}/man1/%{name}*
444 %lang(pl) %{_mandir}/pl/man1/%{name}*
445 %{_infodir}/poldek.info*
446 %if %{with imode}
447 %{_desktopdir}/%{name}.desktop
448 %{_pixmapsdir}/%{name}.png
449 %endif
450
451 %if %{without static}
452 %files libs
453 %defattr(644,root,root,755)
454 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
455 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
456 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
457 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
458 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
459 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
460 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
461 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
462 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
463 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
464 %endif
465
466 %files devel
467 %defattr(644,root,root,755)
468 %{!?with_static:%attr(755,root,root) %{_libdir}/lib*.so}
469 %{_libdir}/lib*.la
470 %{_includedir}/*
471
472 %files static
473 %defattr(644,root,root,755)
474 %{_libdir}/lib*.a
475
476 %if %{with python}
477 %files -n python-poldek
478 %defattr(644,root,root,755)
479 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
480 %{py_sitescriptdir}/poldek.py[co]
481 %{py_sitescriptdir}/poldekmod.py[co]
482 %endif
This page took 0.087291 seconds and 4 git commands to generate.