]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
make th-all virtual repo dynamically from .spec
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_without  python  # don't build python bindings
6 %bcond_with     snap    # install configs for official Th snapshot
7 %bcond_with     db61    # DB 6.1 instead of 5.2
8 %bcond_with     rpm4    # use rpm4/db4.7 instead of rpm5
9
10 # current snapshot name
11 %define         SNAP    2014
12
13 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
14 # NOTE: poldek links with "system db" (-ldb) anyway if it exists
15 %if %{with db61}
16 %define         db_pkg          db6.1
17 %define         ver_db          6.1
18 %define         ver_db_rel      1
19 %else
20 %define         db_pkg          db5.2
21 %define         ver_db          5.2
22 %define         ver_db_rel      3
23 %endif
24
25 %if %{with rpm4}
26 %define         ver_db          4.7.25
27 %define         ver_db_rel      1
28 %define         ver_rpm         4.5-49
29 %else
30 %define         ver_rpm         5.4.10
31 %endif
32
33 %define         rel     5
34 Summary:        RPM packages management helper tool
35 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
36 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
37 Name:           poldek
38 Version:        0.30.1
39 Release:        %{rel}%{?with_snap:.%{SNAP}}
40 License:        GPL v2
41 Group:          Applications/System
42 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
43 Source0:        http://carme.pld-linux.org/~megabajt/releases/poldek/%{name}-%{version}.tar.xz
44 # Source0-md5:  e569c8454df0932df53b09cee9998927
45 Source1:        %{name}.conf
46 Source2:        %{name}-multilib.conf
47 Source5:        %{name}-aliases.conf
48 Source6:        %{name}.desktop
49 Source7:        %{name}.png
50 Source8:        %{name}-debuginfo.conf
51 Source9:        %{name}-aidath.conf
52 Source10:       %{name}-multilib-aidath.conf
53 Source11:       %{name}-archive.conf
54 Source100:      %{name}-snap.conf
55 Source101:      %{name}-multilib-snap.conf
56 Source102:      %{name}-debuginfo-snap.conf
57 Patch0:         %{name}-size-type.patch
58 Patch1:         %{name}-config.patch
59 Patch2:         %{name}-missing-include.patch
60 URL:            http://poldek.pld-linux.org/
61 BuildRequires:  %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
62 BuildRequires:  autoconf
63 BuildRequires:  automake >= 1:1.11
64 BuildRequires:  bzip2-devel
65 BuildRequires:  check-devel
66 BuildRequires:  docbook-dtd412-xml
67 BuildRequires:  gettext-tools
68 BuildRequires:  libtool
69 BuildRequires:  libxml2-devel
70 BuildRequires:  neon-devel
71 BuildRequires:  openssl-devel >= 0.9.7d
72 BuildRequires:  pcre-devel
73 BuildRequires:  pkgconfig
74 BuildRequires:  popt-devel
75 %{?with_python:BuildRequires:   python-devel}
76 BuildRequires:  readline-devel >= 5.0
77 BuildRequires:  rpm-devel >= %{ver_rpm}
78 %{?with_python:BuildRequires:   rpm-pythonprov}
79 BuildRequires:  swig-python
80 BuildRequires:  tar >= 1:1.22
81 BuildRequires:  xmlto
82 BuildRequires:  xz
83 BuildRequires:  zlib-devel
84 %if %{with static}
85 BuildRequires:  %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
86 BuildRequires:  bzip2-static
87 BuildRequires:  glibc-static
88 BuildRequires:  libxml2-static
89 BuildRequires:  ncurses-static
90 BuildRequires:  openssl-static
91 BuildRequires:  pcre-static
92 BuildRequires:  popt-static
93 BuildRequires:  readline-static
94 BuildRequires:  rpm-static
95 BuildRequires:  zlib-static
96 %endif
97 Requires(triggerpostun):        awk
98 Requires(triggerpostun):        sed >= 4.0
99 Requires:       %{db_pkg} >= %{ver_db}-%{ver_db_rel}
100 Requires:       %{name}-libs = %{version}-%{release}
101 Requires:       rpm >= %{ver_rpm}
102 Requires:       rpm-db-ver = %{ver_db}
103 Requires:       rpm-lib >= %{ver_rpm}
104 # vf* scripts use sed
105 Requires:       sed
106 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108 %define         _libexecdir     %{_prefix}/lib/%{name}
109
110 %description
111 poldek is an RPM package management tool which allows you to easily
112 perform package verification, installation (including system
113 installation from scratch), upgrading, and removal.
114
115 Program can be used in batch (like apt-get from Debian's APT) or
116 interactive mode. The interactive mode puts you into a readline
117 interface with command line autocompletion and history, similar to the
118 shell mode of Perl's CPAN.
119
120 %{?with_static:This version is statically linked.}
121
122 %{!?with_imode:This version hasn't got interactive mode.}
123 #'vim
124
125 %description -l hu.UTF-8
126 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
127 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
128 nulláról), frissítést és eltávolítást.
129
130 A program használható parancssorból (mint a Debian apt-get programja)
131 vagy interaktív módban. Az interaktív mód egy readline környezetet
132 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
133 shell módjához.
134
135 %{?with_static:Ez a verzió statikusan linkelt.}
136
137 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
138
139 %description -l pl.UTF-8
140 poldek jest narzędziem linii poleceń służącym do weryfikacji,
141 instalacji (włączając instalację systemu od zera), aktualizacji i
142 usuwania pakietów.
143
144 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
145 interaktywnym. Tryb interaktywny posiada interfejs readline z
146 dopełnianiem komend i historią, podobny do trybu shell perlowego
147 modułu CPAN.
148
149 %{?with_static:Ta wersja jest konsolidowana statycznie.}
150
151 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
152
153 %package libs
154 Summary:        poldek libraries
155 Summary(hu.UTF-8):      A poldek könyvtárai
156 Summary(pl.UTF-8):      Biblioteki poldka
157 Group:          Libraries
158
159 %description libs
160 poldek libraries.
161
162 %description libs -l hu.UTF-8
163 A poldek könyvtárai.
164
165 %description libs -l pl.UTF-8
166 Biblioteki poldka.
167
168 %package devel
169 Summary:        Header files for poldek libraries
170 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
171 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
172 Group:          Development/Libraries
173 Requires:       %{name}-libs = %{version}-%{release}
174 Requires:       rpm-devel >= %{ver_rpm}
175
176 %description devel
177 Header files for poldek libraries.
178
179 %description devel -l hu.UTF-8
180 A poldek könyvtár fejlesztői fájljai.
181
182 %description devel -l pl.UTF-8
183 Pliki nagłówkowe bibliotek poldka.
184
185 %package static
186 Summary:        poldek static libraries
187 Summary(hu.UTF-8):      poldek statikus könyvtárak
188 Summary(pl.UTF-8):      Biblioteki statyczne poldka
189 Group:          Development/Libraries
190 Requires:       %{name}-devel = %{version}-%{release}
191
192 %description static
193 poldek static libraries.
194
195 %description static -l hu.UTF-8
196 poldek statikus könyvtárak.
197
198 %description static -l pl.UTF-8
199 Biblioteki statyczne poldka.
200
201 %package -n python-poldek
202 Summary:        Python modules for poldek
203 Summary(hu.UTF-8):      Python modulok poldek-hez
204 Summary(pl.UTF-8):      Moduły języka Python dla poldka
205 Group:          Libraries/Python
206 Requires:       %{name}-libs = %{version}-%{release}
207 Requires:       python-libs
208
209 %description -n python-poldek
210 Python modules for poldek.
211
212 %description -n python-poldek -l hu.UTF-8
213 Python modulok poldek-hez.
214
215 %description -n python-poldek -l pl.UTF-8
216 Moduły języka Python dla poldka.
217
218 %prep
219 %setup -q
220 %patch0 -p1
221 %patch1 -p1
222 %patch2 -p1
223
224 %{__rm} m4/libtool.m4 m4/lt*.m4
225
226 # cleanup backups after patching
227 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
228 chmod u+x ./configure ./doc/conf-xml2.sh
229
230 %build
231 %{__gettextize}
232 %{__libtoolize}
233 %{__aclocal} -I m4
234 %{__autoheader}
235 %{__autoconf}
236 %{__automake}
237 cd tndb
238 %{__libtoolize}
239 %{__aclocal}
240 %{__autoheader}
241 %{__autoconf}
242 %{__automake}
243 cd ../trurlib
244 %{__libtoolize}
245 %{__aclocal}
246 %{__autoheader}
247 %{__autoconf}
248 %{__automake}
249 cd ..
250
251 CPPFLAGS="%{rpmcppflags} -std=gnu99 -fgnu89-inline"
252 %configure \
253         %{?with_static:--enable-static --disable-shared} \
254         %{!?with_imode:--disable-imode} \
255         --with-pkglibdir=%{_libexecdir} \
256         --enable-nls \
257         %{?with_python:--with-python}
258 %{__make} -j1
259 #       --enable-trace
260
261 %install
262 rm -rf $RPM_BUILD_ROOT
263 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name}/repos.d,/var/cache/%{name}}
264
265 %{__make} install -j1 \
266         DESTDIR=$RPM_BUILD_ROOT
267
268 %if %{with python}
269 %{__make} -C python -j1 install \
270         DESTDIR=$RPM_BUILD_ROOT \
271         libdir=%{py_sitedir}
272 %endif
273
274 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
275
276 %ifarch i486 i686 ppc sparc alpha athlon
277         %define         ftp_arch        %{_target_cpu}
278 %endif
279 %ifarch %{x8664}
280         %define         ftp_arch        x86_64
281         %define         ftp_alt_arch    i686
282         %define         ftp_alt2_arch   x32
283 %endif
284 %ifarch x32
285         %define         ftp_arch        x32
286         %define         ftp_alt_arch    x86_64
287         %define         ftp_alt2_arch   i686
288 %endif
289 %ifarch i586
290         %define         ftp_arch        i486
291 %endif
292 %ifarch pentium2 pentium3 pentium4
293         %define         ftp_arch        i686
294 %endif
295 %ifarch sparcv9 sparc64
296         %define         ftp_arch        sparc
297         %define         ftp_arch        %{_target_cpu}
298         %ifarch sparc64
299                 %define         ftp_alt_arch    sparcv9
300         %endif
301 %endif
302
303 %define pld_conf %{SOURCE1}
304 %define pld_debuginfo_conf %{SOURCE8}
305 %define pld_archive_conf %{SOURCE11}
306
307 %ifarch %{x8664} x32
308         %define pld_multilib_conf %{SOURCE2}
309         %define pld_multilib2_conf %{SOURCE2}
310 %endif
311
312 # aidath
313 %ifarch sparcv9 sparc64
314         %define pld_conf %{SOURCE9}
315         %undefine pld_archive_conf
316 %endif
317 %ifarch sparc64
318         %define pld_multilib_conf %{SOURCE10}
319 %endif
320
321 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
322
323 %if 0%{?pld_multilib_conf:1}
324         %{__sed} 's|%%ARCH%%|%{ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
325 %endif
326
327 %if 0%{?pld_multilib2_conf:1}
328         %{__sed} 's|%%ARCH%%|%{ftp_alt2_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt2_arch}.conf
329 %endif
330
331 %if 0%{?pld_debuginfo_conf:1}
332 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
333 %endif
334
335 %if 0%{?pld_archive_conf:1}
336 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
337 %endif
338
339 # Always install snapshot configs
340 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
341         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
342 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
343         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
344 %ifarch %{x8664} x32
345         %{__sed} -e 's|%%ARCH%%|%{ftp_alt_arch}|g' \
346                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
347         %{__sed} -e 's|%%ARCH%%|%{ftp_alt2_arch}|g' \
348                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt2_arch}.conf
349 %endif
350
351 %if %{with snap}
352 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
353 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
354 %else
355 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
356 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
357 %endif
358
359 # create "all" meta repo
360 %if 0%{?ftp_alt_arch:1}%{?ftp_alt2_arch:1}
361 cat <<'EOF' >  $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-all.conf
362 # group source for referring th+th-multiarch sources together, i.e poldek -n th-all
363 [source]
364 type    = group
365 name    = th-all
366 sources = th %{?ftp_alt_arch:th-%{ftp_alt_arch}} %{?ftp_alt2_arch:th-%{ftp_alt2_arch}}
367 EOF
368 %endif
369
370 # th-2014 snap does not exist for x32 yet
371 %if "%{ftp_arch}" == "x32"
372 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
373 %endif
374 %if "%{ftp_alt2_arch}" == "x32"
375 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-x32.conf
376 %endif
377
378 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
379
380 %if %{with imode}
381 # add desktop file and icon
382 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
383 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
384 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
385 %endif
386
387 # sources we don't package
388 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
389 # include them in %doc
390 %{__rm} -rf configs
391 cp -a conf configs
392 %{__rm} -f configs/Makefile*
393
394 %if %{with python}
395 %py_postclean
396 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
397 %endif
398
399 %find_lang %{name}
400
401 %clean
402 rm -rf $RPM_BUILD_ROOT
403
404 %post
405 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
406 if [ "$1" = "1" ]; then
407         # remove ignore = vserver-packages inside vserver on first install
408         {
409                 while read f ctx; do
410                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
411                 done </proc/self/status
412         } 2>/dev/null
413         if [ -z "$ctx" -o "$ctx" = "0" ]; then
414                 VSERVER=no
415         else
416                 VSERVER=yes
417         fi
418         if [ "$VSERVER" = "yes" ]; then
419                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
420         fi
421 fi
422
423 %postun -p      /sbin/postshell
424 -/usr/sbin/fix-info-dir -c %{_infodir}
425
426 %post   libs -p /sbin/ldconfig
427 %postun libs -p /sbin/ldconfig
428
429 %triggerpostun -- poldek < 0.30-0.20080225.00.1
430 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
431         %{__sed} -i -e '/^%%include source.conf/{
432                 a
433                 a# /etc/poldek/repos.d/*.conf
434                 a%%includedir repos.d
435         }' %{_sysconfdir}/%{name}/poldek.conf
436 fi
437
438 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
439 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
440
441 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
442         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
443         %{__mv} -v %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
444 fi
445
446 %ifarch %{x8664}
447 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
448         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
449         %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
450 fi
451 %endif
452
453 %triggerpostun -- poldek < 0.30.1-3
454 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
455         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
456         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
457 fi
458 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
459         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
460         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
461 fi
462
463 %files -f %{name}.lang
464 %defattr(644,root,root,755)
465 %doc ChangeLog README* NEWS TODO configs
466 %dir %{_sysconfdir}/%{name}
467 %dir %{_sysconfdir}/%{name}/repos.d
468 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
469 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
470 %attr(755,root,root) %{_bindir}/ipoldek
471 %attr(755,root,root) %{_bindir}/poldek
472 %attr(755,root,root) %{_bindir}/rpmvercmp
473 %dir %{_libexecdir}
474 %attr(755,root,root) %{_libexecdir}/*
475 %{_mandir}/man1/%{name}*.1*
476 %lang(pl) %{_mandir}/pl/man1/%{name}*
477 %{_infodir}/poldek.info*
478 %if %{with imode}
479 %{_desktopdir}/%{name}.desktop
480 %{_pixmapsdir}/%{name}.png
481 %endif
482 %dir /var/cache/%{name}
483
484 %if %{without static}
485 %files libs
486 %defattr(644,root,root,755)
487 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
488 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
489 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
490 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
491 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
492 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
493 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
494 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
495 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
496 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
497 %endif
498
499 %files devel
500 %defattr(644,root,root,755)
501 %if %{without static}
502 %attr(755,root,root) %{_libdir}/libpoclidek.so
503 %attr(755,root,root) %{_libdir}/libpoldek.so
504 %attr(755,root,root) %{_libdir}/libtndb.so
505 %attr(755,root,root) %{_libdir}/libtrurl.so
506 %attr(755,root,root) %{_libdir}/libvfile.so
507 %endif
508 %{_libdir}/libpoclidek.la
509 %{_libdir}/libpoldek.la
510 %{_libdir}/libtndb.la
511 %{_libdir}/libtrurl.la
512 %{_libdir}/libvfile.la
513 %{_includedir}/poldek
514 %{_includedir}/tndb
515 %{_includedir}/trurl
516 %{_includedir}/vfile
517 %{_pkgconfigdir}/tndb.pc
518 %{_pkgconfigdir}/trurlib.pc
519
520 %files static
521 %defattr(644,root,root,755)
522 %{_libdir}/libtndb.a
523 %{_libdir}/libtrurl.a
524
525 %if %{with python}
526 %files -n python-poldek
527 %defattr(644,root,root,755)
528 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
529 %{py_sitescriptdir}/poldek.py[co]
530 %{py_sitescriptdir}/poldekmod.py[co]
531 %endif
This page took 0.09608 seconds and 3 git commands to generate.