]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- force switch to db4.2 and rpm built with it, release 16
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_with     curl    # link with curl
6 #
7 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
8 %define ver_db  4.2.50-1
9 %define ver_rpm 4.3-0.20030610.29
10 Summary:        RPM packages management helper tool
11 Summary(pl):    Pomocnicze narzêdzie do zarz±dzania pakietami RPM
12 Name:           poldek
13 Version:        0.18.1
14 Release:        16
15 License:        GPL v2
16 Group:          Applications/System
17 Source0:        http://team.pld.org.pl/~mis/poldek/download/%{name}-%{version}.tar.bz2
18 # Source0-md5:  8af8090d401254939911e456e2f09e60
19 Source1:        %{name}.conf
20 Patch0:         %{name}-static.patch
21 Patch1:         %{name}-etc_dir.patch
22 Patch2:         %{name}-rpm4.2.patch
23 Patch3:         %{name}-rpm4.1-fix.patch
24 Patch4:         %{name}-retr_term.patch
25 Patch5:         %{name}-deps-fix.patch
26 Patch6:         %{name}-broken-rpmdb.patch
27 Patch7:         %{name}-epoch0.patch
28 Patch8:         %{name}-ldb4.patch
29 URL:            http://team.pld.org.pl/~mis/poldek/
30 BuildRequires:  automake
31 BuildRequires:  autoconf
32 BuildRequires:  bzip2-devel
33 %{?with_curl:BuildRequires:     curl-devel >= 7.8}
34 BuildRequires:  db-devel >= %{ver_db}
35 BuildRequires:  gettext-autopoint
36 BuildRequires:  openssl-devel >= 0.9.7c
37 BuildRequires:  pcre-devel
38 BuildRequires:  popt-devel
39 BuildRequires:  readline-devel
40 BuildRequires:  rpm-devel >= %{ver_rpm}
41 BuildRequires:  zlib-devel
42 BuildRequires:  /usr/bin/pod2man
43 %if %{with static}
44 BuildRequires:  bzip2-static
45 %{?with_curl:BuildRequires:     curl-static}
46 BuildRequires:  db-static >= %{ver_db}
47 BuildRequires:  ncurses-static
48 BuildRequires:  openssl-static
49 BuildRequires:  pcre-static
50 BuildRequires:  popt-static
51 BuildRequires:  readline-static
52 BuildRequires:  rpm-static
53 BuildRequires:  zlib-static
54 BuildRequires:  glibc-static
55 %endif
56 Requires:       db >= %{ver_db}
57 Requires:       rpm >= %{ver_rpm}
58 Requires:       sed
59 Requires:       openssl >= 0.9.7c
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 poldek is an RPM package management tool which allows you to easily
64 perform package verification, installation (including system
65 installation from scratch), upgrading, and removal.
66
67 Program can be used in batch (like apt-get from Debian's APT) or
68 interactive mode. The interactive mode puts you into a readline
69 interface with command line autocompletion and history, similar to the
70 shell mode of Perl's CPAN.
71
72 %{?with_static:This version is statically linked.}
73
74 %{!?with_imode:This version hasn't got interactive mode.}
75
76 %description -l pl
77 poldek jest narzêdziem linii poleceñ s³u¿±cym do weryfikacji,
78 instalacji (w³±czaj±c instalacjê systemu od zera), aktualizacji i
79 usuwania pakietów.
80
81 Program mo¿e byæ u¿ywany w trybie wsadowym (jak debianowy apt-get) lub
82 interaktywnym. Tryb interaktywny posiada interfejs readline z
83 dope³nianiem komend i histori±, podobny do trybu shell perlowego
84 modu³u CPAN.
85
86 %{?with_static:Ta wersja jest konsolidowana statycznie.}
87
88 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
89
90 %prep
91 %setup -q
92 %patch0 -p1
93 %patch1 -p1
94 %patch2 -p1
95 %patch3 -p0
96 %patch4 -p1
97 %patch5 -p0
98 %patch6 -p1
99 %patch7 -p1
100 %patch8 -p1
101
102 %build
103 %{__autopoint}
104 %{__aclocal} -I m4
105 %{__autoconf}
106 %{__automake}
107 %configure \
108         %{?with_static:--enable-static} \
109         %{!?with_imode:--disable-imode} \
110         %{?with_curl:--with-curl}
111 %{__make}
112
113 %install
114 rm -rf $RPM_BUILD_ROOT
115 install -d $RPM_BUILD_ROOT%{_sysconfdir}
116
117 %{__make} install \
118         DESTDIR=$RPM_BUILD_ROOT
119
120 %{?with_static:rm -f $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
121 sed "s|/i686/|/%{_target_cpu}/|g" < %{SOURCE1} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}.conf
122
123 %find_lang %{name}
124
125 %clean
126 rm -rf $RPM_BUILD_ROOT
127
128 %files -f %{name}.lang
129 %defattr(644,root,root,755)
130 %doc README* NEWS TODO *sample* conf/poldekrc*
131 %attr(644,root,root) %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/%{name}.conf
132 %attr(755,root,root) %{_bindir}/*
133 %{_mandir}/man1/%{name}*
134 %lang(pl) %{_mandir}/pl/man1/%{name}*
This page took 0.168405 seconds and 3 git commands to generate.