]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
- don't override _libexecdir
[packages/poldek.git] / poldek.spec
1 # TODO
2 # - fix config having escaped html entities:
3 #   # package A requires capability foo >= 1.0 while package B provides "foo"
4
5 # Conditional build:
6 %bcond_with     static  # don't use shared libraries
7 %bcond_without  imode   # don't build interactive mode
8 %bcond_without  python  # don't build python bindings
9 %bcond_with     snap    # install configs for official Th snapshot
10 %bcond_with     rpm4    # use rpm4 instead of rpm5
11 %bcond_without  tests   # tests
12
13 # current snapshot name
14 %define         SNAP    2019
15
16 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
17 %if %{with rpm4}
18 %define         db_pkg          db
19 %define         ver_db          5.3
20 %define         ver_rpm         1:4.14
21 %define         ver_db_devel    %(rpm -q --qf '%|E?{%{E}:}|%{V}-%{R}' --what-provides db-devel)
22 %else
23 %define         ver_db          %(rpm -q --provides rpm | %{__sed} -ne 's/^rpm-db-ver = \\([.0-9]*\\)$/\\1/p')
24 %define         db_pkg          db%{ver_db}
25 %define         ver_rpm         5.4.10
26 %endif
27
28 %define         rel     1
29 Summary:        RPM packages management helper tool
30 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
31 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
32 Name:           poldek
33 Version:        0.42.0
34 Release:        %{rel}%{?with_snap:.%{SNAP}}
35 License:        GPL v2
36 Group:          Applications/System
37 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
38 Source0:        https://github.com/poldek-pm/poldek/releases/download/v%{version}/%{name}-%{version}.tar.xz
39 # Source0-md5:  f224a4f62cdedf0d8bcfe0ce6dd533b2
40 Source1:        %{name}.conf
41 Source2:        %{name}-multilib.conf
42 Source3:        %{name}-config.sh
43 Source5:        %{name}-aliases.conf
44 Source6:        %{name}.desktop
45 Source7:        %{name}.png
46 # Source7-md5:  ee487abede50874e9eceb6495d5ee150
47 Source8:        %{name}-debuginfo.conf
48 Source9:        %{name}-aidath.conf
49 Source10:       %{name}-multilib-aidath.conf
50 Source11:       %{name}-archive.conf
51 Source100:      %{name}-snap.conf
52 Source101:      %{name}-multilib-snap.conf
53 Source102:      %{name}-debuginfo-snap.conf
54 Patch0:         %{name}-config.patch
55 Patch1:         pm-hooks.patch
56 Patch2:         %{name}-ext-down-enable.patch
57 Patch3:         %{name}-pc.patch
58 URL:            http://poldek.pld-linux.org/
59 BuildRequires:  %{db_pkg}-devel >= %{ver_db}
60 BuildRequires:  autoconf >= 2.63
61 BuildRequires:  automake >= 1:1.11
62 BuildRequires:  bzip2-devel
63 BuildRequires:  check-devel
64 BuildRequires:  docbook-dtd412-xml
65 BuildRequires:  gettext-tools >= 0.11.5
66 BuildRequires:  libgomp-devel
67 BuildRequires:  libtool
68 BuildRequires:  libxml2-devel >= 2
69 BuildRequires:  ncurses-devel
70 BuildRequires:  openssl-devel >= 0.9.7d
71 BuildRequires:  pcre-devel
72 BuildRequires:  pkgconfig
73 BuildRequires:  popt-devel
74 %{?with_python:BuildRequires:   python-devel}
75 BuildRequires:  readline-devel >= 5.0
76 BuildRequires:  rpm >= %{ver_rpm}
77 BuildRequires:  rpm-devel >= %{ver_rpm}
78 %{?with_python:BuildRequires:   rpm-pythonprov}
79 BuildRequires:  tar >= 1:1.22
80 BuildRequires:  xmlto
81 BuildRequires:  xz
82 BuildRequires:  zlib-devel
83 BuildRequires:  zstd-devel
84 %if %{with static}
85 BuildRequires:  %{db_pkg}-static >= %{ver_db}
86 BuildRequires:  bzip2-static
87 BuildRequires:  glibc-static
88 BuildRequires:  libxml2-static
89 BuildRequires:  ncurses-static
90 BuildRequires:  openssl-static
91 BuildRequires:  pcre-static
92 BuildRequires:  popt-static
93 BuildRequires:  readline-static
94 BuildRequires:  rpm-static
95 BuildRequires:  zlib-static
96 BuildRequires:  zstd-static
97 %endif
98 Requires(triggerpostun):        awk
99 Requires(triggerpostun):        sed >= 4.0
100 %if %{with rpm4}
101 Requires:       %{db_pkg} >= %{ver_db_devel}
102 %else
103 Requires:       %{db_pkg} >= %{ver_db}
104 Requires:       rpm-db-ver = %{ver_db}
105 %endif
106 Requires:       %{name}-libs = %{version}-%{release}
107 Requires:       /bin/run-parts
108 Requires:       rpm >= %{ver_rpm}
109 Requires:       rpm-lib >= %{ver_rpm}
110 Requires:       sed
111 Conflicts:      etckeeper < 1.18-2
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 # it could be %{_libexecdir}/%{name}, but beware of compatibility (path hardcoded in configurations)
115 %define         pkglibexecdir   %{_prefix}/lib/%{name}
116
117 %description
118 poldek is an RPM package management tool which allows you to easily
119 perform package verification, installation (including system
120 installation from scratch), upgrading, and removal.
121
122 Program can be used in batch (like apt-get from Debian's APT) or
123 interactive mode. The interactive mode puts you into a readline
124 interface with command line autocompletion and history, similar to the
125 shell mode of Perl's CPAN.
126
127 %{?with_static:This version is statically linked.}
128
129 %{!?with_imode:This version hasn't got interactive mode.}
130 #'vim
131
132 %description -l hu.UTF-8
133 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
134 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
135 nulláról), frissítést és eltávolítást.
136
137 A program használható parancssorból (mint a Debian apt-get programja)
138 vagy interaktív módban. Az interaktív mód egy readline környezetet
139 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
140 shell módjához.
141
142 %{?with_static:Ez a verzió statikusan linkelt.}
143
144 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
145
146 %description -l pl.UTF-8
147 poldek jest narzędziem linii poleceń służącym do weryfikacji,
148 instalacji (włączając instalację systemu od zera), aktualizacji i
149 usuwania pakietów.
150
151 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
152 interaktywnym. Tryb interaktywny posiada interfejs readline z
153 dopełnianiem komend i historią, podobny do trybu shell perlowego
154 modułu CPAN.
155
156 %{?with_static:Ta wersja jest konsolidowana statycznie.}
157
158 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
159
160 %package libs
161 Summary:        poldek libraries
162 Summary(hu.UTF-8):      A poldek könyvtárai
163 Summary(pl.UTF-8):      Biblioteki poldka
164 Group:          Libraries
165
166 %description libs
167 poldek libraries.
168
169 %description libs -l hu.UTF-8
170 A poldek könyvtárai.
171
172 %description libs -l pl.UTF-8
173 Biblioteki poldka.
174
175 %package devel
176 Summary:        Header files for poldek libraries
177 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
178 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
179 Group:          Development/Libraries
180 Requires:       %{name}-libs = %{version}-%{release}
181 Requires:       rpm-devel >= %{ver_rpm}
182
183 %description devel
184 Header files for poldek libraries.
185
186 %description devel -l hu.UTF-8
187 A poldek könyvtár fejlesztői fájljai.
188
189 %description devel -l pl.UTF-8
190 Pliki nagłówkowe bibliotek poldka.
191
192 %package static
193 Summary:        poldek static libraries
194 Summary(hu.UTF-8):      poldek statikus könyvtárak
195 Summary(pl.UTF-8):      Biblioteki statyczne poldka
196 Group:          Development/Libraries
197 Requires:       %{name}-devel = %{version}-%{release}
198
199 %description static
200 poldek static libraries.
201
202 %description static -l hu.UTF-8
203 poldek statikus könyvtárak.
204
205 %description static -l pl.UTF-8
206 Biblioteki statyczne poldka.
207
208 %package -n python-poldek
209 Summary:        Python modules for poldek
210 Summary(hu.UTF-8):      Python modulok poldek-hez
211 Summary(pl.UTF-8):      Moduły języka Python dla poldka
212 Group:          Libraries/Python
213 Requires:       %{name}-libs = %{version}-%{release}
214 Requires:       python-libs
215
216 %description -n python-poldek
217 Python modules for poldek.
218
219 %description -n python-poldek -l hu.UTF-8
220 Python modulok poldek-hez.
221
222 %description -n python-poldek -l pl.UTF-8
223 Moduły języka Python dla poldka.
224
225 %prep
226 %setup -q
227 %patch0 -p1
228 %patch1 -p1
229 %patch2 -p1
230 %patch3 -p1
231
232 %{__rm} m4/libtool.m4 m4/lt*.m4
233
234 # cleanup backups after patching
235 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
236 chmod u+x ./configure ./doc/conf-xml2.sh
237
238 %build
239 %{__gettextize}
240 %{__libtoolize}
241 %{__aclocal} -I m4
242 %{__autoheader}
243 %{__autoconf}
244 %{__automake}
245 cd tndb
246 %{__libtoolize}
247 %{__aclocal}
248 %{__autoheader}
249 %{__autoconf}
250 %{__automake}
251 cd ../trurlib
252 %{__libtoolize}
253 %{__aclocal}
254 %{__autoheader}
255 %{__autoconf}
256 %{__automake}
257 cd ..
258
259 %configure \
260         %{?with_static:--enable-static --disable-shared} \
261         %{!?with_imode:--disable-imode} \
262         --with-pkglibdir=%{pkglibexecdir} \
263         --enable-nls \
264         %{?with_python:--with-python}
265 %{__make}
266 #       --enable-trace
267
268 %if %{with python}
269 %{__make} -C python
270 %endif
271
272 %if %{with tests}
273 %{__make} check
274 %endif
275
276 %install
277 rm -rf $RPM_BUILD_ROOT
278 install -d $RPM_BUILD_ROOT/var/cache/%{name}
279
280 %{__make} install \
281         DESTDIR=$RPM_BUILD_ROOT
282
283 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
284
285 %if %{with python}
286 %{__make} -C python install \
287         DESTDIR=$RPM_BUILD_ROOT \
288         py_sitedir=%{py_sitedir}
289 %endif
290
291 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
292
293 %ifarch i486 i686 ppc sparc alpha athlon
294         %define         ftp_arch        %{_target_cpu}
295 %endif
296 %ifarch %{x8664}
297         %define         ftp_arch        x86_64
298         %define         ftp_alt_arch    i686
299         %define         ftp_alt2_arch   x32
300 %endif
301 %ifarch x32
302         %define         ftp_arch        x32
303         %define         ftp_alt_arch    x86_64
304         %define         ftp_alt2_arch   i686
305 %endif
306 %ifarch i586
307         %define         ftp_arch        i486
308 %endif
309 %ifarch pentium2 pentium3 pentium4
310         %define         ftp_arch        i686
311 %endif
312 %ifarch sparcv9 sparc64
313         %define         ftp_arch        sparc
314         %define         ftp_arch        %{_target_cpu}
315         %ifarch sparc64
316                 %define         ftp_alt_arch    sparcv9
317         %endif
318 %endif
319
320 %define pld_conf %{SOURCE1}
321 %define pld_debuginfo_conf %{SOURCE8}
322 %define pld_archive_conf %{SOURCE11}
323
324 %ifarch %{x8664} x32
325         %define pld_multilib_conf %{SOURCE2}
326         %define pld_multilib2_conf %{SOURCE2}
327 %endif
328
329 # aidath
330 %ifarch sparcv9 sparc64
331         %define pld_conf %{SOURCE9}
332         %undefine pld_archive_conf
333 %endif
334 %ifarch sparc64
335         %define pld_multilib_conf %{SOURCE10}
336 %endif
337
338 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
339
340 %if 0%{?pld_multilib_conf:1}
341         %{__sed} 's|%%ARCH%%|%{ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
342 %endif
343
344 %if 0%{?pld_multilib2_conf:1}
345         %{__sed} 's|%%ARCH%%|%{ftp_alt2_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt2_arch}.conf
346 %endif
347
348 %if 0%{?pld_debuginfo_conf:1}
349 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
350 %endif
351
352 %if 0%{?pld_archive_conf:1}
353 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
354 %endif
355
356 # Always install snapshot configs
357 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
358         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
359 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
360         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
361 %ifarch %{x8664} x32
362         %{__sed} -e 's|%%ARCH%%|%{ftp_alt_arch}|g' \
363                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
364         %{__sed} -e 's|%%ARCH%%|%{ftp_alt2_arch}|g' \
365                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt2_arch}.conf
366 %endif
367
368 %if %{with snap}
369 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
370 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
371 %else
372 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
373 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
374 %endif
375
376 # create "all" meta repo
377 %if 0%{?ftp_alt_arch:1}%{?ftp_alt2_arch:1}
378 cat <<'EOF' >  $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-all.conf
379 # group source for referring th+th-multiarch sources together, i.e poldek -n th-all
380 [source]
381 type    = group
382 name    = th-all
383 sources = th %{?ftp_alt_arch:th-%{ftp_alt_arch}} %{?ftp_alt2_arch:th-%{ftp_alt2_arch}}
384 EOF
385 %endif
386
387 # th-2014 snap does not exist for x32 yet
388 %if "%{ftp_arch}" == "x32"
389 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
390 %endif
391 %if "%{ftp_alt2_arch}" == "x32"
392 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-x32.conf
393 %endif
394
395 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
396
397 %if %{with imode}
398 # add desktop file and icon
399 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
400 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
401 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
402 %endif
403
404 # sources we don't package
405 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
406 # include them in %doc
407 %{__rm} -rf configs
408 cp -a conf configs
409 %{__rm} -f configs/Makefile*
410
411 %if %{with python}
412 %py_postclean
413 %{__rm} $RPM_BUILD_ROOT%{_libdir}/_poldekmod.{la,so}
414 %endif
415
416 %find_lang %{name}
417
418 %clean
419 rm -rf $RPM_BUILD_ROOT
420
421 %post
422 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
423 if [ "$1" = "1" ]; then
424         # remove ignore = vserver-packages inside vserver on first install
425         {
426                 while read f ctx; do
427                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
428                 done </proc/self/status
429         } 2>/dev/null
430         if [ -z "$ctx" -o "$ctx" = "0" ]; then
431                 VSERVER=no
432         else
433                 VSERVER=yes
434         fi
435         if [ "$VSERVER" = "yes" ]; then
436                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
437         fi
438 fi
439
440 %postun -p      /sbin/postshell
441 -/usr/sbin/fix-info-dir -c %{_infodir}
442
443 %post   libs -p /sbin/ldconfig
444 %postun libs -p /sbin/ldconfig
445
446 %triggerpostun -- poldek < 0.30-0.20080225.00.1
447 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
448         %{__sed} -i -e '/^%%include source.conf/{
449                 a
450                 a# /etc/poldek/repos.d/*.conf
451                 a%%includedir repos.d
452         }' %{_sysconfdir}/%{name}/poldek.conf
453 fi
454
455 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
456 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
457
458 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
459         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
460         %{__mv} -v %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
461 fi
462
463 %ifarch %{x8664}
464 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
465         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
466         %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
467 fi
468 %endif
469
470 %triggerpostun -- poldek < 0.30.1-3
471 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
472         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
473         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
474 fi
475 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
476         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
477         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
478 fi
479
480 %triggerpostun -- %{name} < 0.30.1-8
481 if [ $1 -le 1 ]; then
482         # revert change on  --downgrade
483         %{__sed} -i -re 's,^pm command = %{pkglibexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
484 else
485         # setup pm command
486         %{__sed} -i -re 's,#?(pm command =).*,\1 %{pkglibexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
487 fi
488
489 %files -f %{name}.lang
490 %defattr(644,root,root,755)
491 %doc ChangeLog README* NEWS configs
492 %dir %{_sysconfdir}/%{name}
493 %dir %{_sysconfdir}/%{name}/pre-install.d
494 %{_sysconfdir}/%{name}/pre-install.d/README
495 %dir %{_sysconfdir}/%{name}/post-install.d
496 %{_sysconfdir}/%{name}/post-install.d/README
497 %dir %{_sysconfdir}/%{name}/repos.d
498 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
499 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
500 %attr(755,root,root) %{_bindir}/ipoldek
501 %attr(755,root,root) %{_bindir}/poldek
502 %attr(755,root,root) %{_bindir}/poldek-config
503 %attr(755,root,root) %{_bindir}/rpmvercmp
504 %dir %{pkglibexecdir}
505 %attr(755,root,root) %{pkglibexecdir}/pm-command.sh
506 %attr(755,root,root) %{pkglibexecdir}/poldekuser-setup.sh
507 %attr(755,root,root) %{pkglibexecdir}/vfcompr
508 %attr(755,root,root) %{pkglibexecdir}/vfjuggle
509 %attr(755,root,root) %{pkglibexecdir}/vfsmb
510 %attr(755,root,root) %{pkglibexecdir}/zlib-in-rpm.sh
511 %{_mandir}/man1/%{name}*.1*
512 %lang(pl) %{_mandir}/pl/man1/%{name}*
513 %{_infodir}/poldek.info*
514 %if %{with imode}
515 %{_desktopdir}/%{name}.desktop
516 %{_pixmapsdir}/%{name}.png
517 %endif
518 %dir /var/cache/%{name}
519
520 %if %{without static}
521 %files libs
522 %defattr(644,root,root,755)
523 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
524 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
525 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
526 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
527 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
528 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.1
529 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.3
530 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
531 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
532 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
533 %endif
534
535 %files devel
536 %defattr(644,root,root,755)
537 %if %{without static}
538 %attr(755,root,root) %{_libdir}/libpoclidek.so
539 %attr(755,root,root) %{_libdir}/libpoldek.so
540 %attr(755,root,root) %{_libdir}/libtndb.so
541 %attr(755,root,root) %{_libdir}/libtrurl.so
542 %attr(755,root,root) %{_libdir}/libvfile.so
543 %endif
544 %{_libdir}/libpoclidek.la
545 %{_libdir}/libpoldek.la
546 %{_libdir}/libtndb.la
547 %{_libdir}/libtrurl.la
548 %{_libdir}/libvfile.la
549 %{_includedir}/poldek
550 %{_includedir}/tndb
551 %{_includedir}/trurl
552 %{_includedir}/vfile
553 %{_pkgconfigdir}/tndb.pc
554 %{_pkgconfigdir}/trurlib.pc
555
556 %files static
557 %defattr(644,root,root,755)
558 %{_libdir}/libtndb.a
559 %{_libdir}/libtrurl.a
560
561 %if %{with python}
562 %files -n python-poldek
563 %defattr(644,root,root,755)
564 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
565 %{py_sitescriptdir}/poldek.py[co]
566 %{py_sitescriptdir}/poldekmod.py[co]
567 %endif
This page took 1.348529 seconds and 3 git commands to generate.