]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
initial tool to ease common operations like:
[packages/poldek.git] / poldek.spec
1 #
2 # Conditional build:
3 %bcond_with     static  # don't use shared libraries
4 %bcond_without  imode   # don't build interactive mode
5 %bcond_without  python  # don't build python bindings
6 %bcond_with     snap    # install configs for official Th snapshot
7 %bcond_with     db61    # DB 6.1 instead of 5.2
8 %bcond_with     rpm4    # use rpm4/db4.7 instead of rpm5
9
10 # current snapshot name
11 %define         SNAP    2014
12
13 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
14 # NOTE: poldek links with "system db" (-ldb) anyway if it exists
15 %if %{with db61}
16 %define         db_pkg          db6.1
17 %define         ver_db          6.1
18 %define         ver_db_rel      1
19 %else
20 %define         db_pkg          db5.2
21 %define         ver_db          5.2
22 %define         ver_db_rel      3
23 %endif
24
25 %if %{with rpm4}
26 %define         ver_db          4.7.25
27 %define         ver_db_rel      1
28 %define         ver_rpm         4.5-49
29 %else
30 %define         ver_rpm         5.4.10
31 %endif
32
33 %define         rel     10
34 Summary:        RPM packages management helper tool
35 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
36 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
37 Name:           poldek
38 Version:        0.30.1
39 Release:        %{rel}%{?with_snap:.%{SNAP}}
40 License:        GPL v2
41 Group:          Applications/System
42 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
43 Source0:        http://carme.pld-linux.org/~megabajt/releases/poldek/%{name}-%{version}.tar.xz
44 # Source0-md5:  e569c8454df0932df53b09cee9998927
45 Source1:        %{name}.conf
46 Source2:        %{name}-multilib.conf
47 Source5:        %{name}-aliases.conf
48 Source6:        %{name}.desktop
49 Source7:        %{name}.png
50 Source8:        %{name}-debuginfo.conf
51 Source9:        %{name}-aidath.conf
52 Source10:       %{name}-multilib-aidath.conf
53 Source11:       %{name}-archive.conf
54 Source100:      %{name}-snap.conf
55 Source101:      %{name}-multilib-snap.conf
56 Source102:      %{name}-debuginfo-snap.conf
57 Patch0:         %{name}-size-type.patch
58 Patch1:         %{name}-config.patch
59 Patch2:         %{name}-missing-include.patch
60 Patch3:         pm-hooks.patch
61 Patch4:         poldek-setenv-null.patch
62 Patch5:         %{name}-assert-sigint.patch
63 URL:            http://poldek.pld-linux.org/
64 BuildRequires:  %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
65 BuildRequires:  autoconf
66 BuildRequires:  automake >= 1:1.11
67 BuildRequires:  bzip2-devel
68 BuildRequires:  check-devel
69 BuildRequires:  docbook-dtd412-xml
70 BuildRequires:  gettext-tools
71 BuildRequires:  libtool
72 BuildRequires:  libxml2-devel
73 BuildRequires:  neon-devel
74 BuildRequires:  openssl-devel >= 0.9.7d
75 BuildRequires:  pcre-devel
76 BuildRequires:  pkgconfig
77 BuildRequires:  popt-devel
78 %{?with_python:BuildRequires:   python-devel}
79 BuildRequires:  readline-devel >= 5.0
80 BuildRequires:  rpm-devel >= %{ver_rpm}
81 %{?with_python:BuildRequires:   rpm-pythonprov}
82 BuildRequires:  swig-python
83 BuildRequires:  tar >= 1:1.22
84 BuildRequires:  xmlto
85 BuildRequires:  xz
86 BuildRequires:  zlib-devel
87 %if %{with static}
88 BuildRequires:  %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
89 BuildRequires:  bzip2-static
90 BuildRequires:  glibc-static
91 BuildRequires:  libxml2-static
92 BuildRequires:  ncurses-static
93 BuildRequires:  openssl-static
94 BuildRequires:  pcre-static
95 BuildRequires:  popt-static
96 BuildRequires:  readline-static
97 BuildRequires:  rpm-static
98 BuildRequires:  zlib-static
99 %endif
100 Requires(triggerpostun):        awk
101 Requires(triggerpostun):        sed >= 4.0
102 Requires:       %{db_pkg} >= %{ver_db}-%{ver_db_rel}
103 Requires:       %{name}-libs = %{version}-%{release}
104 Requires:       /bin/run-parts
105 Requires:       rpm >= %{ver_rpm}
106 Requires:       rpm-db-ver = %{ver_db}
107 Requires:       rpm-lib >= %{ver_rpm}
108 Requires:       sed
109 Conflicts:      etckeeper < 1.18-2
110 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
111
112 %define         _libexecdir     %{_prefix}/lib/%{name}
113
114 %description
115 poldek is an RPM package management tool which allows you to easily
116 perform package verification, installation (including system
117 installation from scratch), upgrading, and removal.
118
119 Program can be used in batch (like apt-get from Debian's APT) or
120 interactive mode. The interactive mode puts you into a readline
121 interface with command line autocompletion and history, similar to the
122 shell mode of Perl's CPAN.
123
124 %{?with_static:This version is statically linked.}
125
126 %{!?with_imode:This version hasn't got interactive mode.}
127 #'vim
128
129 %description -l hu.UTF-8
130 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
131 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
132 nulláról), frissítést és eltávolítást.
133
134 A program használható parancssorból (mint a Debian apt-get programja)
135 vagy interaktív módban. Az interaktív mód egy readline környezetet
136 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
137 shell módjához.
138
139 %{?with_static:Ez a verzió statikusan linkelt.}
140
141 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
142
143 %description -l pl.UTF-8
144 poldek jest narzędziem linii poleceń służącym do weryfikacji,
145 instalacji (włączając instalację systemu od zera), aktualizacji i
146 usuwania pakietów.
147
148 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
149 interaktywnym. Tryb interaktywny posiada interfejs readline z
150 dopełnianiem komend i historią, podobny do trybu shell perlowego
151 modułu CPAN.
152
153 %{?with_static:Ta wersja jest konsolidowana statycznie.}
154
155 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
156
157 %package libs
158 Summary:        poldek libraries
159 Summary(hu.UTF-8):      A poldek könyvtárai
160 Summary(pl.UTF-8):      Biblioteki poldka
161 Group:          Libraries
162
163 %description libs
164 poldek libraries.
165
166 %description libs -l hu.UTF-8
167 A poldek könyvtárai.
168
169 %description libs -l pl.UTF-8
170 Biblioteki poldka.
171
172 %package devel
173 Summary:        Header files for poldek libraries
174 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
175 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
176 Group:          Development/Libraries
177 Requires:       %{name}-libs = %{version}-%{release}
178 Requires:       rpm-devel >= %{ver_rpm}
179
180 %description devel
181 Header files for poldek libraries.
182
183 %description devel -l hu.UTF-8
184 A poldek könyvtár fejlesztői fájljai.
185
186 %description devel -l pl.UTF-8
187 Pliki nagłówkowe bibliotek poldka.
188
189 %package static
190 Summary:        poldek static libraries
191 Summary(hu.UTF-8):      poldek statikus könyvtárak
192 Summary(pl.UTF-8):      Biblioteki statyczne poldka
193 Group:          Development/Libraries
194 Requires:       %{name}-devel = %{version}-%{release}
195
196 %description static
197 poldek static libraries.
198
199 %description static -l hu.UTF-8
200 poldek statikus könyvtárak.
201
202 %description static -l pl.UTF-8
203 Biblioteki statyczne poldka.
204
205 %package -n python-poldek
206 Summary:        Python modules for poldek
207 Summary(hu.UTF-8):      Python modulok poldek-hez
208 Summary(pl.UTF-8):      Moduły języka Python dla poldka
209 Group:          Libraries/Python
210 Requires:       %{name}-libs = %{version}-%{release}
211 Requires:       python-libs
212
213 %description -n python-poldek
214 Python modules for poldek.
215
216 %description -n python-poldek -l hu.UTF-8
217 Python modulok poldek-hez.
218
219 %description -n python-poldek -l pl.UTF-8
220 Moduły języka Python dla poldka.
221
222 %prep
223 %setup -q
224 %patch0 -p1
225 %patch1 -p1
226 %patch2 -p1
227 %patch3 -p1
228 %patch4 -p1
229 %patch5 -p1
230
231 %{__rm} m4/libtool.m4 m4/lt*.m4
232
233 # cleanup backups after patching
234 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
235 chmod u+x ./configure ./doc/conf-xml2.sh
236
237 %build
238 %{__gettextize}
239 %{__libtoolize}
240 %{__aclocal} -I m4
241 %{__autoheader}
242 %{__autoconf}
243 %{__automake}
244 cd tndb
245 %{__libtoolize}
246 %{__aclocal}
247 %{__autoheader}
248 %{__autoconf}
249 %{__automake}
250 cd ../trurlib
251 %{__libtoolize}
252 %{__aclocal}
253 %{__autoheader}
254 %{__autoconf}
255 %{__automake}
256 cd ..
257
258 CPPFLAGS="%{rpmcppflags} -std=gnu99 -fgnu89-inline"
259 %configure \
260         %{?with_static:--enable-static --disable-shared} \
261         %{!?with_imode:--disable-imode} \
262         --with-pkglibdir=%{_libexecdir} \
263         --enable-nls \
264         %{?with_python:--with-python}
265 %{__make} -j1
266 #       --enable-trace
267
268 %install
269 rm -rf $RPM_BUILD_ROOT
270 install -d $RPM_BUILD_ROOT/var/cache/%{name}
271
272 %{__make} install -j1 \
273         DESTDIR=$RPM_BUILD_ROOT
274
275 %if %{with python}
276 %{__make} -C python -j1 install \
277         DESTDIR=$RPM_BUILD_ROOT \
278         libdir=%{py_sitedir}
279 %endif
280
281 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
282
283 %ifarch i486 i686 ppc sparc alpha athlon
284         %define         ftp_arch        %{_target_cpu}
285 %endif
286 %ifarch %{x8664}
287         %define         ftp_arch        x86_64
288         %define         ftp_alt_arch    i686
289         %define         ftp_alt2_arch   x32
290 %endif
291 %ifarch x32
292         %define         ftp_arch        x32
293         %define         ftp_alt_arch    x86_64
294         %define         ftp_alt2_arch   i686
295 %endif
296 %ifarch i586
297         %define         ftp_arch        i486
298 %endif
299 %ifarch pentium2 pentium3 pentium4
300         %define         ftp_arch        i686
301 %endif
302 %ifarch sparcv9 sparc64
303         %define         ftp_arch        sparc
304         %define         ftp_arch        %{_target_cpu}
305         %ifarch sparc64
306                 %define         ftp_alt_arch    sparcv9
307         %endif
308 %endif
309
310 %define pld_conf %{SOURCE1}
311 %define pld_debuginfo_conf %{SOURCE8}
312 %define pld_archive_conf %{SOURCE11}
313
314 %ifarch %{x8664} x32
315         %define pld_multilib_conf %{SOURCE2}
316         %define pld_multilib2_conf %{SOURCE2}
317 %endif
318
319 # aidath
320 %ifarch sparcv9 sparc64
321         %define pld_conf %{SOURCE9}
322         %undefine pld_archive_conf
323 %endif
324 %ifarch sparc64
325         %define pld_multilib_conf %{SOURCE10}
326 %endif
327
328 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
329
330 %if 0%{?pld_multilib_conf:1}
331         %{__sed} 's|%%ARCH%%|%{ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
332 %endif
333
334 %if 0%{?pld_multilib2_conf:1}
335         %{__sed} 's|%%ARCH%%|%{ftp_alt2_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt2_arch}.conf
336 %endif
337
338 %if 0%{?pld_debuginfo_conf:1}
339 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
340 %endif
341
342 %if 0%{?pld_archive_conf:1}
343 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
344 %endif
345
346 # Always install snapshot configs
347 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
348         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
349 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
350         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
351 %ifarch %{x8664} x32
352         %{__sed} -e 's|%%ARCH%%|%{ftp_alt_arch}|g' \
353                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
354         %{__sed} -e 's|%%ARCH%%|%{ftp_alt2_arch}|g' \
355                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt2_arch}.conf
356 %endif
357
358 %if %{with snap}
359 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
360 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
361 %else
362 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
363 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
364 %endif
365
366 # create "all" meta repo
367 %if 0%{?ftp_alt_arch:1}%{?ftp_alt2_arch:1}
368 cat <<'EOF' >  $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-all.conf
369 # group source for referring th+th-multiarch sources together, i.e poldek -n th-all
370 [source]
371 type    = group
372 name    = th-all
373 sources = th %{?ftp_alt_arch:th-%{ftp_alt_arch}} %{?ftp_alt2_arch:th-%{ftp_alt2_arch}}
374 EOF
375 %endif
376
377 # th-2014 snap does not exist for x32 yet
378 %if "%{ftp_arch}" == "x32"
379 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
380 %endif
381 %if "%{ftp_alt2_arch}" == "x32"
382 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-x32.conf
383 %endif
384
385 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
386
387 %if %{with imode}
388 # add desktop file and icon
389 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
390 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
391 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
392 %endif
393
394 # sources we don't package
395 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
396 # include them in %doc
397 %{__rm} -rf configs
398 cp -a conf configs
399 %{__rm} -f configs/Makefile*
400
401 %if %{with python}
402 %py_postclean
403 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
404 %endif
405
406 %find_lang %{name}
407
408 %clean
409 rm -rf $RPM_BUILD_ROOT
410
411 %post
412 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
413 if [ "$1" = "1" ]; then
414         # remove ignore = vserver-packages inside vserver on first install
415         {
416                 while read f ctx; do
417                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
418                 done </proc/self/status
419         } 2>/dev/null
420         if [ -z "$ctx" -o "$ctx" = "0" ]; then
421                 VSERVER=no
422         else
423                 VSERVER=yes
424         fi
425         if [ "$VSERVER" = "yes" ]; then
426                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
427         fi
428 fi
429
430 %postun -p      /sbin/postshell
431 -/usr/sbin/fix-info-dir -c %{_infodir}
432
433 %post   libs -p /sbin/ldconfig
434 %postun libs -p /sbin/ldconfig
435
436 %triggerpostun -- poldek < 0.30-0.20080225.00.1
437 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
438         %{__sed} -i -e '/^%%include source.conf/{
439                 a
440                 a# /etc/poldek/repos.d/*.conf
441                 a%%includedir repos.d
442         }' %{_sysconfdir}/%{name}/poldek.conf
443 fi
444
445 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
446 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
447
448 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
449         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
450         %{__mv} -v %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
451 fi
452
453 %ifarch %{x8664}
454 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
455         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
456         %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
457 fi
458 %endif
459
460 %triggerpostun -- poldek < 0.30.1-3
461 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
462         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
463         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
464 fi
465 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
466         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
467         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
468 fi
469
470 %triggerpostun -- %{name} < 0.30.1-8
471 if [ $1 -le 1 ]; then
472         # revert change on  --downgrade
473         %{__sed} -i -re 's,^pm command = %{_libexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
474 else
475         # setup pm command
476         %{__sed} -i -re 's,#?(pm command =).*,\1 %{_libexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
477 fi
478
479 %files -f %{name}.lang
480 %defattr(644,root,root,755)
481 %doc ChangeLog README* NEWS TODO configs
482 %dir %{_sysconfdir}/%{name}
483 %dir %{_sysconfdir}/%{name}/pre-install.d
484 %{_sysconfdir}/%{name}/pre-install.d/README
485 %dir %{_sysconfdir}/%{name}/post-install.d
486 %{_sysconfdir}/%{name}/post-install.d/README
487 %dir %{_sysconfdir}/%{name}/repos.d
488 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
489 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
490 %attr(755,root,root) %{_bindir}/ipoldek
491 %attr(755,root,root) %{_bindir}/poldek
492 %attr(755,root,root) %{_bindir}/rpmvercmp
493 %dir %{_libexecdir}
494 %attr(755,root,root) %{_libexecdir}/pm-command.sh
495 %attr(755,root,root) %{_libexecdir}/poldekuser-setup.sh
496 %attr(755,root,root) %{_libexecdir}/vfcompr
497 %attr(755,root,root) %{_libexecdir}/vfjuggle
498 %attr(755,root,root) %{_libexecdir}/vfsmb
499 %attr(755,root,root) %{_libexecdir}/zlib-in-rpm.sh
500 %{_mandir}/man1/%{name}*.1*
501 %lang(pl) %{_mandir}/pl/man1/%{name}*
502 %{_infodir}/poldek.info*
503 %if %{with imode}
504 %{_desktopdir}/%{name}.desktop
505 %{_pixmapsdir}/%{name}.png
506 %endif
507 %dir /var/cache/%{name}
508
509 %if %{without static}
510 %files libs
511 %defattr(644,root,root,755)
512 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
513 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
514 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
515 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
516 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
517 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
518 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
519 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
520 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
521 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
522 %endif
523
524 %files devel
525 %defattr(644,root,root,755)
526 %if %{without static}
527 %attr(755,root,root) %{_libdir}/libpoclidek.so
528 %attr(755,root,root) %{_libdir}/libpoldek.so
529 %attr(755,root,root) %{_libdir}/libtndb.so
530 %attr(755,root,root) %{_libdir}/libtrurl.so
531 %attr(755,root,root) %{_libdir}/libvfile.so
532 %endif
533 %{_libdir}/libpoclidek.la
534 %{_libdir}/libpoldek.la
535 %{_libdir}/libtndb.la
536 %{_libdir}/libtrurl.la
537 %{_libdir}/libvfile.la
538 %{_includedir}/poldek
539 %{_includedir}/tndb
540 %{_includedir}/trurl
541 %{_includedir}/vfile
542 %{_pkgconfigdir}/tndb.pc
543 %{_pkgconfigdir}/trurlib.pc
544
545 %files static
546 %defattr(644,root,root,755)
547 %{_libdir}/libtndb.a
548 %{_libdir}/libtrurl.a
549
550 %if %{with python}
551 %files -n python-poldek
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
554 %{py_sitescriptdir}/poldek.py[co]
555 %{py_sitescriptdir}/poldekmod.py[co]
556 %endif
This page took 0.09453 seconds and 3 git commands to generate.