]> git.pld-linux.org Git - packages/poldek.git/blob - poldek.spec
205e803f0c484ea209c186cdf32561dd99214672
[packages/poldek.git] / poldek.spec
1 # TODO
2 # - fix config having escaped html entities:
3 #   # package A requires capability foo >= 1.0 while package B provides "foo"
4
5 # Conditional build:
6 %bcond_with     static  # don't use shared libraries
7 %bcond_without  imode   # don't build interactive mode
8 %bcond_without  python  # don't build python bindings
9 %bcond_with     snap    # install configs for official Th snapshot
10 %bcond_with     db61    # DB 6.1 instead of 5.2
11 %bcond_with     rpm4    # use rpm4/db4.7 instead of rpm5
12
13 # current snapshot name
14 %define         SNAP    2015
15
16 # required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
17 # NOTE: poldek links with "system db" (-ldb) anyway if it exists
18 %if %{with db61}
19 %define         db_pkg          db6.1
20 %define         ver_db          6.1
21 %define         ver_db_rel      1
22 %else
23 %define         db_pkg          db5.2
24 %define         ver_db          5.2
25 %define         ver_db_rel      3
26 %endif
27
28 %if %{with rpm4}
29 %define         db_pkg          db4.7
30 %define         ver_db          4.7.25
31 %define         ver_db_rel      1
32 %define         ver_rpm         4.5-49
33 %else
34 %define         ver_rpm         5.4.10
35 %endif
36
37 %define         rel     1
38 Summary:        RPM packages management helper tool
39 Summary(hu.UTF-8):      RPM csomagkezelést segítő eszköz
40 Summary(pl.UTF-8):      Pomocnicze narzędzie do zarządzania pakietami RPM
41 Name:           poldek
42 Version:        0.32.1
43 Release:        %{rel}%{?with_snap:.%{SNAP}}
44 License:        GPL v2
45 Group:          Applications/System
46 #Source0:       http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
47 Source0:        https://launchpad.net/poldek/0.32/%{version}/+download/%{name}-%{version}.tar.xz
48 # Source0-md5:  24794243d0d4573d7159bd924080c83c
49 Source1:        %{name}.conf
50 Source2:        %{name}-multilib.conf
51 Source3:        %{name}-config.sh
52 Source5:        %{name}-aliases.conf
53 Source6:        %{name}.desktop
54 Source7:        %{name}.png
55 # Source7-md5:  ee487abede50874e9eceb6495d5ee150
56 Source8:        %{name}-debuginfo.conf
57 Source9:        %{name}-aidath.conf
58 Source10:       %{name}-multilib-aidath.conf
59 Source11:       %{name}-archive.conf
60 Source100:      %{name}-snap.conf
61 Source101:      %{name}-multilib-snap.conf
62 Source102:      %{name}-debuginfo-snap.conf
63 Patch0:         %{name}-size-type.patch
64 Patch1:         %{name}-config.patch
65 Patch2:         pm-hooks.patch
66 URL:            http://poldek.pld-linux.org/
67 BuildRequires:  %{db_pkg}-devel >= %{ver_db}-%{ver_db_rel}
68 BuildRequires:  autoconf
69 BuildRequires:  automake >= 1:1.11
70 BuildRequires:  bzip2-devel
71 BuildRequires:  check-devel
72 BuildRequires:  docbook-dtd412-xml
73 BuildRequires:  gettext-tools
74 BuildRequires:  libgomp-devel
75 BuildRequires:  libtool
76 BuildRequires:  libxml2-devel
77 BuildRequires:  openssl-devel >= 0.9.7d
78 BuildRequires:  pcre-devel
79 BuildRequires:  pkgconfig
80 BuildRequires:  popt-devel
81 %{?with_python:BuildRequires:   python-devel}
82 BuildRequires:  readline-devel >= 5.0
83 BuildRequires:  rpm-devel >= %{ver_rpm}
84 %{?with_python:BuildRequires:   rpm-pythonprov}
85 BuildRequires:  tar >= 1:1.22
86 BuildRequires:  xmlto
87 BuildRequires:  xz
88 BuildRequires:  zlib-devel
89 %if %{with static}
90 BuildRequires:  %{db_pkg}-static >= %{ver_db}-%{ver_db_rel}
91 BuildRequires:  bzip2-static
92 BuildRequires:  glibc-static
93 BuildRequires:  libxml2-static
94 BuildRequires:  ncurses-static
95 BuildRequires:  openssl-static
96 BuildRequires:  pcre-static
97 BuildRequires:  popt-static
98 BuildRequires:  readline-static
99 BuildRequires:  rpm-static
100 BuildRequires:  zlib-static
101 %endif
102 Requires(triggerpostun):        awk
103 Requires(triggerpostun):        sed >= 4.0
104 Requires:       %{db_pkg} >= %{ver_db}-%{ver_db_rel}
105 Requires:       %{name}-libs = %{version}-%{release}
106 Requires:       /bin/run-parts
107 Requires:       rpm >= %{ver_rpm}
108 Requires:       rpm-db-ver = %{ver_db}
109 Requires:       rpm-lib >= %{ver_rpm}
110 Requires:       sed
111 Conflicts:      etckeeper < 1.18-2
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         _libexecdir     %{_prefix}/lib/%{name}
115
116 %description
117 poldek is an RPM package management tool which allows you to easily
118 perform package verification, installation (including system
119 installation from scratch), upgrading, and removal.
120
121 Program can be used in batch (like apt-get from Debian's APT) or
122 interactive mode. The interactive mode puts you into a readline
123 interface with command line autocompletion and history, similar to the
124 shell mode of Perl's CPAN.
125
126 %{?with_static:This version is statically linked.}
127
128 %{!?with_imode:This version hasn't got interactive mode.}
129 #'vim
130
131 %description -l hu.UTF-8
132 poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
133 csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
134 nulláról), frissítést és eltávolítást.
135
136 A program használható parancssorból (mint a Debian apt-get programja)
137 vagy interaktív módban. Az interaktív mód egy readline környezetet
138 jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
139 shell módjához.
140
141 %{?with_static:Ez a verzió statikusan linkelt.}
142
143 %{!?with_imode:Ennek a verziónak nincs interaktív módja.}
144
145 %description -l pl.UTF-8
146 poldek jest narzędziem linii poleceń służącym do weryfikacji,
147 instalacji (włączając instalację systemu od zera), aktualizacji i
148 usuwania pakietów.
149
150 Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
151 interaktywnym. Tryb interaktywny posiada interfejs readline z
152 dopełnianiem komend i historią, podobny do trybu shell perlowego
153 modułu CPAN.
154
155 %{?with_static:Ta wersja jest konsolidowana statycznie.}
156
157 %{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
158
159 %package libs
160 Summary:        poldek libraries
161 Summary(hu.UTF-8):      A poldek könyvtárai
162 Summary(pl.UTF-8):      Biblioteki poldka
163 Group:          Libraries
164
165 %description libs
166 poldek libraries.
167
168 %description libs -l hu.UTF-8
169 A poldek könyvtárai.
170
171 %description libs -l pl.UTF-8
172 Biblioteki poldka.
173
174 %package devel
175 Summary:        Header files for poldek libraries
176 Summary(hu.UTF-8):      A poldek könyvtár fejlesztői fájljai
177 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek poldka
178 Group:          Development/Libraries
179 Requires:       %{name}-libs = %{version}-%{release}
180 Requires:       rpm-devel >= %{ver_rpm}
181
182 %description devel
183 Header files for poldek libraries.
184
185 %description devel -l hu.UTF-8
186 A poldek könyvtár fejlesztői fájljai.
187
188 %description devel -l pl.UTF-8
189 Pliki nagłówkowe bibliotek poldka.
190
191 %package static
192 Summary:        poldek static libraries
193 Summary(hu.UTF-8):      poldek statikus könyvtárak
194 Summary(pl.UTF-8):      Biblioteki statyczne poldka
195 Group:          Development/Libraries
196 Requires:       %{name}-devel = %{version}-%{release}
197
198 %description static
199 poldek static libraries.
200
201 %description static -l hu.UTF-8
202 poldek statikus könyvtárak.
203
204 %description static -l pl.UTF-8
205 Biblioteki statyczne poldka.
206
207 %package -n python-poldek
208 Summary:        Python modules for poldek
209 Summary(hu.UTF-8):      Python modulok poldek-hez
210 Summary(pl.UTF-8):      Moduły języka Python dla poldka
211 Group:          Libraries/Python
212 Requires:       %{name}-libs = %{version}-%{release}
213 Requires:       python-libs
214
215 %description -n python-poldek
216 Python modules for poldek.
217
218 %description -n python-poldek -l hu.UTF-8
219 Python modulok poldek-hez.
220
221 %description -n python-poldek -l pl.UTF-8
222 Moduły języka Python dla poldka.
223
224 %prep
225 %setup -q
226 %patch0 -p1
227 %patch1 -p1
228 %patch2 -p1
229
230 %{__rm} m4/libtool.m4 m4/lt*.m4
231
232 # cleanup backups after patching
233 find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
234 chmod u+x ./configure ./doc/conf-xml2.sh
235
236 %build
237 %{__gettextize}
238 %{__libtoolize}
239 %{__aclocal} -I m4
240 %{__autoheader}
241 %{__autoconf}
242 %{__automake}
243 cd tndb
244 %{__libtoolize}
245 %{__aclocal}
246 %{__autoheader}
247 %{__autoconf}
248 %{__automake}
249 cd ../trurlib
250 %{__libtoolize}
251 %{__aclocal}
252 %{__autoheader}
253 %{__autoconf}
254 %{__automake}
255 cd ..
256
257 CPPFLAGS="%{rpmcppflags} -std=gnu99 -fgnu89-inline"
258 %configure \
259         %{?with_static:--enable-static --disable-shared} \
260         %{!?with_imode:--disable-imode} \
261         --with-pkglibdir=%{_libexecdir} \
262         --enable-nls \
263         %{?with_python:--with-python}
264 %{__make} -j1
265 #       --enable-trace
266
267 %install
268 rm -rf $RPM_BUILD_ROOT
269 install -d $RPM_BUILD_ROOT/var/cache/%{name}
270
271 %{__make} install -j1 \
272         DESTDIR=$RPM_BUILD_ROOT
273
274 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
275
276 %if %{with python}
277 %{__make} -C python -j1 install \
278         DESTDIR=$RPM_BUILD_ROOT \
279         libdir=%{py_sitedir}
280 %endif
281
282 %{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
283
284 %ifarch i486 i686 ppc sparc alpha athlon
285         %define         ftp_arch        %{_target_cpu}
286 %endif
287 %ifarch %{x8664}
288         %define         ftp_arch        x86_64
289         %define         ftp_alt_arch    i686
290         %define         ftp_alt2_arch   x32
291 %endif
292 %ifarch x32
293         %define         ftp_arch        x32
294         %define         ftp_alt_arch    x86_64
295         %define         ftp_alt2_arch   i686
296 %endif
297 %ifarch i586
298         %define         ftp_arch        i486
299 %endif
300 %ifarch pentium2 pentium3 pentium4
301         %define         ftp_arch        i686
302 %endif
303 %ifarch sparcv9 sparc64
304         %define         ftp_arch        sparc
305         %define         ftp_arch        %{_target_cpu}
306         %ifarch sparc64
307                 %define         ftp_alt_arch    sparcv9
308         %endif
309 %endif
310
311 %define pld_conf %{SOURCE1}
312 %define pld_debuginfo_conf %{SOURCE8}
313 %define pld_archive_conf %{SOURCE11}
314
315 %ifarch %{x8664} x32
316         %define pld_multilib_conf %{SOURCE2}
317         %define pld_multilib2_conf %{SOURCE2}
318 %endif
319
320 # aidath
321 %ifarch sparcv9 sparc64
322         %define pld_conf %{SOURCE9}
323         %undefine pld_archive_conf
324 %endif
325 %ifarch sparc64
326         %define pld_multilib_conf %{SOURCE10}
327 %endif
328
329 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
330
331 %if 0%{?pld_multilib_conf:1}
332         %{__sed} 's|%%ARCH%%|%{ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
333 %endif
334
335 %if 0%{?pld_multilib2_conf:1}
336         %{__sed} 's|%%ARCH%%|%{ftp_alt2_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt2_arch}.conf
337 %endif
338
339 %if 0%{?pld_debuginfo_conf:1}
340 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
341 %endif
342
343 %if 0%{?pld_archive_conf:1}
344 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
345 %endif
346
347 # Always install snapshot configs
348 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
349         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
350 %{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
351         -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
352 %ifarch %{x8664} x32
353         %{__sed} -e 's|%%ARCH%%|%{ftp_alt_arch}|g' \
354                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
355         %{__sed} -e 's|%%ARCH%%|%{ftp_alt2_arch}|g' \
356                 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt2_arch}.conf
357 %endif
358
359 %if %{with snap}
360 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
361 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
362 %else
363 %{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
364 %{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
365 %endif
366
367 # create "all" meta repo
368 %if 0%{?ftp_alt_arch:1}%{?ftp_alt2_arch:1}
369 cat <<'EOF' >  $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-all.conf
370 # group source for referring th+th-multiarch sources together, i.e poldek -n th-all
371 [source]
372 type    = group
373 name    = th-all
374 sources = th %{?ftp_alt_arch:th-%{ftp_alt_arch}} %{?ftp_alt2_arch:th-%{ftp_alt2_arch}}
375 EOF
376 %endif
377
378 # th-2014 snap does not exist for x32 yet
379 %if "%{ftp_arch}" == "x32"
380 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
381 %endif
382 %if "%{ftp_alt2_arch}" == "x32"
383 rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-x32.conf
384 %endif
385
386 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
387
388 %if %{with imode}
389 # add desktop file and icon
390 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
391 cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
392 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
393 %endif
394
395 # sources we don't package
396 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
397 # include them in %doc
398 %{__rm} -rf configs
399 cp -a conf configs
400 %{__rm} -f configs/Makefile*
401
402 %if %{with python}
403 %py_postclean
404 %{__rm} $RPM_BUILD_ROOT%{py_sitedir}/_poldekmod.la
405 %endif
406
407 %find_lang %{name}
408
409 %clean
410 rm -rf $RPM_BUILD_ROOT
411
412 %post
413 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
414 if [ "$1" = "1" ]; then
415         # remove ignore = vserver-packages inside vserver on first install
416         {
417                 while read f ctx; do
418                         [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
419                 done </proc/self/status
420         } 2>/dev/null
421         if [ -z "$ctx" -o "$ctx" = "0" ]; then
422                 VSERVER=no
423         else
424                 VSERVER=yes
425         fi
426         if [ "$VSERVER" = "yes" ]; then
427                 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
428         fi
429 fi
430
431 %postun -p      /sbin/postshell
432 -/usr/sbin/fix-info-dir -c %{_infodir}
433
434 %post   libs -p /sbin/ldconfig
435 %postun libs -p /sbin/ldconfig
436
437 %triggerpostun -- poldek < 0.30-0.20080225.00.1
438 if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
439         %{__sed} -i -e '/^%%include source.conf/{
440                 a
441                 a# /etc/poldek/repos.d/*.conf
442                 a%%includedir repos.d
443         }' %{_sysconfdir}/%{name}/poldek.conf
444 fi
445
446 %{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
447 %{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
448
449 if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
450         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
451         %{__mv} -v %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
452 fi
453
454 %ifarch %{x8664}
455 if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
456         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
457         %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
458 fi
459 %endif
460
461 %triggerpostun -- poldek < 0.30.1-3
462 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
463         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
464         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
465 fi
466 if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
467         %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
468         %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
469 fi
470
471 %triggerpostun -- %{name} < 0.30.1-8
472 if [ $1 -le 1 ]; then
473         # revert change on  --downgrade
474         %{__sed} -i -re 's,^pm command = %{_libexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
475 else
476         # setup pm command
477         %{__sed} -i -re 's,#?(pm command =).*,\1 %{_libexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
478 fi
479
480 %files -f %{name}.lang
481 %defattr(644,root,root,755)
482 %doc ChangeLog README* NEWS TODO configs
483 %dir %{_sysconfdir}/%{name}
484 %dir %{_sysconfdir}/%{name}/pre-install.d
485 %{_sysconfdir}/%{name}/pre-install.d/README
486 %dir %{_sysconfdir}/%{name}/post-install.d
487 %{_sysconfdir}/%{name}/post-install.d/README
488 %dir %{_sysconfdir}/%{name}/repos.d
489 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
490 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
491 %attr(755,root,root) %{_bindir}/ipoldek
492 %attr(755,root,root) %{_bindir}/poldek
493 %attr(755,root,root) %{_bindir}/poldek-config
494 %attr(755,root,root) %{_bindir}/rpmvercmp
495 %dir %{_libexecdir}
496 %attr(755,root,root) %{_libexecdir}/pm-command.sh
497 %attr(755,root,root) %{_libexecdir}/poldekuser-setup.sh
498 %attr(755,root,root) %{_libexecdir}/vfcompr
499 %attr(755,root,root) %{_libexecdir}/vfjuggle
500 %attr(755,root,root) %{_libexecdir}/vfsmb
501 %attr(755,root,root) %{_libexecdir}/zlib-in-rpm.sh
502 %{_mandir}/man1/%{name}*.1*
503 %lang(pl) %{_mandir}/pl/man1/%{name}*
504 %{_infodir}/poldek.info*
505 %if %{with imode}
506 %{_desktopdir}/%{name}.desktop
507 %{_pixmapsdir}/%{name}.png
508 %endif
509 %dir /var/cache/%{name}
510
511 %if %{without static}
512 %files libs
513 %defattr(644,root,root,755)
514 %attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
515 %attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
516 %attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
517 %attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
518 %attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
519 %attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.0
520 %attr(755,root,root) %ghost %{_libdir}/libpoldek.so.2
521 %attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
522 %attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
523 %attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
524 %endif
525
526 %files devel
527 %defattr(644,root,root,755)
528 %if %{without static}
529 %attr(755,root,root) %{_libdir}/libpoclidek.so
530 %attr(755,root,root) %{_libdir}/libpoldek.so
531 %attr(755,root,root) %{_libdir}/libtndb.so
532 %attr(755,root,root) %{_libdir}/libtrurl.so
533 %attr(755,root,root) %{_libdir}/libvfile.so
534 %endif
535 %{_libdir}/libpoclidek.la
536 %{_libdir}/libpoldek.la
537 %{_libdir}/libtndb.la
538 %{_libdir}/libtrurl.la
539 %{_libdir}/libvfile.la
540 %{_includedir}/poldek
541 %{_includedir}/tndb
542 %{_includedir}/trurl
543 %{_includedir}/vfile
544 %{_pkgconfigdir}/tndb.pc
545 %{_pkgconfigdir}/trurlib.pc
546
547 %files static
548 %defattr(644,root,root,755)
549 %{_libdir}/libtndb.a
550 %{_libdir}/libtrurl.a
551
552 %if %{with python}
553 %files -n python-poldek
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{py_sitedir}/_poldekmod.so
556 %{py_sitescriptdir}/poldek.py[co]
557 %{py_sitescriptdir}/poldekmod.py[co]
558 %endif
This page took 0.092726 seconds and 2 git commands to generate.