]> git.pld-linux.org Git - packages/poldek.git/blame - poldek.spec
- rel 2; uppercase greedy option was dropped
[packages/poldek.git] / poldek.spec
CommitLineData
4117ae1a
ER
1# TODO
2# - fix config having escaped html entities:
3# # package A requires capability foo >= 1.0 while package B provides "foo"
4
de1099c4 5# Conditional build:
9fe14a3f 6%bcond_with static # don't use shared libraries
7%bcond_without imode # don't build interactive mode
58c31de0 8%bcond_without python # don't build python bindings
cf6c3a30 9%bcond_with snap # install configs for official Th snapshot
fc61ee66 10%bcond_with rpm4 # use rpm4 instead of rpm5
36b194b5 11%bcond_with tests # tests
7000d724 12
e1015166 13# current snapshot name
0b18083b 14%define SNAP 2019
a584c5c5 15
373c6f03 16# required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
fc61ee66
JR
17%if %{with rpm4}
18%define db_pkg db
19%define ver_db 5.3
fc61ee66
JR
20%define ver_rpm 1:4.14
21%define ver_db_devel %(rpm -q --qf '%|E?{%{E}:}|%{V}-%{R}' --what-provides db-devel)
6e185c37 22%else
05442e9e 23%define ver_db %(rpm -q --provides rpm-lib | %{__sed} -ne 's/^rpm-db-ver = \\([.0-9]*\\)$/\\1/p')
b99b1fba 24%define db_pkg db%{ver_db}
a17726b5 25%define ver_rpm 5.4.10
5fda028a 26%endif
7000d724 27
c0fe8cdf 28%define rel 2
b44549bf 29Summary: RPM packages management helper tool
9c03ea8f 30Summary(hu.UTF-8): RPM csomagkezelést segítő eszköz
9faf625a 31Summary(pl.UTF-8): Pomocnicze narzędzie do zarządzania pakietami RPM
b44549bf 32Name: poldek
dac9cf18 33Version: 0.42.2
9c1c2b52 34Release: %{rel}%{?with_snap:.%{SNAP}}
9f931ada 35License: GPL v2
8efee472 36Group: Applications/System
85398bac 37#Source0: http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
ba183faf 38Source0: https://github.com/poldek-pm/poldek/releases/download/v%{version}/%{name}-%{version}.tar.xz
dac9cf18 39# Source0-md5: 2759fe45bc50efb6084d5338d725411a
911a8560 40Source1: %{name}.conf
b25cb9a7 41Source2: %{name}-multilib.conf
d9c7cedf 42Source3: %{name}-config.sh
2ccd5d66 43Source5: %{name}-aliases.conf
44Source6: %{name}.desktop
45Source7: %{name}.png
a97b47d4 46# Source7-md5: ee487abede50874e9eceb6495d5ee150
171e07f6 47Source8: %{name}-debuginfo.conf
652b5bc5 48Source9: %{name}-aidath.conf
49Source10: %{name}-multilib-aidath.conf
8db66c11 50Source11: %{name}-archive.conf
a584c5c5
JR
51Source100: %{name}-snap.conf
52Source101: %{name}-multilib-snap.conf
53Source102: %{name}-debuginfo-snap.conf
d7961a02 54Patch0: %{name}-config.patch
55Patch1: pm-hooks.patch
b99b1fba
JB
56Patch2: %{name}-ext-down-enable.patch
57Patch3: %{name}-pc.patch
39ca2371 58URL: http://poldek.pld-linux.org/
b99b1fba
JB
59BuildRequires: %{db_pkg}-devel >= %{ver_db}
60BuildRequires: autoconf >= 2.63
4d0dcbcf 61BuildRequires: automake >= 1:1.11
373c6f03 62BuildRequires: bzip2-devel
065b86e0 63BuildRequires: check-devel
1d67e563 64BuildRequires: docbook-dtd412-xml
b99b1fba 65BuildRequires: gettext-tools >= 0.11.5
0021c1c7 66BuildRequires: libgomp-devel
b25cb9a7 67BuildRequires: libtool
b99b1fba
JB
68BuildRequires: libxml2-devel >= 2
69BuildRequires: ncurses-devel
cbc6f56b 70BuildRequires: openssl-devel >= 0.9.7d
13fd950e 71BuildRequires: pcre-devel
b3ea4b51 72BuildRequires: pkgconfig
13fd950e 73BuildRequires: popt-devel
58c31de0 74%{?with_python:BuildRequires: python-devel}
b25cb9a7 75BuildRequires: readline-devel >= 5.0
373c6f03 76BuildRequires: rpm-devel >= %{ver_rpm}
300927eb 77%{?with_python:BuildRequires: rpm-pythonprov}
340a1e21 78BuildRequires: tar >= 1:1.22
77cfda6e 79BuildRequires: xmlto
340a1e21 80BuildRequires: xz
96475e5e 81BuildRequires: zlib-devel
d7961a02 82BuildRequires: zstd-devel
373c6f03 83%if %{with static}
b99b1fba 84BuildRequires: %{db_pkg}-static >= %{ver_db}
340a1e21 85BuildRequires: bzip2-static
2fac0b02 86BuildRequires: glibc-static
b25cb9a7 87BuildRequires: libxml2-static
373c6f03
JB
88BuildRequires: ncurses-static
89BuildRequires: openssl-static
90BuildRequires: pcre-static
91BuildRequires: popt-static
92BuildRequires: readline-static
93BuildRequires: rpm-static
94BuildRequires: zlib-static
d7961a02 95BuildRequires: zstd-static
373c6f03 96%endif
b25cb9a7 97Requires(triggerpostun): awk
168acc54 98Requires(triggerpostun): sed >= 4.0
fc61ee66
JR
99%if %{with rpm4}
100Requires: %{db_pkg} >= %{ver_db_devel}
101%else
b99b1fba 102Requires: %{db_pkg} >= %{ver_db}
fc61ee66
JR
103Requires: rpm-db-ver = %{ver_db}
104%endif
340a1e21 105Requires: %{name}-libs = %{version}-%{release}
67e6053c 106Requires: /bin/run-parts
373c6f03 107Requires: rpm >= %{ver_rpm}
5fda028a 108Requires: rpm-lib >= %{ver_rpm}
e202a52a 109Requires: sed
c5d1808a 110Conflicts: etckeeper < 1.18-2
b44549bf 111BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
70aeb4cf
JB
113# it could be %{_libexecdir}/%{name}, but beware of compatibility (path hardcoded in configurations)
114%define pkglibexecdir %{_prefix}/lib/%{name}
dcdcebb7 115
b44549bf 116%description
0fa0dc36 117poldek is an RPM package management tool which allows you to easily
118perform package verification, installation (including system
13fd950e 119installation from scratch), upgrading, and removal.
0fa0dc36 120
13fd950e
JB
121Program can be used in batch (like apt-get from Debian's APT) or
122interactive mode. The interactive mode puts you into a readline
123interface with command line autocompletion and history, similar to the
124shell mode of Perl's CPAN.
8efee472 125
9fe14a3f 126%{?with_static:This version is statically linked.}
d94b28a6 127
9fe14a3f 128%{!?with_imode:This version hasn't got interactive mode.}
7f07e487 129#'vim
1f84648f 130
9c03ea8f
ZU
131%description -l hu.UTF-8
132poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
133csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
134nulláról), frissítést és eltávolítást.
135
136A program használható parancssorból (mint a Debian apt-get programja)
137vagy interaktív módban. Az interaktív mód egy readline környezetet
138jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
139shell módjához.
140
141%{?with_static:Ez a verzió statikusan linkelt.}
142
143%{!?with_imode:Ennek a verziónak nincs interaktív módja.}
144
caed9b36
JR
145%description -l pl.UTF-8
146poldek jest narzędziem linii poleceń służącym do weryfikacji,
147instalacji (włączając instalację systemu od zera), aktualizacji i
148usuwania pakietów.
56e1ab51 149
caed9b36 150Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
d82a9cb2 151interaktywnym. Tryb interaktywny posiada interfejs readline z
caed9b36
JR
152dopełnianiem komend i historią, podobny do trybu shell perlowego
153modułu CPAN.
8efee472 154
9fe14a3f 155%{?with_static:Ta wersja jest konsolidowana statycznie.}
a611e0bc 156
9fe14a3f 157%{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
b44549bf 158
b25cb9a7 159%package libs
168acc54 160Summary: poldek libraries
9c03ea8f 161Summary(hu.UTF-8): A poldek könyvtárai
9faf625a 162Summary(pl.UTF-8): Biblioteki poldka
168acc54 163Group: Libraries
b25cb9a7
JB
164
165%description libs
166poldek libraries.
167
9c03ea8f
ZU
168%description libs -l hu.UTF-8
169A poldek könyvtárai.
170
caed9b36 171%description libs -l pl.UTF-8
b25cb9a7
JB
172Biblioteki poldka.
173
174%package devel
168acc54 175Summary: Header files for poldek libraries
9c03ea8f 176Summary(hu.UTF-8): A poldek könyvtár fejlesztői fájljai
9faf625a 177Summary(pl.UTF-8): Pliki nagłówkowe bibliotek poldka
168acc54 178Group: Development/Libraries
09d4c571 179Requires: %{name}-libs = %{version}-%{release}
b980560b 180Requires: rpm-devel >= %{ver_rpm}
b25cb9a7
JB
181
182%description devel
183Header files for poldek libraries.
184
9c03ea8f
ZU
185%description devel -l hu.UTF-8
186A poldek könyvtár fejlesztői fájljai.
187
caed9b36
JR
188%description devel -l pl.UTF-8
189Pliki nagłówkowe bibliotek poldka.
b25cb9a7
JB
190
191%package static
168acc54 192Summary: poldek static libraries
9c03ea8f 193Summary(hu.UTF-8): poldek statikus könyvtárak
9faf625a 194Summary(pl.UTF-8): Biblioteki statyczne poldka
168acc54 195Group: Development/Libraries
09d4c571 196Requires: %{name}-devel = %{version}-%{release}
b25cb9a7
JB
197
198%description static
199poldek static libraries.
200
9c03ea8f
ZU
201%description static -l hu.UTF-8
202poldek statikus könyvtárak.
203
caed9b36 204%description static -l pl.UTF-8
b25cb9a7
JB
205Biblioteki statyczne poldka.
206
58c31de0
JB
207%package -n python-poldek
208Summary: Python modules for poldek
9c03ea8f 209Summary(hu.UTF-8): Python modulok poldek-hez
9faf625a 210Summary(pl.UTF-8): Moduły języka Python dla poldka
58c31de0
JB
211Group: Libraries/Python
212Requires: %{name}-libs = %{version}-%{release}
340a1e21 213Requires: python-libs
58c31de0
JB
214
215%description -n python-poldek
216Python modules for poldek.
217
9c03ea8f
ZU
218%description -n python-poldek -l hu.UTF-8
219Python modulok poldek-hez.
220
caed9b36
JR
221%description -n python-poldek -l pl.UTF-8
222Moduły języka Python dla poldka.
58c31de0 223
03159b71 224%prep
a9c9446a 225%setup -q
85398bac 226%patch0 -p1
13aa6434 227%patch1 -p1
1cf9975a 228%patch2 -p1
b99b1fba 229%patch3 -p1
8dcb75fc 230
5e2c5cc3 231%{__rm} m4/libtool.m4 m4/lt*.m4
b44549bf 232
0579f9b7
ER
233# cleanup backups after patching
234find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
4fa2b79c 235chmod u+x ./configure ./doc/conf-xml2.sh
0579f9b7 236
b44549bf 237%build
5c81138a 238%{__gettextize}
bef9d2a3 239%{__libtoolize}
21a83253 240%{__aclocal} -I m4
d878a63c 241%{__autoheader}
21a83253
MM
242%{__autoconf}
243%{__automake}
f8e81a61 244cd tndb
313cd172 245%{__libtoolize}
5e2c5cc3
JB
246%{__aclocal}
247%{__autoheader}
248%{__autoconf}
249%{__automake}
f8e81a61 250cd ../trurlib
313cd172 251%{__libtoolize}
5e2c5cc3
JB
252%{__aclocal}
253%{__autoheader}
254%{__autoconf}
255%{__automake}
f8e81a61 256cd ..
b25cb9a7 257
1f84648f 258%configure \
b25cb9a7 259 %{?with_static:--enable-static --disable-shared} \
9fe14a3f 260 %{!?with_imode:--disable-imode} \
70aeb4cf 261 --with-pkglibdir=%{pkglibexecdir} \
58c31de0
JB
262 --enable-nls \
263 %{?with_python:--with-python}
6c5e6a74 264%{__make}
8efee472 265
9b77d5f3
JR
266%if %{with python}
267%{__make} -C python
268%endif
269
d090f4be
AM
270%if %{with tests}
271%{__make} check
272%endif
273
b44549bf 274%install
275rm -rf $RPM_BUILD_ROOT
c5d1808a 276install -d $RPM_BUILD_ROOT/var/cache/%{name}
8efee472 277
6c5e6a74 278%{__make} install \
c8f7d829 279 DESTDIR=$RPM_BUILD_ROOT
de1099c4 280
d9c7cedf
ER
281install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
282
58c31de0 283%if %{with python}
6c5e6a74 284%{__make} -C python install \
58c31de0 285 DESTDIR=$RPM_BUILD_ROOT \
9b77d5f3 286 py_sitedir=%{py_sitedir}
58c31de0
JB
287%endif
288
5e2c5cc3 289%{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
a49836bb 290
9639596f 291%ifarch i486 i686 ppc sparc alpha athlon
bd621c72 292 %define ftp_arch %{_target_cpu}
36004ea3 293%endif
9639596f 294%ifarch %{x8664}
bd621c72
ER
295 %define ftp_arch x86_64
296 %define ftp_alt_arch i686
297 %define ftp_alt2_arch x32
fabc4b40
JR
298%endif
299%ifarch x32
bd621c72
ER
300 %define ftp_arch x32
301 %define ftp_alt_arch x86_64
302 %define ftp_alt2_arch i686
36004ea3 303%endif
9639596f 304%ifarch i586
bd621c72 305 %define ftp_arch i486
58820d9b 306%endif
a49836bb 307%ifarch pentium2 pentium3 pentium4
bd621c72 308 %define ftp_arch i686
36004ea3 309%endif
a49836bb 310%ifarch sparcv9 sparc64
bd621c72
ER
311 %define ftp_arch sparc
312 %define ftp_arch %{_target_cpu}
b614e8f7 313 %ifarch sparc64
bd621c72 314 %define ftp_alt_arch sparcv9
23ead09a 315 %endif
652b5bc5 316%endif
32697bd0 317
b614e8f7
JR
318%define pld_conf %{SOURCE1}
319%define pld_debuginfo_conf %{SOURCE8}
320%define pld_archive_conf %{SOURCE11}
7c0e4fc5 321
fabc4b40 322%ifarch %{x8664} x32
b614e8f7 323 %define pld_multilib_conf %{SOURCE2}
fabc4b40 324 %define pld_multilib2_conf %{SOURCE2}
b614e8f7 325%endif
7c0e4fc5 326
b614e8f7
JR
327# aidath
328%ifarch sparcv9 sparc64
329 %define pld_conf %{SOURCE9}
330 %undefine pld_archive_conf
331%endif
332%ifarch sparc64
333 %define pld_multilib_conf %{SOURCE10}
7c0e4fc5 334%endif
23ead09a 335
bd621c72 336%{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
23ead09a 337
7c0e4fc5 338%if 0%{?pld_multilib_conf:1}
bd621c72 339 %{__sed} 's|%%ARCH%%|%{ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
7c0e4fc5
ER
340%endif
341
fabc4b40 342%if 0%{?pld_multilib2_conf:1}
bd621c72 343 %{__sed} 's|%%ARCH%%|%{ftp_alt2_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt2_arch}.conf
fabc4b40
JR
344%endif
345
7c0e4fc5 346%if 0%{?pld_debuginfo_conf:1}
bd621c72 347%{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
652b5bc5 348%endif
b25cb9a7 349
8db66c11 350%if 0%{?pld_archive_conf:1}
bd621c72 351%{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
8db66c11
ER
352%endif
353
7e5296f4 354# Always install snapshot configs
bd621c72 355%{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
a584c5c5 356 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
bd621c72 357%{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
a584c5c5 358 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
fabc4b40 359%ifarch %{x8664} x32
bd621c72
ER
360 %{__sed} -e 's|%%ARCH%%|%{ftp_alt_arch}|g' \
361 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
362 %{__sed} -e 's|%%ARCH%%|%{ftp_alt2_arch}|g' \
363 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt2_arch}.conf
a584c5c5 364%endif
7e5296f4
JR
365
366%if %{with snap}
c88cf671 367%{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
7e5296f4 368%{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
a584c5c5 369%else
7e5296f4 370%{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
c88cf671 371%{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
a584c5c5
JR
372%endif
373
600f8dbc
ER
374# create "all" meta repo
375%if 0%{?ftp_alt_arch:1}%{?ftp_alt2_arch:1}
376cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-all.conf
377# group source for referring th+th-multiarch sources together, i.e poldek -n th-all
378[source]
379type = group
380name = th-all
381sources = th %{?ftp_alt_arch:th-%{ftp_alt_arch}} %{?ftp_alt2_arch:th-%{ftp_alt2_arch}}
382EOF
383%endif
384
8dbabc51 385# th-2014 snap does not exist for x32 yet
bd621c72 386%if "%{ftp_arch}" == "x32"
255ca68a
ER
387rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
388%endif
bd621c72 389%if "%{ftp_alt2_arch}" == "x32"
255ca68a
ER
390rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-x32.conf
391%endif
8dbabc51 392
27edf30a 393cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
b25cb9a7 394
9e6ff4ef 395%if %{with imode}
396# add desktop file and icon
397install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
27edf30a
ER
398cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
399cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
9e6ff4ef 400%endif
401
b43abde7 402# sources we don't package
5e2c5cc3 403%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
b25cb9a7 404# include them in %doc
c88cf671 405%{__rm} -rf configs
b25cb9a7 406cp -a conf configs
c88cf671 407%{__rm} -f configs/Makefile*
b25cb9a7 408
62e80071 409%if %{with python}
58c31de0 410%py_postclean
9b77d5f3 411%{__rm} $RPM_BUILD_ROOT%{_libdir}/_poldekmod.{la,so}
62e80071 412%endif
58c31de0 413
b25cb9a7 414%find_lang %{name}
f373d903 415
b44549bf 416%clean
417rm -rf $RPM_BUILD_ROOT
418
daf0e7ce
ER
419%post
420[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
421if [ "$1" = "1" ]; then
422 # remove ignore = vserver-packages inside vserver on first install
423 {
424 while read f ctx; do
425 [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
426 done </proc/self/status
427 } 2>/dev/null
428 if [ -z "$ctx" -o "$ctx" = "0" ]; then
429 VSERVER=no
430 else
431 VSERVER=yes
432 fi
433 if [ "$VSERVER" = "yes" ]; then
434 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
435 fi
436fi
b25cb9a7 437
3896c8b1
ER
438%postun -p /sbin/postshell
439-/usr/sbin/fix-info-dir -c %{_infodir}
b25cb9a7
JB
440
441%post libs -p /sbin/ldconfig
442%postun libs -p /sbin/ldconfig
443
b43abde7
ER
444%triggerpostun -- poldek < 0.30-0.20080225.00.1
445if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
446 %{__sed} -i -e '/^%%include source.conf/{
447 a
448 a# /etc/poldek/repos.d/*.conf
449 a%%includedir repos.d
450 }' %{_sysconfdir}/%{name}/poldek.conf
451fi
452
453%{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
454%{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
455
456if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
505460c5
JR
457 %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
458 %{__mv} -v %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
b43abde7
ER
459fi
460
461%ifarch %{x8664}
462if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
505460c5
JR
463 %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
464 %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
b43abde7
ER
465fi
466%endif
467
1bacc3e0
JR
468%triggerpostun -- poldek < 0.30.1-3
469if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
bd621c72
ER
470 %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
471 %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
1bacc3e0
JR
472fi
473if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
bd621c72
ER
474 %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
475 %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
1bacc3e0
JR
476fi
477
c5d1808a
ER
478%triggerpostun -- %{name} < 0.30.1-8
479if [ $1 -le 1 ]; then
480 # revert change on --downgrade
70aeb4cf 481 %{__sed} -i -re 's,^pm command = %{pkglibexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
c5d1808a
ER
482else
483 # setup pm command
70aeb4cf 484 %{__sed} -i -re 's,#?(pm command =).*,\1 %{pkglibexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
c5d1808a
ER
485fi
486
767366b0 487%files -f %{name}.lang
b44549bf 488%defattr(644,root,root,755)
ba183faf 489%doc ChangeLog README* NEWS configs
b25cb9a7 490%dir %{_sysconfdir}/%{name}
c5d1808a
ER
491%dir %{_sysconfdir}/%{name}/pre-install.d
492%{_sysconfdir}/%{name}/pre-install.d/README
493%dir %{_sysconfdir}/%{name}/post-install.d
494%{_sysconfdir}/%{name}/post-install.d/README
08335479 495%dir %{_sysconfdir}/%{name}/repos.d
168acc54 496%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
b43abde7 497%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
5e2c5cc3
JB
498%attr(755,root,root) %{_bindir}/ipoldek
499%attr(755,root,root) %{_bindir}/poldek
d9c7cedf 500%attr(755,root,root) %{_bindir}/poldek-config
5e2c5cc3 501%attr(755,root,root) %{_bindir}/rpmvercmp
70aeb4cf
JB
502%dir %{pkglibexecdir}
503%attr(755,root,root) %{pkglibexecdir}/pm-command.sh
504%attr(755,root,root) %{pkglibexecdir}/poldekuser-setup.sh
505%attr(755,root,root) %{pkglibexecdir}/vfcompr
506%attr(755,root,root) %{pkglibexecdir}/vfjuggle
507%attr(755,root,root) %{pkglibexecdir}/vfsmb
508%attr(755,root,root) %{pkglibexecdir}/zlib-in-rpm.sh
5e2c5cc3 509%{_mandir}/man1/%{name}*.1*
d8826405 510%lang(pl) %{_mandir}/pl/man1/%{name}*
b25cb9a7 511%{_infodir}/poldek.info*
9e6ff4ef 512%if %{with imode}
513%{_desktopdir}/%{name}.desktop
514%{_pixmapsdir}/%{name}.png
515%endif
27edf30a 516%dir /var/cache/%{name}
b25cb9a7 517
b43abde7 518%if %{without static}
b25cb9a7
JB
519%files libs
520%defattr(644,root,root,755)
d8aeff9a
MB
521%attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
522%attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
523%attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
524%attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
525%attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
ba183faf 526%attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.1
527%attr(755,root,root) %ghost %{_libdir}/libpoldek.so.3
d8aeff9a
MB
528%attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
529%attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
530%attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
b25cb9a7
JB
531%endif
532
533%files devel
534%defattr(644,root,root,755)
5e2c5cc3
JB
535%if %{without static}
536%attr(755,root,root) %{_libdir}/libpoclidek.so
537%attr(755,root,root) %{_libdir}/libpoldek.so
538%attr(755,root,root) %{_libdir}/libtndb.so
539%attr(755,root,root) %{_libdir}/libtrurl.so
540%attr(755,root,root) %{_libdir}/libvfile.so
541%endif
542%{_libdir}/libpoclidek.la
543%{_libdir}/libpoldek.la
544%{_libdir}/libtndb.la
545%{_libdir}/libtrurl.la
546%{_libdir}/libvfile.la
547%{_includedir}/poldek
548%{_includedir}/tndb
549%{_includedir}/trurl
550%{_includedir}/vfile
551%{_pkgconfigdir}/tndb.pc
c9a1a81d 552%{_pkgconfigdir}/trurlib.pc
b25cb9a7
JB
553
554%files static
555%defattr(644,root,root,755)
5e2c5cc3
JB
556%{_libdir}/libtndb.a
557%{_libdir}/libtrurl.a
58c31de0
JB
558
559%if %{with python}
560%files -n python-poldek
561%defattr(644,root,root,755)
562%attr(755,root,root) %{py_sitedir}/_poldekmod.so
563%{py_sitescriptdir}/poldek.py[co]
564%{py_sitescriptdir}/poldekmod.py[co]
565%endif
This page took 0.917393 seconds and 4 git commands to generate.