]> git.pld-linux.org Git - packages/poldek.git/blame_incremental - poldek.spec
- rel 2; uppercase greedy option was dropped
[packages/poldek.git] / poldek.spec
... / ...
CommitLineData
1# TODO
2# - fix config having escaped html entities:
3# # package A requires capability foo >= 1.0 while package B provides "foo"
4
5# Conditional build:
6%bcond_with static # don't use shared libraries
7%bcond_without imode # don't build interactive mode
8%bcond_without python # don't build python bindings
9%bcond_with snap # install configs for official Th snapshot
10%bcond_with rpm4 # use rpm4 instead of rpm5
11%bcond_with tests # tests
12
13# current snapshot name
14%define SNAP 2019
15
16# required versions (forced to avoid SEGV with mixed db used by rpm and poldek)
17%if %{with rpm4}
18%define db_pkg db
19%define ver_db 5.3
20%define ver_rpm 1:4.14
21%define ver_db_devel %(rpm -q --qf '%|E?{%{E}:}|%{V}-%{R}' --what-provides db-devel)
22%else
23%define ver_db %(rpm -q --provides rpm-lib | %{__sed} -ne 's/^rpm-db-ver = \\([.0-9]*\\)$/\\1/p')
24%define db_pkg db%{ver_db}
25%define ver_rpm 5.4.10
26%endif
27
28%define rel 2
29Summary: RPM packages management helper tool
30Summary(hu.UTF-8): RPM csomagkezelést segítő eszköz
31Summary(pl.UTF-8): Pomocnicze narzędzie do zarządzania pakietami RPM
32Name: poldek
33Version: 0.42.2
34Release: %{rel}%{?with_snap:.%{SNAP}}
35License: GPL v2
36Group: Applications/System
37#Source0: http://poldek.pld-linux.org/download/snapshots/%{name}-%{version}-cvs%{snap}.tar.bz2
38Source0: https://github.com/poldek-pm/poldek/releases/download/v%{version}/%{name}-%{version}.tar.xz
39# Source0-md5: 2759fe45bc50efb6084d5338d725411a
40Source1: %{name}.conf
41Source2: %{name}-multilib.conf
42Source3: %{name}-config.sh
43Source5: %{name}-aliases.conf
44Source6: %{name}.desktop
45Source7: %{name}.png
46# Source7-md5: ee487abede50874e9eceb6495d5ee150
47Source8: %{name}-debuginfo.conf
48Source9: %{name}-aidath.conf
49Source10: %{name}-multilib-aidath.conf
50Source11: %{name}-archive.conf
51Source100: %{name}-snap.conf
52Source101: %{name}-multilib-snap.conf
53Source102: %{name}-debuginfo-snap.conf
54Patch0: %{name}-config.patch
55Patch1: pm-hooks.patch
56Patch2: %{name}-ext-down-enable.patch
57Patch3: %{name}-pc.patch
58URL: http://poldek.pld-linux.org/
59BuildRequires: %{db_pkg}-devel >= %{ver_db}
60BuildRequires: autoconf >= 2.63
61BuildRequires: automake >= 1:1.11
62BuildRequires: bzip2-devel
63BuildRequires: check-devel
64BuildRequires: docbook-dtd412-xml
65BuildRequires: gettext-tools >= 0.11.5
66BuildRequires: libgomp-devel
67BuildRequires: libtool
68BuildRequires: libxml2-devel >= 2
69BuildRequires: ncurses-devel
70BuildRequires: openssl-devel >= 0.9.7d
71BuildRequires: pcre-devel
72BuildRequires: pkgconfig
73BuildRequires: popt-devel
74%{?with_python:BuildRequires: python-devel}
75BuildRequires: readline-devel >= 5.0
76BuildRequires: rpm-devel >= %{ver_rpm}
77%{?with_python:BuildRequires: rpm-pythonprov}
78BuildRequires: tar >= 1:1.22
79BuildRequires: xmlto
80BuildRequires: xz
81BuildRequires: zlib-devel
82BuildRequires: zstd-devel
83%if %{with static}
84BuildRequires: %{db_pkg}-static >= %{ver_db}
85BuildRequires: bzip2-static
86BuildRequires: glibc-static
87BuildRequires: libxml2-static
88BuildRequires: ncurses-static
89BuildRequires: openssl-static
90BuildRequires: pcre-static
91BuildRequires: popt-static
92BuildRequires: readline-static
93BuildRequires: rpm-static
94BuildRequires: zlib-static
95BuildRequires: zstd-static
96%endif
97Requires(triggerpostun): awk
98Requires(triggerpostun): sed >= 4.0
99%if %{with rpm4}
100Requires: %{db_pkg} >= %{ver_db_devel}
101%else
102Requires: %{db_pkg} >= %{ver_db}
103Requires: rpm-db-ver = %{ver_db}
104%endif
105Requires: %{name}-libs = %{version}-%{release}
106Requires: /bin/run-parts
107Requires: rpm >= %{ver_rpm}
108Requires: rpm-lib >= %{ver_rpm}
109Requires: sed
110Conflicts: etckeeper < 1.18-2
111BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113# it could be %{_libexecdir}/%{name}, but beware of compatibility (path hardcoded in configurations)
114%define pkglibexecdir %{_prefix}/lib/%{name}
115
116%description
117poldek is an RPM package management tool which allows you to easily
118perform package verification, installation (including system
119installation from scratch), upgrading, and removal.
120
121Program can be used in batch (like apt-get from Debian's APT) or
122interactive mode. The interactive mode puts you into a readline
123interface with command line autocompletion and history, similar to the
124shell mode of Perl's CPAN.
125
126%{?with_static:This version is statically linked.}
127
128%{!?with_imode:This version hasn't got interactive mode.}
129#'vim
130
131%description -l hu.UTF-8
132poldek egy RPM csomagkezelő eszköz, amely megkönnyíti a
133csomagellenőrzést, telepítést (beleértve a rendszertelepítést a
134nulláról), frissítést és eltávolítást.
135
136A program használható parancssorból (mint a Debian apt-get programja)
137vagy interaktív módban. Az interaktív mód egy readline környezetet
138jelent, parancskiegészítéssel és előzményekkel, hasonlóan a Perl CPAN
139shell módjához.
140
141%{?with_static:Ez a verzió statikusan linkelt.}
142
143%{!?with_imode:Ennek a verziónak nincs interaktív módja.}
144
145%description -l pl.UTF-8
146poldek jest narzędziem linii poleceń służącym do weryfikacji,
147instalacji (włączając instalację systemu od zera), aktualizacji i
148usuwania pakietów.
149
150Program może być używany w trybie wsadowym (jak debianowy apt-get) lub
151interaktywnym. Tryb interaktywny posiada interfejs readline z
152dopełnianiem komend i historią, podobny do trybu shell perlowego
153modułu CPAN.
154
155%{?with_static:Ta wersja jest konsolidowana statycznie.}
156
157%{!?with_imode:Ta wersja nie posiada trybu interaktywnego.}
158
159%package libs
160Summary: poldek libraries
161Summary(hu.UTF-8): A poldek könyvtárai
162Summary(pl.UTF-8): Biblioteki poldka
163Group: Libraries
164
165%description libs
166poldek libraries.
167
168%description libs -l hu.UTF-8
169A poldek könyvtárai.
170
171%description libs -l pl.UTF-8
172Biblioteki poldka.
173
174%package devel
175Summary: Header files for poldek libraries
176Summary(hu.UTF-8): A poldek könyvtár fejlesztői fájljai
177Summary(pl.UTF-8): Pliki nagłówkowe bibliotek poldka
178Group: Development/Libraries
179Requires: %{name}-libs = %{version}-%{release}
180Requires: rpm-devel >= %{ver_rpm}
181
182%description devel
183Header files for poldek libraries.
184
185%description devel -l hu.UTF-8
186A poldek könyvtár fejlesztői fájljai.
187
188%description devel -l pl.UTF-8
189Pliki nagłówkowe bibliotek poldka.
190
191%package static
192Summary: poldek static libraries
193Summary(hu.UTF-8): poldek statikus könyvtárak
194Summary(pl.UTF-8): Biblioteki statyczne poldka
195Group: Development/Libraries
196Requires: %{name}-devel = %{version}-%{release}
197
198%description static
199poldek static libraries.
200
201%description static -l hu.UTF-8
202poldek statikus könyvtárak.
203
204%description static -l pl.UTF-8
205Biblioteki statyczne poldka.
206
207%package -n python-poldek
208Summary: Python modules for poldek
209Summary(hu.UTF-8): Python modulok poldek-hez
210Summary(pl.UTF-8): Moduły języka Python dla poldka
211Group: Libraries/Python
212Requires: %{name}-libs = %{version}-%{release}
213Requires: python-libs
214
215%description -n python-poldek
216Python modules for poldek.
217
218%description -n python-poldek -l hu.UTF-8
219Python modulok poldek-hez.
220
221%description -n python-poldek -l pl.UTF-8
222Moduły języka Python dla poldka.
223
224%prep
225%setup -q
226%patch0 -p1
227%patch1 -p1
228%patch2 -p1
229%patch3 -p1
230
231%{__rm} m4/libtool.m4 m4/lt*.m4
232
233# cleanup backups after patching
234find . '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
235chmod u+x ./configure ./doc/conf-xml2.sh
236
237%build
238%{__gettextize}
239%{__libtoolize}
240%{__aclocal} -I m4
241%{__autoheader}
242%{__autoconf}
243%{__automake}
244cd tndb
245%{__libtoolize}
246%{__aclocal}
247%{__autoheader}
248%{__autoconf}
249%{__automake}
250cd ../trurlib
251%{__libtoolize}
252%{__aclocal}
253%{__autoheader}
254%{__autoconf}
255%{__automake}
256cd ..
257
258%configure \
259 %{?with_static:--enable-static --disable-shared} \
260 %{!?with_imode:--disable-imode} \
261 --with-pkglibdir=%{pkglibexecdir} \
262 --enable-nls \
263 %{?with_python:--with-python}
264%{__make}
265
266%if %{with python}
267%{__make} -C python
268%endif
269
270%if %{with tests}
271%{__make} check
272%endif
273
274%install
275rm -rf $RPM_BUILD_ROOT
276install -d $RPM_BUILD_ROOT/var/cache/%{name}
277
278%{__make} install \
279 DESTDIR=$RPM_BUILD_ROOT
280
281install -p %{SOURCE3} $RPM_BUILD_ROOT%{_bindir}/poldek-config
282
283%if %{with python}
284%{__make} -C python install \
285 DESTDIR=$RPM_BUILD_ROOT \
286 py_sitedir=%{py_sitedir}
287%endif
288
289%{?with_static:%{__rm} $RPM_BUILD_ROOT%{_bindir}/rpmvercmp}
290
291%ifarch i486 i686 ppc sparc alpha athlon
292 %define ftp_arch %{_target_cpu}
293%endif
294%ifarch %{x8664}
295 %define ftp_arch x86_64
296 %define ftp_alt_arch i686
297 %define ftp_alt2_arch x32
298%endif
299%ifarch x32
300 %define ftp_arch x32
301 %define ftp_alt_arch x86_64
302 %define ftp_alt2_arch i686
303%endif
304%ifarch i586
305 %define ftp_arch i486
306%endif
307%ifarch pentium2 pentium3 pentium4
308 %define ftp_arch i686
309%endif
310%ifarch sparcv9 sparc64
311 %define ftp_arch sparc
312 %define ftp_arch %{_target_cpu}
313 %ifarch sparc64
314 %define ftp_alt_arch sparcv9
315 %endif
316%endif
317
318%define pld_conf %{SOURCE1}
319%define pld_debuginfo_conf %{SOURCE8}
320%define pld_archive_conf %{SOURCE11}
321
322%ifarch %{x8664} x32
323 %define pld_multilib_conf %{SOURCE2}
324 %define pld_multilib2_conf %{SOURCE2}
325%endif
326
327# aidath
328%ifarch sparcv9 sparc64
329 %define pld_conf %{SOURCE9}
330 %undefine pld_archive_conf
331%endif
332%ifarch sparc64
333 %define pld_multilib_conf %{SOURCE10}
334%endif
335
336%{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
337
338%if 0%{?pld_multilib_conf:1}
339 %{__sed} 's|%%ARCH%%|%{ftp_alt_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
340%endif
341
342%if 0%{?pld_multilib2_conf:1}
343 %{__sed} 's|%%ARCH%%|%{ftp_alt2_arch}|g' < %{pld_multilib_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt2_arch}.conf
344%endif
345
346%if 0%{?pld_debuginfo_conf:1}
347%{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_debuginfo_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-debuginfo.conf
348%endif
349
350%if 0%{?pld_archive_conf:1}
351%{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' < %{pld_archive_conf} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-archive.conf
352%endif
353
354# Always install snapshot configs
355%{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
356 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE100} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
357%{__sed} -e 's|%%ARCH%%|%{ftp_arch}|g' \
358 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE102} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-debuginfo.conf
359%ifarch %{x8664} x32
360 %{__sed} -e 's|%%ARCH%%|%{ftp_alt_arch}|g' \
361 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
362 %{__sed} -e 's|%%ARCH%%|%{ftp_alt2_arch}|g' \
363 -e 's|%%SNAP%%|%{SNAP}|g' < %{SOURCE101} > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt2_arch}.conf
364%endif
365
366%if %{with snap}
367%{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
368%{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
369%else
370%{__sed} -i -e 's|@@SNAP@@||g' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
371%{__sed} -i '/@@SNAP@@.*/d' $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld.conf
372%endif
373
374# create "all" meta repo
375%if 0%{?ftp_alt_arch:1}%{?ftp_alt2_arch:1}
376cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-all.conf
377# group source for referring th+th-multiarch sources together, i.e poldek -n th-all
378[source]
379type = group
380name = th-all
381sources = th %{?ftp_alt_arch:th-%{ftp_alt_arch}} %{?ftp_alt2_arch:th-%{ftp_alt2_arch}}
382EOF
383%endif
384
385# th-2014 snap does not exist for x32 yet
386%if "%{ftp_arch}" == "x32"
387rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}.conf
388%endif
389%if "%{ftp_alt2_arch}" == "x32"
390rm $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-x32.conf
391%endif
392
393cp -p %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/cli.conf
394
395%if %{with imode}
396# add desktop file and icon
397install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
398cp -p %{SOURCE6} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
399cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
400%endif
401
402# sources we don't package
403%{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/{rh,fedora,centos}-source.conf
404# include them in %doc
405%{__rm} -rf configs
406cp -a conf configs
407%{__rm} -f configs/Makefile*
408
409%if %{with python}
410%py_postclean
411%{__rm} $RPM_BUILD_ROOT%{_libdir}/_poldekmod.{la,so}
412%endif
413
414%find_lang %{name}
415
416%clean
417rm -rf $RPM_BUILD_ROOT
418
419%post
420[ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
421if [ "$1" = "1" ]; then
422 # remove ignore = vserver-packages inside vserver on first install
423 {
424 while read f ctx; do
425 [ "$f" = "VxID:" -o "$f" = "s_context:" ] && break
426 done </proc/self/status
427 } 2>/dev/null
428 if [ -z "$ctx" -o "$ctx" = "0" ]; then
429 VSERVER=no
430 else
431 VSERVER=yes
432 fi
433 if [ "$VSERVER" = "yes" ]; then
434 %{__sed} -i -e '/^ignore/s/vserver-packages//' %{_sysconfdir}/%{name}/poldek.conf
435 fi
436fi
437
438%postun -p /sbin/postshell
439-/usr/sbin/fix-info-dir -c %{_infodir}
440
441%post libs -p /sbin/ldconfig
442%postun libs -p /sbin/ldconfig
443
444%triggerpostun -- poldek < 0.30-0.20080225.00.1
445if ! grep -q '^%%includedir repos.d' %{_sysconfdir}/%{name}/poldek.conf; then
446 %{__sed} -i -e '/^%%include source.conf/{
447 a
448 a# /etc/poldek/repos.d/*.conf
449 a%%includedir repos.d
450 }' %{_sysconfdir}/%{name}/poldek.conf
451fi
452
453%{__sed} -i -e '/%%include %%{_distro}-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
454%{__sed} -i -e '/%%include %%{_distro}-multilib-source.conf/d' %{_sysconfdir}/%{name}/poldek.conf
455
456if [ -f %{_sysconfdir}/%{name}/pld-source.conf.rpmsave ]; then
457 %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld.conf{,.rpmnew}
458 %{__mv} -v %{_sysconfdir}/%{name}/pld-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld.conf
459fi
460
461%ifarch %{x8664}
462if [ -f %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave ]; then
463 %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf{,.rpmnew}
464 %{__mv} -v %{_sysconfdir}/%{name}/pld-multilib-source.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf
465fi
466%endif
467
468%triggerpostun -- poldek < 0.30.1-3
469if [ -f %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave ]; then
470 %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf{,.rpmnew}
471 %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{ftp_alt_arch}.conf
472fi
473if [ -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave ]; then
474 %{__mv} -f %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf{,.rpmnew}
475 %{__mv} -v %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-multilib.conf.rpmsave %{_sysconfdir}/%{name}/repos.d/pld-%{SNAP}-%{ftp_alt_arch}.conf
476fi
477
478%triggerpostun -- %{name} < 0.30.1-8
479if [ $1 -le 1 ]; then
480 # revert change on --downgrade
481 %{__sed} -i -re 's,^pm command = %{pkglibexecdir}/pm-command.sh,#&,' %{_sysconfdir}/%{name}/%{name}.conf
482else
483 # setup pm command
484 %{__sed} -i -re 's,#?(pm command =).*,\1 %{pkglibexecdir}/pm-command.sh,' %{_sysconfdir}/%{name}/%{name}.conf
485fi
486
487%files -f %{name}.lang
488%defattr(644,root,root,755)
489%doc ChangeLog README* NEWS configs
490%dir %{_sysconfdir}/%{name}
491%dir %{_sysconfdir}/%{name}/pre-install.d
492%{_sysconfdir}/%{name}/pre-install.d/README
493%dir %{_sysconfdir}/%{name}/post-install.d
494%{_sysconfdir}/%{name}/post-install.d/README
495%dir %{_sysconfdir}/%{name}/repos.d
496%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*.conf
497%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/repos.d/*.conf
498%attr(755,root,root) %{_bindir}/ipoldek
499%attr(755,root,root) %{_bindir}/poldek
500%attr(755,root,root) %{_bindir}/poldek-config
501%attr(755,root,root) %{_bindir}/rpmvercmp
502%dir %{pkglibexecdir}
503%attr(755,root,root) %{pkglibexecdir}/pm-command.sh
504%attr(755,root,root) %{pkglibexecdir}/poldekuser-setup.sh
505%attr(755,root,root) %{pkglibexecdir}/vfcompr
506%attr(755,root,root) %{pkglibexecdir}/vfjuggle
507%attr(755,root,root) %{pkglibexecdir}/vfsmb
508%attr(755,root,root) %{pkglibexecdir}/zlib-in-rpm.sh
509%{_mandir}/man1/%{name}*.1*
510%lang(pl) %{_mandir}/pl/man1/%{name}*
511%{_infodir}/poldek.info*
512%if %{with imode}
513%{_desktopdir}/%{name}.desktop
514%{_pixmapsdir}/%{name}.png
515%endif
516%dir /var/cache/%{name}
517
518%if %{without static}
519%files libs
520%defattr(644,root,root,755)
521%attr(755,root,root) %{_libdir}/libpoclidek.so.*.*.*
522%attr(755,root,root) %{_libdir}/libpoldek.so.*.*.*
523%attr(755,root,root) %{_libdir}/libtndb.so.*.*.*
524%attr(755,root,root) %{_libdir}/libtrurl.so.*.*.*
525%attr(755,root,root) %{_libdir}/libvfile.so.*.*.*
526%attr(755,root,root) %ghost %{_libdir}/libpoclidek.so.1
527%attr(755,root,root) %ghost %{_libdir}/libpoldek.so.3
528%attr(755,root,root) %ghost %{_libdir}/libtndb.so.0
529%attr(755,root,root) %ghost %{_libdir}/libtrurl.so.0
530%attr(755,root,root) %ghost %{_libdir}/libvfile.so.0
531%endif
532
533%files devel
534%defattr(644,root,root,755)
535%if %{without static}
536%attr(755,root,root) %{_libdir}/libpoclidek.so
537%attr(755,root,root) %{_libdir}/libpoldek.so
538%attr(755,root,root) %{_libdir}/libtndb.so
539%attr(755,root,root) %{_libdir}/libtrurl.so
540%attr(755,root,root) %{_libdir}/libvfile.so
541%endif
542%{_libdir}/libpoclidek.la
543%{_libdir}/libpoldek.la
544%{_libdir}/libtndb.la
545%{_libdir}/libtrurl.la
546%{_libdir}/libvfile.la
547%{_includedir}/poldek
548%{_includedir}/tndb
549%{_includedir}/trurl
550%{_includedir}/vfile
551%{_pkgconfigdir}/tndb.pc
552%{_pkgconfigdir}/trurlib.pc
553
554%files static
555%defattr(644,root,root,755)
556%{_libdir}/libtndb.a
557%{_libdir}/libtrurl.a
558
559%if %{with python}
560%files -n python-poldek
561%defattr(644,root,root,755)
562%attr(755,root,root) %{py_sitedir}/_poldekmod.so
563%{py_sitescriptdir}/poldek.py[co]
564%{py_sitescriptdir}/poldekmod.py[co]
565%endif
This page took 0.058605 seconds and 4 git commands to generate.