]> git.pld-linux.org Git - packages/poedit.git/commitdiff
- updated to 1.3.2
authorRobert Kurowski <koorek@pld-linux.org>
Wed, 2 Mar 2005 13:54:24 +0000 (13:54 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    poedit-system_libs.patch -> 1.3

poedit-system_libs.patch

index b6039015a793621e00a3455b1bcdf4843ac0c6c2..44b7466da1b11f00986dc3637f99c8cf4a284ca5 100644 (file)
@@ -1,30 +1,85 @@
---- poedit-1.2.2/src/Makefile.am.wiget Tue Apr  1 16:55:43 2003
-+++ poedit-1.2.2/src/Makefile.am       Sat May 10 12:59:01 2003
-@@ -28,8 +28,12 @@
+diff -urN poedit-1.3.2/Makefile.am fix/poedit-1.3.2/Makefile.am
+--- poedit-1.3.2/Makefile.am   2004-07-15 18:27:06.000000000 +0200
++++ fix/poedit-1.3.2/Makefile.am       2005-03-02 14:31:40.088608936 +0100
+@@ -1,4 +1,8 @@
+-SUBDIRS = extras src docs install locales
++EXTRADIR = extras
++
++SUBDIRS = $(EXTRADIR) src docs install locales
++
++DIST_SUBDIRS = extras src docs install locales
+ ACLOCAL_AMFLAGS = -I admin
+diff -urN poedit-1.3.2/Makefile.am~ fix/poedit-1.3.2/Makefile.am~
+--- poedit-1.3.2/Makefile.am~  1970-01-01 01:00:00.000000000 +0100
++++ fix/poedit-1.3.2/Makefile.am~      2004-07-15 18:27:06.000000000 +0200
+@@ -0,0 +1,4 @@
++
++SUBDIRS = extras src docs install locales
++
++ACLOCAL_AMFLAGS = -I admin
+diff -urN poedit-1.3.2/src/Makefile.am fix/poedit-1.3.2/src/Makefile.am
+--- poedit-1.3.2/src/Makefile.am       2005-01-22 12:00:09.000000000 +0100
++++ fix/poedit-1.3.2/src/Makefile.am   2005-03-02 14:35:24.658469128 +0100
+@@ -40,4 +40,12 @@
          --include-dir $(srcdir) @RC_WX_INCLUDES@ \
          --define __WIN32__ --define __WIN95__ --define __GNUWIN32__
  
+-poedit_LDADD = $(RESOURCE_FILES) $(XRC_LDADD) $(POEDIT_WX_LIBS)
 +gizmoslib=-L../extras/wx-contrib/src/gizmos -lmy_gizmos
 +expatlib=-L../extras/wx-contrib/src/xrc/expat -lmy_expat
 +xrclib=-L../extras/wx-contrib/src/xrc -lmy_xrc
 +
- poedit_LDADD = $(RESOURCE_FILES) \
--               -L../extras/wx-contrib/src/gizmos \
--               -L../extras/wx-contrib/src/xrc \
--               -L../extras/wx-contrib/src/xrc/expat \
--               -lmy_xrc -lmy_gizmos -lmy_expat $(POEDIT_WX_LIBS)
-+               $(gizmoslib) \
-+                         $(xrclib) \
-+                         $(expatlib) \
-+               $(POEDIT_WX_LIBS)
---- poedit-1.2.2/Makefile.am.wiget     Sat May 10 12:53:51 2003
-+++ poedit-1.2.2/Makefile.am   Sat May 10 13:00:30 2003
-@@ -1,3 +1,7 @@
--SUBDIRS = extras src docs install locales
-+EXTRADIR = extras
++poedit_LDADD = $(RESOURCE_FILES) \
++            $(gizmoslib) \
++                      $(xrclib) \
++                      $(expatlib) \
++            $(POEDIT_WX_LIBS)
+diff -urN poedit-1.3.2/src/Makefile.am~ fix/poedit-1.3.2/src/Makefile.am~
+--- poedit-1.3.2/src/Makefile.am~      1970-01-01 01:00:00.000000000 +0100
++++ fix/poedit-1.3.2/src/Makefile.am~  2005-01-22 12:00:09.000000000 +0100
+@@ -0,0 +1,43 @@
 +
-+SUBDIRS = $(EXTRADIR) src docs install locales
++SUBDIRS = resources
 +
-+DIST_SUBDIRS = extras src docs install locales
++RESCOMP = @RESCOMP@
++POEDIT_WX_LIBS = @POEDIT_WX_LIBS@
++
++if BUILD_XRC
++INCLUDES_XRC = -I$(top_srcdir)/extras/wx-contrib/include
++endif
++INCLUDES = $(INCLUDES_XRC)
++
++if USE_WINDOWS
++RESOURCE_FILES = poedit_resource.o
++endif
++
++if BUILD_XRC
++XRC_LDADD = -L../extras/wx-contrib/src/xrc \
++            -L../extras/wx-contrib/src/xrc/expat \
++            -lmy_xrc -lmy_expat
++endif
++
++bin_PROGRAMS = poedit
++
++poedit_SOURCES = catalog.cpp catalog.h edapp.cpp edapp.h edframe.cpp \
++                 edframe.h fileviewer.cpp fileviewer.h parser.cpp parser.h \
++                 isocodes.cpp isocodes.h prefsdlg.cpp prefsdlg.h \
++                 settingsdlg.cpp settingsdlg.h progressinfo.h \
++                 progressinfo.cpp digger.h digger.cpp gexecute.h \
++                 gexecute.cpp summarydlg.h summarydlg.cpp \
++                 findframe.cpp findframe.h commentdlg.h commentdlg.cpp \
++                 transmem.cpp transmem.h transmemupd.cpp transmemupd.h \
++                 transmemupd_wizard.cpp transmemupd_wizard.h \
++                 manager.h manager.cpp chooselang.cpp chooselang.h \
++                               export_html.cpp icons.h icons.cpp \
++                               pluralforms/pl_evaluate.cpp \
++                               editlbox/editlbox.cpp
++
++poedit_resource.o: poedit.rc
++      $(RESCOMP) -i$(srcdir)/poedit.rc -o poedit_resource.o \
++        --include-dir $(srcdir) @RC_WX_INCLUDES@ \
++        --define __WIN32__ --define __WIN95__ --define __GNUWIN32__
++
++poedit_LDADD = $(RESOURCE_FILES) $(XRC_LDADD) $(POEDIT_WX_LIBS)
This page took 1.538244 seconds and 4 git commands to generate.