]> git.pld-linux.org Git - packages/plymouth.git/commitdiff
- systemd services have been removed from systemd and moved here,
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 21 Jun 2012 11:42:59 +0000 (11:42 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
  install them as they were and restore missing ask-password

Changed files:
    plymouth.spec -> 1.29
    systemd-ask-password-plymouth.path -> 1.1
    systemd-ask-password-plymouth.service -> 1.1

plymouth.spec
systemd-ask-password-plymouth.path [new file with mode: 0644]
systemd-ask-password-plymouth.service [new file with mode: 0644]

index 9afb7b0396eeff1e5998fa4f5e052ad8a551da76..42b9d10f1cd1a46bdfc0d16809130641c8728f53 100644 (file)
@@ -1,6 +1,8 @@
 # TODO
 # - integrate with geninitrd
 # - pldize recent update (r1.18)
+# - verify if systemd services have to be installed for targets,
+#      and remove the symlinks if not
 #
 # Conditional build:
 %bcond_without drm_intel       # disable building with libdrm_intel support
@@ -24,6 +26,8 @@ Source3:      charge.%{name}
 Source4:       boot-duration
 Source5:       %{name}-set-default-plugin
 Source6:       %{name}-update-initrd
+Source7:       systemd-ask-password-plymouth.path
+Source8:       systemd-ask-password-plymouth.service
 Patch0:                text-colors.patch
 URL:           http://www.freedesktop.org/wiki/Software/Plymouth
 BuildRequires: cairo-devel
@@ -37,9 +41,10 @@ BuildRequires:       pkgconfig
 Requires:      %{name}-graphics-libs = %{version}-%{release}
 Requires(post):        %{name}-scripts = %{version}-%{release}
 Requires:      /etc/os-release
-Requires:      systemd-plymouth
+Requires:      systemd-units
 Obsoletes:     plymouth-gdm-hooks
 Obsoletes:     plymouth-utils
+Obsoletes:     systemd-plymouth
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                plymouthdaemon_execdir  /sbin
@@ -369,6 +374,7 @@ sed -i -e 's/fade-in/charge/g' src/plymouthd.defaults
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_pixmapsdir},%{systemdtmpfilesdir}}
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
@@ -402,6 +408,21 @@ install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/plymouth
 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}/plymouth-logo.png
 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
 
+cp -p %{SOURCE7} $RPM_BUILD_ROOT%{systemdunitdir}/systemd-ask-password-plymouth.path
+cp -p %{SOURCE8} $RPM_BUILD_ROOT%{systemdunitdir}/systemd-ask-password-plymouth.service
+
+# install plymouth services for targets
+# http://cgit.freedesktop.org/systemd/systemd/commit/?id=26cbf29c52a36b6ad9d1ccc16d8f7adccefeddca
+install -d $RPM_BUILD_ROOT%{systemdunitdir}/{halt,kexec,poweroff,reboot,sysinit,multi-user}.target.wants
+ln -sf ../plymouth-start.service $RPM_BUILD_ROOT%{systemdunitdir}/sysinit.target.wants/plymouth-start.service
+ln -sf ../plymouth-read-write.service $RPM_BUILD_ROOT%{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
+ln -sf ../plymouth-quit.service $RPM_BUILD_ROOT%{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
+ln -sf ../plymouth-quit-wait.service $RPM_BUILD_ROOT%{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
+ln -sf ../plymouth-reboot.service $RPM_BUILD_ROOT%{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
+ln -sf ../plymouth-kexec.service $RPM_BUILD_ROOT%{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
+ln -sf ../plymouth-poweroff.service $RPM_BUILD_ROOT%{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
+ln -sf ../plymouth-halt.service $RPM_BUILD_ROOT%{systemdunitdir}/halt.target.wants/plymouth-halt.service
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -442,15 +463,25 @@ fi
 %ghost %{_localstatedir}/lib/plymouth/boot-duration
 %{_localstatedir}/run/plymouth
 %{_localstatedir}/spool/plymouth
-# currently packaged in systemd-plymouth
-#%{systemdunitdir}/plymouth-halt.service
-#%{systemdunitdir}/plymouth-kexec.service
-#%{systemdunitdir}/plymouth-poweroff.service
-#%{systemdunitdir}/plymouth-quit-wait.service
-#%{systemdunitdir}/plymouth-quit.service
-#%{systemdunitdir}/plymouth-read-write.service
-#%{systemdunitdir}/plymouth-reboot.service
-#%{systemdunitdir}/plymouth-start.service
+
+%{systemdunitdir}/plymouth-halt.service
+%{systemdunitdir}/plymouth-kexec.service
+%{systemdunitdir}/plymouth-poweroff.service
+%{systemdunitdir}/plymouth-quit-wait.service
+%{systemdunitdir}/plymouth-quit.service
+%{systemdunitdir}/plymouth-read-write.service
+%{systemdunitdir}/plymouth-reboot.service
+%{systemdunitdir}/plymouth-start.service
+%{systemdunitdir}/systemd-ask-password-plymouth.path
+%{systemdunitdir}/systemd-ask-password-plymouth.service
+%{systemdunitdir}/halt.target.wants/plymouth-halt.service
+%{systemdunitdir}/kexec.target.wants/plymouth-kexec.service
+%{systemdunitdir}/multi-user.target.wants/plymouth-quit.service
+%{systemdunitdir}/multi-user.target.wants/plymouth-quit-wait.service
+%{systemdunitdir}/poweroff.target.wants/plymouth-poweroff.service
+%{systemdunitdir}/reboot.target.wants/plymouth-reboot.service
+%{systemdunitdir}/sysinit.target.wants/plymouth-read-write.service
+%{systemdunitdir}/sysinit.target.wants/plymouth-start.service
 
 %files core-libs
 %defattr(644,root,root,755)
diff --git a/systemd-ask-password-plymouth.path b/systemd-ask-password-plymouth.path
new file mode 100644 (file)
index 0000000..9320b4a
--- /dev/null
@@ -0,0 +1,20 @@
+#  This file is part of systemd.
+#
+#  systemd is free software; you can redistribute it and/or modify it
+#  under the terms of the GNU Lesser General Public License as published by
+#  the Free Software Foundation; either version 2.1 of the License, or
+#  (at your option) any later version.
+
+[Unit]
+Description=Forward Password Requests to Plymouth Directory Watch
+Documentation=http://www.freedesktop.org/wiki/Software/systemd/PasswordAgents
+DefaultDependencies=no
+Conflicts=shutdown.target
+After=plymouth-start.service
+Before=basic.target shutdown.target
+ConditionKernelCommandLine=!plymouth.enable=0
+ConditionPathExists=/run/plymouth/pid
+
+[Path]
+DirectoryNotEmpty=/run/systemd/ask-password
+MakeDirectory=yes
diff --git a/systemd-ask-password-plymouth.service b/systemd-ask-password-plymouth.service
new file mode 100644 (file)
index 0000000..7a9eb07
--- /dev/null
@@ -0,0 +1,19 @@
+#  This file is part of systemd.
+#
+#  systemd is free software; you can redistribute it and/or modify it
+#  under the terms of the GNU Lesser General Public License as published by
+#  the Free Software Foundation; either version 2.1 of the License, or
+#  (at your option) any later version.
+
+[Unit]
+Description=Forward Password Requests to Plymouth
+Documentation=http://www.freedesktop.org/wiki/Software/systemd/PasswordAgents
+DefaultDependencies=no
+Conflicts=shutdown.target
+After=plymouth-start.service
+Before=shutdown.target
+ConditionKernelCommandLine=!plymouth.enable=0
+ConditionPathExists=/run/plymouth/pid
+
+[Service]
+ExecStart=/bin/systemd-tty-ask-password-agent --watch --plymouth
This page took 0.35567 seconds and 4 git commands to generate.