]> git.pld-linux.org Git - packages/plymouth.git/blob - plymouth.spec
- exec .so
[packages/plymouth.git] / plymouth.spec
1 # TODO
2 # - revisit subpackages
3 # - fix: Requires: /bin/bash
4 # - integrate with geninitrd
5 Summary:        Graphical Boot Animation and Logger
6 Name:           plymouth
7 Version:        0.8.3
8 Release:        0.2
9 License:        GPL v2+
10 Group:          Base
11 Source0:        http://www.freedesktop.org/software/plymouth/releases/%{name}-%{version}.tar.bz2
12 # Source0-md5:  a479180467b21dd1c5477160d5a1fd35
13 Source1:        %{name}-logo.png
14 # Source1-md5:  6b38a868585adfd3a96a4ad16973c1f8
15 #Patch0:                libdrm.patch
16 URL:            http://www.freedesktop.org/wiki/Software/Plymouth
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  cairo-devel
20 BuildRequires:  gtk+2-devel
21 BuildRequires:  libdrm-devel
22 BuildRequires:  libpng-devel
23 BuildRequires:  libtool
24 BuildRequires:  pango-devel >= 1:1.21.0
25 BuildRequires:  pkgconfig
26 Requires(post): %{name}-scripts = %{version}-%{release}
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %define         plymouthdaemon_execdir  /sbin
30 %define         plymouthclient_execdir  /bin
31 %define         plymouth_libdir                 /%{_lib}
32
33 %description
34 Plymouth provides an attractive graphical boot animation in place of
35 the text messages that normally get shown. Text messages are instead
36 redirected to a log file for viewing after boot.
37
38 %package libs
39 Summary:        Plymouth libraries
40 Group:          Development/Libraries
41
42 %description libs
43 This package contains the libply and libplybootsplash libraries used
44 by Plymouth.
45
46 %package devel
47 Summary:        Libraries and headers for writing Plymouth splash plugins
48 Group:          Development/Libraries
49 Requires:       %{name} = %{version}-%{release}
50 Requires:       pkgconfig
51
52 %description devel
53 This package contains the libply and libplybootsplash libraries and
54 headers needed to develop 3rd party splash plugins for Plymouth.
55
56 %package utils
57 Summary:        Plymouth related utilities
58 Group:          Applications/System
59 Requires:       %{name} = %{version}-%{release}
60
61 %description utils
62 This package contains utilities that integrate with Plymouth including
63 a boot log viewing application.
64
65 %package scripts
66 Summary:        Plymouth related scripts
67 Group:          Applications/System
68
69 %description scripts
70 This package contains scripts that help integrate Plymouth with the
71 system.
72
73 %package gdm-hooks
74 Summary:        Plymouth GDM integration
75 Group:          Applications/System
76 Requires:       %{name} = %{version}-%{release}
77 Requires:       gdm >= 1:2.22.0
78 Requires:       plymouth-utils
79
80 %description gdm-hooks
81 This package contains support files for integrating Plymouth with GDM
82 Namely, it adds hooks to show boot messages at the login screen in the
83 event start-up services fail.
84
85 %prep
86 %setup -q
87 #%patch0 -p1
88
89 %build
90 %{__libtoolize}
91 %{__aclocal}
92 %{__autoconf}
93 %{__automake}
94 %configure \
95         --enable-tracing \
96         --disable-tests \
97         --without-boot-entry \
98         --with-logo=%{_pixmapsdir}/plymouth-logo.png \
99         --with-background-start-color-stop=0x0073B3 \
100         --with-background-end-color-stop=0x00457E \
101         --with-background-color=0x3391cd \
102         --enable-gdm-transition \
103         --with-system-root-install
104
105 %{__make}
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 find $RPM_BUILD_ROOT -name '*.a' -exec rm -f {} \;
114 find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
115
116 # Temporary symlink until rc.sysinit is fixed
117 (cd $RPM_BUILD_ROOT%{_bindir}; ln -s ../../bin/plymouth)
118
119 install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/plymouth
120 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
121 install %SOURCE1 $RPM_BUILD_ROOT%{_pixmapsdir}/plymouth-logo.png
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %postun
127 if [ $1 -eq 0 ]; then
128         rm -f %{_libdir}/plymouth/default.so
129 fi
130
131 %post libs -p /sbin/ldconfig
132 %postun libs -p /sbin/ldconfig
133
134 %files
135 %defattr(644,root,root,755)
136 %doc AUTHORS NEWS README
137 %attr(755,root,root) %{_bindir}/rhgb-client
138 %attr(755,root,root) %{_sbindir}/plymouth-set-default-theme
139 %dir %{_sysconfdir}/plymouth
140 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/plymouth/plymouthd.conf
141 %{_mandir}/man8/plymouth.8*
142 %dir %{_datadir}/plymouth
143 %{_datadir}/plymouth/plymouthd.defaults
144 %{_datadir}/plymouth/themes
145 %dir %{_libexecdir}/plymouth
146 %dir %{_localstatedir}/lib/plymouth
147 %attr(755,root,root) %{plymouthdaemon_execdir}/plymouthd
148 %attr(755,root,root) %{plymouthclient_execdir}/plymouth
149 %attr(755,root,root) %{_bindir}/plymouth
150 %attr(755,root,root) %{_libdir}/plymouth/details.so
151 %attr(755,root,root) %{_libdir}/plymouth/fade-throbber.so
152 %attr(755,root,root) %{_libdir}/plymouth/label.so
153 %attr(755,root,root) %{_libdir}/plymouth/script.so
154 %attr(755,root,root) %{_libdir}/plymouth/space-flares.so
155 %attr(755,root,root) %{_libdir}/plymouth/text.so
156 %attr(755,root,root) %{_libdir}/plymouth/throbgress.so
157 %attr(755,root,root) %{_libdir}/plymouth/two-step.so
158 %{_localstatedir}/run/plymouth
159 %{_localstatedir}/spool/plymouth
160 %{_pixmapsdir}/plymouth-logo.png
161
162 %files devel
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{plymouth_libdir}/libply.so
165 %attr(755,root,root) %{plymouth_libdir}/libply-splash-core.so
166 %attr(755,root,root) %{_libdir}/libply-boot-client.so
167 %attr(755,root,root) %{_libdir}/libply-splash-graphics.so
168 %{_pkgconfigdir}/ply-boot-client.pc
169 %{_pkgconfigdir}/ply-splash-core.pc
170 %{_pkgconfigdir}/ply-splash-graphics.pc
171 %{_includedir}/plymouth-1
172
173 %files libs
174 %defattr(644,root,root,755)
175 %attr(755,root,root) %{plymouth_libdir}/libply.so.*.*.*
176 %attr(755,root,root) %ghost %{plymouth_libdir}/libply.so.2
177 %attr(755,root,root) %{plymouth_libdir}/libply-splash-core.so.*.*.*
178 %attr(755,root,root) %ghost %{plymouth_libdir}/libply-splash-core.so.2
179 %attr(755,root,root) %{_libdir}/libply-boot-client.so.*.*.*
180 %attr(755,root,root) %ghost %{_libdir}/libply-boot-client.so.2
181 %attr(755,root,root) %{_libdir}/libply-splash-graphics.so.*.*.*
182 %attr(755,root,root) %ghost %{_libdir}/libply-splash-graphics.so.2
183 %dir %{_libdir}/plymouth
184 %dir %{_libdir}/plymouth/renderers
185 %attr(755,root,root) %{_libdir}/plymouth/renderers/drm.so
186 %attr(755,root,root) %{_libdir}/plymouth/renderers/frame-buffer.so
187 %attr(755,root,root) %{_libdir}/plymouth/renderers/x11.so
188
189 %files scripts
190 %defattr(644,root,root,755)
191 %attr(755,root,root) %{_libexecdir}/plymouth/plymouth-generate-initrd
192 %attr(755,root,root) %{_libexecdir}/plymouth/plymouth-populate-initrd
193 %attr(755,root,root) %{_libexecdir}/plymouth/plymouth-update-initrd
194
195 %files utils
196 %defattr(644,root,root,755)
197 %attr(755,root,root) %{_bindir}/plymouth-log-viewer
198
199 %files gdm-hooks
200 %defattr(644,root,root,755)
201 %{_datadir}/gdm/autostart/LoginWindow/plymouth-log-viewer.desktop
This page took 0.123799 seconds and 3 git commands to generate.