]> git.pld-linux.org Git - packages/pilot-link.git/commitdiff
- added hack to setting convert charset
authortiwek <tiwek@pld-linux.org>
Thu, 28 Oct 2004 14:24:04 +0000 (14:24 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- export PILOTCHARSET=

Changed files:
    pilot-link-setcharset.patch -> 1.1
    pilot-link.spec -> 1.67

pilot-link-setcharset.patch [new file with mode: 0644]
pilot-link.spec

diff --git a/pilot-link-setcharset.patch b/pilot-link-setcharset.patch
new file mode 100644 (file)
index 0000000..927e9db
--- /dev/null
@@ -0,0 +1,43 @@
+--- pilot-link-0.11.3-back/libpisock/util.c    Tue Jul 30 19:37:13 2002
++++ pilot-link-0.11.3/libpisock/util.c Fri Aug 16 10:26:34 2002
+@@ -32,7 +32,7 @@
+ #include <iconv.h>
+ #endif
+-#define PILOT_CHARSET "CP1252"
++#define DEFAULT_PILOT_CHARSET "CP1252"
+ /***********************************************************************
+  *
+@@ -55,8 +55,14 @@
+               *ob;
+       iconv_t cd;
+       size_t  ibl, obl;
++      char *charset_env;
++
++      charset_env = getenv("PILOTCHARSET");
++      if (charset_env)
++          cd = iconv_open(charset_env, charset);
++      if (!charset_env || !cd)
++          cd = iconv_open(DEFAULT_PILOT_CHARSET, charset);
+-      cd = iconv_open(PILOT_CHARSET, charset);
+       if (!cd)
+               return -1;
+@@ -98,8 +104,14 @@
+               *ob;
+       iconv_t cd;
+       size_t  ibl, obl;
++      char *charset_env;
++
++      charset_env = getenv("PILOTCHARSET");
++      if (charset_env)
++          cd = iconv_open(charset_env, charset);
++      if (!charset_env || !cd)
++      cd = iconv_open(DEFAULT_PILOT_CHARSET, charset);
+-      cd = iconv_open(charset, PILOT_CHARSET);
+       if (!cd)
+               return -1;
index 9c877061394c695acef6f660bc4f10d3aeb791d3..b9e44bcecbf7a013ae9c5522956acfbd7235fda7 100644 (file)
@@ -6,7 +6,7 @@ Summary(ru):    
 Summary(uk):   õÔÉ̦ÔÁ ÐÅÒÅÓÉÌËÉ ÆÁÊ̦נͦ֠Linux ÔÁ PalmPilot
 Name:          pilot-link
 Version:       0.11.8
-Release:       4
+Release:       5
 License:       GPL
 Group:         Applications/Communications
 Source0:       http://www.pilot-link.org/source/%{name}-%{version}.tar.bz2
@@ -15,6 +15,7 @@ Patch0:               %{name}-tcl_m4.patch
 Patch1:                %{name}-link.patch
 Patch2:                %{name}-am18.patch
 Patch3:                %{name}-iconv-in-glibc.patch
+Patch4:                %{name}-setcharset.patch
 URL:           http://www.pilot-link.org/
 BuildRequires: XFree86-devel
 BuildRequires: autoconf
@@ -142,6 +143,7 @@ PalmPilot.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__libtoolize}
This page took 0.153032 seconds and 4 git commands to generate.