]> git.pld-linux.org Git - packages/pidgin.git/blob - pidgin.spec
- moved to proper branch
[packages/pidgin.git] / pidgin.spec
1 # This file does not like to be adapterized!
2 Summary:        A client compatible with AOL's 'Instant Messenger'
3 Summary(pl):    Klient kompatybilny z AOL Instant Messenger
4 Summary(pt_BR): Um cliente para o AOL Instant Messenger (AIM)
5 Name:           gaim
6 Version:        0.59.5
7 Release:        2
8 Epoch:          1
9 License:        GPL
10 Group:          Applications/Communications
11 Source0:        http://belnet.dl.sourceforge.net/sourceforge/gaim/%{name}-%{version}.tar.bz2
12 Patch0:         %{name}-gg_logoff.patch
13 Patch1:         %{name}-am_ac.patch
14 Patch2:         %{name}-tw.patch
15 URL:            http://gaim.sourceforge.net/
16 BuildRequires:  ORBit-devel
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  gnome-libs-devel >= 1.2.13
20 BuildRequires:  esound-devel
21 BuildRequires:  gtk+-devel >= 1.2.5
22 BuildRequires:  gettext-devel
23 BuildRequires:  libtool
24 BuildRequires:  perl-devel
25 BuildRequires:  gnome-core-devel
26 BuildRequires:  gdk-pixbuf-devel
27 Requires:       applnk
28 Requires:       gaim-ui = %{version}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _prefix         /usr/X11R6
32 %define         _sysconfdir     /etc/X11/GNOME
33 %define         _mandir         %{_prefix}/man
34
35 %description
36 Gaim allows you to talk to anyone using AOL's Instant Messenger
37 service (you can sign up at http://www.aim.aol.com). It uses the TOC
38 version of the AOL protocol, so your buddy list is stored on AOL's
39 servers and can be retrieved from anywhere. It contains many of the
40 same features as AOL's IM client while at the same time incorporating
41 many new features. Gaim also contains a multiple connection feature
42 which consists of protocol plugins. These plugins allow you to use
43 gaim to connect to other chat services such as Yahoo!, ICQ, MSN,
44 Jabber, Napster, Zephyr, IRC and Gadu-Gadu.
45
46 %description -l pl
47 Gaim pozwala na rozmowy z dowoln± osob± u¿ywaj±c± us³ugi AOL Instant
48 Messenger (mo¿na siê zarejstrowaæ pod adresem
49 http://www.aim.aol.com/). Program u¿ywa wersji TOC protoko³u AOL wiêc
50 Twoja lista kontaktów jest zapisana na serwerze AOL i mo¿e byc
51 przes³ana gdziekolwiek. Gaim zawiera wiele udogodnieñ dostêpnych w
52 kliencie AOL IM jak równie¿ dodaje w³asne. Gaim umo¿liwia tak¿e dostêp
53 do us³ug takich jak Yahoo!, ICQ, MSN, Jabber, Napster, Zephyr, IRC
54 oraz Gadu-Gadu.
55
56 %description -l pt_BR
57 GAIM é um cliente para o AOL Instant Messenger (AIM) que usa o serviço
58 tik/toc da AOL. É desenvolvido ativamente e suporta muitas das
59 características do cliente da AOL, tendo uma interface similiar.
60 Também oferece suporte a outros protocolos, como: ICQ, IRC, Yahoo!,
61 MSN, Jabber e Napster.
62
63 %package ui-gtk
64 Summary:        gtk+ user interface for gaim
65 Summary(pl):    Interfejs u¿ytkownika gaim korzystaj±cy z gtk+
66 Group:          Applications/Communications
67 Provides:       gaim-ui = %{version}-%{release}
68
69 %description ui-gtk
70 gtk+ user interface for gaim.
71
72 %description ui-gtk -l pl
73 Interfejs u¿ytkownika gaim korzystaj±cy z gtk+.
74
75 %package ui-gnome
76 Summary:        GNOME user interface for gaim (applet)
77 Summary(pl):    Interfejs u¿ytkownika gaim korzystaj±cy z GNOME (applet)
78 Group:          Applications/Communications
79 Provides:       gaim-ui = %{version}-%{release}
80
81 %description ui-gnome
82 GNOME user interface for gaim (applet).
83
84 %description ui-gnome -l pl
85 Interfejs u¿ytkownika gaim korzystaj±cy z GNOME (applet).
86
87 %prep
88 %setup -qn %{name}-%{version}
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92
93 %build
94 rm -f missing
95 %{__libtoolize}
96 %{__gettextize} --intl
97 if [ -f po/Makevars.template ]; then
98         cp po/Makevars.template po/Makevars
99 fi
100 %{__aclocal} -I m4
101 %{__autoheader}
102 %{__autoconf}
103 %{__automake}
104 %configure \
105         --disable-panel \
106         --enable-esd \
107         --disable-nas \
108         --disable-artsc \
109         --disable-gnome \
110         --with-gtk-prefix=/usr/X11R6 \
111         --with-gdk-pixbuf-config=/usr/X11R6/bin/gdk-pixbuf-config 
112 %{__make} 
113 mv plugins/iconaway{,_standalone}.so
114 mv src/gaim{,_standalone}
115 %{__make} clean
116
117 %configure \
118         --enable-panel \
119         --enable-esd \
120         --disable-nas \
121         --disable-artsc \
122         --enable-gnome \
123         --with-gtk-prefix=/usr/X11R6 \
124         --with-gdk-pixbuf-config=/usr/X11R6/bin/gdk-pixbuf-config 
125 %{__make}
126         
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 # NOTE: make ignores gaimdesktopdir set below.
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT \
133         gaimdesktopdir=%{_applnkdir}/Network/Communications \
134         distribdesktopdir=%{_applnkdir}/Network/Communications
135
136 mv $RPM_BUILD_ROOT{%{_datadir}/gnome/apps/Internet/gaim.desktop,%{_applnkdir}/Network/Communications}
137
138 mv $RPM_BUILD_ROOT%{_libdir}/gaim/iconaway{,_applet}.so
139 install plugins/iconaway_standalone.so $RPM_BUILD_ROOT%{_libdir}/gaim/iconaway.so
140 install src/gaim_standalone $RPM_BUILD_ROOT%{_bindir}/gaim
141
142 gzip -9nf AUTHORS ChangeLog NEWS README* TODO HACKING \
143         doc/{CREDITS,FAQ}
144
145 %find_lang %{name} --with-gnome --all-name
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %files -f %{name}.lang
151 %defattr(644,root,root,755)
152 %doc {*,doc/*}.gz
153 %dir %{_libdir}/gaim
154 %attr(755,root,root) %{_libdir}/gaim/[^i]*.so
155 %{_pixmapsdir}/*
156 %{_mandir}/man?/*
157
158 %files ui-gtk
159 %defattr(644,root,root,755)
160 %attr(755,root,root) %{_bindir}/gaim
161 %attr(755,root,root) %{_libdir}/gaim/iconaway.so
162 %{_applnkdir}/Network/Communications/gaim.desktop
163
164 %files ui-gnome
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_bindir}/gaim_applet
167 %attr(755,root,root) %{_libdir}/gaim/iconaway_applet.so
168 %{_applnkdir}/Network/Communications/gaim_applet.desktop
169 %{_sysconfdir}/CORBA/servers/*
This page took 0.102702 seconds and 3 git commands to generate.