]> git.pld-linux.org Git - packages/pidgin.git/blob - pidgin.spec
fixed a small typo
[packages/pidgin.git] / pidgin.spec
1 # This file does not like to be adapterized!
2 Summary:        A client compatible with AOL's 'Instant Messenger'
3 Summary(pl):    Klient kompatybilny z AOL Instant Messenger
4 Summary(pt_BR): Um cliente para o AOL Instant Messenger (AIM)
5 Name:           gaim
6 Version:        0.56
7 Release:        0.1
8 Epoch:          1
9 License:        GPL
10 Group:          Applications/Communications
11 Source0:        http://prdownloads.sourceforge.net/gaim/%{name}-%{version}.tar.bz2
12 Patch0:         %{name}-gg_logoff.patch
13 Patch1:         %{name}-AC_LIBOBJ.patch
14 Patch2:         %{name}-am_ac.patch
15 URL:            http://gaim.sourceforge.net/
16 BuildRequires:  ORBit-devel
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 BuildRequires:  gnome-libs-devel >= 1.2.13
20 BuildRequires:  esound-devel
21 BuildRequires:  gtk+-devel >= 1.2.5
22 BuildRequires:  gettext-devel
23 BuildRequires:  libtool
24 BuildRequires:  perl-devel
25 BuildRequires:  gnome-core-devel
26 BuildRequires:  gdk-pixbuf-devel
27 Requires:       applnk
28 Requires:       gaim-ui
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _prefix         /usr/X11R6
32 %define         _sysconfdir     /etc/X11/GNOME
33 %define         _mandir         %{_prefix}/man
34
35 %description
36 Gaim allows you to talk to anyone using AOL's Instant Messenger
37 service (you can sign up at http://www.aim.aol.com). It uses the TOC
38 version of the AOL protocol, so your buddy list is stored on AOL's
39 servers and can be retrieved from anywhere. It contains many of the
40 same features as AOL's IM client while at the same time incorporating
41 many new features. Gaim also contains a multiple connection feature
42 which consists of protocol plugins. These plugins allow you to use
43 gaim to connect to other chat services such as Yahoo!, ICQ, MSN,
44 Jabber, Napster, Zephyr, IRC and Gadu-Gadu.
45
46 %description -l pl
47 Gaim pozwala na rozmowy z dowoln± osob± u¿ywaj±c± us³ugi AOL Instant
48 Messenger (mo¿na siê zarejstrowaæ pod adresem
49 http://www.aim.aol.com/). Program u¿ywa wersji TOC protoko³u AOL wiêc
50 Twoja lista kontaktów jest zapisana na serwerze AOL i mo¿e byc
51 przes³ana gdziekolwiek. Gaim zawiera wiele udogodnieñ dostêpnych w
52 kliencie AOL IM jak równie¿ dodaje w³asne. Gaim umo¿liwia tak¿e dostêp
53 do us³ug takich jak Yahoo!, ICQ, MSN, Jabber, Napster, Zephyr, IRC
54 oraz Gadu-Gadu.
55
56 %description -l pt_BR
57 GAIM é um cliente para o AOL Instant Messenger (AIM) que usa o serviço
58 tik/toc da AOL. É desenvolvido ativamente e suporta muitas das
59 características do cliente da AOL, tendo uma interface similiar.
60 Também oferece suporte a outros protocolos, como: ICQ, IRC, Yahoo!,
61 MSN, Jabber e Napster.
62
63 %package ui-gtk
64 Summary:        gtk+ user interface for gaim
65 Summary(pl):    Interfejs u¿ytkownika gaim korzystaj±cy z gtk+
66 Group:          Applications/Communications
67 Provides:       gaim-ui
68
69 %description ui-gtk
70 gtk+ user interface for gaim.
71
72 %description ui-gtk -l pl
73 Interfejs u¿ytkownika gaim korzystaj±cy z gtk+.
74
75 %package ui-gnome
76 Summary:        GNOME user interface for gaim (applet)
77 Summary(pl):    Interfejs u¿ytkownika gaim korzystaj±cy z GNOME (applet)
78 Group:          Applications/Communications
79 Provides:       gaim-ui
80
81 %description ui-gnome
82 GNOME user interface for gaim (applet).
83
84 %description ui-gnome -l pl
85 Interfejs u¿ytkownika gaim korzystaj±cy z GNOME (applet).
86
87 %prep
88 %setup -q
89 %patch0 -p1
90 %patch1 -p1
91 %patch2 -p1
92
93 %build
94 rm -f missing
95 rm -f configure.in
96 libtoolize --copy --force
97 gettextize --copy --force
98 aclocal -I m4
99 autoheader
100 autoconf
101 automake -a -c -f
102 %configure \
103         --disable-panel \
104         --enable-esd \
105         --disable-nas \
106         --disable-artsc \
107         --disable-gnome \
108         --with-gtk-prefix=/usr/X11R6 \
109         --with-gdk-pixbuf-config=/usr/X11R6/bin/gdk-pixbuf-config 
110 %{__make} 
111 mv plugins/iconaway{,_standalone}.so
112 mv src/gaim{,_standalone}
113 %{__make} clean
114
115 %configure \
116         --enable-panel \
117         --enable-esd \
118         --disable-nas \
119         --disable-artsc \
120         --enable-gnome \
121         --with-gtk-prefix=/usr/X11R6 \
122         --with-gdk-pixbuf-config=/usr/X11R6/bin/gdk-pixbuf-config 
123 %{__make}
124         
125 %install
126 rm -rf $RPM_BUILD_ROOT
127
128 # NOTE: make ignores gaimdesktopdir set below.
129 %{__make} install \
130         DESTDIR=$RPM_BUILD_ROOT \
131         gaimdesktopdir=%{_applnkdir}/Network/Communications \
132         distribdesktopdir=%{_applnkdir}/Network/Communications
133
134 mv $RPM_BUILD_ROOT{%{_datadir}/gnome/apps/Internet/gaim.desktop,%{_applnkdir}/Network/Communications}
135
136 mv $RPM_BUILD_ROOT%{_libdir}/gaim/iconaway{,_applet}.so
137 install plugins/iconaway_standalone.so $RPM_BUILD_ROOT%{_libdir}/gaim/iconaway.so
138 install src/gaim_standalone $RPM_BUILD_ROOT%{_bindir}/gaim
139
140 gzip -9nf AUTHORS ChangeLog NEWS README* TODO HACKING \
141         doc/{CREDITS,FAQ}
142
143 %find_lang %{name} --with-gnome --all-name
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %files -f %{name}.lang
149 %defattr(644,root,root,755)
150 %doc {*,doc/*}.gz
151 %dir %{_libdir}/gaim
152 %attr(755,root,root) %{_libdir}/gaim/[^i]*.so
153 %{_pixmapsdir}/*
154 %{_mandir}/man?/*
155
156 %files ui-gtk
157 %defattr(644,root,root,755)
158 %attr(755,root,root) %{_bindir}/gaim
159 %attr(755,root,root) %{_libdir}/gaim/iconaway.so
160 %{_applnkdir}/Network/Communications/gaim.desktop
161
162 %files ui-gnome
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/gaim_applet
165 %attr(755,root,root) %{_libdir}/gaim/iconaway_applet.so
166 %{_applnkdir}/Network/Communications/gaim_applet.desktop
167 %{_sysconfdir}/CORBA/servers/*
This page took 0.077296 seconds and 3 git commands to generate.