]> git.pld-linux.org Git - packages/picard.git/blob - picard.spec
updated build directory name
[packages/picard.git] / picard.spec
1 Summary:        Picard, the Next-Generation MusicBrainz Tagger
2 Summary(pl.UTF-8):      Picard - znaczniki MusicBrainz nowej generacji
3 Name:           picard
4 Version:        1.3.1
5 Release:        0.1
6 License:        GPL v2+
7 Group:          Applications
8 Source0:        ftp://ftp.musicbrainz.org/pub/musicbrainz/picard/%{name}-%{version}.tar.gz
9 # Source0-md5:  2c155a0c4a5589c18bac3016365d7fbd
10 Patch0:         %{name}-desktop.patch
11 URL:            http://musicbrainz.org/doc/PicardTagger
12 BuildRequires:  ffmpeg-devel
13 BuildRequires:  gettext-tools
14 BuildRequires:  libofa-devel
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  pkgconfig
17 BuildRequires:  python-devel >= 1:2.5
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.219
20 Requires(post,postun):  gtk-update-icon-cache
21 Requires(post,postun):  hicolor-icon-theme
22 Requires:       python-PyQt4
23 Requires:       python-musicbrainz2
24 Requires:       python-mutagen
25 Requires:       python-tunepimp
26 Requires:       python-wxPython
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 The project code-named Picard is the next generation MusicBrainz
31 tagging application. This new tagging concept is Release oriented, as
32 opposed to track oriented like the ClassicTagger was. Picard is
33 written in Python, which is a cross-platform language - this allows
34 the same code to run both on Windows and on Linux. Before too long we
35 will add Mac OS X support as well.
36
37 %description -l pl.UTF-8
38 Projekt o nazwie Picard jest programem nowej generacji do generowania
39 znaczników MusicBranz. Picard jest napisany w Pythonie, który jest
40 językiem cross-platform - co pozwala uruchamiać ten sam kod zarówno
41 pod Windows jak i Linuksem. Niedługo zostanie dodana obsługa Mac OS X.
42
43 %prep
44 %setup -q -n %{name}-release-%{version}
45 %patch0 -p1
46
47 find -type f | xargs sed -i -e 's|#!.*python.*|#!%{_bindir}/python|g'
48
49 %build
50 %{__python} setup.py config
51 %{__python} setup.py build
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
56
57 %{__python} setup.py install \
58         --optimize=2 \
59         --root=$RPM_BUILD_ROOT
60
61 %py_postclean
62 %find_lang %{name}
63
64 %post
65 %update_icon_cache hicolor
66
67 %postun
68 %update_icon_cache hicolor
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files -f %{name}.lang
74 %defattr(644,root,root,755)
75 %doc AUTHORS.txt NEWS.txt
76 %attr(755,root,root) %{_bindir}/%{name}
77 %{py_sitedir}/picard
78 %{py_sitedir}/%{name}-%{version}-py*.egg-info
79 %{_desktopdir}/%{name}.desktop
80 %{_iconsdir}/hicolor/*/apps/picard.png
This page took 0.077546 seconds and 3 git commands to generate.