]> git.pld-linux.org Git - packages/phpPgAdmin.git/commitdiff
- upgraded to 5.0-beta2
authorTomasz Pala <gotar@pld-linux.org>
Fri, 1 Oct 2010 23:49:39 +0000 (23:49 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    phpPgAdmin-calendar.patch -> 1.3
    phpPgAdmin-config.patch -> 1.6
    phpPgAdmin.spec -> 1.81

phpPgAdmin-calendar.patch
phpPgAdmin-config.patch
phpPgAdmin.spec

index 6fbbba3e49ddb48ad6270f57ac3b7f5b7934e031..bde4ab1a79f984eaac997c778c2d54f5374afeee 100644 (file)
@@ -1,7 +1,7 @@
 diff -ur phpPgAdmin-4.2.2.orig/classes/database/Postgres.php phpPgAdmin-4.2.2/classes/database/Postgres.php
 --- phpPgAdmin-4.2.2.orig/classes/database/Postgres.php        2008-12-18 06:28:57.000000000 +0100
 +++ phpPgAdmin-4.2.2/classes/database/Postgres.php     2010-09-30 01:01:41.000000000 +0200
-@@ -303,6 +303,14 @@ class Postgres extends ADODB_base {
+@@ -302,6 +302,14 @@ class Postgres extends ADODB_base {
                                echo htmlspecialchars($value);
                                echo "</textarea>\n";
                                break;
@@ -14,12 +14,12 @@ diff -ur phpPgAdmin-4.2.2.orig/classes/database/Postgres.php phpPgAdmin-4.2.2/cl
 +                              echo "<script type=\"text/javascript\">Calendar.setup( { inputField: \"", htmlspecialchars($name), "\", button: \"trigger", htmlspecialchars($name), "\", showsTime: $showsTime, ifFormat: \"%Y-%m-%d$timeFormat\" }); </script>";
 +                              break;
                        default:
-                               echo "<input name=\"", htmlspecialchars($name), "\" value=\"", htmlspecialchars($value), "\" size=\"35\"{$action_str} {$extra} />\n";
+                               echo "<input name=\"", htmlspecialchars($name), "\" value=\"", htmlspecialchars($value), "\" size=\"35\"{$extra_str} />\n";
                                break;
 diff -ur phpPgAdmin-4.2.2.orig/classes/Misc.php phpPgAdmin-4.2.2/classes/Misc.php
 --- phpPgAdmin-4.2.2.orig/classes/Misc.php     2008-12-18 06:28:57.000000000 +0100
 +++ phpPgAdmin-4.2.2/classes/Misc.php  2009-04-13 17:22:01.000000000 +0200
-@@ -374,6 +374,12 @@
+@@ -395,6 +395,12 @@
                                echo "<meta http-equiv=\"Content-Type\" content=\"text/html; charset={$lang['appcharset']}\" />\n";
                                // Theme
                                echo "<link rel=\"stylesheet\" href=\"themes/{$conf['theme']}/global.css\" type=\"text/css\" />\n";
@@ -34,25 +34,28 @@ diff -ur phpPgAdmin-4.2.2.orig/classes/Misc.php phpPgAdmin-4.2.2/classes/Misc.ph
                                echo "<title>", htmlspecialchars($appName);
 diff -ur phpPgAdmin-4.2.2.orig/display.php phpPgAdmin-4.2.2/display.php
 --- phpPgAdmin-4.2.2.orig/display.php  2008-12-18 06:28:57.000000000 +0100
-+++ phpPgAdmin-4.2.2/display.php       2009-03-01 14:15:00.000000000 +0100
-@@ -73,6 +73,7 @@
++++ phpPgAdmin-4.2.2/display.php       2010-10-02 01:41:27.000000000 +0200
+@@ -61,6 +61,7 @@
                                echo "<th class=\"data\">{$lang['strnull']}</th><th class=\"data\">{$lang['strvalue']}</th></tr>";
  
                                $i = 0;
 +                              $shift=0;
                                while (!$attrs->EOF) {
-                                       $szValueName = "values[{$attrs->fields['attname']}]";
-                                       $szEvents = '';
-@@ -127,11 +128,12 @@
+                                       $attrs->fields['attnotnull'] = $data->phpBool($attrs->fields['attnotnull']);
+@@ -106,7 +107,7 @@
+                                       // keep track of which element offset we're up to.  We can't refer to the null checkbox by name
                                        // as it contains '[' and ']' characters.
                                        if (!$attrs->fields['attnotnull']) {
-                                               echo $data->printField($szValueName, $rs->fields[$attrs->fields['attname']], $attrs->fields['type'], 
--                                                                                                      array('onChange' => 'elements[' . ($elements - 1) . '].checked = false;'),$szEvents) . $szDivPH;
-+                                                                                                      array('onChange' => 'elements[' . ($elements - 1 + $shift) . '].checked = false;'),$szEvents) . $szDivPH;
-                                       }
-                                       else {
-                                               echo $data->printField($szValueName, $rs->fields[$attrs->fields['attname']], $attrs->fields['type'],array(),$szEvents) . $szDivPH;
+-                                              $extras['onChange'] = 'elements[' . ($elements - 1) . '].checked = false;';
++                                              $extras['onChange'] = 'elements[' . ($elements - 1 + $shift) . '].checked = false;';
                                        }
+                                       if (($fksprops !== false) && isset($fksprops['byfield'][$attrs->fields['attnum']])) {
+@@ -116,6 +117,7 @@
+                                       echo $data->printField("values[{$attrs->fields['attnum']}]", $rs->fields[$attrs->fields['attname']], $attrs->fields['type'], $extras);
 +                                      if (in_array(substr($attrs->fields['type'],0,9),array('date','timestamp'))) $shift++;
                                        echo "</td>";
                                        $elements++;
index ca857990f89c43167ea121570b4bee23e834367c..222230da748e89d857f54b5457a579884d02228f 100644 (file)
@@ -1,6 +1,6 @@
 --- phpPgAdmin-4.0.1/libraries/lib.inc.php~    2005-12-02 17:19:47.000000000 +0200
 +++ phpPgAdmin-4.0.1/libraries/lib.inc.php     2005-12-02 17:24:01.259851274 +0200
-@@ -26,12 +26,12 @@
+@@ -27,12 +27,12 @@
                exit(sprintf('Version of PHP not supported. Please upgrade to version %s or later.', $phpMinVer));
  
        // Check to see if the configuration file exists, if not, explain
  
 --- phpPgAdmin-4.0.1/libraries/lib.inc.php     2005-12-02 17:38:56.000000000 +0200
 +++ phpPgAdmin-4.0.1-org/libraries/lib.inc.php 2005-12-02 17:37:20.000000000 +0200
-@@ -9,7 +9,7 @@
+@@ -10,7 +10,7 @@
        include_once('./lang/translations.php');
-       
        // Set error reporting level to max
 -      error_reporting(E_ALL);
 +      error_reporting(E_ALL & ~E_NOTICE);
-       ini_set('display_errors', 'on');
-       // Application name 
-
+  
+       // Application name
+       $appName = 'phpPgAdmin';
index 67d47849355618ebe86c46ad5fabb4e60e063b3b..00f3e5d17dc0c05b1800a5e1dbe02de9d8e7f0dc 100644 (file)
@@ -8,8 +8,8 @@ Version:        5.0
 Release:       0.2
 License:       GPL v2+
 Group:         Applications/Databases/Interfaces
-Source0:       http://dl.sourceforge.net/phppgadmin/%{name}-%{version}-beta1.tar.bz2
-# Source0-md5: 7d026386eb3320be583f3710f3482eda
+Source0:       http://dl.sourceforge.net/phppgadmin/%{name}-%{version}-beta2.tar.bz2
+# Source0-md5: 739247e0334a44ea4ee2c1754b7b1119
 Source1:       %{name}-apache.conf
 Source2:       %{name}-lighttpd.conf
 Source3:       http://www.quarto.pl/~gotar/%{name}-jscalendar.tar.bz2
@@ -47,7 +47,7 @@ podstawowe możliwości, jak i część bardziej zaawansowanych jak
 przełączniki, widoki i funkcje (procedury składowane).
 
 %prep
-%setup -q -a3 -n %{name}-%{version}-beta1
+%setup -q -a3 -n %{name}-%{version}-beta2
 %patch0 -p1
 #%patch1 -p1
 %patch2 -p1
This page took 0.094364 seconds and 4 git commands to generate.