]> git.pld-linux.org Git - packages/phpMyAdmin.git/blob - phpMyAdmin.spec
- codepress todo
[packages/phpMyAdmin.git] / phpMyAdmin.spec
1 # TODO
2 # - add codepress (http://codepress.org/index.php) patch
3 Summary:        phpMyAdmin - web-based MySQL administration
4 Summary(pl.UTF-8):      phpMyAdmin - administracja bazami MySQL przez WWW
5 Name:           phpMyAdmin
6 Version:        2.11.6
7 Release:        2
8 License:        GPL v2
9 Group:          Applications/Databases/Interfaces
10 Source0:        http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.bz2
11 # Source0-md5:  0477a97e80e12c97fef671365db910a5
12 Source1:        %{name}.conf
13 Source2:        %{name}-lighttpd.conf
14 Patch0:         %{name}-config.patch
15 URL:            http://www.phpmyadmin.net/
16 BuildRequires:  rpmbuild(macros) >= 1.268
17 Requires(triggerpostun):        sed >= 4.0
18 Requires:       php(ctype)
19 Requires:       php(mcrypt)
20 Requires:       php(mbstring)
21 Requires:       php(mysql)
22 Requires:       php(pcre)
23 Requires:       webapps
24 Requires:       webserver(access)
25 Requires:       webserver(alias)
26 Requires:       webserver(php)
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %define         _appdir         %{_datadir}/%{name}
31 %define         _webapps        /etc/webapps
32 %define         _webapp         %{name}
33 %define         _sysconfdir     %{_webapps}/%{_webapp}
34
35 %description
36 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
37 but also a single database. To accomplish the latter you'll need a
38 properly set up MySQL-user who can read/write only the desired
39 database. It's up to you to look up the appropiate part in the MySQL
40 manual. Currently phpMyAdmin can:
41 - create and drop databases
42 - create, copy, drop and alter tables
43 - delete, edit and add fields
44 - execute any SQL-statement, even batch-queries
45 - manage keys on fields
46 - load text files into tables
47 - create (*) and read dumps of tables
48 - export (*) and import data to CSV values
49 - administer multiple servers and single databases
50 - check referencial integrity
51 - create complex queries automatically connecting required tables
52 - create PDF graphics of your database layout
53 - communicate in more than 50 different languages
54
55 %description -l pl.UTF-8
56 phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
57 uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
58 Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
59 baz, którymi chcemy administrować (więcej informacji w odpowiedniej
60 podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
61 - tworzyć i usuwać bazy
62 - wykonywać create, copy, drop oraz alter na tabelach
63 - dodawać, usuwać i modyfikować pola
64 - wykonywać dowolne zapytania SQL
65 - zarządzać kluczami na rekordach
66 - wczytywać tekst z plików do tabel
67 - obsługiwać ponad 20 języków
68 - zarządzać wieloma serwerami i pojedynczymi bazami danych
69 - eksportować i importować dane do wartości CSV
70 - tworzyć i czytać zrzuty tabel
71
72 %prep
73 %setup -q -n %{name}-%{version}-all-languages
74 %patch0 -p1
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/{js,lang,libraries/{auth,dbg,dbi,engines,export,tcpdf/font,import,transformations}}}
79
80 install *.php *.html *.css $RPM_BUILD_ROOT%{_appdir}
81 install lang/*.php $RPM_BUILD_ROOT%{_appdir}/lang
82 cp -rf pmd $RPM_BUILD_ROOT%{_appdir}
83 cp -rf themes $RPM_BUILD_ROOT%{_appdir}
84 install js/* $RPM_BUILD_ROOT%{_appdir}/js
85 install libraries/*.php $RPM_BUILD_ROOT%{_appdir}/libraries
86 install libraries/auth/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/auth
87 install libraries/dbg/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbg
88 install libraries/dbi/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbi
89 install libraries/engines/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/engines
90 install libraries/export/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/export
91 install libraries/import/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/import
92 install libraries/tcpdf/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf
93 install libraries/tcpdf/font/*.{php,z} $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf/font
94 install libraries/transformations/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/transformations
95
96 install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
97 ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
98
99 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
100 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
101 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
102
103 cp -f libraries/tcpdf/README{,-tcpdf}
104 cp -f libraries/import/README{,-import}
105 cp -f libraries/transformations/README{,-transformations}
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %triggerin -- apache1 < 1.3.37-3, apache1-base
111 %webapp_register apache %{_webapp}
112
113 %triggerun -- apache1 < 1.3.37-3, apache1-base
114 %webapp_unregister apache %{_webapp}
115
116 %triggerin -- apache < 2.2.0, apache-base
117 %webapp_register httpd %{_webapp}
118
119 %triggerun -- apache < 2.2.0, apache-base
120 %webapp_unregister httpd %{_webapp}
121
122 %triggerin -- lighttpd
123 %webapp_register lighttpd %{_webapp}
124
125 %triggerun -- lighttpd
126 %webapp_unregister lighttpd %{_webapp}
127
128 %files
129 %defattr(644,root,root,755)
130 %doc Documentation.* CREDITS ChangeLog INSTALL README TODO translators.html scripts libraries/tcpdf/README-tcpdf libraries/import/README-import libraries/transformations/README-transformations libraries/transformations/TEMPLATE* libraries/transformations/*.sh lang/*.sh
131 %dir %attr(750,root,http) %{_sysconfdir}
132 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
133 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
134 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
135 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
136 %dir %{_appdir}
137 %{_appdir}/js
138 %{_appdir}/lang
139 %{_appdir}/libraries
140 %{_appdir}/pmd
141 %{_appdir}/themes
142 %{_appdir}/*.css
143 %{_appdir}/*.html
144 %{_appdir}/*.php
This page took 0.033317 seconds and 4 git commands to generate.