]> git.pld-linux.org Git - packages/phpMyAdmin.git/blob - phpMyAdmin.spec
- ServerSelectDisplayName
[packages/phpMyAdmin.git] / phpMyAdmin.spec
1 # TODO
2 # - add codepress (http://codepress.org/index.php) patch
3 Summary:        phpMyAdmin - web-based MySQL administration
4 Summary(pl.UTF-8):      phpMyAdmin - administracja bazami MySQL przez WWW
5 Name:           phpMyAdmin
6 Version:        2.11.8.1
7 Release:        2
8 License:        GPL v2
9 Group:          Applications/Databases/Interfaces
10 Source0:        http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.bz2
11 # Source0-md5:  d45c5467228876b44ff8e60cce4b487a
12 Source1:        %{name}.conf
13 Source2:        %{name}-lighttpd.conf
14 Patch0:         %{name}-config.patch
15 Patch1:         %{name}-ServerSelectDisplayName.patch
16 Patch2:         %{name}-ServerSelectDisplayName-config.patch
17 URL:            http://www.phpmyadmin.net/
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires(triggerpostun):        sed >= 4.0
20 Requires:       php(ctype)
21 Requires:       php(mbstring)
22 Requires:       php(mcrypt)
23 Requires:       php(mysql)
24 Requires:       php(pcre)
25 Requires:       webapps
26 Requires:       webserver(access)
27 Requires:       webserver(alias)
28 Requires:       webserver(php)
29 Suggests:       webserver(indexfile)
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %define         _appdir         %{_datadir}/%{name}
34 %define         _webapps        /etc/webapps
35 %define         _webapp         %{name}
36 %define         _sysconfdir     %{_webapps}/%{_webapp}
37
38 %description
39 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
40 but also a single database. To accomplish the latter you'll need a
41 properly set up MySQL-user who can read/write only the desired
42 database. It's up to you to look up the appropiate part in the MySQL
43 manual. Currently phpMyAdmin can:
44 - create and drop databases
45 - create, copy, drop and alter tables
46 - delete, edit and add fields
47 - execute any SQL-statement, even batch-queries
48 - manage keys on fields
49 - load text files into tables
50 - create (*) and read dumps of tables
51 - export (*) and import data to CSV values
52 - administer multiple servers and single databases
53 - check referencial integrity
54 - create complex queries automatically connecting required tables
55 - create PDF graphics of your database layout
56 - communicate in more than 50 different languages
57
58 %description -l pl.UTF-8
59 phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
60 uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
61 Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
62 baz, którymi chcemy administrować (więcej informacji w odpowiedniej
63 podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
64 - tworzyć i usuwać bazy
65 - wykonywać create, copy, drop oraz alter na tabelach
66 - dodawać, usuwać i modyfikować pola
67 - wykonywać dowolne zapytania SQL
68 - zarządzać kluczami na rekordach
69 - wczytywać tekst z plików do tabel
70 - obsługiwać ponad 20 języków
71 - zarządzać wieloma serwerami i pojedynczymi bazami danych
72 - eksportować i importować dane do wartości CSV
73 - tworzyć i czytać zrzuty tabel
74
75 %prep
76 %setup -q -n %{name}-%{version}-all-languages
77 %patch0 -p1
78 %patch1 -p0
79 %patch2 -p0
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/{js,lang,libraries/{auth,dbg,dbi,engines,export,tcpdf/font,import,transformations}}}
84
85 install *.php *.html *.css $RPM_BUILD_ROOT%{_appdir}
86 install lang/*.php $RPM_BUILD_ROOT%{_appdir}/lang
87 cp -rf pmd $RPM_BUILD_ROOT%{_appdir}
88 cp -rf themes $RPM_BUILD_ROOT%{_appdir}
89 install js/* $RPM_BUILD_ROOT%{_appdir}/js
90 install libraries/*.php $RPM_BUILD_ROOT%{_appdir}/libraries
91 install libraries/auth/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/auth
92 install libraries/dbg/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbg
93 install libraries/dbi/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbi
94 install libraries/engines/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/engines
95 install libraries/export/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/export
96 install libraries/import/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/import
97 install libraries/tcpdf/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf
98 install libraries/tcpdf/font/*.{php,z} $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf/font
99 install libraries/transformations/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/transformations
100
101 install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
102 ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
103
104 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
105 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
106 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
107
108 cp -f libraries/tcpdf/README{,-tcpdf}
109 cp -f libraries/import/README{,-import}
110 cp -f libraries/transformations/README{,-transformations}
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %triggerin -- apache1 < 1.3.37-3, apache1-base
116 %webapp_register apache %{_webapp}
117
118 %triggerun -- apache1 < 1.3.37-3, apache1-base
119 %webapp_unregister apache %{_webapp}
120
121 %triggerin -- apache < 2.2.0, apache-base
122 %webapp_register httpd %{_webapp}
123
124 %triggerun -- apache < 2.2.0, apache-base
125 %webapp_unregister httpd %{_webapp}
126
127 %triggerin -- lighttpd
128 %webapp_register lighttpd %{_webapp}
129
130 %triggerun -- lighttpd
131 %webapp_unregister lighttpd %{_webapp}
132
133 %files
134 %defattr(644,root,root,755)
135 %doc Documentation.* CREDITS ChangeLog INSTALL README TODO translators.html scripts libraries/tcpdf/README-tcpdf libraries/import/README-import libraries/transformations/README-transformations libraries/transformations/TEMPLATE* libraries/transformations/*.sh lang/*.sh
136 %dir %attr(750,root,http) %{_sysconfdir}
137 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
138 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
139 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
140 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
141 %dir %{_appdir}
142 %{_appdir}/js
143 %{_appdir}/lang
144 %{_appdir}/libraries
145 %{_appdir}/pmd
146 %{_appdir}/themes
147 %{_appdir}/*.css
148 %{_appdir}/*.html
149 %{_appdir}/*.php
This page took 0.164289 seconds and 4 git commands to generate.