]> git.pld-linux.org Git - packages/phpMyAdmin.git/blob - phpMyAdmin.spec
- added S: webserver(indexfile)
[packages/phpMyAdmin.git] / phpMyAdmin.spec
1 # TODO
2 # - add codepress (http://codepress.org/index.php) patch
3 Summary:        phpMyAdmin - web-based MySQL administration
4 Summary(pl.UTF-8):      phpMyAdmin - administracja bazami MySQL przez WWW
5 Name:           phpMyAdmin
6 Version:        2.11.6
7 Release:        3
8 License:        GPL v2
9 Group:          Applications/Databases/Interfaces
10 Source0:        http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.bz2
11 # Source0-md5:  0477a97e80e12c97fef671365db910a5
12 Source1:        %{name}.conf
13 Source2:        %{name}-lighttpd.conf
14 Patch0:         %{name}-config.patch
15 URL:            http://www.phpmyadmin.net/
16 BuildRequires:  rpmbuild(macros) >= 1.268
17 Requires(triggerpostun):        sed >= 4.0
18 Requires:       php(ctype)
19 Requires:       php(mbstring)
20 Requires:       php(mcrypt)
21 Requires:       php(mysql)
22 Requires:       php(pcre)
23 Requires:       webapps
24 Requires:       webserver(access)
25 Requires:       webserver(alias)
26 Requires:       webserver(php)
27 Suggests:       webserver(indexfile)
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %define         _appdir         %{_datadir}/%{name}
32 %define         _webapps        /etc/webapps
33 %define         _webapp         %{name}
34 %define         _sysconfdir     %{_webapps}/%{_webapp}
35
36 %description
37 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
38 but also a single database. To accomplish the latter you'll need a
39 properly set up MySQL-user who can read/write only the desired
40 database. It's up to you to look up the appropiate part in the MySQL
41 manual. Currently phpMyAdmin can:
42 - create and drop databases
43 - create, copy, drop and alter tables
44 - delete, edit and add fields
45 - execute any SQL-statement, even batch-queries
46 - manage keys on fields
47 - load text files into tables
48 - create (*) and read dumps of tables
49 - export (*) and import data to CSV values
50 - administer multiple servers and single databases
51 - check referencial integrity
52 - create complex queries automatically connecting required tables
53 - create PDF graphics of your database layout
54 - communicate in more than 50 different languages
55
56 %description -l pl.UTF-8
57 phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
58 uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
59 Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
60 baz, którymi chcemy administrować (więcej informacji w odpowiedniej
61 podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
62 - tworzyć i usuwać bazy
63 - wykonywać create, copy, drop oraz alter na tabelach
64 - dodawać, usuwać i modyfikować pola
65 - wykonywać dowolne zapytania SQL
66 - zarządzać kluczami na rekordach
67 - wczytywać tekst z plików do tabel
68 - obsługiwać ponad 20 języków
69 - zarządzać wieloma serwerami i pojedynczymi bazami danych
70 - eksportować i importować dane do wartości CSV
71 - tworzyć i czytać zrzuty tabel
72
73 %prep
74 %setup -q -n %{name}-%{version}-all-languages
75 %patch0 -p1
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/{js,lang,libraries/{auth,dbg,dbi,engines,export,tcpdf/font,import,transformations}}}
80
81 install *.php *.html *.css $RPM_BUILD_ROOT%{_appdir}
82 install lang/*.php $RPM_BUILD_ROOT%{_appdir}/lang
83 cp -rf pmd $RPM_BUILD_ROOT%{_appdir}
84 cp -rf themes $RPM_BUILD_ROOT%{_appdir}
85 install js/* $RPM_BUILD_ROOT%{_appdir}/js
86 install libraries/*.php $RPM_BUILD_ROOT%{_appdir}/libraries
87 install libraries/auth/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/auth
88 install libraries/dbg/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbg
89 install libraries/dbi/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbi
90 install libraries/engines/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/engines
91 install libraries/export/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/export
92 install libraries/import/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/import
93 install libraries/tcpdf/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf
94 install libraries/tcpdf/font/*.{php,z} $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf/font
95 install libraries/transformations/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/transformations
96
97 install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
98 ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
99
100 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
101 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
102 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
103
104 cp -f libraries/tcpdf/README{,-tcpdf}
105 cp -f libraries/import/README{,-import}
106 cp -f libraries/transformations/README{,-transformations}
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %triggerin -- apache1 < 1.3.37-3, apache1-base
112 %webapp_register apache %{_webapp}
113
114 %triggerun -- apache1 < 1.3.37-3, apache1-base
115 %webapp_unregister apache %{_webapp}
116
117 %triggerin -- apache < 2.2.0, apache-base
118 %webapp_register httpd %{_webapp}
119
120 %triggerun -- apache < 2.2.0, apache-base
121 %webapp_unregister httpd %{_webapp}
122
123 %triggerin -- lighttpd
124 %webapp_register lighttpd %{_webapp}
125
126 %triggerun -- lighttpd
127 %webapp_unregister lighttpd %{_webapp}
128
129 %post
130 if [ "$1" = 1 ]; then
131 %banner -e %{name} <<EOF
132 To access phpMyAdmin type in a web browser following url:
133 http://localhost/myadmin/index.php
134 If you have installed webserver(indexfile) you can use shorter version:
135 http://localhost/myadmin
136 EOF
137 fi
138
139 %files
140 %defattr(644,root,root,755)
141 %doc Documentation.* CREDITS ChangeLog INSTALL README TODO translators.html scripts libraries/tcpdf/README-tcpdf libraries/import/README-import libraries/transformations/README-transformations libraries/transformations/TEMPLATE* libraries/transformations/*.sh lang/*.sh
142 %dir %attr(750,root,http) %{_sysconfdir}
143 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
144 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
145 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
146 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
147 %dir %{_appdir}
148 %{_appdir}/js
149 %{_appdir}/lang
150 %{_appdir}/libraries
151 %{_appdir}/pmd
152 %{_appdir}/themes
153 %{_appdir}/*.css
154 %{_appdir}/*.html
155 %{_appdir}/*.php
This page took 0.353479 seconds and 4 git commands to generate.