]> git.pld-linux.org Git - packages/phpMyAdmin.git/blob - phpMyAdmin.spec
e18ef2d9e538a06f2a2196473d829c62be25a826
[packages/phpMyAdmin.git] / phpMyAdmin.spec
1 # TODO
2 # - add codepress (http://codepress.org/index.php) patch
3 # - use system jquery (js/jquery), tcpdf (libraries/tcpdf) and php-gettext (libraries/gettext)
4 Summary:        phpMyAdmin - web-based MySQL administration
5 Summary(pl.UTF-8):      phpMyAdmin - administracja bazami MySQL przez WWW
6 Name:           phpMyAdmin
7 Version:        3.5.2
8 Release:        1
9 License:        GPL v2
10 Group:          Applications/Databases/Interfaces
11 Source0:        http://downloads.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.bz2
12 # Source0-md5:  1e56ff858ed10dcd4affd4df1e92daff
13 Source1:        %{name}.conf
14 Source2:        %{name}-lighttpd.conf
15 Patch0:         %{name}-config.patch
16 Patch1:         %{name}-ServerSelectDisplayName.patch
17 Patch2:         %{name}-ServerSelectDisplayName-config.patch
18 URL:            http://www.phpmyadmin.net/
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 Requires(triggerpostun):        sed >= 4.0
21 Requires:       php-common >= 4:5.2
22 Requires:       php-ctype
23 Requires:       php-filter
24 Requires:       php-json
25 Requires:       php-mbstring
26 Requires:       php-mcrypt
27 Requires:       php-mysql
28 Requires:       php-pcre
29 Requires:       php-session
30 Requires:       php-simplexml
31 Requires:       webapps
32 Requires:       webserver(access)
33 Requires:       webserver(alias)
34 Suggests:       php-mysqli
35 Suggests:       webserver(indexfile)
36 Suggests:       webserver(php)
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _appdir         %{_datadir}/%{name}
41 %define         _webapps        /etc/webapps
42 %define         _webapp         %{name}
43 %define         _sysconfdir     %{_webapps}/%{_webapp}
44
45 %description
46 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
47 but also a single database. To accomplish the latter you'll need a
48 properly set up MySQL-user who can read/write only the desired
49 database. It's up to you to look up the appropiate part in the MySQL
50 manual. Currently phpMyAdmin can:
51 - create and drop databases
52 - create, copy, drop and alter tables
53 - delete, edit and add fields
54 - execute any SQL-statement, even batch-queries
55 - manage keys on fields
56 - load text files into tables
57 - create (*) and read dumps of tables
58 - export (*) and import data to CSV values
59 - administer multiple servers and single databases
60 - check referencial integrity
61 - create complex queries automatically connecting required tables
62 - create PDF graphics of your database layout
63 - communicate in more than 50 different languages
64
65 %description -l pl.UTF-8
66 phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
67 uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
68 Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
69 baz, którymi chcemy administrować (więcej informacji w odpowiedniej
70 podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
71 - tworzyć i usuwać bazy
72 - wykonywać create, copy, drop oraz alter na tabelach
73 - dodawać, usuwać i modyfikować pola
74 - wykonywać dowolne zapytania SQL
75 - zarządzać kluczami na rekordach
76 - wczytywać tekst z plików do tabel
77 - obsługiwać ponad 20 języków
78 - zarządzać wieloma serwerami i pojedynczymi bazami danych
79 - eksportować i importować dane do wartości CSV
80 - tworzyć i czytać zrzuty tabel
81
82 %prep
83 %setup -q -n %{name}-%{version}-all-languages
84 %patch0 -p1
85 %patch1 -p0
86 %patch2 -p0
87
88 %install
89 rm -rf $RPM_BUILD_ROOT
90 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
91
92 install *.php *.html *.css robots.txt $RPM_BUILD_ROOT%{_appdir}
93 cp -a locale themes js libraries $RPM_BUILD_ROOT%{_appdir}
94
95 install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
96 ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
97
98 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
99 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
100 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
101
102 cp -f libraries/import/README{,-import}
103 cp -f libraries/transformations/README{,-transformations}
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %triggerin -- apache1 < 1.3.37-3, apache1-base
109 %webapp_register apache %{_webapp}
110
111 %triggerun -- apache1 < 1.3.37-3, apache1-base
112 %webapp_unregister apache %{_webapp}
113
114 %triggerin -- apache < 2.2.0, apache-base
115 %webapp_register httpd %{_webapp}
116
117 %triggerun -- apache < 2.2.0, apache-base
118 %webapp_unregister httpd %{_webapp}
119
120 %triggerin -- lighttpd
121 %webapp_register lighttpd %{_webapp}
122
123 %triggerun -- lighttpd
124 %webapp_unregister lighttpd %{_webapp}
125
126 %files
127 %defattr(644,root,root,755)
128 %doc Documentation.* ChangeLog README README.VENDOR libraries/import/README-import libraries/transformations/README-transformations libraries/transformations/TEMPLATE* libraries/transformations/*.sh
129 %dir %attr(750,root,http) %{_sysconfdir}
130 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
131 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
132 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
133 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
134 %dir %{_appdir}
135 %{_appdir}/js
136 %{_appdir}/libraries
137 %{_appdir}/locale
138 %{_appdir}/themes
139 %{_appdir}/*.css
140 %{_appdir}/*.html
141 %{_appdir}/*.php
142 %{_appdir}/robots.txt
This page took 0.056224 seconds and 3 git commands to generate.