]> git.pld-linux.org Git - packages/phpMyAdmin.git/blob - phpMyAdmin.spec
- updated to 4.8.5 (solves CVE-2019-6798, CVE-2019-6799)
[packages/phpMyAdmin.git] / phpMyAdmin.spec
1 # TODO
2 # - add codepress (http://codepress.org/index.php) patch
3 # - use system jquery (js/jquery), tcpdf (libraries/tcpdf) and php-gettext (libraries/gettext)
4 Summary:        phpMyAdmin - web-based MySQL administration
5 Summary(pl.UTF-8):      phpMyAdmin - administracja bazami MySQL przez WWW
6 Name:           phpMyAdmin
7 Version:        4.8.5
8 Release:        1
9 License:        GPL v2
10 Group:          Applications/Databases/Interfaces
11 Source0:        https://files.phpmyadmin.net/phpMyAdmin/%{version}/%{name}-%{version}-all-languages.tar.xz
12 # Source0-md5:  e3737a28fff076003e56a83fe1920d04
13 Source1:        apache.conf
14 Source2:        %{name}-lighttpd.conf
15 Patch0:         %{name}-config.patch
16 Patch1:         %{name}-ServerSelectDisplayName.patch
17 Patch2:         %{name}-ServerSelectDisplayName-config.patch
18 URL:            http://www.phpmyadmin.net/
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 BuildRequires:  tar >= 1:1.22
21 BuildRequires:  xz
22 # phpMyAdmin doesn't support mysql < 5.5 and won't work with php < 5.3
23 Requires:       mysql-libs >= 5.5
24 Requires:       php(core) >= 5.3
25 Requires:       php(ctype)
26 Requires:       php(filter)
27 Requires:       php(json)
28 Requires:       php(mbstring)
29 Requires:       php(mcrypt)
30 Requires:       php(mysql)
31 Requires:       php(pcre)
32 Requires:       php(session)
33 Requires:       php(simplexml)
34 Requires:       webapps
35 Requires:       webserver(access)
36 Requires:       webserver(alias)
37 Requires(triggerpostun):        sed >= 4.0
38 Suggests:       php(mysqli)
39 Suggests:       webserver(indexfile)
40 Suggests:       webserver(php)
41 BuildArch:      noarch
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         _appdir         %{_datadir}/%{name}
45 %define         _webapps        /etc/webapps
46 %define         _webapp         %{name}
47 %define         _sysconfdir     %{_webapps}/%{_webapp}
48
49 %description
50 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
51 but also a single database. To accomplish the latter you'll need a
52 properly set up MySQL-user who can read/write only the desired
53 database. It's up to you to look up the appropiate part in the MySQL
54 manual. Currently phpMyAdmin can:
55 - create and drop databases
56 - create, copy, drop and alter tables
57 - delete, edit and add fields
58 - execute any SQL-statement, even batch-queries
59 - manage keys on fields
60 - load text files into tables
61 - create and read dumps of tables
62 - export and import data to CSV values
63 - administer multiple servers and single databases
64 - check referencial integrity
65 - create complex queries automatically connecting required tables
66 - create PDF graphics of your database layout
67 - communicate in more than 72 different languages
68
69 %description -l pl.UTF-8
70 phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
71 uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
72 Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
73 baz, którymi chcemy administrować (więcej informacji w odpowiedniej
74 podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
75 - tworzyć i usuwać bazy
76 - wykonywać create, copy, drop oraz alter na tabelach
77 - dodawać, usuwać i modyfikować pola
78 - wykonywać dowolne zapytania SQL
79 - zarządzać kluczami na rekordach
80 - wczytywać tekst z plików do tabel
81 - obsługiwać ponad 72 języków
82 - zarządzać wieloma serwerami i pojedynczymi bazami danych
83 - eksportować i importować dane do wartości CSV
84 - tworzyć i czytać zrzuty tabel
85
86 %prep
87 %setup -q -n %{name}-%{version}-all-languages
88 %patch0 -p1
89 %patch1 -p1
90 %patch2 -p0
91
92 # cleanup backups after patching
93 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
94
95 %{__rm} .editorconfig .eslintignore .eslintrc.json composer.json composer.lock package.json phpcs.xml.dist yarn.lock
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
100
101 cp -a . $RPM_BUILD_ROOT%{_appdir}
102
103 cp -p libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
104 ln -s %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
105
106 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
107 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
108 cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
109
110 # packaged as doc
111 %{__rm} $RPM_BUILD_ROOT%{_appdir}/{CONTRIBUTING.md,ChangeLog,DCO,LICENSE,README,RELEASE-DATE-*,CODE_OF_CONDUCT.md}
112 # cleanup not packaged stuff
113 %{__rm} -r $RPM_BUILD_ROOT%{_appdir}/{doc,examples,setup,sql}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %triggerin -- apache1 < 1.3.37-3, apache1-base
119 %webapp_register apache %{_webapp}
120
121 %triggerun -- apache1 < 1.3.37-3, apache1-base
122 %webapp_unregister apache %{_webapp}
123
124 %triggerin -- apache < 2.2.0, apache-base
125 %webapp_register httpd %{_webapp}
126
127 %triggerun -- apache < 2.2.0, apache-base
128 %webapp_unregister httpd %{_webapp}
129
130 %triggerin -- lighttpd
131 %webapp_register lighttpd %{_webapp}
132
133 %triggerun -- lighttpd
134 %webapp_unregister lighttpd %{_webapp}
135
136 %files
137 %defattr(644,root,root,755)
138 %doc CONTRIBUTING.md ChangeLog DCO LICENSE README examples/
139 %dir %attr(750,root,http) %{_sysconfdir}
140 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
141 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
142 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
143 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
144 %dir %{_appdir}
145 %{_appdir}/*.css
146 %{_appdir}/*.php
147 %{_appdir}/favicon.ico
148 %{_appdir}/js
149 %{_appdir}/libraries
150 %{_appdir}/locale
151 %{_appdir}/robots.txt
152 %{_appdir}/themes
153 %{_appdir}/templates
154 %{_appdir}/vendor
This page took 0.0435990000000001 seconds and 3 git commands to generate.