]> git.pld-linux.org Git - packages/phpMyAdmin.git/blob - phpMyAdmin.spec
- updated to 4.1.4
[packages/phpMyAdmin.git] / phpMyAdmin.spec
1 # TODO
2 # - add codepress (http://codepress.org/index.php) patch
3 # - use system jquery (js/jquery), tcpdf (libraries/tcpdf) and php-gettext (libraries/gettext)
4 Summary:        phpMyAdmin - web-based MySQL administration
5 Summary(pl.UTF-8):      phpMyAdmin - administracja bazami MySQL przez WWW
6 Name:           phpMyAdmin
7 Version:        4.1.4
8 Release:        1
9 License:        GPL v2
10 Group:          Applications/Databases/Interfaces
11 Source0:        http://downloads.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.xz
12 # Source0-md5:  9802ba0a7ee6afd8941dc8d0af589913
13 Source1:        %{name}-apache.conf
14 Source2:        %{name}-lighttpd.conf
15 Source3:        %{name}-httpd.conf
16 Patch0:         %{name}-config.patch
17 Patch1:         %{name}-ServerSelectDisplayName.patch
18 Patch2:         %{name}-ServerSelectDisplayName-config.patch
19 URL:            http://www.phpmyadmin.net/
20 BuildRequires:  rpmbuild(macros) >= 1.268
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 # phpMyAdmin doesn't support mysql < 5.5 and won't work with php < 5.3
24 Requires:       mysql-libs >= 5.5
25 Requires:       php(core) >= 5.3
26 Requires:       php(ctype)
27 Requires:       php(filter)
28 Requires:       php(json)
29 Requires:       php(mbstring)
30 Requires:       php(mcrypt)
31 Requires:       php(mysql)
32 Requires:       php(pcre)
33 Requires:       php(session)
34 Requires:       php(simplexml)
35 Requires:       webapps
36 Requires:       webserver(access)
37 Requires:       webserver(alias)
38 Requires(triggerpostun):        sed >= 4.0
39 Suggests:       php-mysqli
40 Suggests:       webserver(indexfile)
41 Suggests:       webserver(php)
42 Conflicts:      apache-base < 2.4.0-1
43 BuildArch:      noarch
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         _appdir         %{_datadir}/%{name}
47 %define         _webapps        /etc/webapps
48 %define         _webapp         %{name}
49 %define         _sysconfdir     %{_webapps}/%{_webapp}
50
51 %description
52 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
53 but also a single database. To accomplish the latter you'll need a
54 properly set up MySQL-user who can read/write only the desired
55 database. It's up to you to look up the appropiate part in the MySQL
56 manual. Currently phpMyAdmin can:
57 - create and drop databases
58 - create, copy, drop and alter tables
59 - delete, edit and add fields
60 - execute any SQL-statement, even batch-queries
61 - manage keys on fields
62 - load text files into tables
63 - create (*) and read dumps of tables
64 - export (*) and import data to CSV values
65 - administer multiple servers and single databases
66 - check referencial integrity
67 - create complex queries automatically connecting required tables
68 - create PDF graphics of your database layout
69 - communicate in more than 50 different languages
70
71 %description -l pl.UTF-8
72 phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
73 uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
74 Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
75 baz, którymi chcemy administrować (więcej informacji w odpowiedniej
76 podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
77 - tworzyć i usuwać bazy
78 - wykonywać create, copy, drop oraz alter na tabelach
79 - dodawać, usuwać i modyfikować pola
80 - wykonywać dowolne zapytania SQL
81 - zarządzać kluczami na rekordach
82 - wczytywać tekst z plików do tabel
83 - obsługiwać ponad 20 języków
84 - zarządzać wieloma serwerami i pojedynczymi bazami danych
85 - eksportować i importować dane do wartości CSV
86 - tworzyć i czytać zrzuty tabel
87
88 %prep
89 %setup -q -n %{name}-%{version}-all-languages
90 %patch0 -p1
91 %patch1 -p0
92 %patch2 -p0
93
94 %install
95 rm -rf $RPM_BUILD_ROOT
96 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}}
97
98 install *.php *.css favicon.ico robots.txt $RPM_BUILD_ROOT%{_appdir}
99 cp -a locale themes js libraries $RPM_BUILD_ROOT%{_appdir}
100
101 install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
102 ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
103
104 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
105 install %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
106 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
107
108 %clean
109 rm -rf $RPM_BUILD_ROOT
110
111 %triggerin -- apache1 < 1.3.37-3, apache1-base
112 %webapp_register apache %{_webapp}
113
114 %triggerun -- apache1 < 1.3.37-3, apache1-base
115 %webapp_unregister apache %{_webapp}
116
117 %triggerin -- apache-base
118 %webapp_register httpd %{_webapp}
119
120 %triggerun -- apache-base
121 %webapp_unregister httpd %{_webapp}
122
123 %triggerin -- lighttpd
124 %webapp_register lighttpd %{_webapp}
125
126 %triggerun -- lighttpd
127 %webapp_unregister lighttpd %{_webapp}
128
129 %files
130 %defattr(644,root,root,755)
131 %doc ChangeLog README examples
132 %dir %attr(750,root,http) %{_sysconfdir}
133 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
134 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
135 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
136 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
137 %dir %{_appdir}
138 %{_appdir}/js
139 %{_appdir}/libraries
140 %{_appdir}/locale
141 %{_appdir}/themes
142 %{_appdir}/*.css
143 %{_appdir}/*.php
144 %{_appdir}/favicon.ico
145 %{_appdir}/robots.txt
This page took 0.963583 seconds and 3 git commands to generate.