]> git.pld-linux.org Git - packages/phpMyAdmin.git/blob - phpMyAdmin.spec
- no php application requires mod_php, so just suggest it, it's no requirement at all
[packages/phpMyAdmin.git] / phpMyAdmin.spec
1 # TODO
2 # - add codepress (http://codepress.org/index.php) patch
3 Summary:        phpMyAdmin - web-based MySQL administration
4 Summary(pl.UTF-8):      phpMyAdmin - administracja bazami MySQL przez WWW
5 Name:           phpMyAdmin
6 Version:        3.2.3
7 Release:        1
8 License:        GPL v2
9 Group:          Applications/Databases/Interfaces
10 Source0:        http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.bz2
11 # Source0-md5:  69fc1d7118f16ccd7ea6f7b330723684
12 Source1:        %{name}.conf
13 Source2:        %{name}-lighttpd.conf
14 Patch0:         %{name}-config.patch
15 Patch1:         %{name}-ServerSelectDisplayName.patch
16 Patch2:         %{name}-ServerSelectDisplayName-config.patch
17 URL:            http://www.phpmyadmin.net/
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires(triggerpostun):        sed >= 4.0
20 Requires:       php-common >= 4:5.2
21 Requires:       php-ctype
22 Requires:       php-mbstring
23 Requires:       php-mcrypt
24 Requires:       php-mysql
25 Requires:       php-pcre
26 Requires:       webapps
27 Requires:       webserver(access)
28 Requires:       webserver(alias)
29 Suggests:       webserver(php)
30 Suggests:       php-mysqli
31 Suggests:       webserver(indexfile)
32 BuildArch:      noarch
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %define         _appdir         %{_datadir}/%{name}
36 %define         _webapps        /etc/webapps
37 %define         _webapp         %{name}
38 %define         _sysconfdir     %{_webapps}/%{_webapp}
39
40 %description
41 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
42 but also a single database. To accomplish the latter you'll need a
43 properly set up MySQL-user who can read/write only the desired
44 database. It's up to you to look up the appropiate part in the MySQL
45 manual. Currently phpMyAdmin can:
46 - create and drop databases
47 - create, copy, drop and alter tables
48 - delete, edit and add fields
49 - execute any SQL-statement, even batch-queries
50 - manage keys on fields
51 - load text files into tables
52 - create (*) and read dumps of tables
53 - export (*) and import data to CSV values
54 - administer multiple servers and single databases
55 - check referencial integrity
56 - create complex queries automatically connecting required tables
57 - create PDF graphics of your database layout
58 - communicate in more than 50 different languages
59
60 %description -l pl.UTF-8
61 phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
62 uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
63 Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
64 baz, którymi chcemy administrować (więcej informacji w odpowiedniej
65 podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
66 - tworzyć i usuwać bazy
67 - wykonywać create, copy, drop oraz alter na tabelach
68 - dodawać, usuwać i modyfikować pola
69 - wykonywać dowolne zapytania SQL
70 - zarządzać kluczami na rekordach
71 - wczytywać tekst z plików do tabel
72 - obsługiwać ponad 20 języków
73 - zarządzać wieloma serwerami i pojedynczymi bazami danych
74 - eksportować i importować dane do wartości CSV
75 - tworzyć i czytać zrzuty tabel
76
77 %prep
78 %setup -q -n %{name}-%{version}-all-languages
79 %patch0 -p1
80 %patch1 -p0
81 %patch2 -p0
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/{js,lang,libraries/{auth/swekey,dbg,dbi,engines,export,tcpdf/font,import,transformations}}}
86
87 install *.php *.html *.css $RPM_BUILD_ROOT%{_appdir}
88 install lang/*.php $RPM_BUILD_ROOT%{_appdir}/lang
89 cp -rf pmd $RPM_BUILD_ROOT%{_appdir}
90 cp -rf themes $RPM_BUILD_ROOT%{_appdir}
91 cp -rf js $RPM_BUILD_ROOT%{_appdir}
92 install libraries/*.php $RPM_BUILD_ROOT%{_appdir}/libraries
93 install libraries/auth/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/auth
94 install libraries/auth/swekey/*.{php,crt} $RPM_BUILD_ROOT%{_appdir}/libraries/auth/swekey
95 install libraries/dbg/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbg
96 install libraries/dbi/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbi
97 install libraries/engines/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/engines
98 install libraries/export/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/export
99 install libraries/import/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/import
100 install libraries/tcpdf/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf
101 install libraries/tcpdf/font/*.{php,z} $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf/font
102 install libraries/transformations/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/transformations
103
104 install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
105 ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
106
107 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
108 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
109 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
110
111 cp -f libraries/import/README{,-import}
112 cp -f libraries/transformations/README{,-transformations}
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %triggerin -- apache1 < 1.3.37-3, apache1-base
118 %webapp_register apache %{_webapp}
119
120 %triggerun -- apache1 < 1.3.37-3, apache1-base
121 %webapp_unregister apache %{_webapp}
122
123 %triggerin -- apache < 2.2.0, apache-base
124 %webapp_register httpd %{_webapp}
125
126 %triggerun -- apache < 2.2.0, apache-base
127 %webapp_unregister httpd %{_webapp}
128
129 %triggerin -- lighttpd
130 %webapp_register lighttpd %{_webapp}
131
132 %triggerun -- lighttpd
133 %webapp_unregister lighttpd %{_webapp}
134
135 %files
136 %defattr(644,root,root,755)
137 %doc Documentation.* CREDITS ChangeLog INSTALL README TODO translators.html scripts libraries/import/README-import libraries/transformations/README-transformations libraries/transformations/TEMPLATE* libraries/transformations/*.sh lang/*.sh
138 %dir %attr(750,root,http) %{_sysconfdir}
139 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
140 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
141 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
142 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
143 %dir %{_appdir}
144 %{_appdir}/js
145 %{_appdir}/lang
146 %{_appdir}/libraries
147 %{_appdir}/pmd
148 %{_appdir}/themes
149 %{_appdir}/*.css
150 %{_appdir}/*.html
151 %{_appdir}/*.php
This page took 0.163462 seconds and 3 git commands to generate.