]> git.pld-linux.org Git - packages/phpMyAdmin.git/blob - phpMyAdmin.spec
15a4703ab8e19ca848af938a5bd313f42a2e6fbf
[packages/phpMyAdmin.git] / phpMyAdmin.spec
1 # TODO
2 # - add codepress (http://codepress.org/index.php) patch
3 Summary:        phpMyAdmin - web-based MySQL administration
4 Summary(pl.UTF-8):      phpMyAdmin - administracja bazami MySQL przez WWW
5 Name:           phpMyAdmin
6 Version:        3.3.5.1
7 Release:        1
8 License:        GPL v2
9 Group:          Applications/Databases/Interfaces
10 Source0:        http://dl.sourceforge.net/phpmyadmin/%{name}-%{version}-all-languages.tar.bz2
11 # Source0-md5:  cf6a1de87b8b590703aaa61aafefc95a
12 Source1:        %{name}.conf
13 Source2:        %{name}-lighttpd.conf
14 Patch0:         %{name}-config.patch
15 Patch1:         %{name}-ServerSelectDisplayName.patch
16 Patch2:         %{name}-ServerSelectDisplayName-config.patch
17 URL:            http://www.phpmyadmin.net/
18 BuildRequires:  rpmbuild(macros) >= 1.268
19 Requires(triggerpostun):        sed >= 4.0
20 Requires:       php-common >= 4:5.2
21 Requires:       php-ctype
22 Requires:       php-mbstring
23 Requires:       php-mcrypt
24 Requires:       php-mysql
25 Requires:       php-pcre
26 Requires:       php-session
27 Requires:       webapps
28 Requires:       webserver(access)
29 Requires:       webserver(alias)
30 Suggests:       php-mysqli
31 Suggests:       webserver(indexfile)
32 Suggests:       webserver(php)
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _appdir         %{_datadir}/%{name}
37 %define         _webapps        /etc/webapps
38 %define         _webapp         %{name}
39 %define         _sysconfdir     %{_webapps}/%{_webapp}
40
41 %description
42 phpMyAdmin can administer a whole MySQL-server (needs a super-user)
43 but also a single database. To accomplish the latter you'll need a
44 properly set up MySQL-user who can read/write only the desired
45 database. It's up to you to look up the appropiate part in the MySQL
46 manual. Currently phpMyAdmin can:
47 - create and drop databases
48 - create, copy, drop and alter tables
49 - delete, edit and add fields
50 - execute any SQL-statement, even batch-queries
51 - manage keys on fields
52 - load text files into tables
53 - create (*) and read dumps of tables
54 - export (*) and import data to CSV values
55 - administer multiple servers and single databases
56 - check referencial integrity
57 - create complex queries automatically connecting required tables
58 - create PDF graphics of your database layout
59 - communicate in more than 50 different languages
60
61 %description -l pl.UTF-8
62 phpMyAdmin potrafi zarządzać całymi bazami MySQL (potrzebne
63 uprawnienia superużytkownika) jak i pojedynczymi bazami danych.
64 Potrzebny jest użytkownik, który ma prawa zapisu/odczytu tylko tych
65 baz, którymi chcemy administrować (więcej informacji w odpowiedniej
66 podręcznika MySQL). Aktualnie phpMyAdmin potrafi:
67 - tworzyć i usuwać bazy
68 - wykonywać create, copy, drop oraz alter na tabelach
69 - dodawać, usuwać i modyfikować pola
70 - wykonywać dowolne zapytania SQL
71 - zarządzać kluczami na rekordach
72 - wczytywać tekst z plików do tabel
73 - obsługiwać ponad 20 języków
74 - zarządzać wieloma serwerami i pojedynczymi bazami danych
75 - eksportować i importować dane do wartości CSV
76 - tworzyć i czytać zrzuty tabel
77
78 %prep
79 %setup -q -n %{name}-%{version}-all-languages
80 %patch0 -p1
81 %patch1 -p0
82 %patch2 -p0
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_appdir}/{js,lang,libraries/{auth/swekey,dbg,dbi,engines,export,tcpdf/font,import,transformations}}}
87
88 install *.php *.html *.css $RPM_BUILD_ROOT%{_appdir}
89 install lang/*.php $RPM_BUILD_ROOT%{_appdir}/lang
90 cp -rf pmd $RPM_BUILD_ROOT%{_appdir}
91 cp -rf themes $RPM_BUILD_ROOT%{_appdir}
92 cp -rf js $RPM_BUILD_ROOT%{_appdir}
93 install libraries/*.php $RPM_BUILD_ROOT%{_appdir}/libraries
94 install libraries/auth/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/auth
95 install libraries/auth/swekey/*.{php,crt} $RPM_BUILD_ROOT%{_appdir}/libraries/auth/swekey
96 install libraries/dbg/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbg
97 install libraries/dbi/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/dbi
98 install libraries/engines/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/engines
99 install libraries/export/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/export
100 install libraries/import/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/import
101 install libraries/tcpdf/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf
102 install libraries/tcpdf/font/*.{php,z} $RPM_BUILD_ROOT%{_appdir}/libraries/tcpdf/font
103 install libraries/transformations/*.php $RPM_BUILD_ROOT%{_appdir}/libraries/transformations
104
105 install libraries/config.default.php $RPM_BUILD_ROOT%{_sysconfdir}/config.inc.php
106 ln -sf %{_sysconfdir}/config.inc.php $RPM_BUILD_ROOT%{_appdir}/config.inc.php
107
108 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/httpd.conf
109 install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/apache.conf
110 install %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/lighttpd.conf
111
112 cp -f libraries/import/README{,-import}
113 cp -f libraries/transformations/README{,-transformations}
114
115 %clean
116 rm -rf $RPM_BUILD_ROOT
117
118 %triggerin -- apache1 < 1.3.37-3, apache1-base
119 %webapp_register apache %{_webapp}
120
121 %triggerun -- apache1 < 1.3.37-3, apache1-base
122 %webapp_unregister apache %{_webapp}
123
124 %triggerin -- apache < 2.2.0, apache-base
125 %webapp_register httpd %{_webapp}
126
127 %triggerun -- apache < 2.2.0, apache-base
128 %webapp_unregister httpd %{_webapp}
129
130 %triggerin -- lighttpd
131 %webapp_register lighttpd %{_webapp}
132
133 %triggerun -- lighttpd
134 %webapp_unregister lighttpd %{_webapp}
135
136 %files
137 %defattr(644,root,root,755)
138 %doc Documentation.* CREDITS ChangeLog INSTALL README TODO translators.html scripts libraries/import/README-import libraries/transformations/README-transformations libraries/transformations/TEMPLATE* libraries/transformations/*.sh lang/*.sh
139 %dir %attr(750,root,http) %{_sysconfdir}
140 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/apache.conf
141 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/httpd.conf
142 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lighttpd.conf
143 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*.php
144 %dir %{_appdir}
145 %{_appdir}/js
146 %{_appdir}/lang
147 %{_appdir}/libraries
148 %{_appdir}/pmd
149 %{_appdir}/themes
150 %{_appdir}/*.css
151 %{_appdir}/*.html
152 %{_appdir}/*.php
This page took 0.068348 seconds and 2 git commands to generate.