]> git.pld-linux.org Git - packages/php4.git/commitdiff
- hack flex scanners to avoid colliding global symbol
authorJakub Bogusz <qboosh@pld-linux.org>
Thu, 22 Oct 2020 19:57:03 +0000 (21:57 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Thu, 22 Oct 2020 19:57:03 +0000 (21:57 +0200)
- enhanced qt patch to fix build with -fno-common

php4-qt.patch
php4.spec

index aaf94713085fe06864b19731ae2854cb36c6d516..4daa9da8497538c52ea775fefeaf648b5dcbb8ff 100644 (file)
    PHP_ADD_INCLUDE($QTDOM_INCDIR)
    PHP_NEW_EXTENSION(qtdom, qtdom.c qtdom_qt.cpp, $ext_shared)
    PHP_SUBST(QTDOM_SHARED_LIBADD)
+--- php-4.4.9/ext/qtdom/qtdom_qt.h.orig        2001-01-04 13:29:07.000000000 +0100
++++ php-4.4.9/ext/qtdom/qtdom_qt.h     2020-10-22 21:19:25.667779334 +0200
+@@ -62,6 +62,6 @@
+ struct qdom_doc *qdom_do_init( const char *arg );
+ void qdom_do_free( struct qdom_doc *doc );
+-struct qdom_message *g_qdom_message_log;
++extern struct qdom_message *g_qdom_message_log;
+ #endif // QDOM_QT_H
+--- php-4.4.9/ext/qtdom/qtdom_qt.cpp.orig      2001-01-04 13:30:19.000000000 +0100
++++ php-4.4.9/ext/qtdom/qtdom_qt.cpp   2020-10-22 21:20:56.769184131 +0200
+@@ -22,6 +22,7 @@
+ #include <qglobal.h>
+ struct qdom_node *qdom_to_node( QDomNode *node );
++struct qdom_message *g_qdom_message_log;
+ /*!
+   Initialises certain global variables, they are:
index 5321df6e02b5c5ec4adc7479f3b34f448701a05b..dfbc9ab9aefbf46348f9e1f69928c8e789391830 100644 (file)
--- a/php4.spec
+++ b/php4.spec
@@ -1655,6 +1655,9 @@ zcat %{SOURCE8} | patch -p1
 
 cp -f Zend/LICENSE{,.Zend}
 
+# make colliding symbol static
+%{__sed} -i -e 's/^char \*yytext/static &/' Zend/zend_{ini,language}_scanner.c
+
 %build
 API=$(awk '/#define PHP_API_VERSION/{print $3}' main/php.h)
 if [ $API != %{php_api_version} ]; then
This page took 0.102506 seconds and 4 git commands to generate.